Jump to content


Photo

Reg trick to boost GPS and run Totom

- - - - -

  • Please log in to reply
23 replies to this topic

#1
ninjaw

ninjaw

    Enthusiast

  • Members
  • PipPipPip
  • 254 posts
  • Location:France
  • Interests:Nine Inch Nails
  • Devices:Omnia pro B7610
  • Twitter:@ninjaw
HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\InputBufferSize: set from 4096 to 512

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\OutputBufferSize: set from 4096 to 512

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\SleepOnNoData: set from 100 to 0

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer\MaxBufferSize: set from 16384 to 1024

I just tried this reg trick I founds on XDA, i had really awful GPS on 6.1 and lots of proxy tools, and now with fresh official 6.5, this works really well, fast, without freeze, and even allow Totom to work without any tool !

  • 0

#2
ttrevelian

ttrevelian

    Regular

  • Members
  • PipPip
  • 97 posts
  • Devices:Samsung B7610
I will try it now with garmin since it is not working for me right now with 6.5.5 rom. It had garmin working fine before on 6.5.3 \. Lets see what happens

thanks for sharing

  • 0

#3
ttrevelian

ttrevelian

    Regular

  • Members
  • PipPip
  • 97 posts
  • Devices:Samsung B7610
I tried the reg tweaks on daskalos 6.5.5 rom but didn't work and when I turned GPS on the phone locks (ony way was to soft reset)

  • 0

#4
ninjaw

ninjaw

    Enthusiast

  • Members
  • PipPipPip
  • 254 posts
  • Location:France
  • Interests:Nine Inch Nails
  • Devices:Omnia pro B7610
  • Twitter:@ninjaw

I tried the reg tweaks on daskalos 6.5.5 rom but didn't work and when I turned GPS on the phone locks (ony way was to soft reset)


well, at leats you can undo it

  • 0

#5
ttrevelian

ttrevelian

    Regular

  • Members
  • PipPip
  • 97 posts
  • Devices:Samsung B7610
yes, thats what i did, and everything working normal after.

  • 0

#6
fier03

fier03

    Regular

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
  • Location:Bassano of the Grappa
  • Devices:Samsung B7610 Omnia Pro
it worked 4 me with IL2 original!!thanks!!

  • 0

#7
RainerRabe2

RainerRabe2

    Newbie

  • Members
  • Pip
  • 41 posts

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\InputBufferSize: set from 4096 to 512

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\OutputBufferSize: set from 4096 to 512

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\SleepOnNoData: set from 100 to 0

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer\MaxBufferSize: set from 16384 to 1024

I just tried this reg trick I founds on XDA, i had really awful GPS on 6.1 and lots of proxy tools, and now with fresh official 6.5, this works really well, fast, without freeze, and even allow Totom to work without any tool !

All, posting here maybe someone knows the answer:

I use those registry settings
XTRA enabled, also the SNTP server, although I see no difference it it is on or off
anyway, GPS finds a fix mostly very fast and works stable.

BUT: while GPS is running (tomtom or Igo or google maps), I have two strange behaviours of the phone with all ROMS I used so far (PDA):
1. POUTLOOK does not work properly any more: you find no contacts while navi is in background, cannot open calendar items, and onyl preview emails but not opening them (I use 6.5.5. rom with Office 10 from Daraklos - but that behaviour also happend in stock rom and all other roms)

2. even more : when using the PHONE (independent if Samsung dial pad or WM 6.5 stock dial pad), while any navi is in background, after some calls, after hanging up the call, the PHONE app (cprog.exe) freezes, and only reboot helps. Navigation system continues to work, but you are not reachable by phone nor can you do an outobund call, since the phone app is simply frozen.
Also bleutooth connection to hands-free in car is breaking down and starting, stopping starting, etc. calls via hands-free keys also not possible (so not only a display problem on the device). only reboot helps.

maybe the CSC files I use are not compatiple with the hardware any more, tried B7610BTIL4.csc, where it happens "often", B7610NXXIL4 (and then the ATO version inside) . where it happens ALWAYS. Phone has German keyboard, so German CSC files need to be used.

does anyone have similar issues, or even better: did anyone of you SOLVE those issues so far? and if yes, or if it does simply work on your end?
- what navi version are you using
- what ROM are you using (PDA file)
- what PHONE file are you using
- what CSC file are you using (all can found in samsung settings-system-version-hardware - and if it is the CSC issue, does anyone have a WORKING German CSC file I can flash...

txs..

  • 0

#8
Klusek

Klusek

    Newbie

  • Members
  • Pip
  • 30 posts
  • Devices:Samsung Omnia Pro B7610

I tried the reg tweaks on daskalos 6.5.5 rom but didn't work and when I turned GPS on the phone locks (ony way was to soft reset)


I have the same problem on ROM from daskalos :)

  • 0

#9
Ajacied410_NL

Ajacied410_NL

    Newbie

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:Sweetlakecity (NL)
  • Devices:LG GC900 + Omnia Pro B7160
Why isn't it working normally like mine without any regedit or other programs.
I just select other GPS in TomTom and select com7.
Wait for a few minutes and it works like a charm.
Sometimes it won't get a signal..than i just reboot my B7610 and startup TomTom again..works always!!!

Using TomTom 7.910.9185 VGA BLACK

  • 0

#10
ninjaw

ninjaw

    Enthusiast

  • Members
  • PipPipPip
  • 254 posts
  • Location:France
  • Interests:Nine Inch Nails
  • Devices:Omnia pro B7610
  • Twitter:@ninjaw

Why isn't it working normally like mine without any regedit or other programs.
I just select other GPS in TomTom and select com7.
Wait for a few minutes and it works like a charm.
Sometimes it won't get a signal..than i just reboot my B7610 and startup TomTom again..works always!!!
Using TomTom 7.910.9185 VGA BLACK


Isn't taht obvious ? you're a lucky guy, your rom was corrected, this trick correct the problem

  • 0

#11
RainerRabe2

RainerRabe2

    Newbie

  • Members
  • Pip
  • 41 posts

Why isn't it working normally like mine without any regedit or other programs.
I just select other GPS in TomTom and select com7.
Wait for a few minutes and it works like a charm.
Sometimes it won't get a signal..than i just reboot my B7610 and startup TomTom again..works always!!!

Using TomTom 7.910.9185 VGA BLACK


I confirm it always worked also without tweaks - just quicker GPS fix with tweaks...

..do your outlook contacts (jost open contacts, not samsung phonebook), and calenda itemas and emails in outlook open correctly while using tomtom in the background..?

  • 0

#12
FortKnox101

FortKnox101

    Regular

  • Members
  • PipPip
  • 91 posts
  • Devices:Samsung OmniaPRO B7610
Works for me too, using daskalos roms. created a cab file for easy reg change.

Attached Files


  • 0

#13
Welssan

Welssan

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:Samsung Omnia Qwerty

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\InputBufferSize: set from 4096 to 512

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\OutputBufferSize: set from 4096 to 512

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\SleepOnNoData: set from 100 to 0

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer\MaxBufferSize: set from 16384 to 1024

I just tried this reg trick I founds on XDA, i had really awful GPS on 6.1 and lots of proxy tools, and now with fresh official 6.5, this works really well, fast, without freeze, and even allow Totom to work without any tool !



It works for me! ;) Thanks,
now I don't need any port splitter like software ;)

  • 0

#14
qquixx

qquixx

    Newbie

  • Members
  • Pip
  • 14 posts
  • Devices:Samsung B7610
Hi guys,

I'm having problems with the GPS on my B7610. When I enable GPS on the camera, it fails with the following error: "Failed to Receiving GPS Signal". Im using the Samsung ROM WinMo 6.5 that comes with the phone.

I already installed GPSMod and B7610GPSFix.cab but its not working. I still can't enable the GPS feature on my phone. Help...

  • 0

#15
ninjaw

ninjaw

    Enthusiast

  • Members
  • PipPipPip
  • 254 posts
  • Location:France
  • Interests:Nine Inch Nails
  • Devices:Omnia pro B7610
  • Twitter:@ninjaw

Hi guys,
I'm having problems with the GPS on my B7610. When I enable GPS on the camera, it fails with the following error: "Failed to Receiving GPS Signal". Im using the Samsung ROM WinMo 6.5 that comes with the phone.
I already installed GPSMod and B7610GPSFix.cab but its not working. I still can't enable the GPS feature on my phone. Help...


Igo8

  • 0

#16
ErnstJanF

ErnstJanF

    Addict

  • Members
  • PipPipPipPipPip
  • 572 posts
  • Location:The Netherlands
  • Devices:Omnia QWERTY, Galaxy S II
I've heard this fix has some problems.. Please try this too.. it worked for me and it's easy-to-install :P

http://forum.xda-dev...ad.php?t=571266

  • 0

#17
qquixx

qquixx

    Newbie

  • Members
  • Pip
  • 14 posts
  • Devices:Samsung B7610

I've heard this fix has some problems.. Please try this too.. it worked for me and it's easy-to-install :P

http://forum.xda-dev...ad.php?t=571266


I already installed this and it didnt worked for me. I'm only enabling the GPS in the camera function, just to enable geotagging in the pictures. And everytime I enable GPS, it only returns the error Fail to Receiving GPS Signal. When I installed and launch GPSMod, I can see that there are 12sats available.

GPS is not seeking in Googlemaps too.

  • 0

#18
ErnstJanF

ErnstJanF

    Addict

  • Members
  • PipPipPipPipPip
  • 572 posts
  • Location:The Netherlands
  • Devices:Omnia QWERTY, Galaxy S II

I already installed this and it didnt worked for me. I'm only enabling the GPS in the camera function, just to enable geotagging in the pictures. And everytime I enable GPS, it only returns the error Fail to Receiving GPS Signal. When I installed and launch GPSMod, I can see that there are 12sats available.

GPS is not seeking in Googlemaps too.


Are you sure you set the right COM port? After installing the CAB file you must tell Windows which port to use :P

  • 0

#19
darkhelmetnl

darkhelmetnl

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:Omnia i900
But does Garmin still work? Any experiences?

  • 0

#20
boyong

boyong

    Regular

  • Members
  • PipPip
  • 62 posts
  • Devices:Samsung B7610, i780
I've been using garmin since I got my i780 and B7610 and it works great. The GPS of google maps works for me too.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users