Jump to content


Photo

24/May r4 - HTC Legend rooting guide - Now with 1.31.x

* * * * * 4 votes

  • Please log in to reply
663 replies to this topic

Poll: The Legend rooting poll (247 member(s) have cast votes)

Did you use this guide to root your HTC Legend?

  1. Yessireee and it's great! (170 votes [68.83%])

    Percentage of vote: 68.83%

  2. No because i'm too scared! (41 votes [16.60%])

    Percentage of vote: 16.60%

  3. No because it didn't work! (36 votes [14.57%])

    Percentage of vote: 14.57%

Vote Guests cannot vote

#621
Holmes108

Holmes108

    Newbie

  • Members
  • Pip
  • 3 posts
Hello all.

I'm actually stuck at the downgrading step... I ran the crackin.bat from the Hack4legend.zip. and the guide I used said my phone would reboot 5 times. It only reboots twice, and the message in the terminal is stuck on "adb server is out of date. killing..."

I created my goldcard while the SD card was in my phone (in "Disk Drive" mode), and have never taken the card out. I used the little application that creates and patches the image to the card. I don't know if this is the problem... if I have a bad card, or if the crackin.bat isn't working... Is there any reason I need to remove my SD card and create the gold card directly on my PC?

Any advice would be appreciated.


Edit: Nevermind. It seems I had 2 instances of ADB.EXE running... closing one of them solved the issue.

Edited by Holmes108, 28 September 2010 - 12:42 PM.

  • 0

#622
randy_khoo

randy_khoo

    Newbie

  • Members
  • Pip
  • 2 posts
Hi there,

My name is Randy Khoo. I'm from the South East Asia region.
Just wanna say thanks to all of you guys for your help, namely Paul and wag3slav3.

Just to put down this for the other SEA boys.
1) I started off with my goldcard creation (no problems) and followed Paul's advice at unlockr.com

2) I encountered problems with step 1 -> Remote 43 main check version fail

3) I bumped into "[HOWTO] DOWNGRADE to 1.31 which you can then root for Legend 2.1" at the XDA forums.

4) I ran crackin and reached
crwxrwxrwx 1 1001 2002 90, 0 Jul 19 16:19 /dev/mtd/mtd0
However, i kept getting permission errors while attempting this.

5) Despite the error messages, I decided at this point to just give the downgrade a try anyway...
RUU_Legend_HTC_WWE_1.31.405.5_R_Radio_47.26.35.04_ 7.05.35.26L_release_126592_signed.exe


6) I succeeded and I continued Paul's instruction for Step 1 and Step 2...

7) Sweet success! Thank you...
Really appreciate this community of dedicated developers making rooting possible on the legend!


However i had a few speed bumps i wanted to run through with anyone else of you here that are experts in this field.

1) I had problems accessing SuperUser after the Step 2 => solved by restarting my phone.

2) ROM Manager / ClockWorkMod -> i've installed this and backed up my ROM. I wish to install Azure 6.0.0, however i am not sure if this requires a goldcard?

3) After the downgrade, i noticed there's an upgrade to 1.31.405.5 (3.89MB) when i do a system update. What will happen when I download this? Will it close up all the root vulnerabilities, letting me start all over to where i began in the first place? Will my phone brick with this update? I've read that some people had issues with their phones after they downloaded this...

  • 0

#623
alexhtclegend

alexhtclegend

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:HTC Legend
After running "step2-windows.bat", I get stuck on the red exclamation mark screen, rather than the "recovery" screen. Does anyone have a solution for this?

I haven't actually bricked my phone though, if I take out and re-insert the battery I get back to my normal (unrooted) ROM. Also, I have the correct software/bootloader versions; I downgraded to 1.31 using the method over on XDA.

Thanks in advance!

  • 0

#624
alexhtclegend

alexhtclegend

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:HTC Legend

After running "step2-windows.bat", I get stuck on the red exclamation mark screen, rather than the "recovery" screen. Does anyone have a solution for this?

I haven't actually bricked my phone though, if I take out and re-insert the battery I get back to my normal (unrooted) ROM. Also, I have the correct software/bootloader versions; I downgraded to 1.31 using the method over on XDA.

Thanks in advance!


Also, I have had no luck when I keep the gold card in either (the guide tells you to replace it with a non-goldcard after stage 1)

  • 0

#625
wiggyter

wiggyter

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Legend

Also, I have had no luck when I keep the gold card in either (the guide tells you to replace it with a non-goldcard after stage 1)


Hi alexhtclegend,

On Linux he same happened to me, but running the second script with root permissions was succesful. Can you run the script on windows with 'run as administrator'? Maybe that will help.

  • 0

#626
GQKKE

GQKKE

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Legend
I am stuck at step 2, this is what i got from cmd.exe:

C:\r4-legend-root>step2-windows.bat
Legend Root Step 2

Pushing required files to device...

* daemon not running. starting it now on port 5037 *
* daemon started successfully *
push: files/etc/mtab -> /etc/mtab
push: files/etc/fstab -> /etc/fstab
push: files/sbin/wipe -> /sbin/wipe
push: files/sbin/unyaffs -> /sbin/unyaffs
push: files/sbin/ums_toggle -> /sbin/ums_toggle
push: files/sbin/um -> /sbin/um
push: files/sbin/tune2fs -> /sbin/tune2fs
push: files/sbin/toolbox -> /sbin/toolbox
push: files/sbin/sdparted -> /sbin/sdparted
push: files/sbin/recovery -> /sbin/recovery
push: files/sbin/reboot -> /sbin/reboot
push: files/sbin/parted -> /sbin/parted
push: files/sbin/nandroid-mobile.sh -> /sbin/nandroid-mobile.sh
push: files/sbin/mkyaffs2image -> /sbin/mkyaffs2image
push: files/sbin/mke2fs -> /sbin/mke2fs
push: files/sbin/log2sd -> /sbin/log2sd
push: files/sbin/fs -> /sbin/fs
push: files/sbin/flash_image -> /sbin/flash_image
push: files/sbin/fix_permissions -> /sbin/fix_permissions
push: files/sbin/e2fsck -> /sbin/e2fsck
push: files/sbin/dump_image -> /sbin/dump_image
push: files/sbin/busybox -> /sbin/busybox
push: files/sbin/backuptool.sh -> /sbin/backuptool.sh
push: files/sbin/adbd -> /sbin/adbd
push: files/system/bin/sh -> /system/bin/sh
push: files/system/bin/linker -> /system/bin/linker
push: files/system/lib/libstdc++.so -> /system/lib/libstdc++.so
push: files/system/lib/libm.so -> /system/lib/libm.so
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
link_image[1721]: 75 could not load needed library 'libc.so' for '/system/bin
/sh' (load_library[1051]: Library 'libc.so' not found)CANNOT LINK EXECUTABLE

Pushing update file to device sdcard - this may take a few minutes...

adb server is out of date. killing...
* daemon started successfully *
** daemon still not runningerror: cannot connect to daemon
adb server is out of date. killing...
* daemon started successfully *
^CAfbryd batchjob (J/N)? n

Now wipe and apply rootedupdate.zip from the recovery image menu.

adb server is out of date. killing...
* daemon started successfully *

After this cmd quits and my phone still stands on the !-screen without goin into RECOVERY screen..

  • 0

#627
Swamp

Swamp

    Newbie

  • Members
  • Pip
  • 7 posts
Hey i have a issue with this.

On step 2 it just goes to start deamon then it closes, no push nothing.. :/

Any ideas?

CMD says:

Legend Root Step 2

Pushing required files to device...

'adb-windows.exe' is not recognized as an internal or external command,
operable program or batch file.
'adb-windows.exe' is not recognized as an internal or external command,
operable program or batch file.
'adb-windows.exe' is not recognized as an internal or external command,
operable program or batch file.

Pushing update file to device sdcard - this may take a few minutes...

'adb-windows.exe' is not recognized as an internal or external command,
operable program or batch file.
'adb-windows.exe' is not recognized as an internal or external command,
operable program or batch file.

Now wipe and apply rootedupdate.zip from the recovery image menu.

'adb-windows.exe' is not recognized as an internal or external command,
operable program or batch file.

Edited by Swamp, 16 October 2010 - 01:08 PM.

  • 0

#628
Swamp

Swamp

    Newbie

  • Members
  • Pip
  • 7 posts
okey now i have a HUGE issue, flash failed big time some how, some were, i could redo everything but i can't formate my Sdcard, cuz my computer can't find my phone. can only find fastboot in fastboot mode, nothing else. not disk mode, adb or bootloder.

Any ideas?

  • 0

#629
843

843

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:HTC Legend
I've been having wonderful luck with gold cards. So far I've tried 2GB Kingston, 2GB Sandisk and 1GB Samsung. None of them works for the first step and I keep getting '42 custom id check fail' on all of them. Yet I managed to downgrade my Legend to an earlier version. Is it a gold card problem or am I doing something wrong?

  • 0

#630
Tobsenseless

Tobsenseless

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:HTC Legend
I got it now managed, had vodafone Legend with Bootmanager 0.43.0003.
I used this to downgrade: http://forum.xda-dev...ad.php?t=725430

Then i wanted to root the device which gave me the same problem as I think iziy has.
Step two cant be performed on the phone. I noticed that always when i had the phone plugged in my xp pc, the device manager came up and looked for a driver. But he could not find one.
So i found at the unlockr a thread telling me to use usbdeview to delete all drivers of htc currently installed and the plug the legend back in and let it search for drivers.
This worked for me after a restart of the pc and i was able to get adb devices and also the step 2 of this howto.

tHx Paul and everyone for dealing with sh17 like this :P

GQKKE and swamp try usbdeview to delete the htc drivers, this was my problem... I had the same signs.

Edited by Tobsenseless, 22 October 2010 - 09:19 PM.

  • 0

#631
sybrows

sybrows

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:HTC Legend, Orange SF
  • Twitter:@sybrows
Hi This is my first post here.

I have been trying to root my legend for ages now, here is where I am at :

I had a Vodafone HTC Legend and I did have the shonky Vodafone update on it 2.1 xxxxx something that came down over the air.

Anyways I went ahead and downgraded the system to 1.31.405.5 as explained on unlockr using the crackin.bat file this worked as far as I can tell and it is currently unbranded with bootloader v 43.0001.

Using the same goldcard I have used to downgrade to 1.31 I have mounted the linux build under VM to try and root the phone. I run step1.sh and get the Remote: 43 Main Version Check Fail Error.

---------------------------------------------------------------------------------------------------------------------

I have also tried the step1-windows.bat method and it just gets stuck at writing ZIP....

Now as I managed to downgrade the phone using crackin.bat I am guessing that the Goldcard Works, I have also tried without HTC synch running in the background and just get the same error. I have tried to take off the drivers and reinstall them but all give me the same error 43 and I cannot continue with step2.

Any help here would be much appreciated as I am now fully out of Ideas !!!

BrOw


EDIT:

Just to let you know I managed to Root my legend in the end. I had pretty much given up hope as all I was getting was the 43 error but then I managed it. The main changes I made to the above where that I made a new goldcard using the goldcard tool and I used my Win7 32bit machine and it worked. I think it was the OS change that did it as the drivers may well have been the problem. Anyways now I am enjoying Froyo on my legend and am all round Chuffed Cheers to all in this thread particularly Paul.

BrOw

Edited by sybrows, 28 October 2010 - 11:02 AM.

  • 0

#632
HanSieT

HanSieT

    Newbie

  • Members
  • Pip
  • 4 posts
  • Location:Stiens
  • Devices:HTC Legend
  • Twitter:@HanSieT
Please note that this didnt work for me on Windows 7 64bits.
I tried on Vista 32 and that worked out good for me.
Also i had some troubles with the device not found error but that was helped by downloading the latest HTCsync from the HTC website.

I followed this howto and i rooted my legend and upgraded to 2.2 ( Cyanogen mod )


Thanks Paul U THA MAN!!!

  • 0

#633
HanSieT

HanSieT

    Newbie

  • Members
  • Pip
  • 4 posts
  • Location:Stiens
  • Devices:HTC Legend
  • Twitter:@HanSieT

Using the same goldcard I have used to downgrade to 1.31 I have mounted the linux build under VM to try and root the phone. I run step1.sh and get the Remote: 43 Main Version Check Fail Error.

---------------------------------------------------------------------------------------------------------------------

BrOw



Maybe u need to create a new goldcard

  • 0

#634
sybrows

sybrows

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:HTC Legend, Orange SF
  • Twitter:@sybrows

Maybe u need to create a new goldcard


All good got it sorted in the end By Creating New GC and changing OS to Win 7 32bit. Not sure which did it but prob OS

BrOw

  • 0

#635
peter_ng

peter_ng

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:Blackberry 9700 & HTC Legend

Pushing required files to device...

error: device not found
error: device not found

Pushing update file to device sdcard - this may take a few minutes...

error: device not found
error: device not found

Now wipe and apply rootedupdate.zip from the recovery image menu.

$ error: device not found


Can easily solve when u using HTCSync 2.0.33...don't use any other newest version


HTCSync 2.0.33 Download Here

  • 0

#636
andreas083

andreas083

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:ks20
Problem with step 2.. Using w7 32bit. Legend with 43.0001 and ROM 131.405.4

16 Gb Kingston memory card

First had problems with step 1 and "adb out of date", but unistalled htc synd and got by it.


c:\r4-legend-root>step2-windows
Legend Root Step 2

Pushing required files to device...

* daemon not running. starting it now on port 5037 *
* daemon started successfully *
push: files/etc/mtab -> /etc/mtab
...
push: files/system/lib/libc.so -> /system/lib/libc.so
31 files pushed. 0 files skipped.
1132 KB/s (3734509 bytes in 3.219s)
- exec '/system/bin/sh' failed: Permission denied (13) -

Pushing update file to device sdcard - this may take a few minutes...

- exec '/system/bin/sh' failed: Permission denied (13) - Protocol failure

What to do?

Edit: I can run step 1 without having my sd card as goldcard... Is this right? How do i know that step 1 worked?

Edited by andreas083, 07 November 2010 - 02:01 PM.

  • 0

#637
nikosma

nikosma

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:HTC Legend
Thank you very much!!!!great work Paul

Edit: I can run step 1 without having my sd card as goldcard... Is this right?

Andreas083....if your phone is unbranded you don't need goldcard

I've had almost the same problem like you on step2,how i've solved it?
Make the first step on a windows box,Download the ISO Image – MD5SUM: c56dd594f0a1179ed3a44924fca456d2,
burn it, run it and continue the second step with this method (the iso method)

Edited by nikosma, 09 November 2010 - 01:57 PM.

  • 0

#638
andreas083

andreas083

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:ks20

Andreas083....if your phone is unbranded you don't need goldcard

I've had almost the same problem like you on step2,how i've solved it?
Make the first step on a windows box,Download the ISO Image – MD5SUM: c56dd594f0a1179ed3a44924fca456d2,
burn it, run it and continue the second step with this method (the iso method)


Thanks for trying to help me here..

Where can I download this? It isn't avalible any more.

Funny thing though. Now after step 1 I installed mybackup and it detected my phone as rooted. Tried rom manager but can't install a new rom.

Tried wxp, same error.

Tried to do it from Ubuntu, booted from cd and had the files on local hd. Opened a terminal, managed to get to the right folder tried sudo ./step2-linux.sh got "command not found" tried sudo sh step2-linux.sh wich launched but got some syntax errors with adb-linux

How do I tun this from Ubuntu?

  • 0

#639
nikosma

nikosma

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:HTC Legend
You're welcome andreas083...
Here you are http://www.megaupload.com/?d=5LO8I8UJ

Tried to do it from Ubuntu, booted from cd and had the files on local hd. Opened a terminal, managed to get to the right folder tried sudo ./step2-linux.sh got "command not found" tried sudo sh step2-linux.sh wich launched but got some syntax errors with adb-linux


It is a little complicated

  • 0

#640
andreas083

andreas083

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:ks20

Thank you very much!!!!great work Paul

Edit: I can run step 1 without having my sd card as goldcard... Is this right?

Andreas083....if your phone is unbranded you don't need goldcard

I've had almost the same problem like you on step2,how i've solved it?
Make the first step on a windows box,Download the ISO Image – MD5SUM: c56dd594f0a1179ed3a44924fca456d2,
burn it, run it and continue the second step with this method (the iso method)

I've had almost the same problem like you on step2,how i've solved it?
Make the first step on a windows box,Download the ISO Image – MD5SUM: c56dd594f0a1179ed3a44924fca456d2,
burn it, run it and continue the second step with this method (the iso method)


Worked like a charm!

Great work guys!

I can't run either step 2 or recovery from windows though. Used Rom manager to install new rom instead of the revocery-step

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users