Jump to content


Photo

24/May r4 - HTC Legend rooting guide - Now with 1.31.x

* * * * * 4 votes

  • Please log in to reply
663 replies to this topic

Poll: The Legend rooting poll (247 member(s) have cast votes)

Did you use this guide to root your HTC Legend?

  1. Yessireee and it's great! (170 votes [68.83%])

    Percentage of vote: 68.83%

  2. No because i'm too scared! (41 votes [16.60%])

    Percentage of vote: 16.60%

  3. No because it didn't work! (36 votes [14.57%])

    Percentage of vote: 14.57%

Vote Guests cannot vote

#61
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,369 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
I'll update this to install 1.31 as part of the root on Monday! :huh:

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#62
Warrior Of Ice

Warrior Of Ice

    Newbie

  • Members
  • Pip
  • 18 posts
Thanks again, i hope this update will work.

  • 0

#63
Yblih

Yblih

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:HTC Ledgend
Thanks Paul :huh:

Downgrading to 1.23 is not an option: bootloader version mismatch.

So I will wait until monday... is it monday already? LOL ;-)

  • 0

#64
KL君

KL君

    Newbie

  • Members
  • Pip
  • 24 posts

I'll update this to install 1.31 as part of the root on Monday! :P

P


Thank you so much, Paul.

You're the man!!! :huh:

  • 0

#65
jakontil

jakontil

    Newbie

  • Members
  • Pip
  • 14 posts
  • Devices:O2 Atom Life
Can anyone give some advice which virtual machine will run the tinycore linux?
I tried the VMware but it doesnt want to detect the ISOLinux i downloaded from the first page.

Im using a mac and have no idea how to burn a bootable ISO..

THANKS..

  • 0

#66
NikMel

NikMel

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:HTC LEGEND, HTC DIAMOND
I use VMware and it works like it should!
Just mount as cdrom and boot from it.

Can anyone give some advice which virtual machine will run the tinycore linux?
I tried the VMware but it doesnt want to detect the ISOLinux i downloaded from the first page.

Im using a mac and have no idea how to burn a bootable ISO..

THANKS..


  • 0

#67
Warrior Of Ice

Warrior Of Ice

    Newbie

  • Members
  • Pip
  • 18 posts
Finally i´ve update to version 1.31 with an ruu from shipped-roms.com
have i loose the root?
can i update the 1.31 with root permission?

  • 0

#68
chinana

chinana

    Newbie

  • Members
  • Pip
  • 18 posts
  • Devices:HTC Legend
hi all,
im seeking help..
as im currently using the netbook (without cdrom) thus i cant burn the iso file to cd and boot it...
but i saw there written " or boot it with ur virtual machine" what is that means?

anybody can assist? pls.....
i just made my gold card..
thx...

  • 0

#69
lucky58

lucky58

    Newbie

  • Members
  • Pip
  • 6 posts

I'll update this to install 1.31 as part of the root on Monday! :huh:

P


Almost Monday, counting down -:P

Thanks P !

  • 0

#70
wkyzp

wkyzp

    Newbie

  • Members
  • Pip
  • 5 posts

hi all,
im seeking help..
as im currently using the netbook (without cdrom) thus i cant burn the iso file to cd and boot it...
but i saw there written " or boot it with ur virtual machine" what is that means?

anybody can assist? pls.....
i just made my gold card..
thx...


look like you are chinese....

如果你的计算机没有光驱,你可以在百度中搜索虚拟机,一
下载VMWARE即可
然后用vmware虚拟一台linux的机器,然后用你下载的ISO文件引导

另外,你的LEGEND软件版本是1.31的还是1.23的?如果是前者,你
先不用折腾了。Paul估计今天或者明天发放1.31的root文件。。
。。。等等吧
如果还有什么事情,可以给我留言。

  • 0

#71
chinana

chinana

    Newbie

  • Members
  • Pip
  • 18 posts
  • Devices:HTC Legend

look like you are chinese....

如果你的计算机没有光驱,你可以在百度中搜索虚拟机,一

下载VMWARE即可
然后用vmware虚拟一台linux的机器,然后用你下载的ISO文件引导

另外,你的LEGEND软件版本是1.31的还是1.23的?如果是前者,你
��先不用折腾了。Paul估计今天或者明天发放1.31的root文件

��。。。等等吧
如果还有什么事情,可以给我留言。


thanks lot.
i checked is 1.31. but there are ppl post there successfully rooted 1.31?
mm... confuse.. thx

  • 0

#72
Peganos

Peganos

    Newbie

  • Members
  • Pip
  • 46 posts

once i click on recovery, (just before step 2), my device shows an exclamation mark with a triangle and i have to remove the battery to reboot, i suppose that isn't normal, but is this related to the issues of this procedure or is caused by anything else? (by the way trying to launch the step 2 i get the error "device not found" like all the others)


Hi,

you had to start the step2.sh while you see the triangle on your phone. This script starts the recovery menu on your phone, so that you can wipe and flash your device.

  • 0

#73
SimoxTa

SimoxTa

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:HTC Legend

Hi,

you had to start the step2.sh while you see the triangle on your phone. This script starts the recovery menu on your phone, so that you can wipe and flash your device.


Thanks for your answer, by the way, once I try to start the second step, terminal says "device not found" like all the others, and i can't select anything. Should i see any another screens in the meanwhile?


Sorry for my noobish questions but it's my first android device :P so i need to make a little traning (no problem at all (at least) while creating the goldcard :huh: )

  • 0

#74
KL君

KL君

    Newbie

  • Members
  • Pip
  • 24 posts
Paul, please forgot that guy. I got so f' ppl like him. They just want to make you angry and make you to stop cracking the machine.

  • 0

#75
chinana

chinana

    Newbie

  • Members
  • Pip
  • 18 posts
  • Devices:HTC Legend
mayb he is HTC programmer...
got scolded just bcoz u successfully cracked the phone..
hahahh...

if there is no ppl cracked it, we will not enjoy the current advancement of technology.. :huh:

just ignore him.. hahah

  • 0

#76
Peganos

Peganos

    Newbie

  • Members
  • Pip
  • 46 posts

Thanks for your answer, by the way, once I try to start the second step, terminal says "device not found" like all the others, and i can't select anything. Should i see any another screens in the meanwhile?
Sorry for my noobish questions but it's my first android device :P so i need to make a little traning (no problem at all (at least) while creating the goldcard :huh: )


Normally your device shows the triangle, then you start step2. A little while after that your phone should show a progress bar and boot into recovery menu. And here you follow the instructions of paul's guide again.

Perhaps you should try it with an ruu and start again from the beginning.. But remember !! The Legend had to be powered on for step2 !!

Hope that helps you.

  • 0

#77
jakontil

jakontil

    Newbie

  • Members
  • Pip
  • 14 posts
  • Devices:O2 Atom Life
Darn.... i tried to downgrade the rom to 1.23 but i got error bootloader mismatch.... gonna wait for the root update....

  • 0

#78
SimoxTa

SimoxTa

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:HTC Legend

Normally your device shows the triangle, then you start step2. A little while after that your phone should show a progress bar and boot into recovery menu. And here you follow the instructions of paul's guide again.

Perhaps you should try it with an ruu and start again from the beginning.. But remember !! The Legend had to be powered on for step2 !!

Hope that helps you.


Thanks for your help, btw, after the screen with the triangle, as soon as i start the step 2, nothing appears, i see on the console that the daemon has been started but just few seconds later it says "device not found". (i tried the kill the daemon and restart executing "./adb devices" but it shows nothing connected).

I tried both with the CD and on the Virtual Machine (WMWare) and the only difference i noticed is a slower transfer speed in VMWare but anything else. I even tried to unplug every other USB devices to avoid conflicts but nothing seems to change :P
(during transfer i always receive the warning "remote: 43 main version check fail")

Finally i tried to follow your steps to downgrade but i received the "Error 140: bootloader version error" (with the goldcard inserted).

I followed the guide to make the goldcard and trying it just after the replace of the headers, it seems to work, cause it is recognized by system.

As far as i know, i should have a 1.31 Rom with HBOOT 0.43.0001 and RADIO 7.05.35.26L

About any other informations, as motherboard i have an Asus P5K-SE, and I don't know if it's normal but in VMWare as soon i move from "fastboot" to "bootloader" the device is recognized as a storage device (while in first time was recognized as "High Android Device 1.0").

One last thing: on Hboot menu, the system checks for images on the SD and it says that nothing can be found. Is that normal?

Thanks for your precious time :huh:

  • 0

#79
rodriguezstyle

rodriguezstyle

    Regular

  • Members
  • PipPip
  • 90 posts
  • Location:Home
  • Interests:good old SE Modder...
  • Devices:Legend on MoDaCoMoDrOm

Darn.... i tried to downgrade the rom to 1.23 but i got error bootloader mismatch.... gonna wait for the root update....


yes is still impossible i hope the Update comes today...

  • 0
Posted Image

HTC Legend Rodriguezstyle MoDaCoMoD Rom fast as hell!
http://forum.xda-dev...ad.php?t=679122

#80
Peganos

Peganos

    Newbie

  • Members
  • Pip
  • 46 posts

Thanks for your help, btw, after the screen with the triangle, as soon as i start the step 2, nothing appears, i see on the console that the daemon has been started but just few seconds later it says "device not found". (i tried the kill the daemon and restart executing "./adb devices" but it shows nothing connected).

I tried both with the CD and on the Virtual Machine (WMWare) and the only difference i noticed is a slower transfer speed in VMWare but anything else. I even tried to unplug every other USB devices to avoid conflicts but nothing seems to change :P
(during transfer i always receive the warning "remote: 43 main version check fail")

Finally i tried to follow your steps to downgrade but i received the "Error 140: bootloader version error" (with the goldcard inserted).

I followed the guide to make the goldcard and trying it just after the replace of the headers, it seems to work, cause it is recognized by system.

As far as i know, i should have a 1.31 Rom with HBOOT 0.43.0001 and RADIO 7.05.35.26L

About any other informations, as motherboard i have an Asus P5K-SE, and I don't know if it's normal but in VMWare as soon i move from "fastboot" to "bootloader" the device is recognized as a storage device (while in first time was recognized as "High Android Device 1.0").

One last thing: on Hboot menu, the system checks for images on the SD and it says that nothing can be found. Is that normal?

Thanks for your precious time :huh:


Normally I would say you had to enable USB-Debugging - But then step1 wouldn't run correctly.. But try it..
Howto: Boot your phone -> Settings -> Applications -> Development -> USB Debugging

I would do the rooting on a physical maschine..

I don't know exactly, but I think the image will be copied in step 2 - So it's normal that nothing can be found.

One little tip: Don't unplug your phone while you are in the recovery menu, because it runs the menu from your pc and hangs up if you unplug before you restart.

Regards..

Edited by Peganos, 03 May 2010 - 08:26 AM.

  • 0




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users