Jump to content


Photo

[HOWTO] Unroot your HTC Desire


  • Please log in to reply
206 replies to this topic

#201
EddyOS

EddyOS

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,536 posts
  • Gender:Male
  • Location:Liverpool, Merseyside
  • Devices:Google Nexus 5
  • Twitter:@dj_e1d
Yes, an RUU replaces EVERYTHING back to stock

  • 0
Google Nexus 4 (LG-E960)
ROM: Android 4.3 (JWR66V)
Bootloader: MAKOZ20i
Recovery: Stock
Radio: 2.0.1700.84
Kernel: Stock

#202
Endriu90

Endriu90

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:HTC Desire (GSM)
Hi everybody!

First of all, I'm pretty a newbie in Android hacking world, so, please, be patient with me! :D

I'm going to tell you my Desire Story, and I'd like you (all) to help me recover it! (if possible ;) )

I rooted my Desire (GSM) with the unrevoked method and everything went well. Before rooting, my bootloader was 0.93 and it was 0.93 after rooting. After that, I wanted to expand data partition in the internal storage, so I got S-off using the Alpharev method and applied the Sense table partition. Here too, everything went quite well (not without getting blasphemous B) ).
Yesterday, I thought I want to revert everything and go back to stock Sense ROM (no brand and I'm from Italy).
I read everything in this thread and I downloaded the RUU Utility. I've run it on my PC and had some problems with drivers. I've installed the right drivers and tried again. After updating the signature (as said by the utility), it's stopped, reporting error 140, saying I have a non-compatible bootloader (now, it's 0.75 and I don't know how and when it downgraded :D ).

Finally, my Desire runs only the bootloader (and some trace of ClockworkMod 2.5.0.7 remained). I tried using other RUUs (downloaded by shipped-roms.com) but the error remains the same (cit. Led Zeppelin, LOL! :( )

Please, I really need your help!

P.s.: now I'm trying to flash some PB99IMG from shipped-roms.com, I'll edit this post as soon as I get some kind of result (good or bad)

EDIT: PB99IMG method failed. Error "Main version is older. Update fail." :D

EDIT 2: just to be as much clear as possible, my bootloader version shows this:

BRAVO UNKNOWN SHIP S-ON
HBOOT-0.75.0000
MICROP-031d
TOUCH PANEL-SYNT0101
RADIO-4.05.00.11
Mar 5 2010,21:12: 15

EDIT 3: I tried using these instructions, as said by xda. MISC partition correctly fixed, but the RUU fails again.

Edited by Endriu90, 04 April 2011 - 10:23 AM.

  • 0

#203
EddyOS

EddyOS

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,536 posts
  • Gender:Male
  • Location:Liverpool, Merseyside
  • Devices:Google Nexus 5
  • Twitter:@dj_e1d
Which RUU are you trying to use?

  • 0
Google Nexus 4 (LG-E960)
ROM: Android 4.3 (JWR66V)
Bootloader: MAKOZ20i
Recovery: Stock
Radio: 2.0.1700.84
Kernel: Stock

#204
Endriu90

Endriu90

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:HTC Desire (GSM)

Which RUU are you trying to use?


First, I tried with this, then with the first linked in this thread. The RUU says the ROM version in my phone is 2.29.[cannot remember], that's the last version of stock HTC ROM I updated before rooting (talking of about 2 or 3 months ago). All I can do is to boot my Desire in FastBoot or HBoot mode. No ROMs installed. I cannot recharge battery (as I connect phone to PC or AC charger, it automatically boots in FastBoot mode).

EDIT 1: I've just been able to flash succesfully CyanogenMod 6.1.1, all gapps and the latest Radio version. What now?! :D
EDIT 2: I've noticed that internal storage partitions have come back according to stock partition but still now the RUU doesn't work, giving the same 140 error...

EVERYTHING SOLVED: I used a downgrade utility to restore the (broken) BootLoader and it also installed the stock HTC ROM

Edited by Endriu90, 04 April 2011 - 09:23 PM.

  • 0

#205
evenlut

evenlut

    Newbie

  • Members
  • Pip
  • 1 posts

EVERYTHING SOLVED: I used a downgrade utility to restore the (broken) BootLoader and it also installed the stock HTC ROM


Hi - what downgrade utility? I have the same challenge, do you have a link or something?

EDIT: Found it myself: http://forum.xda-dev...ad.php?t=768256

Edited by evenlut, 19 April 2011 - 08:49 AM.

  • 0

#206
Surematu

Surematu

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Desire
  • Twitter:@NONE
Hello!
I hawe download and install htc sync, and run the HTC RUU. When the install of the new RUU start, its comming a HTC mark at the phone, and my computer say that i must conect my phone to the computer...? I hawe conected it, and startet the installation, but every time this thing comes upp...

  • 0

#207
Tomaco

Tomaco

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Desire
It's not clear to me, but is this guide for every bootloader or only 0.80? I have 0.93 and I want to know if i can uses this

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users