Jump to content


Photo

Pulse 2.1 Windows Drivers - 7, Vista & XP

* * * * * 3 votes

  • Please log in to reply
98 replies to this topic

#41
ogiogi

ogiogi

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,351 posts
  • Gender:Male
  • Location:Skopje, Macedonia
  • Devices:HTC Desire
  • Twitter:@ogigoce

Ah yes, they seem to have installed correctly now - thanks ;)

I think the issue was that the ADB driver has to be installed LAST, after all the other drivers (3G, PCUI, DBAdapter) are in place, and the "unknown device" popup wasn't working on that basis.

It's not totally clear when there are just a set of unknown devices listed.



hi all,

im very new to this but decided to give 2.1 a go. i have got the hungarian update on my phone (only the lager of the two updates) but my pc refuses to install the abd driver, keeps telling me the driver is not for the platform. im running vista x64 and the other 3 drivers installed fine through device manager.

anyone else having this problem or have a solution? im stuck on stock 2.1 till i get this sorted.

cheers, rob.


Installing the ADB driver last worked for Stevos. Did u try that?

  • 0

#42
HyvelTjuven

HyvelTjuven

    Diehard

  • Members
  • PipPipPipPip
  • 381 posts
  • Devices:Huawei U8220
I am what you would call a "total badword noob", I've downloaded the drivers, but now what should I do to install them correctly?

  • 0

#43
ogiogi

ogiogi

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,351 posts
  • Gender:Male
  • Location:Skopje, Macedonia
  • Devices:HTC Desire
  • Twitter:@ogigoce

I am what you would call a "total badword noob", I've downloaded the drivers, but now what should I do to install them correctly?

1. Open Device Manager
2. Right Click "Unknown Device" (you should have four of these)
3. Select update driver
4. Select install from a list or specific location and press Next
5. Select Don't search, I will choose the driver to install and press Next
6. Press Have Disk, browse to the folder where you extracted the drivers and select android_usb.inf
7. Press Next and installation should begin
8. Repeat 2-7 for each unknown device

Edited by ogiogi, 16 June 2010 - 10:23 PM.

  • 0

#44
Rob Jackson

Rob Jackson

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:Pulse
Hi,

Finally got it working last night. I reinstalled the ABD driver 2 or 3 times with the same result (driver not for this platform), then i decided to try one more time and it worked. I have no idea why it worked but it did. Device manager is reporting that the device has a problem until i put the phone into Bootloader mode and then it is fine. Also when connecting the phone to the PC windows driver wizard it still looking for the driver to be installed every time.

I think someone else on this thread has similar issues where the driver suddenly decided to work for no apparent reason, but its working anyways.

Rob

  • 0

#45
h3dshot

h3dshot

    Diehard

  • Members
  • PipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:United Kingdom
  • Devices:Coolpad F1 8297w, SGS 2

Try uninstalling all T-Mobile devices. Delete or move the folder containing the drivers. Restart your PC and then manually install the drivers from device manager.



sorry for being such a pest but im desperate for a customised 2.1 and in order to do that i need amon ra installed, which i cant do unless my stupid laptop recognizes the 2.1 phone!!!!

anyway back on topic:P in my device manager (XP) i dont have 4 unknown devices as you mentioned in a post after this one, instead i have a single one, any ideas? and also where would the folder containing my drivers be?


ive attached a pic to help describe this problem, so which of the drivers installed on my laptop are tmobile ones?

thanks

also, if you look at the thread i linked you to earlier, ive uploaded some more pictures which show some errors im getting, id be grateful if you could spare your time to help poor old me out:)

Attached Files


Edited by h3dshot, 17 June 2010 - 08:00 PM.

  • 0

#46
raisin68

raisin68

    Newbie

  • Members
  • Pip
  • 1 posts

1. Open Device Manager
2. Right Click "Unknown Device" (you should have four of these)
3. Select update driver
4. Select install from a list or specific location and press Next
5. Select Don't search, I will choose the driver to install and press Next
6. Press Have Disk, browse to the folder where you extracted the drivers and select android_usb.inf
7. Press Next and installation should begin
8. Repeat 2-7 for each unknown device


Have XP. After step 7 I got the message "Given path doesn't contain data about hardware". What can I do?
Thx in advance!

  • 0

#47
ogiogi

ogiogi

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,351 posts
  • Gender:Male
  • Location:Skopje, Macedonia
  • Devices:HTC Desire
  • Twitter:@ogigoce

sorry for being such a pest but im desperate for a customised 2.1 and in order to do that i need amon ra installed, which i cant do unless my stupid laptop recognizes the 2.1 phone!!!!

anyway back on topic:P in my device manager (XP) i dont have 4 unknown devices as you mentioned in a post after this one, instead i have a single one, any ideas? and also where would the folder containing my drivers be?

Do you install the drivers when the phone is booted or in fastboot mode (blue screen)? The folder with the drivers is where you extracted the zip containing the drivers.

You should be installing the drivers when the phone is booted

You can see the four devices mentioned in the picture below

Attached File  Capture.JPG   70.24KB   189 downloads

  • 0

#48
h3dshot

h3dshot

    Diehard

  • Members
  • PipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:United Kingdom
  • Devices:Coolpad F1 8297w, SGS 2

Do you install the drivers when the phone is booted or in fastboot mode (blue screen)? The folder with the drivers is where you extracted the zip containing the drivers.

You should be installing the drivers when the phone is booted

You can see the four devices mentioned in the picture below

Attached File  Capture.JPG   70.24KB   189 downloads



a little progress, ive tried installing the drivers while phone is booted, now the drivers are visible on device manager, they arent however unknown devices, and each time i try to update i get the same error along the lines of the selected destination doesnt have any info on your hardware, im really baffled as to why this is.

the blue dots are the drivers im trying to update i get the same error for each of them when selecting the android_usb.inf and then clicking ok.
is there any other way of installing these drivers so windows doesnt interfere?

thanks

Attached Files


  • 0

#49
h3dshot

h3dshot

    Diehard

  • Members
  • PipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:United Kingdom
  • Devices:Coolpad F1 8297w, SGS 2
are you sure the xp drivers are for the x32 one instead of the x64 one?
that might be why im having trouble installing, either that or my desktop and laptop computers both hate me:p

  • 0

#50
ogiogi

ogiogi

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,351 posts
  • Gender:Male
  • Location:Skopje, Macedonia
  • Devices:HTC Desire
  • Twitter:@ogigoce

are you sure the xp drivers are for the x32 one instead of the x64 one?
that might be why im having trouble installing, either that or my desktop and laptop computers both hate me:p

Yeah. The drives installed correctly on 2 XP PC's, ADB and fastboot working. And there are no x64 XP drivers for the Pulse i think.

Try and uninstall everything. I mean all Pulse devices from device manager, PC Suite (delete the folder from program files too), delete all drivers and folders that you have downloaded. Restart the PC and make sure that you have 4 unknown devices in device manager with the phone booted. Then download the drivers and install.

  • 0

#51
h3dshot

h3dshot

    Diehard

  • Members
  • PipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:United Kingdom
  • Devices:Coolpad F1 8297w, SGS 2

Yeah. The drives installed correctly on 2 XP PC's, ADB and fastboot working. And there are no x64 XP drivers for the Pulse i think.

Try and uninstall everything. I mean all Pulse devices from device manager, PC Suite (delete the folder from program files too), delete all drivers and folders that you have downloaded. Restart the PC and make sure that you have 4 unknown devices in device manager with the phone booted. Then download the drivers and install.



ha your a mind reader! i was in the middle of doing that:)

have uninstalled pc suite and deleted drivers from device manager

gunna reinstall pc suite then not connect my pulse, go to program files and replace those drivers with 2.1 drivers
and hopefully that will work ;)

  • 0

#52
h3dshot

h3dshot

    Diehard

  • Members
  • PipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:United Kingdom
  • Devices:Coolpad F1 8297w, SGS 2
update: tried uninstalling tmob devices from device manager, uninstalled pc suite and deleted all folders and drivers of it, rebooted reinstalled pc suite>replaced drivers in programfiles-pcsuite>tried updating in dev manager and still same error box

also after that i repeated the uninstalls in dev manager and uninstalled pc suite deleting all folders and files again, this time i did not reinstall pc suite and just connected phone with unknown devices in dev manager, tried updating and again same errors...


does this mean ill have to wait for tmob uk to release an official 2.1 with official drivers?

  • 0

#53
ogiogi

ogiogi

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,351 posts
  • Gender:Male
  • Location:Skopje, Macedonia
  • Devices:HTC Desire
  • Twitter:@ogigoce

update: tried uninstalling tmob devices from device manager, uninstalled pc suite and deleted all folders and drivers of it, rebooted reinstalled pc suite>replaced drivers in programfiles-pcsuite>tried updating in dev manager and still same error box

also after that i repeated the uninstalls in dev manager and uninstalled pc suite deleting all folders and files again, this time i did not reinstall pc suite and just connected phone with unknown devices in dev manager, tried updating and again same errors...
does this mean ill have to wait for tmob uk to release an official 2.1 with official drivers?

There is a new PC Suite in the Hungarian update zip with new drivers.

  • 0

#54
h3dshot

h3dshot

    Diehard

  • Members
  • PipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:United Kingdom
  • Devices:Coolpad F1 8297w, SGS 2

There is a new PC Suite in the Hungarian update zip with new drivers.



ooooh i still have those files on my pc too! YOU ARE GOD:p

ill give it a bash and let you know how it goes thanks

  • 0

#55
h3dshot

h3dshot

    Diehard

  • Members
  • PipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:United Kingdom
  • Devices:Coolpad F1 8297w, SGS 2
eurghhhhhh!!

still doesnt recognise the phone when in bootloader

just looked in program files>driver > and theres no folder for xp, im assuming this means theres no drivers for xp?

  • 0

#56
ogiogi

ogiogi

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,351 posts
  • Gender:Male
  • Location:Skopje, Macedonia
  • Devices:HTC Desire
  • Twitter:@ogigoce

eurghhhhhh!!

still doesnt recognise the phone when in bootloader

just looked in program files>driver > and theres no folder for xp, im assuming this means theres no drivers for xp?

Yeap you're right. Just checked.

  • 0

#57
h3dshot

h3dshot

    Diehard

  • Members
  • PipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:United Kingdom
  • Devices:Coolpad F1 8297w, SGS 2

Yeap you're right. Just checked.



hahahaha:D my god! i think my pulse and computers both detest me:p

  • 0

#58
doggies

doggies

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Pulse
;) Thanks!!!

  • 0

#59
jackwang

jackwang

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:T-Mobile Pulse
Thanks, I will try it. :angry:

  • 0

#60
kijinobita

kijinobita

    Newbie

  • Members
  • Pip
  • 1 posts
thanks for share .................... :angry:

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users