Jump to content


Photo

19/Aug - Streak 1.6 downloads / how-tos (ROM / Superboot / Recovery)


  • Please log in to reply
205 replies to this topic

#21
Andy Garton

Andy Garton

    Newbie

  • Members
  • Pip
  • 45 posts
When following the above instructions on a Mac I get an error, but also some apparent success (!) - is this ok?

./install-recovery-mac.sh
ERROR: could not get pipe properties
sending 'recovery' (3034 KB)... OKAY
writing 'recovery'... OKAY

... the device then stayed at the "Download RECOVERY Done!" stage.

  • 0

#22
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,179 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
It worked. :)

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#23
gingernator

gingernator

    Enthusiast

  • Members
  • PipPipPip
  • 162 posts
  • Location:North West, UK
  • Devices:HTC Hero, Dell Streak
Hi Paul,

Firstly, thanks for all your hard work, I've lurked in the shadows of these forums for quite a while now but this is my first post. When I'm trying to install the recovery and root images on ubuntu and fastboot mode is showing on my streak, the terminal just says 'waiting for device'.

Any ideas?

Thanks

  • 0

#24
knightpants

knightpants

    Newbie

  • Members
  • Pip
  • 36 posts
Have you rebooted the streak into fastboot first before trying to apply the images?

I'm in ubuntu lucid x64 and everything working fine, however ADB not working for me, I believe this is a USB driver error... as I get the error "error: closed" whenever I run an ADB command, only command working is "adb devices" where it lists the device, but that's it.... :)

  • 0

#25
knightpants

knightpants

    Newbie

  • Members
  • Pip
  • 36 posts
ty ty :)

  • 0

#26
Orrwil

Orrwil

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:iPhone 3GS
  • Twitter:@Orrwil
Excellent!!

I'm another step closer to buying the Streak, where's my froyo ;-)

  • 0

#27
Ash_786

Ash_786

    Regular

  • Members
  • PipPip
  • 57 posts

Excellent!!

I'm another step closer to buying the Streak, where's my froyo ;-)


Lmao .... You asked the question that I daren't not ask !!!!!!

  • 0

#28
courtlandre

courtlandre

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Devices:HTC Evo, Samsung Focus

I cant install the driver for mine :)
When I try to install it I dont get the Android FastBoot option. I only get Android ADB Interface, Android Bootloader Interface or Android Composite ADB Interface?
can I use one of these?


I set it to bootloader mode and it worked just fine.

  • 0

#29
stuliv12

stuliv12

    Regular

  • Validating
  • PipPip
  • 121 posts
  • Location:london
  • Devices:Dell Streak
i have completed the instructions, fastboot_mode comes up i run install recovery windows, downloads and writes - OKAY , i hold both up+down vol keys choose option2 which is the update.pkg and all i get is a black screen ?

anyone else?

there isnt a file on my sdcard called update.pkg?

Edited by stuliv12, 11 June 2010 - 08:15 PM.

  • 0

#30
Warpedflash

Warpedflash

    Regular

  • Members
  • PipPip
  • 82 posts
  • Devices:Dell Streak

i have completed the instructions, fastboot_mode comes up i run install recovery windows, downloads and writes - OKAY , i hold both up+down vol keys choose option2 which is the update.pkg and all i get is a black screen ?

anyone else?

there isnt a file on my sdcard called update.pkg?


I am getting the same thing?

  • 0

#31
stuliv12

stuliv12

    Regular

  • Validating
  • PipPip
  • 121 posts
  • Location:london
  • Devices:Dell Streak
im not sure if this will help to find a problem, (i have run the root process) i downloaded telnet app, and i had connection refused, and to see if i could reach SU i downloaded titanium Backup and i was told i had to download a new version of busybox for it to run. Of which i did at then titanium was fine.

i tried to run the linux su in ubuntu to try and flash recovery but it wouldnt pick up my device, i just said waiting for device, when i was at the fastboot_mode.

may not help but thought id post this.

  • 0

#32
HorusUK

HorusUK

    Newbie

  • MoDaCo Silver
  • Pip
  • 29 posts
Smashing, Paul!

Today's the day I root my baby. :)

  • 0

#33
Loconinja

Loconinja

    Enthusiast

  • Members
  • PipPipPip
  • 238 posts
  • Location:Chiddingfold
  • Interests:Author of Mobile Signal Widget.
  • Devices:Samsung Galaxy S2, Omnia 7
  • Twitter:@alexroebuck
Does this work with Windows 7 64-bit, or will I need to use 32-bit XP or 7?

Edited to add: OK, worked fine on Win 7 64-bit. As above, when the Streak was displaying "Waiting for USB FastBoot connect...", I opened Device Manager, right-clicked "Android 1.0" and searched for and installed "Android Bootloader Interface". Windows gives you a nannying warning, but if you accept that, it works fine.

Edited by Loconinja, 13 June 2010 - 07:39 AM.

  • 0

#34
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,179 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Download updated, apologies!

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#35
Andy Garton

Andy Garton

    Newbie

  • Members
  • Pip
  • 45 posts
What has changed please? I assume I need it (I did apply the first one already)?

  • 0

#36
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,179 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
The first one didn't work. :)

The update still doesn't backup / restore firstboot, but it loads! :)

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#37
Techneut

Techneut

    Regular

  • Members
  • PipPip
  • 83 posts
  • Gender:Male
  • Location:Netherlands
  • Interests:Everything!
  • Devices:Dell Streak 5
Mediafire now tells me:

"Invalid or Deleted File
The key you provided for file download was invalid. This is usually caused because the file is no longer stored on Mediafire. This occurs when the file is removed by the originating user or Mediafire."

The mirror seems to work...

  • 0
Techneut®
Are you the dove or the statue?

#38
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,179 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Link typo fixed.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#39
knightpants

knightpants

    Newbie

  • Members
  • Pip
  • 36 posts
I'm getting the following files after a backup using nandroid;

boot
cache
data
nandroid.md5
recovery
system

Everything went smoothly.

  • 0

#40
SgtDavePwnage

SgtDavePwnage

    Regular

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:South Yorkshire, UK
  • Devices:HTC Dream, HTC Leo, HTC Desire
  • Twitter:@n/a

I'm getting the following files after a backup using nandroid;

boot
cache
data
nandroid.md5
recovery
system

Everything went smoothly.


Please don't start using nandroid for doing backups and restores

If Paul says its not working...its not working
The last thing we want are broken devices

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users