Jump to content


Photo

Help with LG Fathom VS750

- - - - -

  • Please log in to reply
4 replies to this topic

#1
Solus59

Solus59

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Omnia 910i
  • Twitter:@none
I know this is a brand new phone, but I'm looking to severely customize it. The phone itself is faster than any windows phone I have ever used, probably due to the 1ghz processor, but the main problem with it is that Verizon has nerfed the OS, as usual. Obviously they took out ICS, but also the conversation mode of the text messaging which I really liked on my Omnia. Is there a way I can import Internet Connection Sharing and other windows mobile standard items by copying files and using registry edits?

Thanks in advance for any help.


*Figured out the wifi and ICS, still need to find out how to do conversation mode for text messaging in place of their ArcSoft PowerMobia Message program. Help!

Edited by Solus59, 14 June 2010 - 07:56 PM.

  • 0

#2
Com32

Com32

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:LG Fathom
Im in exactly the same boat Solus59 is. LG made the worst windows mobile decision known to man and used the ArcSoft client for both MMS and SMS. I have futzed around w/ it since i bought the phone launch day to no avail. Couldnt they just have left well enough alone? the built in SMS client is light years ahead of this crap... I hope somebody more versed in WM haxing can come up w/ something at one point.

  • 0

#3
can90

can90

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:omniaII

Im in exactly the same boat Solus59 is. LG made the worst windows mobile decision known to man and used the ArcSoft client for both MMS and SMS. I have futzed around w/ it since i bought the phone launch day to no avail. Couldnt they just have left well enough alone? the built in SMS client is light years ahead of this crap... I hope somebody more versed in WM haxing can come up w/ something at one point.


Hi. You may try change this from the registry:
* Threaded SMS Input Space: if you using the default Tmail for Threaded SMS (and not some 3rd party program… I recently gave up on VITO SMS-chat after too many bugs/problems for me), you will notice that the space to input text is really too small. To change it, look for the file \Windows\thread_sms.htm You can open the file with Word Mobile to edit it:

Find the line <Inbox:content id="COMPOSESUBJECT" width="98%" height=35 spell ......>
and modify the value of height from 35 to 65 or 70, to get 3 line spacing for the input
Save the edited file somewhere and then use Total Commander or Resco Explorer to move it to Windows overwriting the old file.

* Using 3rd party programs as the default SMS

Go to: HKLM/Software/Microsoft/Shell/Rai/:MSINBOX
Change key 1 (default : Tmail.exe) with your software
---Example to use VITO SMS-Chat, change to: "\Program Files\VITO\SMS-Chat\SMSChat.exe"
---Example to use the Sms program from Resco Contact, change to: RPhoneMan -sms
By the way, if you also want to change to Resco Contact Manager change this key:
HKLM>Software>Microsoft>Shell>Rai>:MSCONTACTS
Change key labelled 1 to :RPMContacts

* Remove the Samsung skinned SMS application and SMS sent notification (this can be done with SKtools and AdvConfigTools too, after disabling Samsung SMS app.)

Go To: HKCU > Software > Microsoft > Inbox > MsgTypes > IPM > SMSText
Change: DLL value from mms.dll to htmlnote.dll
Soft reset and then
Go To: HKLM > Software > Microsoft > Inbox > Settings
Change: MMSNoSentMsg name to SMSNoSentMsg (just in case you have it)
Change: SMSNoSentMsg value to 1
Soft Reset

Note: can be done with SKtools too: TuneUp/Phone Edition/Do not show "Message sent" bubble

* Remove SMS sent notification without disabling the Samsung skinned SMS application (by AndrewTan, not tested myself yet)

Go to: HKEY_LOCAL_MACHINE\Software\Samsung\MMS\setting and change the value from 1 to 0 of
SMSForegegroundSend - disable sms/mms successful send notification
SMSDeliveryReport - disable delivery notification

(Thanks to tachan23 for making that wonderful guide.)

You can find the complete guide in here:
http://www.modaco.co...q/#entry1092923

The registries has to be very similar.

To make it clear, I guess this is the part that you need to disable the SMS application and bring the original Windows Mobile SMS skin:
* Remove the Samsung skinned SMS application and SMS sent notification (this can be done with SKtools and AdvConfigTools too, after disabling Samsung SMS app.)

Go To: HKCU > Software > Microsoft > Inbox > MsgTypes > IPM > SMSText
Change: DLL value from mms.dll to htmlnote.dll
Soft reset

Edited by can90, 27 June 2010 - 07:20 PM.

  • 0

#4
Com32

Com32

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:LG Fathom
Thanks for your response, however... i checked out the regkeys you noted and it seems that everything is as it should be. Even...

Go to: HKLM/Software/Microsoft/Shell/Rai/:MSINBOX
Change key 1 (default : Tmail.exe) with your software
---Example to use VITO SMS-Chat, change to: "\Program Files\VITO\SMS-Chat\SMSChat.exe"
---Example to use the Sms program from Resco Contact, change to: RPhoneMan -sms
By the way, if you also want to change to Resco Contact Manager change this key:
HKLM>Software>Microsoft>Shell>Rai>:MSCONTACTS
Change key labelled 1 to :RPMContacts

Points to Tmail.exe, which is ultra strange. how does windows know to call this app when an SMS comes in? lol

how does WinMo know what to do when an SMS comes in? is it a URI or...? nothing seems to point at the "messages.exe" of that app... which leads me to believe that Tmail might actually be getting the SMS, then this just intercepts its index or library...

  • 0

#5
WaltA

WaltA

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:Touch Pro

*Figured out the wifi and ICS, ...


Could you please let us know what you figured out?

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users