Jump to content


Photo

Easy Set S3Clock

* * * * * 1 votes

  • Please log in to reply
75 replies to this topic

#61
daskalos

daskalos

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,297 posts
  • Devices:LG Expo,Samsung Omnia i900
  • Twitter:@E1i077

hi daskalos,

just want to confirm that do i need to keep the FPU enabler running?
Quote :

How to use:
1. Install in Device. In Samsung Settings, Set Performance at Auto or High.
2. Open Easy Set S3Clock.
3. If this is the first time you will overclock (or your device came from fresh soft reset), tap FPUEnabler and tap patch then tap OK
............


No, you just need to patch one time


Hey daskalos, can you post which registry keys are changed with Easy Set S3Clock so we can set values to S3Clock manually?


HKCU\Software\S3clock

  • 0
Like my ROMs?

There are many ways to say thank you, one way is by clicking below









Posted Image

#62
HESAM1

HESAM1

    Newbie

  • Members
  • Pip
  • 5 posts
hi
is there any way to use this outstanding tool on wm 6.5.3 ?

  • 0

#63
sakisds

sakisds

    Enthusiast

  • Members
  • PipPipPip
  • 199 posts
  • Gender:Male
  • Location:Athens, Greece
  • Devices:Samsung Nexus S

No, you just need to patch one time
HKCU\Software\S3clock


Thanks a lot, I tried messing with the values and i have a question. What does MPLL change? Usually when I set it over 280 I get strange artifacts on the screen. Just wondering what it does.

  • 0

#64
youngdosha31

youngdosha31

    Newbie

  • Members
  • Pip
  • 3 posts
Awesome app. just tried it out and when I set it to 954mhz and the checker board pattern you see in opera 9 when you scroll up and down the web page only flashes now instead of hanging and waiting for the screen to catch up. Great app.

  • 0

#65
daskalos

daskalos

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,297 posts
  • Devices:LG Expo,Samsung Omnia i900
  • Twitter:@E1i077

Thanks a lot, I tried messing with the values and i have a question. What does MPLL change? Usually when I set it over 280 I get strange artifacts on the screen. Just wondering what it does.


Hmmm

From what I understand our processor have 3 PLL (phase lock loop) or generated clocks that control the whole hardware system in groups

APLL which generates the ARM operating clock (S3C6410 processor)
MPLL which generates the main system clocks
EPLL which generate the clocks used for peripheral IPs (whatever that means B) )

When we adjust APLL it raises/lowers our processor's clock (which is by advertised, 800Mhz)

When we adjust MPLL it raises/lowers bus speed or the data connection speed of the processor to it's hardware components (like the AMOLED screen) so raising it might make some hardware became glitchy. Other hardware might benefit from it and others may not (like the AMOLED screen).

  • 0
Like my ROMs?

There are many ways to say thank you, one way is by clicking below









Posted Image

#66
sakisds

sakisds

    Enthusiast

  • Members
  • PipPipPip
  • 199 posts
  • Gender:Male
  • Location:Athens, Greece
  • Devices:Samsung Nexus S

Hmmm

From what I understand our processor have 3 PLL (phase lock loop) or generated clocks that control the whole hardware system in groups

APLL which generates the ARM operating clock (S3C6410 processor)
MPLL which generates the main system clocks
EPLL which generate the clocks used for peripheral IPs (whatever that means :) )

When we adjust APLL it raises/lowers our processor's clock (which is by advertised, 800Mhz)

When we adjust MPLL it raises/lowers bus speed or the data connection speed of the processor to it's hardware components (like the AMOLED screen) so raising it might make some hardware became glitchy. Other hardware might benefit from it and others may not (like the AMOLED screen).


Ok, thanks a lot for the information. B)

  • 0

#67
fubo

fubo

    Regular

  • Members
  • PipPip
  • 146 posts
  • Gender:Male
  • Devices:Samsung Galaxy S2 GT-I9100

Ok, thanks a lot for the information. B)

Here it seems it does not work (WM 6.5.3.23148). I tried different APLL settings (modifying register entries) but SKTools gives me always same result.
Executing S3Clock does not give me any windows, so I suppose it's not opening, right?

Edited by fubo, 20 November 2010 - 11:41 AM.

  • 0
My works:

---< DONATE >---
Thx to everyone!


#68
sakisds

sakisds

    Enthusiast

  • Members
  • PipPipPip
  • 199 posts
  • Gender:Male
  • Location:Athens, Greece
  • Devices:Samsung Nexus S

Here it seems it does not work (WM 6.5.3.23148). I tried different APLL settings (modifying register entries) but SKTools gives me always same result.
Executing S3Clock does not give me any windows, so I suppose it's not opening, right?


1) Run Easy Set S3Clock
2) Run FPU Enabler.
3) Press Patch and wait for it to finish.
4) Close FPU Enabler.
5) If you want the FPU chip to be enabled, do 3 and 4 again.
6) Select your clock speed.
7) Run S3Clock.
8) Press Set CPU speed. (And I suggest you check the checkbox)
9) Press hide.

If you want to set the speed again, run S3Clock, press quit, set new speed and run again.

First posts says it cleary I think.

  • 0

#69
fubo

fubo

    Regular

  • Members
  • PipPip
  • 146 posts
  • Gender:Male
  • Devices:Samsung Galaxy S2 GT-I9100

1) Run Easy Set S3Clock
2) Run FPU Enabler.
3) Press Patch and wait for it to finish.
4) Close FPU Enabler.
5) If you want the FPU chip to be enabled, do 3 and 4 again.
6) Select your clock speed.
7) Run S3Clock.
8) Press Set CPU speed. (And I suggest you check the checkbox)
9) Press hide.

If you want to set the speed again, run S3Clock, press quit, set new speed and run again.

First posts says it cleary I think.

FPU Enabler does nothing.

  • 0
My works:

---< DONATE >---
Thx to everyone!


#70
sakisds

sakisds

    Enthusiast

  • Members
  • PipPipPip
  • 199 posts
  • Gender:Male
  • Location:Athens, Greece
  • Devices:Samsung Nexus S

FPU Enabler does nothing.


Are you running a ROM based on JH2? I think thats the problem with a lot Omnia II users, because I worked for any 6.5.3 rom based on JC2/JE2 I tried.

  • 0

#71
Twomix

Twomix

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:i8000 omnia ii
CMIIW, when i enable FPU enabler, the battery drains so fast
the CPU performance was set to auto.
Does it use auto mhz, or stays in 954mhz (on idle) ?

  • 0

#72
fubo

fubo

    Regular

  • Members
  • PipPip
  • 146 posts
  • Gender:Male
  • Devices:Samsung Galaxy S2 GT-I9100

Are you running a ROM based on JH2? I think thats the problem with a lot Omnia II users, because I worked for any 6.5.3 rom based on JC2/JE2 I tried.

Yes JH2 based as per my signature. So up to JE2 it worked. I should check for coredll.dll of that build.

  • 0
My works:

---< DONATE >---
Thx to everyone!


#73
reaper83

reaper83

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Devices:htc touch diamond p3700
Runs great on I8000; 900 mhz perfect stability, 945 mhz with ocasional incidents (I`m keeping it at 945 :) )
It allso speeds up sense animations.

Thank you.

Edited by reaper83, 11 December 2010 - 10:34 AM.

  • 0

#74
BLEK0TA

BLEK0TA

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Bratislava
  • Devices:omnia II
daskalos u r numero uno mastero :)

thanks for gr8 job u do..
many many thanks..

i running on 1ghz and i woul like ock to higher speed cuz 1ghz is stable for me and only one problem i have on thees speed is sometimes i cant hide your soft and in main menu i have on right side SHOW button.. but for that high speed is this little bug, and it worth for that speed..

i woul like to ock on higer speed mayby 1,1ghz.. is there any possibility to the higher speed? I think the registry editing.. or something...

  • 0

#75
Eer210

Eer210

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:ETEN DX900
Hello Daskalos, Thanks for the overclocking tool.

I tried it on my DX900 with s3c 6400 processor but it looks like the processor speed is decreased by 20 times. I can push the buttons but have to wait a long time. In the task manager I can see the task using all the processor resources. The phone is very unresponsive on all actions when the program program is running.
I did do the patch. The result was that 13 tweaks where not positive so where rest to the old value. Then I tried to set the default processor speed but this was not working. Also pushing on of the buttons e.g. 650MHz was no effect visible.

Do you have any idea's?

  • 0

#76
Eer210

Eer210

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:ETEN DX900
I have some new info, the tool in not working because the GPIOgfx is making my machine very slow.

I just installed the S3clock 1.10 from http://tanguy.ath.cx/?q=GPIOgfx and now it's working. The maximum speed is arround 650 MHz.

The change is only the main processor speed: APLL on this moment. It doesn't allow me to change the MPLL value...

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users