Jump to content


Photo

15/Jan [GUIDE] Installing the MoDaCo Custom Froyo ROM from scratch (and other ROMS)

* * * * * 18 votes

  • This topic is locked This topic is locked
673 replies to this topic

#61
nick_sub

nick_sub

    Regular

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Devices:ZTE Blade (OLED), ZTE Skate
Thanks for this Stephen. Just been through the process and, combined with the links to other thread and Paul's video it all worked fine. I'm sure it would have taken twice as long without this guide - keep up the good work!

  • 0

#62
judoblo

judoblo

    Newbie

  • Members
  • Pip
  • 1 posts
Just a quick thank you for this excellent guide. Managed to go through it step by step without a hitch - and I've never had a smartphone before!

  • 0

#63
bignred84

bignred84

    Regular

  • Members
  • PipPip
  • 51 posts
  • Gender:Male

Clockwork mod. Gives you a safety net when you are doing future updates. The recovery boot part of the phone's Rom is separate from the normal boot part. When you install clockwork mod you replace the recovery boot with a much more usefull tool.



have followed the instructions for the clockwork mod, looked liked the picture/screenshot above in post 53

after the last option of fastboot

what is supposed to happen??? mine appeared to power up (is this correct)

are there any notable differences, are there any new files/folders on the sd card ??

thanks

  • 0

#64
mELIANTE

mELIANTE

    Diehard

  • Members
  • PipPipPipPip
  • 440 posts
  • Location:Portugal
  • Devices:Little SanFran
Can this guide be used to flash other ROMs, say, sebastian404's r4?

  • 0
ZTE Blade CM7 "Gen2ed" OLED.

#65
nick_sub

nick_sub

    Regular

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Devices:ZTE Blade (OLED), ZTE Skate

Can this guide be used to flash other ROMs, say, sebastian404's r4?

Yes, I did it yesterday and it worked perfectly.

  • 0

#66
mELIANTE

mELIANTE

    Diehard

  • Members
  • PipPipPipPip
  • 440 posts
  • Location:Portugal
  • Devices:Little SanFran

Yes, I did it yesterday and it worked perfectly.

Just gotta swap step 3's file with 404's file right?
Forgive the noob question, but I'm a complete noob regarding to Android. :)

  • 0
ZTE Blade CM7 "Gen2ed" OLED.

#67
wadge

wadge

    Newbie

  • Members
  • Pip
  • 5 posts
Thanks...got there.

  • 0

#68
kissofjudas

kissofjudas

    Newbie

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:uk
  • Devices:SE Xperia Arc
going ok up to now report back in a minute - looks like I followed the instructions ok THANKS To All Involved

Edited by kissofjudas, 14 October 2010 - 08:57 PM.

  • 0

#69
nick_sub

nick_sub

    Regular

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Devices:ZTE Blade (OLED), ZTE Skate

Just gotta swap step 3's file with 404's file right?
Forgive the noob question, but I'm a complete noob regarding to Android. :)

Yes, that's right. The process is exactly the same.

  • 0

#70
mELIANTE

mELIANTE

    Diehard

  • Members
  • PipPipPipPip
  • 440 posts
  • Location:Portugal
  • Devices:Little SanFran

Yes, that's right. The process is exactly the same.


Nice! Gonna flash me some android!! :)

Thank you.

  • 0
ZTE Blade CM7 "Gen2ed" OLED.

#71
mephestic

mephestic

    Newbie

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Location:Leicestershire
all seems a bit scary.

im completely new to this whole thing and quite inexperienced and dont want to risk bricking my new phone :S

is it as easy as this makes out? :S

Also what further options become available once rooted? what more can i do with it that I cant out the box and unlocked?

Sorry for the n00b questions :)

  • 0

Running: ZTE Orange San Francisco with R3 Modaco Rom


#72
papasmurfster

papasmurfster

    Newbie

  • MoDaCo Silver
  • Pip
  • 3 posts
  • Devices:htc desire
great guide, worked perfect.

thankyou

  • 0

#73
StevenHarperUK

StevenHarperUK

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 1,431 posts
  • Gender:Male
  • Location:United Kingdom
  • Devices:Orange San Francisco

great guide, worked perfect.

thankyou



Should I make this post a little more Vanilla and cover Sebastian404's de-orangeated ROM also?

Or should I make another Thread for that?

  • 0

#74
mephestic

mephestic

    Newbie

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Location:Leicestershire
Edit:

Just to update - I finally did it!

It seems the problem everyone is having with the "waiting for device" on windows is the drivers are messing up when using bootloader mode and recovery mode.

These drivers fixed the problem (mostly anyways): http://android.modac...rivers-and-adb/

It worked after I installed that driver for the second device on my device manager.

This allowed bootloader mode to be recognised as prior windows would not pick it.

Once updated I followed the instructions exactly upto stage 3. On the clockwork recovery again this problem resurfaced and I couldnt transfer the modaco custom rom over because the laptop wouldnt let me mount while it was in the menu....luckily I have a microSD card adapter and I simply used that to transfer the modaco rom over and put the sdcard back into the phone and just followed the steps...It worked.

The phone started off slow but seems quicker than before.

I would advise noobs like myself out there that wish to do this, read everything very carefully and make sure firstly the drivers are installed correctly and you see your device manager pick up:

*Android ADB interface
*Android Composite ADB interface

You need both otherwise bootloader mode wont work.

Hope this helps...damn its 2am in the morning...time for sleep.

Steve - many thanks for your help, it was invaluable and also my thanks to paul...wherever he is..

  • 0

Running: ZTE Orange San Francisco with R3 Modaco Rom


#75
rbbrslmn

rbbrslmn

    Diehard

  • Members
  • PipPipPipPip
  • 305 posts
thanks for this, followed the steps for rooting and installing clockwork mod, now waiting for r4 to be more widely available (or anything with apps2sd already in)

  • 0

#76
goods

goods

    Regular

  • Members
  • PipPip
  • 54 posts
Downloaded drivers from different location, same thing, still can't get "Android ADB interface" in device manger, what would be the reason for this?

  • 0

#77
stoge

stoge

    Newbie

  • Members
  • Pip
  • 12 posts
  • Devices:ORANGE SAN FRANCISCO

If you use this guide and it works, please give me a post so I can see that it's doing it's job.

Also if you spot any typo's - or get stuck because something wasn't clear - please post also.

ta


thanks great guide.

btw.. i had the 'waiting for device' problem like others so i unpluged the usb lead to the computer and used another usb slot.... next thing i new it had written the data.

  • 0

#78
StevenHarperUK

StevenHarperUK

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 1,431 posts
  • Gender:Male
  • Location:United Kingdom
  • Devices:Orange San Francisco
Updated to support all known ROMS that are Clockwork Mod installable.

  • 0

#79
Terry W

Terry W

    Newbie

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Bristol, UK
  • Devices:Orange San Francisco
  • Twitter:@tezza73uk
Hi, I'm a newbie and finding my way around. Picked up a San Fran yesterday and am keen to wipe the Orange branding, root and load r4 mod.

So I noticed ClockworkMod Recovery was needed. So I tried to flash it but it hung at "waiting for device", so I installed the drivers(!) but now my SanFran will not boot to the Green Android. Instead, when I hold the Vol+ and power up, it boots normally!?

Wonder if I should have loaded r3 first before trying ClockworkMod Recovery? Help please, how can I get it to stick with the Green Android so I can flash the r3 ROM first?

Cheers
Terry.

  • 0

#80
StevenHarperUK

StevenHarperUK

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 1,431 posts
  • Gender:Male
  • Location:United Kingdom
  • Devices:Orange San Francisco

Hi, I'm a newbie and finding my way around. Picked up a San Fran yesterday and am keen to wipe the Orange branding, root and load r4 mod.

So I noticed ClockworkMod Recovery was needed. So I tried to flash it but it hung at "waiting for device", so I installed the drivers(!) but now my SanFran will not boot to the Green Android. Instead, when I hold the Vol+ and power up, it boots normally!?

Wonder if I should have loaded r3 first before trying ClockworkMod Recovery? Help please, how can I get it to stick with the Green Android so I can flash the r3 ROM first?

Cheers
Terry.


Did you follow the guide at the top of the thread?
Did you do step1 - Superboot?
Have you got the Superuser app in your App Drawer?

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users