Jump to content


Photo

28/Oct r4b gforums Custom Rom FroYo for ZTE blade (Alpha!)

* * * * * 1 votes

  • Please log in to reply
251 replies to this topic

#221
fryguyse

fryguyse

    Newbie

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Devices:SF Blade

Because, as it says in several places in this thread and others, not all MP3's play in froyo. Converting to ogg does work. Many thanks to OP.


Oki sorry missed that.

  • 0

#222
schkinx

schkinx

    Enthusiast

  • Members
  • PipPipPip
  • 181 posts
  • Gender:Male
  • Location:england
  • Devices:xolo x900 .. Nexus 7 cm10
should i start i thread of its own for this find ??

  • 0

#223
mattlcfc

mattlcfc

    Newbie

  • Members
  • Pip
  • 47 posts
  • Devices:san fransisco
hi using this in a day to day basis and after adding theme and playing am more than happy with it
wifi issue has cured itself as has dial usage ?
got the hte keybord working and gps does kick in after a while (usually a minute or two) not ideal but suits me as dont use it much
couldnt care for mp3 or radio so not concerened about those
need to sort flash player(not available on market)
fast rom and stability is top notch
battery life is hit and miss and i never use 3g (battery eater)or anything that i dont need and can manage a day and a bit (no worse than 2.1 imho)
could do with more battery life but you can only blow all the wistles if you have enough puff??

i carry a little nokia with a little credit incase of emergency but will be getting a car charger and extra battery soon
if anyone can help with the above gripes please let me know


cheers

matt


Swype sorted thanks to a helping hand from a comrade on here thanks

Edited by mattlcfc, 10 November 2010 - 09:40 AM.

  • 0

#224
siwi

siwi

    Newbie

  • Members
  • Pip
  • 6 posts

  • With the device on, charge to 100% (until the red LED turns green).
  • Unplug the device and turn it off.
  • Charge the device until the red led turns green (took another 45 minutes for me).
  • Unplug the device and turn it on.
  • Wait for the device to fully boot then turn it off.
  • Charge the device until the red led turns green (took another 20 minutes for me).
The following is not from the thread but just what I added from various forum posts.
  • Boot into clockwork recovery mod and go to advanced -> wipe battery stats.
  • Reboot device.
  • Run device down until it powers off before charging.


the wipe has to be done after the charges or before?

Edited by siwi, 09 November 2010 - 09:30 PM.

  • 0

#225
Ally Weir

Ally Weir

    Newbie

  • Members
  • Pip
  • 33 posts
Can the maker of this thread please keep their original post updated with all the information. It is difficult to understand all the information in a badly organised way.


thanks, great work,
ally.

  • 0

#226
factro

factro

    Enthusiast

  • Members
  • PipPipPip
  • 194 posts
  • Gender:Male
  • Location:England
  • Devices:Orange San Francisco
for me everything works just fine..youtube was not working so i delete it and install new one and its working with that green line above every video, but i dont like the icon that are in this version its not default icons..newy..there r few other application which are working partially like audioanywhere..i used this to listen BBC documenty podcast it used to work very nicely in 2.1(update)..but in 2.2 it runs but it dont play podcast at all??..idk why its happening..and same goes to other audio podcast player

Edited by factro, 12 November 2010 - 05:20 PM.

  • 0

#227
SWOriginal

SWOriginal

    Diehard

  • Members
  • PipPipPipPip
  • 341 posts
  • Location:Essex, London
  • Devices:ZTE Blade, Advent Vega
  • Twitter:@@SW0riginal
Anyone know the name of the news application in this rom? would love it on 2.1 but cant figure out which application itis in /system/app

  • 0

#228
gforums

gforums

    Regular

  • Members
  • PipPip
  • 120 posts
  • Gender:Male
  • Location:Germany
  • Devices:null

Anyone know the name of the news application in this rom? would love it on 2.1 but cant figure out which application itis in /system/app


think you mean "geniewidget" which is googles news/weather app!

  • 0

#229
SWOriginal

SWOriginal

    Diehard

  • Members
  • PipPipPipPip
  • 341 posts
  • Location:Essex, London
  • Devices:ZTE Blade, Advent Vega
  • Twitter:@@SW0riginal

think you mean "geniewidget" which is googles news/weather app!

Thanks, works great

  • 0

#230
spicysomtam

spicysomtam

    Regular

  • Members
  • PipPip
  • 72 posts
  • Gender:Male
  • Devices:G300, IMobile IQ 5.1
  • Twitter:@amunro
I would just like to say thanks to everyone who has worked on this 2.2 Alpha rom and 2.2 issues in general. Really appreciate the effort.

Just some feedback from me. I downloaded and installed the version from post #1. Most of the issues reported are fixed in this release; I suspect the zip has been updated. Only issues I encountered:
  • YouTube didn't work. Removed and downloaded from Market. Now have HD youtube :rolleyes:
  • Acrobat Reader didn't work. Removed this and have not reinstalled yet. Will wait until I need to read a pdf.
  • Su access seemed to work straight off. No problems with Titanium backup registering itself as a su app. I changed permissions on su via adb just in case.
  • GPS works fine.
  • Dialer issue using battery in the battery usage menu. However, is it really using battery since battery performance seems fine?
  • Wifi still has some problems, but seems slightly different to 2.1 roms. Seems to have more problems maintaining a connection/poor signal. However the wifi dropping due to screen sleep seems less of a problem (which was really bugging me; waiting for the wifi to reconnect). Blade wifi fix from the market helps.
  • Minor issue: web browser home page goes to a Chinese site (why?). Might be worth pointing this at google.com when someone has a spare moment. I was worried it might be collecting stats from me, etc, but since I just reflashed the phone, there is nothing to steal from me apart from the gmail signon!
  • I followed advice on signing into gtalk/gmail/market using a mobile connection, then switched to wifi. No probs with this.
  • No one has mentioned this: camera and video apps seem much better. Also many more settings to play with to get best picture/video.
Conclusion: a pretty painless upgrade to Froyo and worth the effort. If you want Andriod 2.2 I highly recommend this rom!!! I also think you are not far off from a proper release.

Also maybe this topic should be pinned now?

Edited by spicysomtam, 14 November 2010 - 09:20 AM.

  • 0

#231
miali

miali

    Newbie

  • MoDaCo Silver
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Southampton, UK
  • Devices:San Francisco

I would just like to say thanks to everyone who has worked on this 2.2 Alpha rom and 2.2 issues in general. Really appreciate the effort.

Just some feedback from me. I downloaded and installed the version from post #1. Most of the issues reported are fixed in this release; I suspect the zip has been updated. Only issues I encountered:

  • YouTube didn't work. Removed and downloaded from Market. Now have HD youtube :rolleyes:
  • Acrobat Reader didn't work. Removed this and have not reinstalled yet. Will wait until I need to read a pdf.
  • Su access seemed to work straight off. No problems with Titanium backup registering itself as a su app. I changed permissions on su via adb just in case.
  • GPS works fine.
  • Dialer issue using battery in the battery usage menu. However, is it really using battery since battery performance seems fine?
  • Wifi still has some problems, but seems slightly different to 2.1 roms. Seems to have more problems maintaining a connection/poor signal. However the wifi dropping due to screen sleep seems less of a problem (which was really bugging me; waiting for the wifi to reconnect). Blade wifi fix from the market helps.
  • Minor issue: web browser home page goes to a Chinese site (why?). Might be worth pointing this at google.com when someone has a spare moment. I was worried it might be collecting stats from me, etc, but since I just reflashed the phone, there is nothing to steal from me apart from the gmail signon!
  • I followed advice on signing into gtalk/gmail/market using a mobile connection, then switched to wifi. No probs with this.
  • No one has mentioned this: camera and video apps seem much better. Also many more settings to play with to get best picture/video.
Conclusion: a pretty painless upgrade to Froyo and worth the effort. If you want Andriod 2.2 I highly recommend this rom!!! I also think you are not far off from a proper release.

Also maybe this topic should be pinned now?


I second what spicysomtam has said about this 2.2 update. I have been using it for over 2 weeks now and its working just great. Also thanks to nicksoph for posting the fixes.

  • 0

#232
Totyasrác

Totyasrác

    Addict

  • MoDaCo Silver
  • PipPipPipPipPip
  • 545 posts
  • Gender:Male
  • Location:Bp.
  • Devices:HTC Desire / MildWild CM 2.9
Hi there!

Just installed this on my SanFran - first impressions: awesome!!! Cheers for all that made this available for my phone.
I'll do some search if there's an answer but I only found one issue: APNs can not be edited.
(I have to set MMS auth type to PAP but there's just no way I could edit any APNs... T-Mobile Hungary)

Edit: nothing about this in this topic. Anyone could tell me how I have to edit the appropriate xml please?
(Actually how should I edit the line belonging to T-Mo HU MMS APN)

Edited by Totyasrác, 14 November 2010 - 04:24 PM.

  • 0

#233
misterLjay

misterLjay

    Regular

  • MoDaCo Silver
  • PipPip
  • 73 posts
  • Gender:Male
  • Location:London
  • Devices:ZTE Blade

Hi there!

Just installed this on my SanFran - first impressions: awesome!!! Cheers for all that made this available for my phone.
I'll do some search if there's an answer but I only found one issue: APNs can not be edited.
(I have to set MMS auth type to PAP but there's just no way I could edit any APNs... T-Mobile Hungary)

Edit: nothing about this in this topic. Anyone could tell me how I have to edit the appropriate xml please?
(Actually how should I edit the line belonging to T-Mo HU MMS APN)


Download APN Backup & Restore from the market. Using the app delete the APNs and then you can enter the required APN settings for MMS and GPRS. Then back them up using the app (backs up to the sd card)

  • 0

#234
finbaar

finbaar

    Regular

  • Members
  • PipPip
  • 110 posts
  • Devices:Orange San Francisco

for me everything works just fine..youtube was not working so i delete it and install new one and its working with that green line above every video, but i dont like the icon that are in this version its not default icons..newy..there r few other application which are working partially like audioanywhere..i used this to listen BBC documenty podcast it used to work very nicely in 2.1(update)..but in 2.2 it runs but it dont play podcast at all??..idk why its happening..and same goes to other audio podcast player


Podcasts are a deal breaker for me. If they can be made to work with this Rom then I will give it a go. Anyone got any ideas?

  • 0

#235
factro

factro

    Enthusiast

  • Members
  • PipPipPip
  • 194 posts
  • Gender:Male
  • Location:England
  • Devices:Orange San Francisco

Podcasts are a deal breaker for me. If they can be made to work with this Rom then I will give it a go. Anyone got any ideas?

ya me too..but i got another solution..or work around for a while..i use a podcast apps like greader or doggcatcher and download my podcast and use poweramp to play it..but takes time :huh:..but there is another problem idk if ne1 notice this or not..but my phone goes automatic to slients after 11pm(idk exact time but at nite)..its good in some way not in other way like whn gf is callin u at nite..:rolleyes:..newy also whn i manually keep the phone in silent mode or vibration mode its keep changing after a while..and rings???..

  • 0

#236
alasota

alasota

    Newbie

  • MoDaCo Silver
  • Pip
  • 15 posts
Stable ROM for me since I put it on. Usual fixes, but strangely kept having problems with Chomp SMS (freezing with white screen?) so moved to Handcent. Seems better so far.

This is my standard daily build and I like it a lot! Thanks for sorting it. I strongly recommend you give it a go!

  • 0

#237
spicysomtam

spicysomtam

    Regular

  • Members
  • PipPip
  • 72 posts
  • Gender:Male
  • Devices:G300, IMobile IQ 5.1
  • Twitter:@amunro
I worked out what is causing the high battery usage on Dialer. This rom has this issue. If you kill the messages process, the Dialer battery usage drops. Actually drops quite quickly. So Dialer was 97% battery usage. A couple of minutes after killing messages, dropped down to 60%, with Andriod system battery usage increasing (what you would expect). Reason I found it is I googled for the issue, and came across a similar issue with the htc hero. With this issue they recommended you disable notifications within Messages. However this does not work with the Blade; guess its looping checking for new messages, but not as drastically as on the hero. Messages process actually needs to be terminated. I wonder if someone can look into updating the messages app to a later release from Froyo main release tree? Or temporarily disabling its startup and maybe use a messaging app from the market until someone can fix it?

If we can resolve this issue, then as far as I can see this seems to be the only MAJOR issue with this rom. Battery is much reduced compared to the 2.1 stock roms.

http://androidforums...t-lets-fix.html

  • 0

#238
MIKEYMC

MIKEYMC

    Regular

  • MoDaCo Silver
  • PipPip
  • 140 posts
  • Location:Lowestoft, UK
  • Devices:Orange San Francisco
Just checked battery status and it didn't mention the dialer. It did earlier though with the 98% usage.

  • 0
XBL & PSN ID MIKEYMCC

#239
spicysomtam

spicysomtam

    Regular

  • Members
  • PipPip
  • 72 posts
  • Gender:Male
  • Devices:G300, IMobile IQ 5.1
  • Twitter:@amunro
Not sure if Messages is the whole story. Now its 75% Dialer and 25% Andriod. If I download Spare Parts, the Sensor battery usage mirrors the overall battery usage. Maybe the sensor code is not working correctly? Can it be disabled? Assume this is the light sensor for whether the phone is next to your face or not? Anyhow battery usage is much better now. I would need to go back to 2.1 to compare; maybe do a backup and restore my 2.1.

  • 0

#240
chall32

chall32

    Enthusiast

  • Members
  • PipPipPip
  • 181 posts
So if dialer is the culprit, and Dialer comes from phone.apk, (correct me if I'm wrong here!) what happens if you replace phone.apk with a version from, say a Nexus One Froyo ROM?

Would that be Bad?

How about replacing the SanFran / Blade Froyo phone.apk with the stock Éclair / 2.1 version from Orange / ZTE source?

Just shooting the breeze here..... :rolleyes:

  • 0
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users