Jump to content


Photo

Re-installing / enabling Flash on the Vega


  • Please log in to reply
106 replies to this topic

#1
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,220 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Flash support on the Vega seems a little strange. Strange in the way it's installed and strange in itself.

Upgrading or updating seems to occasionally break Flash support in the browser, as does installing an updated version from the Market (the Vega seems to have an accelerated version specifically for the Tegra hardware).

If Flash has stopped working on your machine, the fix is super easy!

Simply browse in iFileManager on the device to /system/etc/shuttle_priv and click on the APK file to install.

DONE! :P

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#2
5c00ter

5c00ter

    Regular

  • MoDaCo Silver
  • PipPip
  • 90 posts
  • Devices:Advent Vega, ZTE Blade
  • Twitter:@5c00ter
Excellent stuff. I've now got it working. :P true hero !!

  • 0

#3
unclebob31

unclebob31

    Regular

  • MoDaCo Silver
  • PipPip
  • 52 posts
  • Devices:Samsung Galaxy S

Flash support on the Vega seems a little strange. Strange in the way it's installed and strange in itself.

Upgrading or updating seems to occasionally break Flash support in the browser, as does installing an updated version from the Market (the Vega seems to have an accelerated version specifically for the Tegra hardware).

If Flash has stopped working on your machine, the fix is super easy!

Simply browse in iFileManager on the device to /system/etc/shuttle_priv and click on the APK file to install.

DONE! :P

P


Thanks Paul. iplayer works...usual network issues for me lol

  • 0

#4
Carbonize

Carbonize

    Diehard

  • Members
  • PipPipPipPip
  • 413 posts
  • Gender:Male
  • Location:Bristol, UK
  • Interests:(X)HTML, CSS, PHP, JavaScript, working out and reading.
  • Devices:ZTE Blade(CM7 N257+ KANG)
  • Twitter:@carbonize
I thought BBC iPlayer was supposed to be getting HTML5 Video tag support?

  • 0
<strong class='bbc'>C a r b o n i z e</strong>

<strong class='bbc'><em class='bbc'>Do or do not, there is no try.</em> - Yoda</strong>

#5
tonyyeb

tonyyeb

    Addict

  • MoDaCo Silver
  • PipPipPipPipPip
  • 613 posts
  • Gender:Male
  • Location:Hull, UK
  • Devices:HTC Desire, iPad
  • Twitter:@tonyyeb
Thanks Paul, working a treat!

  • 0
Vega Battery For Sale: eBay
Vega Power Supply For Sale: eBay

#6
logicalstep

logicalstep

    Newbie

  • Members
  • Pip
  • 8 posts
ha ha, was wondering what happened after the updates :P

Many thanks Paul, my Mrs was about to brain me for tampering!

Logicalstep

  • 0
Phones: Mpx 200 mpx 220 (wish i hadn't but loved it) SPV C500, O2 XDA IQ and M700 (current)

#7
@dap

@dap

    Newbie

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:London, UK
  • Devices:LG O2X, ADVENT Vega
  • Twitter:@derekp

If Flash has stopped working on your machine, the fix is super easy!

Simply browse in iFileManager on the device to /system/etc/shuttle_priv and click on the APK file to install.

DONE! :P

P


Fantastic! Works a treat -thanks!

  • 0

#8
Dentist Jed

Dentist Jed

    Newbie

  • MoDaCo Silver
  • Pip
  • 20 posts
Thanks Paul, you are indeed the Vega God.

  • 0

#9
royalhornet

royalhornet

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:Mac XPS1730 Advent Vega
Hi Gang

Please can you help me, My Flash stopped several days ago... I've followd Pauls instructions using Astro File Manager device to /system/etc/shuttle_priv. Theres only on file in there "libflashplayer_froyo v10.1.95.18_signed. I click it then have the option to Browse or Open App. Clicking Open All brings up a new page i click the launch button butit says Activity Not Found - com adobe flashplayer.


TIA

R.H.

  • 0

#10
royalhornet

royalhornet

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:Mac XPS1730 Advent Vega
Ok Sorry. It worked fine using iFileManager. Sorry for being a dufus!


Cheers

R.H.

  • 0

#11
gws999

gws999

    Newbie

  • MoDaCo Silver
  • Pip
  • 7 posts
  • Location:hornchurch
  • Devices:advent vega
  • Twitter:@gws9
Hi, my flash is not working, when i try to watch video clip and click on it it closes down the browser, when i try to do the fix " Simply browse in iFileManager on the device to /system/etc/shuttle_priv and click on the APK file to install." i click system and then etc but do not have shuttle_priv all i have is shuttle.sh and shuttle_ins.sh, also downloaded flash from market but still no luck, any ideas what is wrong.

  • 0

#12
terminaljunkie

terminaljunkie

    Regular

  • MoDaCo Silver
  • PipPip
  • 84 posts
  • Location:Darlington UK
  • Interests:Networking, Presence technologies
  • Devices:HTC Desire / Vega

Hi, my flash is not working, when i try to watch video clip and click on it it closes down the browser, when i try to do the fix " Simply browse in iFileManager on the device to /system/etc/shuttle_priv and click on the APK file to install." i click system and then etc but do not have shuttle_priv all i have is shuttle.sh and shuttle_ins.sh, also downloaded flash from market but still no luck, any ideas what is wrong.


The shuttle_priv is another folder in the /system/etc location, are you sure you have not missed it because I almost did when doing exactly the same thing!

I still don't understand why you cannot update flash from the market - as there is a later version now and I get the nag to update but it breaks again if I do, and i have to revert back to the .apk in the above location. Will this be a permanent issue without the ability to perform the market updates?

  • 0
terminaljunkie

#13
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,220 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Flash for the Vega is a special version optimised for GLES2. The market versions aren't, hence the issue.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#14
terminaljunkie

terminaljunkie

    Regular

  • MoDaCo Silver
  • PipPip
  • 84 posts
  • Location:Darlington UK
  • Interests:Networking, Presence technologies
  • Devices:HTC Desire / Vega

Flash for the Vega is a special version optimised for GLES2. The market versions aren't, hence the issue.

P



Salutes ;)

  • 0
terminaljunkie

#15
gws999

gws999

    Newbie

  • MoDaCo Silver
  • Pip
  • 7 posts
  • Location:hornchurch
  • Devices:advent vega
  • Twitter:@gws9
Hi Paul, do you know where I can download a copy of Flash version GLES2 for the vega so i can get flash to work.

  • 0

#16
remlap

remlap

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 282 posts
  • Gender:Male
  • Location:South Wales
  • Devices:Nexus7, GalaxyNexus, NookGlo
  • Twitter:@remlap1986
Thanks for the tip noticed it wasn't working with iPlayer after installing the MoDaCo rom, oddly Adobe site seems to think it was Safari browser hehe.

  • 0

#17
arad85

arad85

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 258 posts

Hi Paul, do you know where I can download a copy of Flash version GLES2 for the vega so i can get flash to work.


It's already on the device. Open a command window. With USB debugging enabled and connected to the PC, and being in the directory that you have install-windows.bat, do:


adb-windows.exe shell pm install -r /system/etc/shuttle_priv/libflashplayer_froyo_gles2_20101019_v10.1.95.18_signed.apk

That will get flash working again...

  • 0
Can't get the drivers right for updating the Vega? See this thread
Need to find out what Windows thinks is installed? Download and run [url="http://"http://www.nirsoft.net/utils/usb_devices_view.html"]this tool[/url]

#18
Kirk Sim

Kirk Sim

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Advent Vega
Hi Paul,

So far I have not been able to purchase a Vega and now it seems the next batch of stock will be shipped without flash installed.

Will installing your custom ROM add flash support to a Vega shipped without it pre-installed? If not does anyone know a way of installing flash?

Thanks :)

  • 0

#19
deadite66

deadite66

    Regular

  • MoDaCo Silver
  • PipPip
  • 82 posts
  • Devices:Desire HD, Advent Vega
  • Twitter:@metaton
pauls rom will re-enable flash.

  • 0

#20
kfou

kfou

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:Advent Vega, HTC Desire
Hi Paul,

I don't actually have n apk file in "priv" folder, i can't find it anywhere, is there a place i can just download the apk file and move it onto the vega, i can't open command on my laptop right now...

Thanks

  • 1




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users