Jump to content


Photo

Problem installing Advent Tablet Companion on XP


  • Please log in to reply
10 replies to this topic

#1
trevor432990

trevor432990

    Hardcore

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 1,423 posts
Tried to load the Advent Vega Companion software onto my PC but when I attach the device via USB to my PC (running XP SP3) then kick off the setup.exe from the SD drive it comes up with the attached Microsoft .NET Framework error and does not create a shortcut icon on my desktop so I don't think the installation has completed. This same error message comes up each time I restart my PC and the only way to get rid of it is to uninstall the companion application.

Any ideas gratefully received?

Attached Files


  • 0
Advent Vega running Vegacomb v3.2 Build 6

#2
Advent Vega

Advent Vega

    Newbie

  • Members
  • Pip
  • 15 posts

Tried to load the Advent Vega Companion software onto my PC but when I attach the device via USB to my PC (running XP SP3) then kick off the setup.exe from the SD drive it comes up with the attached Microsoft .NET Framework error and does not create a shortcut icon on my desktop so I don't think the installation has completed. This same error message comes up each time I restart my PC and the only way to get rid of it is to uninstall the companion application.

Any ideas gratefully received?


Hi,

There is a base requirement of .NET 2.0 for the Transfer Companion.

We have tested the TC on Windows XP SP3 images (but we used Advent Windows XP SP3 images which have to include all of the latest updates at time of creation) so maybe these would be 2.0/3.0. You may want to update your version of .NET installed or double-check which version is installed.

The error message will continue to appear as the TC is added to the startup section (until you uninstall of course ;-))


Regards,
Advent Vega Team.

  • 0

#3
trevor432990

trevor432990

    Hardcore

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 1,423 posts

Hi,

There is a base requirement of .NET 2.0 for the Transfer Companion.

We have tested the TC on Windows XP SP3 images (but we used Advent Windows XP SP3 images which have to include all of the latest updates at time of creation) so maybe these would be 2.0/3.0. You may want to update your version of .NET installed or double-check which version is installed.

The error message will continue to appear as the TC is added to the startup section (until you uninstall of course ;-))
Regards,
Advent Vega Team.


Thanks for the rapid response guys ... have checked what versions of .NET I have installed on my PC and there are several as follows:-
Microsoft .NET Framework 1.1
Microsoft .NET Framework 2.0 Service Pack 2
Microsoft .NET Framework 3.0 Service Pack 2
Microsoft .NET Framework 3.5 SP1
Microsoft .NET Framework 4 Client Profile (installed by Advent Vega setup I believe?)

Not sure if having so many versions can cause issues but installing latest versions does not automatically remove the previous releases apparently.

Any more suggestions please?

Regards

Trevor

  • 0
Advent Vega running Vegacomb v3.2 Build 6

#4
Advent Vega

Advent Vega

    Newbie

  • Members
  • Pip
  • 15 posts

Thanks for the rapid response guys ... have checked what versions of .NET I have installed on my PC and there are several as follows:-
Microsoft .NET Framework 1.1
Microsoft .NET Framework 2.0 Service Pack 2
Microsoft .NET Framework 3.0 Service Pack 2
Microsoft .NET Framework 3.5 SP1
Microsoft .NET Framework 4 Client Profile (installed by Advent Vega setup I believe?)

Not sure if having so many versions can cause issues but installing latest versions does not automatically remove the previous releases apparently.

Any more suggestions please?

Regards

Trevor


Hi,

Can you copy the entire text from the error box and paste into here so we can attempt to reproduce here please.

Regards,
Advent Vega Team

  • 0

#5
trevor432990

trevor432990

    Hardcore

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 1,423 posts

Hi,

Can you copy the entire text from the error box and paste into here so we can attempt to reproduce here please.

Regards,
Advent Vega Team


As requested this is the entire text from the error message :-


************** Exception Text **************
System.Management.ManagementException: Not found
at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)
at System.Management.PropertyData.RefreshPropertyInfo()
at System.Management.PropertyDataCollection.get_Item(String propertyName)
at System.Management.ManagementBaseObject.GetPropertyValue(String propertyName)
at System.Management.ManagementBaseObject.get_Item(String propertyName)
at USB_Detection.Startup.Grab_HW_IDs()
at USB_Detection.Startup.Startup_Load(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at USB_Detection.Startup.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3615 (GDR.050727-3600)
CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
USB_Detection
Assembly Version: 1.0.0.3
Win32 Version: 1.0.0.3
CodeBase: file:///C:/Program%20Files/Advent/Advent%20Tablet%20Companion/USB_Detection.exe
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3614 (GDR.050727-3600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3082 (QFE.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Management
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Management/2.0.0.0__b03f5f7f11d50a3a/System.Management.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

  • 0
Advent Vega running Vegacomb v3.2 Build 6

#6
Advent Vega

Advent Vega

    Newbie

  • Members
  • Pip
  • 15 posts
...

We have uploaded an updated version, just overwrite the existing file in the folder: C:\Program Files\Advent\Advent Tablet Companion.

This is a test version, if this fixes your problem we will update our web site with a new version.

Regards,
Advent Vega Team

Attached Files


  • 0

#7
trevor432990

trevor432990

    Hardcore

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 1,423 posts

...

We have uploaded an updated version, just overwrite the existing file in the folder: C:\Program Files\Advent\Advent Tablet Companion.

This is a test version, if this fixes your problem we will update our web site with a new version.

Regards,
Advent Vega Team


There was no existing version of the USB Detection application in C:\Program Files\Advent\Advent Tablet Companion so I am wondering if the setup.exe in VegaMedia directory on device is working correctly? I have manually inserted it now as you requested and will reboot and see if it fixes the error message problem and will post the results.

Out of interest what exactly does the ATC software do and could the same not be achieved using Windows Explorer instead ?

  • 0
Advent Vega running Vegacomb v3.2 Build 6

#8
trevor432990

trevor432990

    Hardcore

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 1,423 posts

There was no existing version of the USB Detection application in C:\Program Files\Advent\Advent Tablet Companion so I am wondering if the setup.exe in VegaMedia directory on device is working correctly? I have manually inserted it now as you requested and will reboot and see if it fixes the error message problem and will post the results.

Out of interest what exactly does the ATC software do and could the same not be achieved using Windows Explorer instead ?


** Before the reboot .... I just noticed that the program called USB Detection which you sent me is EXACTLY the same size as the Advent Tablet Application already in the folder. Are they exactly the same program and if so shouldn't I remove the old and rename the new version ?? **

  • 0
Advent Vega running Vegacomb v3.2 Build 6

#9
Advent Vega

Advent Vega

    Newbie

  • Members
  • Pip
  • 15 posts

There was no existing version of the USB Detection application in C:\Program Files\Advent\Advent Tablet Companion so I am wondering if the setup.exe in VegaMedia directory on device is working correctly? I have manually inserted it now as you requested and will reboot and see if it fixes the error message problem and will post the results.

Out of interest what exactly does the ATC software do and could the same not be achieved using Windows Explorer instead ?


Hi,

The TC is simply to make the process of copying files to the right folder easier. You could use Windows Explorer.

Regards,
Advent Vega Team

  • 0

#10
Advent Vega

Advent Vega

    Newbie

  • Members
  • Pip
  • 15 posts

** Before the reboot .... I just noticed that the program called USB Detection which you sent me is EXACTLY the same size as the Advent Tablet Application already in the folder. Are they exactly the same program and if so shouldn't I remove the old and rename the new version ?? **


Hi,

As this is simply a test, you can either delete the original file name and rename this file or double-click the one I uploaded to see if it runs without the error.

Regards,
Advent Vega Team

  • 0

#11
trevor432990

trevor432990

    Hardcore

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 1,423 posts

Hi,

As this is simply a test, you can either delete the original file name and rename this file or double-click the one I uploaded to see if it runs without the error.

Regards,
Advent Vega Team


Good news is the test worked and I no longer get the error message I originally posted so thanks very much for that. I have however found one or two other glitches that you may wish to fix namely:-
  • ATC could really do with a minimize button as well as the close button
  • Spelling mistake 'revevant' > 'relevant'
  • Media is only visible on the Vega once ATC or USB link is closed, is this correct? If so needs note in manual
  • On start-up Windows reports ATC does not have a valid digital signature and throws up a 'Open File Security Warning' each time unless you uncheck the box
  • Can you advise me of the path to the \vegamedia folder on the tablet please?
Not sure if it is just my PC setup or if others might experience the attached pop-up windows when USB cable is connected as well?

Attached Files


  • 0
Advent Vega running Vegacomb v3.2 Build 6




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users