Jump to content


Photo

Feature Request for the Vega


  • Please log in to reply
6 replies to this topic

#1
TylerDurdenK

TylerDurdenK

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 373 posts
  • Gender:Male
  • Devices:TMobile G2
I have been trying to get my Vega to connect with my Hero, but because it is only to be able to create an AdHoc network the Vega won't play ball.

Is it possible to have this option included in an upcoming ROM?

There is some good information from Bisto321 on this thread that should be clear to some, but not to me.

http://android.modac...r/#entry1494335

  • 0

#2
Bisto321

Bisto321

    Enthusiast

  • Members
  • PipPipPip
  • 177 posts
  • Devices:HTC Hero

I have been trying to get my Vega to connect with my Hero, but because it is only to be able to create an AdHoc network the Vega won't play ball.

Is it possible to have this option included in an upcoming ROM?

There is some good information from Bisto321 on this thread that should be clear to some, but not to me.

http://android.modac...r/#entry1494335


It is not too difficult to do, I assume that you are already rooted and running pauls rom?

If you can get hold of Root Explorer ( http://www.androidzo...n_download.html ) it is really good and well worth the small payment, you can then have a look in the data/misc/wifi/ folder and look for the wpa_supplicant.conf file.

If this file does not exist at that location you should perform a search for wpa_supplicant.conf, it may be in a different folder on the vega.
You may find one in /system/etc/wifi - this is usually a system file that contains example info and configuration information for wpa_supplican.conf, I made a copy of this one too.

once you find the copy of wpa_supplicant.conf that contains info like that shown below copy and paste in the same folder to create a backup and then copy another to your SD card for extra saftey

network={
ssid="AndroidTether" <-------- this is your ssid for your hotspot
scan_ssid=1
key_mgmt=NONE
auth_alg=OPEN SHARED
wep_key0=abcdefghijklm <-------- this is your wep key
{

then, making sure you have mounted the file system as r/w, open in a text editor and follow the XDA thread to add the missing bits and save
should now look more like this(missing bits in bold);

ap_scan=2
network={
ssid="AndroidTether" <-------- this is your ssid for your hotspot
scan_ssid=1
mode=1
key_mgmt=NONE
auth_alg=OPEN SHARED
wep_key0=abcdefghijklm <-------- this is your wep key
Priority=999
{

there will be references at the top of the file to another path and file and maybe an update_config=1 too, ignore these, only work with the bit that has your wirless tether details as shown above
If you do not see your tether details but can see your wifi router, your adhoc info may have been overwritten or you have not manually added it from the wifi manager.

To do this turn on your wifi but do not connect to your router, then go to settings/wireless and network/Wi-Fi settings and add a network (at bottom of list if you can’t see it) then add your tether details.
The default for the Hero 2.2 Rom is usually AndroidTether for ssid and wep is abcdefghijklm. Then turn off Wi-Fi.
once you have done that, browse using root explorer again and look for the wpa_supplicant.conf file open it and add the missing bits shown above and save your new wpa_supplicant.conf file.
Exit root explorer and rescan for networks and AndroidTether should show up and you should be able to connect.

This worked for me first time (jammy git) and I then had to progress to the next stage of using the nl.rogro.GScriptLite.apk app, from the download in the second post i linked to, to switch (it is just a script to copy and rename the files) This may need some modification if your wpa_supplicant.conf is not in the 'default' folder.

If you are not happy doing the above you may have to wait for paul or someone else to fully modify the wpa_supplicant file to allow adhoc - this would be the preferred option for most - but this method should work.

Can anyone with a vega and root explorer confirm the wpa_supplicant file is in data/misc/wifi/ or where it does live? this may help your fellow 'adhoc only' vega chums to tether.
It may be the case that the vega is a bit more bespoke and uses a slightly different setup (my Galaxy Tab does) without confirmation from somone with root file explorer access we can’t tell yet.

Someone must be tethering adhoc? But has not yet seen your cry for help - I am sure someone will be along soon to help out :P

  • 0

#3
paulsmith

paulsmith

    Regular

  • MoDaCo Silver
  • PipPip
  • 75 posts
  • Devices:HTC Hero , Advent Vega
Thanks for the post.

The /data/misc/wifi/ folder does indeed hold the wpa_supplicant.conf

Editing as suggested allowed me to connect to my hero running wireless tether for root users.

In the future , I'd love to use my hero in infrastructure mode and/or get a proper fix for the vega to connect to ad-hoc.

  • 0

#4
Bisto321

Bisto321

    Enthusiast

  • Members
  • PipPipPip
  • 177 posts
  • Devices:HTC Hero

Thanks for the post.

The /data/misc/wifi/ folder does indeed hold the wpa_supplicant.conf

Editing as suggested allowed me to connect to my hero running wireless tether for root users.

In the future , I'd love to use my hero in infrastructure mode and/or get a proper fix for the vega to connect to ad-hoc.


Thanks for that.

If you use that little scripting tool and create the two config files suggested in the second link from my post, you should be able to toggle between infrastructure and adhoc.

This is not an ideal solution, but a couple of button presses (and the original wpa_supplicant.conf edit) is all that is then needed to switch between the two.

The galaxy tab has got a modified wpa_supplicant file now and works with adhoc, I think the folio dev on XDA (dexter) is also working on this and this may also help you guys too.

  • 0

#5
TylerDurdenK

TylerDurdenK

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 373 posts
  • Gender:Male
  • Devices:TMobile G2
I can't get this to work.

I ahev found the file and edited as requested, but I still cannot connect to the ad-hoc network.

Every time I try it, and it fails to connect, I go back and look at the file and it has reverted to the pre edited state.

This is all the info I see.

network={
ssid="AndroidTether"
key_mgmt=NONE
priority=21
}

There is quite a bit missing compared to yours. (I haven't the need to add encryption to the android tether)

Edited by TylerDurdenK, 01 December 2010 - 02:15 PM.

  • 0

#6
Bisto321

Bisto321

    Enthusiast

  • Members
  • PipPipPip
  • 177 posts
  • Devices:HTC Hero

I can't get this to work.

I ahev found the file and edited as requested, but I still cannot connect to the ad-hoc network.

Every time I try it, and it fails to connect, I go back and look at the file and it has reverted to the pre edited state.


Yes that can happen. Keep a copy of your edited file while you attempt to connect.

Also, when you are editing the file for adhoc, remove all of the other wifi hotspot details - not the top few lines of the file, just the bits that contain other wifi details.

Your file now only contains the adhoc info - make sure that your unit is not connecting to another wifi location before the tether is seen and you could try decreasing the priority in the edited file to something like 20 (it is set at 999 to try and force this connection first - higher number = higher priority)

You could also run your hotospot without wep :P Not as bad as it sounds the tether app i use gives the option to allow or deny access anyway.

  • 0

#7
TylerDurdenK

TylerDurdenK

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 373 posts
  • Gender:Male
  • Devices:TMobile G2
I've done it. not this way, but after getting the ClockWorkMod Recovery and a Nandroid Backup done I risked installing the patch from this thread. I did this via the install .zip option in the recovery.

http://forum.xda-dev...ad.php?t=754961

After doing that and rebooting, I can now connect to the adhoc network on my hero, and browse the internet, then switch back to my router, and browse. Occasionally I need to restart the Vegas wifi to get it to connect to the alternative network (I'm sure there's some pattern to this) but it's working pretty well.

Happy Days.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users