Jump to content


Photo

[THEME] Gingerbread 2.2 MCR R6

- - - - -

  • Please log in to reply
59 replies to this topic

#1
SWOriginal

SWOriginal

    Diehard

  • Members
  • PipPipPipPip
  • 341 posts
  • Location:Essex, London
  • Devices:ZTE Blade, Advent Vega
  • Twitter:@@SW0riginal
Attached File  home.png   420.12KB   189 downloads Attached File  draw.png   45.02KB   171 downloads Attached File  market.png   138KB   124 downloads

::::PAULS FROYO ROM ONLY::::


Google Android 2.3 theme for froyo, For best results install pauls "Gingerbread Launcher" From the market, This is inteded to be as close to the gingerbread theme as possible


WARNING: do not use with sim lock enabled if using pauls rom with stock lockscreen


:::Whats new?:::

R6 improves the signal bar, fixes allot of issues with text, over-obtrusive icons, battery icons now fixed*(v2 fixes 10% battery icon) & now uses a white menu for best compatibility with market apps


Thanks to Frankish for fixing coarse location ;)


:::Other Versions:::

Frankish has released versions of the gingerbread theme which includes images from the desire framework & some green additions Link


Clivec has moded together a version of the theme with black menu, green signal & battery percentage here


:::Download:::

GingerbreadR6


Edited by SWOriginal, 21 December 2010 - 07:20 AM.

  • 0

#2
大猫脸脸大

大猫脸脸大

    Newbie

  • Members
  • Pip
  • 15 posts
  • Location:江苏徐州
  • Devices:ZTE-Blade
i like it

  • 0
我的话不多,不会讨好

#3
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,535 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
Saved me a job doing this theme i will edit the text today at some point to fit the theme.

  • 0

#4
SWOriginal

SWOriginal

    Diehard

  • Members
  • PipPipPipPip
  • 341 posts
  • Location:Essex, London
  • Devices:ZTE Blade, Advent Vega
  • Twitter:@@SW0riginal

i like it

Hopefully rem1x or someone els will fix the text then it'll look so much better ;)

Edit: see post above

Edited by SWOriginal, 19 December 2010 - 07:11 AM.

  • 0

#5
AlphaVision

AlphaVision

    Regular

  • Members
  • PipPip
  • 126 posts
  • Gender:Male
  • Location:Sofia, Bulgaria
  • Devices:ZTE Blade G1 (OLED)
My phone seems a slower now when I am using the gingerbread theme and launcher ;) Especially when I open the apps drawer.

  • 0

#6
SWOriginal

SWOriginal

    Diehard

  • Members
  • PipPipPipPip
  • 341 posts
  • Location:Essex, London
  • Devices:ZTE Blade, Advent Vega
  • Twitter:@@SW0riginal

Saved me a job doing this theme i will edit the text today at some point to fit the theme.

Cheers ;) I didnt have enough time to edit all the files... spent ages sorting out the battery images :P

  • 0

#7
SWOriginal

SWOriginal

    Diehard

  • Members
  • PipPipPipPip
  • 341 posts
  • Location:Essex, London
  • Devices:ZTE Blade, Advent Vega
  • Twitter:@@SW0riginal

My phone seems a slower now when I am using the gingerbread theme and launcher ;) Especially when I open the apps drawer.


A restart or 2 after you flash a new framework will usuall fix the slowness

  • 0

#8
Winston69

Winston69

    Enthusiast

  • Members
  • PipPipPip
  • 154 posts
  • Devices:ZTE Blade - San Francisco
Isn't wiping dalvik-cache recommend also?

  • 0

#9
SWOriginal

SWOriginal

    Diehard

  • Members
  • PipPipPipPip
  • 341 posts
  • Location:Essex, London
  • Devices:ZTE Blade, Advent Vega
  • Twitter:@@SW0riginal

Isn't wiping dalvik-cache recommend also?

Not when flashing themes, if anything it'll make first boot slower whilst it cache's again

  • 0

#10
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,535 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
I've done it but i changed the operator name to black and not sure if it was ok left as white? Opinions please?

EDIT: Scratch that. When you press menu i haven't changed the text colours in there. Not sure where that is, looking around now...

Edited by Frankish, 08 December 2010 - 11:53 AM.

  • 0

#11
Winston69

Winston69

    Enthusiast

  • Members
  • PipPipPip
  • 154 posts
  • Devices:ZTE Blade - San Francisco

I've done it but i changed the operator name to black and not sure if it was ok left as white? Opinions please?

EDIT: Scratch that. When you press menu i haven't changed the text colours in there. Not sure where that is, looking around now...


Black IMO

  • 0

#12
SWOriginal

SWOriginal

    Diehard

  • Members
  • PipPipPipPip
  • 341 posts
  • Location:Essex, London
  • Devices:ZTE Blade, Advent Vega
  • Twitter:@@SW0riginal

I've done it but i changed the operator name to black and not sure if it was ok left as white? Opinions please?

EDIT: Scratch that. When you press menu i haven't changed the text colours in there. Not sure where that is, looking around now...

thanks for working on it ;) , have you managed to solve the menu problem?

  • 0

#13
fonix232

fonix232

    Addict

  • Members
  • PipPipPipPipPip
  • 942 posts
  • Location:Hungary, Debrecen
  • Devices:ZTE Blade [TFT 512RAM]
  • Twitter:@fonix232
Please, create a Metamorph of it! Thanks!

  • 0
If you like my work, invite me for a drink or two!

Also, take a look at my Blade-dedicated site too! fonix232.co.cc

#14
fboldog

fboldog

    Newbie

  • Members
  • Pip
  • 5 posts
  • Location:Hungary
  • Devices:Nexus One, ZTE Blade, etc
  • Twitter:@fboldog
Hi,

the fix for the menu items text:
change this line in the styles.xml in the framework-res.apk
from:
<style name="TextAppearance.Widget.IconMenu.Item" parent="@style/TextAppearance.Small">
		<item name="textColor">?textColorPrimaryInverse</item>
	</style>

to:
<style name="TextAppearance.Widget.IconMenu.Item" parent="@style/TextAppearance.Small">
		<item name="textColor">@color/bright_foreground_dark</item>
	</style>

Currently i cannot rebuild the framework-res (i had some stupid compile errors) to test.


Known Bugs: Notification draw and menu text needs fixing (can some other member fix and i'll update the post ;) )


  • 0

#15
fboldog

fboldog

    Newbie

  • Members
  • Pip
  • 5 posts
  • Location:Hungary
  • Devices:Nexus One, ZTE Blade, etc
  • Twitter:@fboldog
and the fix for the notification items:

change the layout file:
res/layout/status_bar_latest_event_content.xml in the framework-res.apk
each
android:textColor="#ffffffff"

to:
android:textColor="#ff000000"

  • 0

#16
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,535 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
I already did fix the notification text and i did spot that line earlier in strings but had no time to test. Been out all day. Now to work with making all themes for alpha 4 and fix this one...long night!

  • 0

#17
SWOriginal

SWOriginal

    Diehard

  • Members
  • PipPipPipPip
  • 341 posts
  • Location:Essex, London
  • Devices:ZTE Blade, Advent Vega
  • Twitter:@@SW0riginal

Hi,

the fix for the menu items text:
change this line in the styles.xml in the framework-res.apk

<style name="TextAppearance.Widget.IconMenu.Item" parent="@style/TextAppearance.Small">
		<item name="textColor">@color/bright_foreground_dark</item>
	</style>

Currently i cannot rebuild the framework-res (i had some stupid compile errors) to test.


Thanks for the fix ;), i cant fix it as i don't have sdk or eclipse installed on my netbook (any other way to edit android xml in ubuntu?) but it looks like Frankish will fix it

Edited by SWOriginal, 08 December 2010 - 11:22 PM.

  • 0

#18
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,535 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
Yeah if i can get this piece of crap internet to go slower than dial up ;)

  • 0

#19
fboldog

fboldog

    Newbie

  • Members
  • Pip
  • 5 posts
  • Location:Hungary
  • Devices:Nexus One, ZTE Blade, etc
  • Twitter:@fboldog

Thanks for the fix ;), i cant fix it as i don't have sdk or eclipse installed on my netbook (any other way to edit android xml in ubuntu?) but it looks like Frankish will fix it


On ubuntu, try it out 'gedit'.

  • 0

#20
SWOriginal

SWOriginal

    Diehard

  • Members
  • PipPipPipPip
  • 341 posts
  • Location:Essex, London
  • Devices:ZTE Blade, Advent Vega
  • Twitter:@@SW0riginal

On ubuntu, try it out 'gedit'.


thats what i thought but it dont work ;)

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users