Jump to content


Photo

ZTE V9 Tablet

* * * * * 2 votes

  • Please log in to reply
490 replies to this topic

#61
BlcakFox

BlcakFox

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:Huawei U8230 + ZTE (V9) Light
  • Twitter:@lisiusblack
trying to download the source... the speed is about 5 kB/s, so long time to go...
any ideas what soft will I need to compile/build it?

  • 0

#62
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404

trying to download the source... the speed is about 5 kB/s, so long time to go...
any ideas what soft will I need to compile/build it?


Unfortunatly the Froyo Source for the Blade also was pushed out at the same time, so theres a riot broken out over that with everyone in the world downloading it at once..

Theres loads of tutorials around the net for how to do it.... but basicaly.. unzip it, then

make ARCH=arm CROSS_COMPILE=~/android/prebuilt/toolchain/arm-eabi-4.4.0/bin/arm-eabi- $1

you need to adjust that for your enviorment of course...

and based on experience with the ZTE Blade, it wont compile from the off, so you'll need to fix the bugs/typos in their source.

  • 0

#63
BlcakFox

BlcakFox

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:Huawei U8230 + ZTE (V9) Light
  • Twitter:@lisiusblack
finally downloaded. now installing linux on virtual machine, and then I'll try to build it.
if anybody wants, I can upload the source to some filesharing (ie depositfiles)

  • 0

#64
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404

finally downloaded. now installing linux on virtual machine, and then I'll try to build it.
if anybody wants, I can upload the source to some filesharing (ie depositfiles)


It might be a good idea

  • 0

#65
BlcakFox

BlcakFox

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:Huawei U8230 + ZTE (V9) Light
  • Twitter:@lisiusblack
building died at


alternate url to download the source
http://depositfiles....files/uxouqywz6

  • 0

#66
serialmonkey

serialmonkey

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:Newcastle, Australia
  • Devices:ZTE Light Tablet

alternate url to download the source
http://depositfiles....files/uxouqywz6


Ta, I'll have a play later today.

  • 0

#67
serialmonkey

serialmonkey

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:Newcastle, Australia
  • Devices:ZTE Light Tablet

Is that with your build? or my b8? if its mine let me know what you did so I can fix it and promote it to 'final'


Nope, mine - I had my own init.rc which wasn't setting permissions on /system

  • 0

#68
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404

Nope, mine - I had my own init.rc which wasn't setting permissions on /system


Cool, I've removed the old builds and promoted b8 to 'final'

Im trying to get the kernel built, so I can then rebuild another version with EXT3 support

  • 0

#69
serialmonkey

serialmonkey

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:Newcastle, Australia
  • Devices:ZTE Light Tablet
Spent 5 minutes on it this morning. I can get it to compile with the attached patch, but it doesn't boot (surprise surprise). I just spliced it into my recovery.img.

Might have time later today to have another look - I'm currently fighting with java compiliation issues with cyanogen-froyo-stable

Edited by serialmonkey, 07 January 2011 - 12:43 AM.

  • 0

#70
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404

Spent 5 minutes on it this morning. I can get it to compile with the attached patch, but it doesn't boot (surprise surprise). I just spliced it into my recovery.img.

Might have time later today to have another look - I'm currently fighting with java compiliation issues with cyanogen-froyo-stable


I've remebered why I hated JAVA so much... its scary how much of my Unviersity course has come flooding back... along with memories of the pain and suffering..... Im starting to think I blanked a lot of the horror out....

  • 0

#71
serialmonkey

serialmonkey

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:Newcastle, Australia
  • Devices:ZTE Light Tablet

I've remebered why I hated JAVA so much... its scary how much of my Unviersity course has come flooding back... along with memories of the pain and suffering..... Im starting to think I blanked a lot of the horror out....


This is something they have broken - lots of people have reported the issue, but I can't google up a solution at this stage. Might just have to remove the offending code and see what happens. It's basically this problem here - http://pastebin.com/VunEG4d3

  • 0

#72
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404

This is something they have broken - lots of people have reported the issue, but I can't google up a solution at this stage. Might just have to remove the offending code and see what happens. It's basically this problem here - http://pastebin.com/VunEG4d3


your building the froyo branch, not the gingerbread or eclair?

  • 0

#73
serialmonkey

serialmonkey

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:Newcastle, Australia
  • Devices:ZTE Light Tablet

your building the froyo branch, not the gingerbread or eclair?


Correct, both the froyo and froyo-stable branches fail with the same error.

  • 0

#74
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404

Correct, both the froyo and froyo-stable branches fail with the same error.


you could try grabbing an ealier commit version I guess... tho Im not sure how you'd know when they introduced that bug

  • 0

#75
hajj_3

hajj_3

    Enthusiast

  • Members
  • PipPipPip
  • 206 posts
  • Devices:Orange San Francisco
is this available to buy in UK or U.S? if so what price?

  • 0

#76
serialmonkey

serialmonkey

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:Newcastle, Australia
  • Devices:ZTE Light Tablet
So Sebastian, let's say you got the cryanogen froyo stable branch to compile into an update zip and convinced the recovery to load it. You reboot and get the ANDROiD text for 60 seconds, then the device just reloads into recovery. USB never comes up.

Where would you start ? :-)

P.S. we néed to add ro.product.name to the props file of the recovery so it accepts an update zip.

P.P.S. Backup/recovery definitely works :-D

Edited by serialmonkey, 07 January 2011 - 11:29 AM.

  • 0

#77
raniah

raniah

    Newbie

  • Members
  • Pip
  • 2 posts
@Sebastian404 & @serialmonkey:

It would be really nice if you guys succeed in what you're trying to do; ZTE support doesn't seem much enthusiastic in the 2.2 upgrade. I'll be following this thread :unsure:

  • 0

#78
Pegaxs

Pegaxs

    Regular

  • Members
  • PipPip
  • 56 posts
  • Location:Melbourne
  • Devices:ZTE V9 Light

P.P.S. Backup/recovery definitely works :-D


I will second that... recovery definatly working...

  • 0

#79
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404

So Sebastian, let's say you got the cryanogen froyo stable branch to compile into an update zip and convinced the recovery to load it. You reboot and get the ANDROiD text for 60 seconds, then the device just reloads into recovery. USB never comes up.

Where would you start ? :-)


harsh language mostly... have you tried swearing at it?

First thing I'd do is try the image you made in the emulator... see if that gives you any better results..

Next thing I'd try using the 'standard' boot.img with your built system.img see if its something to do with your kernel/boot build...




P.S. we néed to add ro.product.name to the props file of the recovery so it accepts an update zip.


it is in usb.conf.. it should get picked up/set by the usbconfig process....

I've been using clockworkmod on the blade for a while without having it set... sorry still not got around to building some update zips for the V9 yet... been hella busy this week..

Edited by Sebastian404, 08 January 2011 - 01:04 AM.

  • 0

#80
serialmonkey

serialmonkey

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:Newcastle, Australia
  • Devices:ZTE Light Tablet
Not alot of success today.

Tried to build a base android froyo (not cyranmod). Good news is that it kinda booted - hung at the green screen but adb was alive. At that point I decided to restore back to my backup and everything went downhill.

Getting into 'adb shell' is a real hit-and-miss. 90% of the time I get the '#' prompt, but then it just hangs (like we saw in the past). Recovery is also having troubles seeing all my partitions. I get errors like 'Can't mount /dev/block/mtdblock4 (File exists)'. My backups won't restore and nothing boots.

So at 3am, it's time to sleep and hopefully I'll work out how to revive it in the morning.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users