Jump to content


Photo

Daskalos B7610 MEGA-lit-EX

* * * * * 2 votes

  • Please log in to reply
141 replies to this topic

#81
angel_tedted

angel_tedted

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:B7610
Hello everyone,

I'm new here and I was wondering if anyone can point me to how I can get this rom to run on my phone? Ive been reading around the forums but I still cant find a solid guide to backup and flashing my phone. I always end up with a thread thats "gone" or a link that is broken and its a dead end from there. Im lost now. I really want a rom change for my phone coz it looks so slow when i put it beside the other devices.

Thanks in advance!!

  • 0

#82
jbarrick

jbarrick

    Regular

  • Members
  • PipPip
  • 92 posts
  • Devices:samsung b7610
I am still having the ringtone problems of not being to change it.

  • 0

#83
angel_tedted

angel_tedted

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:B7610
OK, so I downloaded the rom, the mx applications, and the apps update 1, then i copied the xdu_uc folder from the rom directory and started dumping all the cabs from the mx application and apps update into it (i just put it in the root of the xdu_uc, i hope i got that correct). then i put that into the mini sd card and put it into the phone. then i flashed the rom.

a few things off the bat.
1. i cant get the menu key to work. its the one between the call and end call buttons. but it maybe just me.

blazingly fast btw, compared to the original samsung os.

I'll try out this rom for a while and return with some feedback :lol:

thanks so much,
ted

  • 0

#84
20x

20x

    Diehard

  • Members
  • PipPipPipPip
  • 301 posts
I am also unable to change the ringtone. Works for the first instance but selects only one ringtone and then no other selection can be made. It really doesn't matter is new samsung settings is installed or if none is there.

Manual registry editing hasn't helped. I missed out a few calls because of this, so had to revert back to earlier megalite one.

btw, @daskalos, got the USSD thing working! I copied 4 files from megalite rom and no problem was there, there is no registry dependence or any other dependency too.

Files I copied were, USSDPH1.exe and ussdph1.exe.0409.mui and USSDPH2.exe and USSDPH2.exe.0409.mui

Please suggest some ringtone workaround.

  • 0

#85
Freezy1982

Freezy1982

    Diehard

  • Members
  • PipPipPipPip
  • 425 posts
  • Devices:B7610, E-Ten M800, HTC P3600

I am also unable to change the ringtone. Works for the first instance but selects only one ringtone and then no other selection can be made. It really doesn't matter is new samsung settings is installed or if none is there.


Have you installed SamsungCamera? If yes - try to uninstall it and check if the Problem persist...

  • 0
Projects:
+-----------------------------+
| ShortMorts..................... |
| T LCARSv1.0.................. |
| T Simplicity v1.1............. |
| JMLMenuSense Collection |
+-----------------------------+

#86
20x

20x

    Diehard

  • Members
  • PipPipPipPip
  • 301 posts
@freezy, thanks for the suggestion. I will try it, but if you are suggesting some files using camera cab, initial analysis has brought forth few filters like that mp3 etc. stored in this camera cab. I need to compare with a working rom. Let's see if some solution can be found.

  • 0

#87
daskalos

daskalos

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,297 posts
  • Devices:LG Expo,Samsung Omnia i900
  • Twitter:@E1i077

I am also unable to change the ringtone. Works for the first instance but selects only one ringtone and then no other selection can be made. It really doesn't matter is new samsung settings is installed or if none is there.

Manual registry editing hasn't helped. I missed out a few calls because of this, so had to revert back to earlier megalite one.

btw, @daskalos, got the USSD thing working! I copied 4 files from megalite rom and no problem was there, there is no registry dependence or any other dependency too.

Files I copied were, USSDPH1.exe and ussdph1.exe.0409.mui and USSDPH2.exe and USSDPH2.exe.0409.mui

Please suggest some ringtone workaround.


Hmmm I currently looking what's causing it...

for the meantime, I've read someone in this thread (or in my other ROM thread) suggesting a workaround that worked for him: I think it's by using a certain file explorer, selecting an audio file, and by the options, setting it as a ringtone....
Or can anyone try if ringo mobile works?

Strange I don't have the ringtone problem... My installed apps are MX Camera,Settings and Touch Player

Well I'm too lazy to read the whole thread :lol:

Edited by daskalos, 22 January 2011 - 09:23 AM.

  • 0
Like my ROMs?

There are many ways to say thank you, one way is by clicking below









Posted Image

#88
20x

20x

    Diehard

  • Members
  • PipPipPipPip
  • 301 posts
@daskalos

A simple solution for a massive problem, I went to winmos native sound panel, first choice ie, ring wouldn't work, all options flicker and settle to one, say Ring___. At that time click Increasing ring and let the phone get selection working, later you can change other options of ringtone and back ring also after once saving.

@ freezy, no error in camera cab. Decompliled the camera cab and all other related files but none worked. The above solution is working.

Be sure everyone that you install all the three files as mentioned by daskalos.

Another precaution if required uninstall touchplayer and restart, reinstall and restart!

All the best!

  • 0

#89
jbarrick

jbarrick

    Regular

  • Members
  • PipPip
  • 92 posts
  • Devices:samsung b7610
Thanks 20X but this still doesnt work for me. Even using File explorer seemed to work in selecting a file as a ringtone but no sounds when I get a call.

The problem for me is that even though I have installed the files deskalos did, I have my own mp3 ringtone which automatically shows up and is default selected in the sounds and notification tab but it will not let me play it or tap "ok" and exit out.
even trying the increasing ring trick hasnt worked for me.

I do love this idea the best out of all the rom's, just a few small bugs, but you I need a ringtone of some sort, but I will keep watching this post for a solution for my phone although others arent haaving the same problem.

Edited by jbarrick, 22 January 2011 - 10:20 PM.

  • 0

#90
20x

20x

    Diehard

  • Members
  • PipPipPipPip
  • 301 posts
The ghost returns, after working for a about 8 hours, no ringtone again!! :lol:
@jbarrick
I suggest you proceed this way: Put XDA_UC folder in storage medium, have a folder Copy2root in it with Windows folder only and inside windows folder single file from your installation that of fexplore.exe

Reflash/hard reset, let the the phone reboot with xda uc installation and reboot.

Then install Mx camera, it will ask for reboot, let it reboot
Then install mx settings, it will ask for reboot, let it reboot
Then install mx touch player, it will ask for reboot, let it reboot

I didn't reboot so many times, but all files want a reboot and I am trying to play safe here.

Now proceed with usual stuff of going through winmo's native settings>sound panel settings.

It has to work this way.

This is just to see if it works properly. You can always restart the uc_net, directing it to another folder where your files for xda_uc are there, but exclude three files from earlier installs.

Then recheck the sound and zero down on the error.

@dasklos and all other users,

there is some problem with mx touchplayer cab, first it is whooping 27mb in size, and then it installs three cab files directly in windows folder, all are cabs with name *daskalos touchplayer __.cab, two with versions v2 and v3 and these are not required, delete all three manually.

Plus you may have a 10mb of _memap_* type of file, which can also be deleted safely.

I saw the contents of this cab and it has got all three cabs, perhaps a little cleaning by daskalos is required.

All the best.

Edited by 20x, 23 January 2011 - 04:27 AM.

  • 0

#91
Freezy1982

Freezy1982

    Diehard

  • Members
  • PipPipPipPip
  • 425 posts
  • Devices:B7610, E-Ten M800, HTC P3600

@daskalos

A simple solution for a massive problem, I went to winmos native sound panel, first choice ie, ring wouldn't work, all options flicker and settle to one, say Ring___. At that time click Increasing ring and let the phone get selection working, later you can change other options of ringtone and back ring also after once saving.

@ freezy, no error in camera cab. Decompliled the camera cab and all other related files but none worked. The above solution is working.

Be sure everyone that you install all the three files as mentioned by daskalos.

Another precaution if required uninstall touchplayer and restart, reinstall and restart!

All the best!


Ok, I tested this ROM too... And it was working fine until I installed Camera... After uninstalling - it was working fine again (1 1/2days). So I thought about a Camera.cab Problem... But as I can read - there is something else going strange :lol:

I hope you all will find it soon!

  • 0

#92
daskalos

daskalos

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,297 posts
  • Devices:LG Expo,Samsung Omnia i900
  • Twitter:@E1i077

OK, so I downloaded the rom, the mx applications, and the apps update 1, then i copied the xdu_uc folder from the rom directory and started dumping all the cabs from the mx application and apps update into it (i just put it in the root of the xdu_uc, i hope i got that correct). then i put that into the mini sd card and put it into the phone. then i flashed the rom.

a few things off the bat.
1. i cant get the menu key to work. its the one between the call and end call buttons. but it maybe just me.

blazingly fast btw, compared to the original samsung os.

I'll try out this rom for a while and return with some feedback :)

thanks so much,
ted


thanks for testing. The error is due to the fact that there is no Samsung Menu in the ROM. You can always map the center button to other programs though


I am also unable to change the ringtone. Works for the first instance but selects only one ringtone and then no other selection can be made. It really doesn't matter is new samsung settings is installed or if none is there.

Manual registry editing hasn't helped. I missed out a few calls because of this, so had to revert back to earlier megalite one.

btw, @daskalos, got the USSD thing working! I copied 4 files from megalite rom and no problem was there, there is no registry dependence or any other dependency too.

Files I copied were, USSDPH1.exe and ussdph1.exe.0409.mui and USSDPH2.exe and USSDPH2.exe.0409.mui

Please suggest some ringtone workaround.


Can you make a cab for those people using USSD too? Thanks

@daskalos

A simple solution for a massive problem, I went to winmos native sound panel, first choice ie, ring wouldn't work, all options flicker and settle to one, say Ring___. At that time click Increasing ring and let the phone get selection working, later you can change other options of ringtone and back ring also after once saving.

@ freezy, no error in camera cab. Decompliled the camera cab and all other related files but none worked. The above solution is working.

Be sure everyone that you install all the three files as mentioned by daskalos.

Another precaution if required uninstall touchplayer and restart, reinstall and restart!

All the best!


I wonder if the solution 100 percent works. I just have to wait the ringtone problem to show up to test. :lol:


Thanks 20X but this still doesnt work for me. Even using File explorer seemed to work in selecting a file as a ringtone but no sounds when I get a call.

The problem for me is that even though I have installed the files deskalos did, I have my own mp3 ringtone which automatically shows up and is default selected in the sounds and notification tab but it will not let me play it or tap "ok" and exit out.
even trying the increasing ring trick hasnt worked for me.

I do love this idea the best out of all the rom's, just a few small bugs, but you I need a ringtone of some sort, but I will keep watching this post for a solution for my phone although others arent haaving the same problem.


Yup, still searching for the cause :)


The ghost returns, after working for a about 8 hours, no ringtone again!! :o
@jbarrick
I suggest you proceed this way: Put XDA_UC folder in storage medium, have a folder Copy2root in it with Windows folder only and inside windows folder single file from your installation that of fexplore.exe

Reflash/hard reset, let the the phone reboot with xda uc installation and reboot.

Then install Mx camera, it will ask for reboot, let it reboot
Then install mx settings, it will ask for reboot, let it reboot
Then install mx touch player, it will ask for reboot, let it reboot

I didn't reboot so many times, but all files want a reboot and I am trying to play safe here.

Now proceed with usual stuff of going through winmo's native settings>sound panel settings.

It has to work this way.

This is just to see if it works properly. You can always restart the uc_net, directing it to another folder where your files for xda_uc are there, but exclude three files from earlier installs.

Then recheck the sound and zero down on the error.

@dasklos and all other users,

there is some problem with mx touchplayer cab, first it is whooping 27mb in size, and then it installs three cab files directly in windows folder, all are cabs with name *daskalos touchplayer __.cab, two with versions v2 and v3 and these are not required, delete all three manually.

Plus you may have a 10mb of _memap_* type of file, which can also be deleted safely.

I saw the contents of this cab and it has got all three cabs, perhaps a little cleaning by daskalos is required.

All the best.


Oh, let me check. The other cabs are experimental ones that have been included accidentally when I'm cabbing the files.

Yup there is a memap file that is generated. Deleting it is not a complete solution as it will be gereated back. The solution is, create a new text document in your pc, rename it to the name of the memmap ( also editing the extention) and placing it on /Windows


Ok, I tested this ROM too... And it was working fine until I installed Camera... After uninstalling - it was working fine again (1 1/2days). So I thought about a Camera.cab Problem... But as I can read - there is something else going strange ;)

I hope you all will find it soon!



For those really like the MEGA-li-EX versions, but are annoyed by the ringtone issue, help me in finding what's causing it.
From my experiments, it's seemed caused by a certain reg entry that I can't pinpoint. Well why does it comes out all of the sudden?
Well these are my 2 theories:

1.One of the new MX MEGA-lit-EX cabs contain the reg entry, so by installing the cab, it rewrites the annoying reg entry that affects ringtone changing.
2.There is a certain exe file in the MX cabs that when accessed,it may or may not have no graphical UI, that automatically rewrites the reg entry.

For now, as I said, I can't pinpoint the reg entry that is the culprit, so if you have some time, please help me in determining which cabs causes it by.

1. Flashing your device with MEGA-lit-EX, putting ONLY these cabs in XDA-UC:.Net CF, WM Basic Apps, the *NEW* MX Samsung Settings (the latest uploaded app pack) ,MX Touch Player and MX Camera.
2. From there on, check if the ringtone problem exists.If not, you can now install other MX Samsung Apps one by one, and see if the ringtone problem will appear.
3. Please note what apps are you going to uninstall too, if it will have an effect with the ringtone too.

I know this will be kind of lengthy process, but if you really like the ROM and also like to help me in improving it, your help is surely welcome.

Edited by daskalos, 23 January 2011 - 05:48 PM.

  • 0
Like my ROMs?

There are many ways to say thank you, one way is by clicking below









Posted Image

#93
tskok

tskok

    Newbie

  • Members
  • Pip
  • 7 posts
  • Devices:samsung b7610
hello, my experience is not all mp3 file is playable, still finding which type mp3 file is effect

  • 0

#94
20x

20x

    Diehard

  • Members
  • PipPipPipPip
  • 301 posts

1.One of the new MX MEGA-lit-EX cabs contain the reg entry, so by installing the cab, it rewrites the annoying reg entry that affects ringtone changing.
2.There is a certain exe file in the MX cabs that when accessed,it may or may not have no graphical UI, that automatically rewrites the reg entry.

For now, as I said, I can't pinpoint the reg entry that is the culprit, so if you have some time, please help me in determining which cabs causes it by.

1. Flashing your device with MEGA-lit-EX, putting ONLY these cabs in XDA-UC:.Net CF, WM Basic Apps, the *NEW* MX Samsung Settings (the latest uploaded app pack) ,MX Touch Player and MX Camera.
2. From there on, check if the ringtone problem exists.If not, you can now install other MX Samsung Apps one by one, and see if the ringtone problem will appear.
3. Please note what apps are you going to uninstall too, if it will have an effect with the ringtone too.

I know this will be kind of lengthy process, but if you really like the ROM and also like to help me in improving it, your help is surely welcome.


I am already on it, let's see if I will be able to point on to something!
Wish me luck!

  • 0

#95
20x

20x

    Diehard

  • Members
  • PipPipPipPip
  • 301 posts

Can you make a cab for those people using USSD too? Thanks


USSD cab for mega-lit-EX is attached!

It will add four ussdph*.* files to windows directory which will facilitate service provider's messages.

Attached Files

  • Attached File  ussd.cab   40.64KB   42 downloads

  • 0

#96
20x

20x

    Diehard

  • Members
  • PipPipPipPip
  • 301 posts
Right now, I have installed:
.net 3.5
MX touch player
MX Samsung Settings
MX camera
Adobe flashlite
MX fm radio
MX MS office

and getting ringtones!

  • 0

#97
jbarrick

jbarrick

    Regular

  • Members
  • PipPip
  • 92 posts
  • Devices:samsung b7610

USSD cab for mega-lit-EX is attached!

It will add four ussdph*.* files to windows directory which will facilitate service provider's messages.



I dont know what USSD is. So I am assuming I dont need it?

  • 0

#98
20x

20x

    Diehard

  • Members
  • PipPipPipPip
  • 301 posts

I dont know what USSD is. So I am assuming I dont need it?


Unstructured Supplementary Service Data (USSD) is a protocol used by GSM cellular telephones to communicate with the service provider's computers. USSD can be used for WAP browsing, prepaid callback service, location-based content services, menu-based information services, and as part of configuring the phone on the network.

USSD messages are up to 182 alphanumeric characters in length. Unlike Short Message Service (SMS) messages, USSD messages create a real-time connection during a USSD session. The connection remains open, allowing a two-way exchange of a sequence of data. This makes USSD more responsive than services that use SMS.

http://en.wikipedia.org/wiki/USSD

  • 0

#99
jbarrick

jbarrick

    Regular

  • Members
  • PipPip
  • 92 posts
  • Devices:samsung b7610
following the previous couple of post from daskalos and 20x I have ring tone working. I can change them from both wm sounds and settings and samsung settings.

But I have not yet followed the instructions about delete the extra files from the large touch player file. Dont know if I will try or just wait for a update cab.
( I think my problem was always rooted with the touchplayer cab, I also found that if I loaded XDA-UC with to many files it wasnt installing them all or at least not correctly.)

I have now tried it with every can I have it everything is working well. I did install everything but daskalos base 3 files by hand, not with XDA-UC, and allowing a reset whenever I was asked or given the option. This includes the new CHome file which works, Thanks.


But in playing with the additional cabs i have found a bug.
1)When installing additional samsung apps such as phone log and phone book, the phone beeps each each sceen tap, but only on these app when I go back to other apps it only vibrates as is selected by the windows setting.
2)if I use the stock dialer pad I can tap on the contact and it will open up the full contact allowing me to see thier address or select send txt, but if I do it from the samsung files it will not let me select between home, cell, or send txt. Also it wont switch from the dialer, to the address book or log, even though I have installed them all, but I can open the log and address directly from the menu page.

I will try to work with this some more but would love to get it to work because I like the in-call recording feature of the samsung dialer compared to wm skin.


daskalos although were working on a few bugs we you at any point work on the sms file for this rom?

Edited by jbarrick, 25 January 2011 - 09:14 AM.

  • 0

#100
jbarrick

jbarrick

    Regular

  • Members
  • PipPip
  • 92 posts
  • Devices:samsung b7610
On a side note
why does XDA-UC sometimes automatically copy files from the storage folder into storage and other files such as office always wait for me to say select storage myself?

Also what are these files for?
Video Rec plus? (why is it so small 1.22KB)
Flash addons?
Landscape launcher?
Midomi?
Touch Response?

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users