Jump to content


Photo

[THEMES]For FLB G2 r7 *All Themes Available!*

* * * * * 1 votes

  • This topic is locked This topic is locked
141 replies to this topic

#41
Xenon0816

Xenon0816

    Enthusiast

  • Members
  • PipPipPip
  • 222 posts
  • Gender:Male
  • Location:Berlin
  • Devices:HTC Blackstone, OSF
Thanks for porting all the themes to every new rom!
Gingerbread theme works fine for me.

  • 0

#42
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200

Frankish,

I had a look thought the black menu ones and cant see any problems there maybe
there is a difference in frameworks xmls form builds.
But i still cant get why these are still giving problems.

B


Thanks for taking a look. I was sure i checked over everything!

Yeah same here, no problems so far. Might be worth mentioning the default theme in the stock Orange ROM has black menus, I know its for 2.1 but it still might have something useful in it, see if their theme causes these sorts of problems. Other than that I cant think of anything. If the framework doesnt actually HAVE the files needed to draw a white menu then it must be rendering it within the app, which it didnt do before O.o


Does it really? I never knew that as i have never used the Orange rom. So it could be something not controlled by framework-res.apk... or somethign pretty obscure in there :D

I really wanna sort this bad boy out.

  • 0

#43
xzyk

xzyk

    Enthusiast

  • Members
  • PipPipPip
  • 249 posts
  • Gender:Male
  • Location:U.K.
  • Interests:mobiles, Winmo, Android
  • Devices:various

Thanks for taking a look. I was sure i checked over everything!
Does it really? I never knew that as i have never used the Orange rom. So it could be something not controlled by framework-res.apk... or somethign pretty obscure in there :D

I really wanna sort this bad boy out.


Frankish, I left you a message in FLB rl6 thread. Basically stating that on the theme FLB put out with his rls6 (the gingerbread one), he also has black menus but the application background/text display correctly in his. If you remember I sent you the pic of how it shows on 'Home Switcher', this shows correctly using FLB's theme !
Hope it helps you track it down mate..

  • 0
May your jouney be uneventful !
Nexus 4......SlimMako-4.3
ZTE Blade Blade Mix V2.2.
Advent VEGA VegaComb 3.2 9n.
SGS2 -Insanity JB 0.83
Asus FonePad...stock
Huawei Y300 Stock (B186) with CWM recovery.
Arnova 7G3 -stock.
Alcatel OT-983....stock

#44
jtc42

jtc42

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 288 posts
  • Location:Oxfordshire
  • Devices:ZTE Blade
  • Twitter:@joelsack

Does it really? I never knew that as i have never used the Orange rom. So it could be something not controlled by framework-res.apk... or somethign pretty obscure in there :D

I really wanna sort this bad boy out.

Could you decompile the framework from the links in the ROM thread? I was surprised that it had black menus but it definitely does. Again like I said it is for 2.1 but it could give you a clue as to why it works on that theme.

  • 0

#45
Geoff_UK

Geoff_UK

    Newbie

  • Members
  • Pip
  • 31 posts
  • Devices:ZTE Blade
just installed "Gingerbread Circle Mod" - looks great, just love that battery indicator - on ext power it alternates between current charge level and the lighting symbol to show it's charging.

Any chance of the same theme, but without the orange menu selections, similar to the "blue" theme ???

Cheers mate

  • 0

#46
HypnoPig

HypnoPig

    Newbie

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Scotland
  • Devices:ZTE Blade/Orange San Francisco
Does installing a new theme replace the previous one, in terms of space used on my phones memory?

  • 0

#47
Mike_P

Mike_P

    Regular

  • Members
  • PipPip
  • 86 posts
  • Location:UK
  • Devices:Orange San Francisco
Can't comment on other apps that have white menus but I followed what was in 2.1 theme and it seemed to work in 2.2 (well in RootExplorer at least).

You need to edit the res\values\styles.xml and the res\drawable\menu_selector.xml.

In styles.xml add the 5th 'item name' line like below...

<style name="Theme.ExpandedMenu" parent="@style/Theme">
		<item name="listViewStyle">@style/Widget.ListView.Menu</item>
		<item name="windowAnimationStyle">@style/Animation.OptionsPanel</item>
		<item name="background">@null</item>
		<item name="itemTextAppearance">?textAppearanceLarge</item>
		<item name="itemBackground">@drawable/menu_selector</item>
</style>

In menu_selector.xml add the 'item android drawable' line at the end like below...

<?xml version="1.0" encoding="UTF-8"?>
<selector
  xmlns:android="http://schemas.android.com/apk/res/android">
	<item android:state_enabled="true" android:state_pressed="true" android:drawable="@drawable/highlight_pressed" />
	<item android:state_enabled="false" android:state_selected="true" android:drawable="@drawable/highlight_disabled" />
	<item android:state_enabled="true" android:state_selected="true" android:drawable="@drawable/highlight_selected" />
	<item android:state_focused="true" android:state_enabled="false" android:drawable="@drawable/highlight_disabled" />
	<item android:state_focused="true" android:state_enabled="true" android:drawable="@drawable/highlight_selected" />
	<item android:drawable="@drawable/screen_background_dark" />
</selector>

Attached Files


  • 0

#48
donkey523

donkey523

    Newbie

  • MoDaCo Silver
  • Pip
  • 11 posts
  • Devices:pulse, san francisco
Thanks for this Frankish.. gingerbread theme works with modaco r6

  • 0

#49
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200

Can't comment on other apps that have white menus but I followed what was in 2.1 theme and it seemed to work in 2.2 (well in RootExplorer at least).

You need to edit the res\values\styles.xml and the res\drawable\menu_selector.xml.

In styles.xml add the 5th 'item name' line like below...

<style name="Theme.ExpandedMenu" parent="@style/Theme">
		<item name="listViewStyle">@style/Widget.ListView.Menu</item>
		<item name="windowAnimationStyle">@style/Animation.OptionsPanel</item>
		<item name="background">@null</item>
		<item name="itemTextAppearance">?textAppearanceLarge</item>
		<item name="itemBackground">@drawable/menu_selector</item>
</style>

In menu_selector.xml add the 'item android drawable' line at the end like below...

<?xml version="1.0" encoding="UTF-8"?>
<selector
  xmlns:android="http://schemas.android.com/apk/res/android">
	<item android:state_enabled="true" android:state_pressed="true" android:drawable="@drawable/highlight_pressed" />
	<item android:state_enabled="false" android:state_selected="true" android:drawable="@drawable/highlight_disabled" />
	<item android:state_enabled="true" android:state_selected="true" android:drawable="@drawable/highlight_selected" />
	<item android:state_focused="true" android:state_enabled="false" android:drawable="@drawable/highlight_disabled" />
	<item android:state_focused="true" android:state_enabled="true" android:drawable="@drawable/highlight_selected" />
	<item android:drawable="@drawable/screen_background_dark" />
</selector>


Almost there but i still have a big white line between the two sets and it looks really out of place...thanks for the help so far though it's great!

Here are the menus with weird white lines. Must just be missing something else. Maybe a line in styles.xml? Upload your please Mike_P?

Posted Image
Posted Image

Edited by Frankish, 13 January 2011 - 03:37 PM.

  • 0

#50
Mike_P

Mike_P

    Regular

  • Members
  • PipPip
  • 86 posts
  • Location:UK
  • Devices:Orange San Francisco
I think I've found the problem I'd forgotten I'd made 3 edits to styles.xml doh!

I saw your post about the big white lines so I thought I'd download your TrueGingerbread-blackmenu-JJRLS3.zip and see if I got the same problem. Well I did, so I compared my styles.xml to yours and spotted the 2nd edit I'd forgotten about. No probs I thought just changed that then recompile/copy/flash.......bugger it still wasn't quite there. ;)

The 3rd edit I'd made I ignored because I assumed (wrongly it seems) that it was specific to the PNGs I was using (my theme is a cobbled together desire one) which are slightly different colours to the ones in yours. Then followed hours of edit/recompile/copy/flash to the point I'm totally pissed off with it all. It seems the 3rd edit I'd done is important but I don't understand why??

In my desire theme the divider_vertical_dark.9.png and divider_horizontal_dark.9.png aren't the same colour. The horizontal one was full white which I assumed wouldn't be suitable and as my image editing skills aren't good I saw that the divider_horizontal_dark_opaque.9.png was the same colour as the vertical one so I decided to use that instead just incase I destroyed any transparency or stuff with my hamfisted image editing. This worked and seemed to have some sort of logic to it which is why I didn't apply it to your theme because as you know your vertical and horizontal divider colours are both the same colour. As I said after hours of messing about it's the only way I can get your theme working but I don't understand why. So (finally you all say lol) are the 3 edits I made to styles.xml...

1 - adding the 5th 'item name' line to the Theme.ExpandedMenu part (the edit I had posted yesterday)
2 - removed .Menu from the listViewStyle line in the Theme.ExpandedMenu part (this was the edit I'd forgotten to post yesterday)
3 - changed the horizontalDivider line in the Theme.IconMenu part, made sense in my theme, doesn't for yours but seems to be needed! I'm pretty zonked out atm perhaps I'm missing something here I just don't know.

<style name="Theme.IconMenu" parent="@style/Theme">
		<item name="windowAnimationStyle">@style/Animation.OptionsPanel</item>
		<item name="background">@null</item>
		<item name="itemTextAppearance">@style/TextAppearance.Widget.IconMenu.Item</item>
		<item name="horizontalDivider">@drawable/divider_horizontal_dark_opaque</item>
		<item name="verticalDivider">@drawable/divider_vertical_dark</item>
		<item name="itemBackground">@drawable/menu_selector</item>
		<item name="itemIconDisabledAlpha">?disabledAlpha</item>
		<item name="moreIcon">@drawable/ic_menu_more</item>
	</style>
	<style name="Theme.ExpandedMenu" parent="@style/Theme">
		<item name="listViewStyle">@style/Widget.ListView</item>
		<item name="windowAnimationStyle">@style/Animation.OptionsPanel</item>
		<item name="background">@null</item>
		<item name="itemTextAppearance">?textAppearanceLarge</item>
		<item name="itemBackground">@drawable/menu_selector</item>
	</style>
Couple of pics of your theme now....

Attached Files


  • 0

#51
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
I've done what you posted and it's fixed the first menu that's great. But for some reason my second screen the extended menu list thing is still having obvious white lines :@

I've attached my current test one. I've checked the images AGAIN. ;)

Can you take a look and see if i've missed something obvious again? Thanks.

EDIT:

Sack that off for a laugh. I somehow removed the .menu part then re added the fucker at some point! Just done it, has to replace the images relating to dividers as mine seem to be messed up. Took the 10 divider images from another theme and added your fixes to styles.xml and they are all fixed now. B-E-A-UTIFUL!

All versions with fixes coming soon. :)

Edited by Frankish, 14 January 2011 - 03:04 PM.

  • 0

#52
Mike_P

Mike_P

    Regular

  • Members
  • PipPip
  • 86 posts
  • Location:UK
  • Devices:Orange San Francisco

I've done what you posted and it's fixed the first menu that's great. But for some reason my second screen the extended menu list thing is still having obvious white lines :@

I've attached my current test one. I've checked the images AGAIN. ;)

Can you take a look and see if i've missed something obvious again? Thanks.

Looks like you missed edit #2 under the Theme.ExpandedMenu part you need to change...
<item name="listViewStyle">@style/Widget.ListView.Menu</item>
to this...
<item name="listViewStyle">@style/Widget.ListView</item>

  • 0

#53
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
Yeah just spotted it and edited my post as you posted that. I did change it but then i think i did something else and changed it again. All good now it looks great. You're a legend mate.

  • 0

#54
madboffin

madboffin

    Newbie

  • Members
  • Pip
  • 18 posts
  • Devices:Orange San Francisco
I'm a little confused are the black menu (circle battery) gingerbread themes on the first page now fixed or do I need to wait for them to be updated ?

Thanks for all your efforts on the blade Frankish. Much appreciated !

Madboffin

  • 0

#55
xzyk

xzyk

    Enthusiast

  • Members
  • PipPipPip
  • 249 posts
  • Gender:Male
  • Location:U.K.
  • Interests:mobiles, Winmo, Android
  • Devices:various

Yeah just spotted it and edited my post as you posted that. I did change it but then i think i did something else and changed it again. All good now it looks great. You're a legend mate.


Frankish, does it mean that 'Download Gingerbread Circle Mod with Black Menu's' is now fixed ? cause i'm keen to go back to this green circle battery one.
thanks.
I just downloaded it again and the MD5 is still the same as before !

  • 0
May your jouney be uneventful !
Nexus 4......SlimMako-4.3
ZTE Blade Blade Mix V2.2.
Advent VEGA VegaComb 3.2 9n.
SGS2 -Insanity JB 0.83
Asus FonePad...stock
Huawei Y300 Stock (B186) with CWM recovery.
Arnova 7G3 -stock.
Alcatel OT-983....stock

#56
jtc42

jtc42

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 288 posts
  • Location:Oxfordshire
  • Devices:ZTE Blade
  • Twitter:@joelsack
Looking forward to fully working black menus! Glad I noticed the stock theme now haha >.<

Also, because these are the new resigned versions, can they be used with Pauls R8 ROM? Just out of interest. I believe he uses the new system doesnt he?

  • 0

#57
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
Themes are yet to be updated. I've done Jap Jelly first as its my current rom.

Looking forward to fully working black menus! Glad I noticed the stock theme now haha >.<

Also, because these are the new resigned versions, can they be used with Pauls R8 ROM? Just out of interest. I believe he uses the new system doesnt he?


No. The signing doesn't matter when the frameworks are from two different base roms. Chinese/Japanese.

  • 0

#58
jtc42

jtc42

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 288 posts
  • Location:Oxfordshire
  • Devices:ZTE Blade
  • Twitter:@joelsack

Themes are yet to be updated. I've done Jap Jelly first as its my current rom.
No. The signing doesn't matter when the frameworks are from two different base roms. Chinese/Japanese.

Aaah okay thats cool. And fair enough.

I think doing a stock gingerbread theme (ie, no percentage, black menus) for pauls R8 would be cool because he could build it in as part of the Gingerbread Apps option.

  • 0

#59
ladiko

ladiko

    Regular

  • Members
  • PipPip
  • 61 posts
  • Devices:Orange San Francisco
Hello Frankish,

i installed Blue Gingerbread Colour Mod, but still have my custom wallpaper and i dont find the one from the screenshot in the galery or proposed wallpapers. how to set the one from the screenshot?

  • 0

#60
ladiko

ladiko

    Regular

  • Members
  • PipPip
  • 61 posts
  • Devices:Orange San Francisco
Hello Frankish,

i installed Blue Gingerbread Colour Mod, but still have my custom wallpaper and i dont find the one from the screenshot in the galery or proposed wallpapers. how to set the one from the screenshot?

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users