Jump to content


Photo

[maybe solved] Touchscreen does not react after flashing an new ROM

- - - - -

  • Please log in to reply
242 replies to this topic

#1
Seb801

Seb801

    Newbie

  • Members
  • Pip
  • 17 posts
  • Devices:ZTE Blade aka San Francisco
Hi,

i have an B05 OLED SF. Running fine with Seb404s r6 ROM. Now i have tried to flash a newer Version like Seb404s R8 or R9. After flashing the phone boots in the normal way, but the touchscreen does not react. Unlock the screen or SIM input is not possible. The notification-LED is flashing red.

Same issue with FLB-Froyo G2 ROM.

Flashed with Clockwork 2.5.1.8 and both partitions wiped. MD5 sums are correct.

further information:
going back to Seb404s R6 by clockwork the touchscreen function is fine.

Can sombody help?

Thanks Seb.

Edited by Seb801, 08 February 2011 - 11:51 AM.

  • 0

#2
Seb801

Seb801

    Newbie

  • Members
  • Pip
  • 17 posts
  • Devices:ZTE Blade aka San Francisco
No ideas? Any suggestion is welcome. :P

  • 0

#3
phlum

phlum

    Regular

  • Members
  • PipPip
  • 130 posts
  • Gender:Male
  • Location:Catland
  • Devices:ZTE Blade and Nexus 7
  • Twitter:@phlum
At the end of your post you said

going back to Seb404s R6 by clockwork the touchscreen function is fine.

so you appear to be sorted.

  • 0

Install Launcher Pro
Notice it's quicker
???
Profit.

Posted Image

An Android a day keeps the Apple away.

#4
Seb801

Seb801

    Newbie

  • Members
  • Pip
  • 17 posts
  • Devices:ZTE Blade aka San Francisco
Going back to R6 is one way, but i'd like to know the cause of the problem.

  • 0

#5
Seb801

Seb801

    Newbie

  • Members
  • Pip
  • 17 posts
  • Devices:ZTE Blade aka San Francisco
Have tried some more ROMs.

Eclair:
Sebastian404's de-orangeated-rom [OLED only] - r4 =>Touchscreen is o.k.
Sebastian404's de-orangeated-rom [OLED only] - r6 =>Touchscreen is o.k.
Sebastian404's de-orangeated-rom [OLED/TFT] - r8 =>Touchscreen unresponsive
Sebastian404's de-orangeated-rom [OLED/TFT] - r9 =>Touchscreen unresponsive

Froyo:
-FLB-Froyo G2 for ZTE Blade (r8a) [OLED/TFT] => Touchscreen unresponsive
-de-crossed (cheque) r0.2 [OLED/TFT] => Touchscreen unresponsive
-Japanese Jellyfish RLS9 [OLED/TFT] => Touchscreen unresponsive
-stackbladroid_v0.2 [OLED only] =>Touchscreen is o.k.

It seems to be a problem with the dual OLED/TFT ROMs, all ROMs only for OLED runnig fine. ROMs for both shows the issue.

  • 0

#6
Seb801

Seb801

    Newbie

  • Members
  • Pip
  • 17 posts
  • Devices:ZTE Blade aka San Francisco
Have foud a first solution, changing the boot.img [flb-froyo-blade-r8a OLED/TFT] with an OLED only version, the touchscreen is usable.

Don't know why the dual version won't work on my SF. :P

  • 0

#7
isambard

isambard

    Diehard

  • Members
  • PipPipPipPip
  • 391 posts
  • Devices:ZTE Blade

Have foud a first solution, changing the boot.img [flb-froyo-blade-r8a OLED/TFT] with an OLED only version, the touchscreen is usable.

Don't know why the dual version won't work on my SF. :P


nice sleuthing!

  • 0
The best Android Timer application. See also website here: DroidGram Timer Pro.
Download Blade Buddy, the essential companion for your Blade.
Un-lock your Blade with Blade Un-locker.
Free and ad-free basic settings editor: Spare Parts Plus!

#8
Seb801

Seb801

    Newbie

  • Members
  • Pip
  • 17 posts
  • Devices:ZTE Blade aka San Francisco
O.k. back to my old r6 ROM. With the changed OLED boot.img WIFI is not working.

Is ist possible to build an actual Froyo boot.img with OLED support only? I'm wondering no one other has this problem.

  • 0

#9
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,637 posts
Must be a problem with your phone as my phone is OLED and the touchscreen is fine.

Yes you could use an older boot.img but you'll be using old bug filled kernels which cause the screen freeze issues.

Honestly if there were problems with OLED I'd be seeing them myself.

  • 0

#10
Seb801

Seb801

    Newbie

  • Members
  • Pip
  • 17 posts
  • Devices:ZTE Blade aka San Francisco

Must be a problem with your phone as my phone is OLED and the touchscreen is fine.

Yes you could use an older boot.img but you'll be using old bug filled kernels which cause the screen freeze issues.

Honestly if there were problems with OLED I'd be seeing them myself.


Thanks for your answer, any idea how i can locate the problem?

  • 0

#11
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,637 posts

Thanks for your answer, any idea how i can locate the problem?


Not too sure if it's hardware issue. Do you ever get screen freezes using older roms?

BTW you can use the boot img from FLB r6 with r8. Just replace the file in the rom zip and flash it. You'll lose the backlit lights and auto brightness may not function but at least it'll give you a mostly working phone.

  • 0

#12
Seb801

Seb801

    Newbie

  • Members
  • Pip
  • 17 posts
  • Devices:ZTE Blade aka San Francisco

Not too sure if it's hardware issue. Do you ever get screen freezes using older roms?


No, no such issues on any rom. Phone works "perfect".


BTW you can use the boot img from FLB r6 with r8. Just replace the file in the rom zip and flash it. You'll lose the backlit lights and auto brightness may not function but at least it'll give you a mostly working phone.


I will try it. :P

  • 0

#13
Seb801

Seb801

    Newbie

  • Members
  • Pip
  • 17 posts
  • Devices:ZTE Blade aka San Francisco
Hi, exchange the boot.img with the one from FLB r6 dont work => phone stuck @ green android. Maybe you have misunderstood, i was going back to my old eclair ROM (Sebastian404's de-orangeated-rom- r6). Not your FLB r6 :D

Flashing your origin FLB r6 same issue, no touchscreen working. (FLB r6 is also an OLED/TFT version). :P

  • 0

#14
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,637 posts

Hi, exchange the boot.img with the one from FLB r6 dont work => phone stuck @ green android. Maybe you have misunderstood, i was going back to my old eclair ROM (Sebastian404's de-orangeated-rom- r6). Not your FLB r6 :D

Flashing your origin FLB r6 same issue, no touchscreen working. (FLB r6 is also an OLED/TFT version). :P


Sorry.. r5a and lower. You can get the boot.img from this zip

  • 0

#15
gremlinman

gremlinman

    Enthusiast

  • Members
  • PipPipPip
  • 211 posts

Have tried some more ROMs.

Eclair:
Sebastian404's de-orangeated-rom [OLED only] - r4 =>Touchscreen is o.k.
Sebastian404's de-orangeated-rom [OLED only] - r6 =>Touchscreen is o.k.
Sebastian404's de-orangeated-rom [OLED/TFT] - r8 =>Touchscreen unresponsive
Sebastian404's de-orangeated-rom [OLED/TFT] - r9 =>Touchscreen unresponsive

Froyo:
-FLB-Froyo G2 for ZTE Blade (r8a) [OLED/TFT] => Touchscreen unresponsive
-de-crossed (cheque) r0.2 [OLED/TFT] => Touchscreen unresponsive
-Japanese Jellyfish RLS9 [OLED/TFT] => Touchscreen unresponsive
-stackbladroid_v0.2 [OLED only] =>Touchscreen is o.k.

It seems to be a problem with the dual OLED/TFT ROMs, all ROMs only for OLED runnig fine. ROMs for both shows the issue.


Looks to me like roms capable of OLED an TFT dont work for some wierd reason on yuor phone
Try using ROMS capable of Just OLED

  • 0

#16
SpringNBreeze

SpringNBreeze

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:C600

Looks to me like roms capable of OLED an TFT dont work for some wierd reason on yuor phone
Try using ROMS capable of Just OLED



Hi,

I have the same problem with jellyfish R8 or R9.. please help.

Thanks

  • 0

#17
Rotmann

Rotmann

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,019 posts
  • Devices:Nexus One, ZTE Blade

Have tried some more ROMs.

Eclair:
Sebastian404's de-orangeated-rom [OLED only] - r4 =>Touchscreen is o.k.
Sebastian404's de-orangeated-rom [OLED only] - r6 =>Touchscreen is o.k.
Sebastian404's de-orangeated-rom [OLED/TFT] - r8 =>Touchscreen unresponsive
Sebastian404's de-orangeated-rom [OLED/TFT] - r9 =>Touchscreen unresponsive

Froyo:
-FLB-Froyo G2 for ZTE Blade (r8a) [OLED/TFT] => Touchscreen unresponsive
-de-crossed (cheque) r0.2 [OLED/TFT] => Touchscreen unresponsive
-Japanese Jellyfish RLS9 [OLED/TFT] => Touchscreen unresponsive
-stackbladroid_v0.2 [OLED only] =>Touchscreen is o.k.

It seems to be a problem with the dual OLED/TFT ROMs, all ROMs only for OLED runnig fine. ROMs for both shows the issue.

Could you try CM7 RC2 or N15? A guy on IRC has the same problems, but he has the BASE Lutea (german ZTE Blade).

  • 0

#18
noveltylamp

noveltylamp

    Newbie

  • Members
  • Pip
  • 3 posts
Did you clean the Dalvik cache under advanced in clockworkmod?

  • 0

#19
SpringNBreeze

SpringNBreeze

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:C600

Did you clean the Dalvik cache under advanced in clockworkmod?


I did clean cache and partition as per the instructions.

  • 0

#20
Dovbush

Dovbush

    Newbie

  • Members
  • Pip
  • 44 posts
  • Devices:San Francisco TFT
Hi, I have the same problem:
After the install any ROM (JJR9 or CyanogenMod 2.3) - the touchscreen does not react.
When I downgrade to fuctory setting(2.1) everything works fine.
Upgrade Software is fine -100%. All the same set of installs on another phone - everything works fine.
Please help.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users