Jump to content


Photo

Galaxy S touch screen freezes / becomes unresponsive


  • Please log in to reply
1 reply to this topic

#1
cahooky

cahooky

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:GT-I9000
The weirdest thing happened to my Galaxy S a couple weeks ago. The touch screen freezes 3 times a day or sometimes it might last even a full day before freezing again.

By freezing I mean the screen becomes unresponsive but it still shows picture and everything.

The only way I've found to fix this temporarily is to unconnect the screen cable connector from motherboard and connect it again. Taking just the battery off doesn't help.. The other solution is that I can just leave the phone laying on a table for several hours (sometimes 5minutes) and it works when I pick it up.

So I'm kind of confused what the problem could be. I've updated from 2.1 to 2.2 froyo after this problem started.

Has anyone had this problem? I hope that it's a software problem but I don't know... Any ideas?

Edited by cahooky, 28 February 2011 - 10:14 PM.

  • 0

#2
cristy_15kis

cristy_15kis

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:samsung galaxy s

The weirdest thing happened to my Galaxy S a couple weeks ago. The touch screen freezes 3 times a day or sometimes it might last even a full day before freezing again.

By freezing I mean the screen becomes unresponsive but it still shows picture and everything.

The only way I've found to fix this temporarily is to unconnect the screen cable connector from motherboard and connect it again. Taking just the battery off doesn't help.. The other solution is that I can just leave the phone laying on a table for several hours (sometimes 5minutes) and it works when I pick it up.

So I'm kind of confused what the problem could be. I've updated from 2.1 to 2.2 froyo after this problem started.

Has anyone had this problem? I hope that it's a software problem but I don't know... Any ideas?

mabye u didnt flashed a wipe version or u might have too much apps running in backgroung... try a reflash with a new version like JSB or JVK
__________
Igo android

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users