Jump to content


Photo

GT540 1.6 to 2.1 reception issue and radio Firmware

- - - - -

  • Please log in to reply
10 replies to this topic

#1
neilfellows

neilfellows

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:GT540
I've recently upgraded my LG GT540 from Andoid 1.6 to 2.1 via the LG PC suite. It was purchased from Carphone Warehouse. Upgrade went fine and phone works. Since the update, if someone calls my phone it often (but not always) takes them straight to voicemail rather than ringing. First I know of it is a voicemail sysmbol. I'm in a good reception area at work where (prior to the update) the phone would of ringed normally.

Also, when making a call out, about 50% of the time the phone would fail to connect my call. Cancelling it and dialling again is the only cure. Again, this is in a full strength signal area. Once connected the call is fine.

I'm on the GiffGaff network (it's O2). I've discussed this issue with them and they are adamant that it's a handset software/firmware issue, which I believe is correct. They've stated that they've had a number of customers that have done this and it's resulted in the same issue. I've also searched their own forum and one member has recommended that I need to also update the radio firmware. That last bit is beyond me I'm afraid!

Has anyone else experienced this issue with their GT540 after upgrading? Any help would be greatly appreciated.

Many thanks guys.

Neil

  • 0

#2
LinxAndroid

LinxAndroid

    Newbie

  • Members
  • Pip
  • 18 posts
  • Devices:LG GT540
Well when I had the 2.1 I didn't update via THELG pc suite. But I downloaded the KDZ updater and The greek rom. Worked fine. Try doing that?

  • 0

#3
neilfellows

neilfellows

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:GT540

Well when I had the 2.1 I didn't update via THELG pc suite. But I downloaded the KDZ updater and The greek rom. Worked fine. Try doing that?


Many thanks for the reply. Can you point me in the direction of the KDZ updater and the greek rom pls?. Excuse my lack of understanding here, but as the phone is already updated to 2.1, is it OK to run these new updates again - will it clear the LG Suite version and replace with the new version OK?

Finally, I've seen on here a wide variety of roms, all with different names and countries - should I be using a an O2 one, a Carphone Warehouse one, European one, or am I OK with the greek rom

Thanks for the help, appreciated.

  • 0

#4
Clarkey15

Clarkey15

    Newbie

  • Members
  • Pip
  • 44 posts
  • Location:South Wales, UK
  • Devices:LG Optimus
Believe me, you are far from alone with this problem. I had the same problem too, ever since I updated to 2.1 3g never worked for me, However if you're not concerned about using data/internet you can switch off 3G and stick to 2G reception and the phone will work fine without flashing your phone with KDZ updater. If you do choose to flash you can flash 2.1 over the top of 2.1, it doesn't matter which region/version it is as long as it's 2.1. Although do not attempt to reflash 1.6 over 2.1 as you will completely brick your phone making it almost impossible to bring back to life.

  • 0

#5
Dr.Alani

Dr.Alani

    Regular

  • Members
  • PipPip
  • 112 posts
  • Devices:LG-GT540
This is you best friend:
http://android.modac...ference-thread/
I recommend downloading open europe v20b ROM using this link:
http://csmg.lgmobile..._00/V20B_00.kdz
and following the steps in the reference thread. Apparently, the CPW ROM that you have is defected.

  • 0
Optimus One LG P500 (and loving it)
Twitter: @mohammedmalani
Website: http://www.mohammedalani.com

#6
neilfellows

neilfellows

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:GT540
That's excellent - many thanks Dr. Alani and Clarkey 15 - this is a great help. For now I've put my phone onto 2g to see how I get on for a while, I don't use 3G a huge amount.

However, I'll have a good read of the reference thread you've kindly sent a link to and try flashing again, using the open europe rom as soon as I get 5 mins. I'll stay well clear of 1.6!

Thanks again guys, appreciated.

  • 0

#7
shadow wave

shadow wave

    Regular

  • Members
  • PipPip
  • 56 posts
  • Devices:LG GT540, Advent Vega
Mind telling me how this went? I have the same problem but I took mine to Carphone Warehouse to have it fixed. Not sure if they can fix it if it's firmware related.

  • 0

#8
neilfellows

neilfellows

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:GT540

Mind telling me how this went? I have the same problem but I took mine to Carphone Warehouse to have it fixed. Not sure if they can fix it if it's firmware related.



Hiya,

I didn't get a chance over the weekend to try this, hopefully giving it a bash tonight. Providing I can find my USB cable......

I'll report back.

  • 0

#9
1lp

1lp

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:LG GT540
I've got the same problem. So far I tried Russian 20D, European 20B, CyanogenMod 7, all the same. Things are worse for me because thee.co.uk is 3G only. Worked perfectly on 1.6.

  • 0

#10
1lp

1lp

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:LG GT540

Well when I had the 2.1 I didn't update via THELG pc suite. But I downloaded the KDZ updater and The greek rom. Worked fine. Try doing that?


LinxAndroid, did you have the same problem and Greek ROM solved it?

  • 0

#11
neilfellows

neilfellows

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:GT540
Finally got round to this - tried the open Europe V20B as mentioned above and all is well, update went very smooth. I was surprised that my contacts / apps etc were still there after the update.

All thats different is 3G works!

Happy bunny.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users