Jump to content


Photo

[Guide] Flashing firmware to Blade/Libra via windows

* * * * * 8 votes

  • Please log in to reply
207 replies to this topic

#201
Smart-T

Smart-T

    Newbie

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Devices:ZTE Blade
I have a Blade gen2 that was delivered with stock Android 2.2.2.

BladeChecker app said:

European Blade (512MB RAM) detected
Stock/Windows Upgraded Gen 2 Phone detected

Current partition sizes:

System: 220MB
Data: 162MB
Cache: 37MB


I rooted with z4root, then I installed ROM Manager v5.0.2.5 , CWM Recovery 6.0.1.1 and then the following ROMs:

- CM7.2(2.3.7)
- CM10.1(4.2.2) (runs not smoothly, some apps aborted...)
- CM10(4.1.2)
- ParanoidAndroid 2.8.1 (CM10/4.1.2)

Because the phonememory is very small, and at the system partition only 140MB are used at the moment, I want to change the partition sizes like this layout:

System: 220MB -> 160MB
Data: 162MB -> 294MB
Cache: 37MB -> 2MB

Sum: 419MB -> 454MB


Is 2MB cache enough without using any additional relocation tools?

Where does the additional 35MB (=454-419) come from? Was it just unused space before?

Should I backup some ID's (IMEI, other ID's)?

Can I use this method and this TPT file (160/294/2)?

It's not quite clear to me, how to use the stock recovery. Is it still there, if I installed CWM Recovery 6.0.1.1 and several custom ROMs before?
If not, would it be OK to install the stock recovery "over" the CWM? Is this stock recovery the correct version for my Blade (gen2)?
How to do it exactly?

What happens, if something was going wrong and no recovery system works at the end?
How could I restore my old CWM(Nandroid) backups? Or would the Blade then be bricked...?

  • 0

#202
hedgepigdaniel

hedgepigdaniel

    Addict

  • Members
  • PipPipPipPipPip
  • 850 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Devices:Galaxy Nexus, ZTE Blade (OLED)

I have a Blade gen2 that was delivered with stock Android 2.2.2.

BladeChecker app said:



I rooted with z4root, then I installed ROM Manager v5.0.2.5 , CWM Recovery 6.0.1.1 and then the following ROMs:

- CM7.2(2.3.7)
- CM10.1(4.2.2) (runs not smoothly, some apps aborted...)
- CM10(4.1.2)
- ParanoidAndroid 2.8.1 (CM10/4.1.2)

Because the phonememory is very small, and at the system partition only 140MB are used at the moment, I want to change the partition sizes like this layout:



Is 2MB cache enough without using any additional relocation tools?

Where does the additional 35MB (=454-419) come from? Was it just unused space before?

Should I backup some ID's (IMEI, other ID's)?

Can I use this method and this TPT file (160/294/2)?

It's not quite clear to me, how to use the stock recovery. Is it still there, if I installed CWM Recovery 6.0.1.1 and several custom ROMs before?
If not, would it be OK to install the stock recovery "over" the CWM? Is this stock recovery the correct version for my Blade (gen2)?
How to do it exactly?

What happens, if something was going wrong and no recovery system works at the end?
How could I restore my old CWM(Nandroid) backups? Or would the Blade then be bricked...?


The ZTE Blade has 2 underlying partition layouts (including for partitions other than system data cache, OEM, etc). One is the original Gen1 layout, and the other is the Gen2/Gen3 layout. The extra 35MB is there because the Gen2 layout takes up about 15MB more space with these hidden partitions, and also because the stock layout has a OEM partition that takes up space for no good reason.

I recommend you flash one of the Gen2 TPTs from here: http://www.modaco.co...zte-blade-tpts/. This is safer and faster than flashing via windows, and 15MB isn't much.

If you do decide to flash via windows, follow the guide here: http://www.modaco.co...ra-via-windows/. Make sure you follow the instructions properly. You can usually recover channel1.nvm (which is a backup of your imei) as long as the flasher is running, but making a backup yourself is definitely a good idea. You can get the extra 15MB like this but it is slower and much more likely to give you problems.

  • 0

#203
Smart-T

Smart-T

    Newbie

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Devices:ZTE Blade
Hi Daniel,
I tried this method:

I recommend you flash one of the Gen2 TPTs from here: http://www.modaco.co...zte-blade-tpts/. This is safer and faster than flashing via windows, and 15MB isn't much.

After copying the files to the SD card and verification (MD5), I switched the phone off an on again (holding "menu"+"VOL+" as described) when it started into "T-Flash...(something)" (green letters on black background). A progress bar was running from 0 to 84 or 85% when an error accurred.
I thougt I bricked the phone now and was a little bit shocked... :wacko:
But then it rebooted into CWM Recovery 5.0.2.0 (I had 6.0.1.1 before!) so I wiped data, cache, dalvik and restored my last backup (ParanoidAndroid 2.81).
Reboot took a while, but in the end it booted normally. :)

I checked "Partition Info":
/system: 160MB
/data:279MB
/cache: 2MB

The partition sizes looks as expected and the phone seems to run normally.
The user installed apps were not there because of wiped user data - no problem to reinstall manually.

What went wrong in the beginning? Should I repeat the TPT procedure?
Or is everything OK now?

Should I update CWM to ver. 6.0.1.1 again? (how?)

Edited by Smart-T, 04 April 2013 - 10:42 PM.

  • 0

#204
khizhny

khizhny

    Regular

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Ukraine
  • Devices:ZTE Libra (ak Blade, Spark)
Hi, I want to restore my Libra original partition layout.
Blade Checker says my phone is: GEN3 phone,System 220Mb, Cache 27,5 Mb, Data 162,5
Long time ago I've made a ROM backup GBR_KYIVSTAR_P733V1.0.0B04.rar via Recovery and its system size is 115Mb.
Now phone repatitioned to GEN2 I want restore original ROM.
But I can't convert it back to GEN3 with 220 Mb System.
Allavailable GEN3 TPTs is just 200Mb (max).

  • 0

#205
Anton_M

Anton_M

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:ZTE BLADE
Every time i try to flash it completes and then i restart phone, first comes the green androind and then zte logo flashes quickly and it goes to FTM mode, what should i do? :(

  • 0

#206
samphillips1992

samphillips1992

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Orange Monte Carlo
Hi, I am having a few problems... I have got to step 7 and everything was going well until I took the battery out and put it back in. Now all i am getting is a blank screen. The phone is turned on as the backlight is on but it just doesnt go any further and stays blank.

If anyone has any help I would really appreciate it!

Thanks

  • 0

#207
BMN1

BMN1

    Newbie

  • Members
  • Pip
  • 5 posts

i tried the guide but step five does not work i see the FTM on the blades  screan connect the blade to the pc but i do not see the blade in the pc i mean there is no new disc or anything after conecting the blade to the pc and the only thing i can do is shut off the blade by removing the batery.


  • 0

#208
chorao

chorao

    Newbie

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Devices:zte A5 (libra) | minix g4

i tried the guide but step five does not work i see the FTM on the blades  screan connect the blade to the pc but i do not see the blade in the pc i mean there is no new disc or anything after conecting the blade to the pc and the only thing i can do is shut off the blade by removing the batery.

did you install the zte drivers?


  • 0




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users