Jump to content


Photo

stuck after a2sd

- - - - -

  • Please log in to reply
7 replies to this topic

#1
graviton

graviton

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:LG GT540
Hi,
I'm a proud holder of lg gt540, updated to the official 2.1.
After about half a year since the update I've managed to try installation of app2sd
I read a few guides and tutorials..
I downloaded a zip which on the site they said was once updated after a bug was found..
In gparted I made a fat32 ext2 and swap partitions
copied the trhee directories from the zip
I downloaded gscript lite and runned the a2sd.sh with it..
then restarted..
when I tried check.sh, it said it's installed but I could not move the app in the app manager to sd.
So i read some more..
and here:
http://forum.xda-dev...ad.php?t=803689
I've read
"11.in existing scripts in Application GScript, choose a distinguished name a2sd_data and wait until the script execute and complete. (if finished script back to the List2 view more)"

So I tried to run a2sd_data.sh
And I should have not been doing that.
Messageboxes with "do you want to end this app" started to pop out on me..
i left it that way.. after a while it restarted itself.. and again.. than it logged in, showed locked screen.. I can get to the "Lg home screen" but many apps are gone
so is the Market, so I can't redownload gscript and try other scripts..
The phone keeps lagging and once in a while a popup with "system android stopped to work do you want to end it?" etc. appears.
I tried a Hard reset, pressed vol-dn + power + search (I think, or is this a em-download mode?)
The hard reset popup showed, I clicked ok, It restarted.. but it came right into the same lagging state after it..

Now, I tried to look for a solution, BUT I have to know that I won't mess it up more than it is.
So should I try:
From here
http://android.modac...s-1-click-root/
download the bat file
and if there is a menu-option to remove a2sd, should I click it, and hope?


There is a directory "data" on the ext2 partition when I viewed it.. there were data-property or what and ohter directories in it.
I think that these ARE important. so I should not reformate the sd card.

Also I can go to the emergency-download mode, should I try insert new firmware? I've never done that, is there somewhere a good tutorial?

Someone on our czech android-forum said that he runned into the same problem, and he get out by KDZ-updater. I've never used it, is that possible? What should I do with it, and is there a tutorial?

and at last..
on all the tutorials there were mentioning the script names : app2sd.sh, although I'd got a2sd.sh in my app2sd.zip, I thought it's not a big deal.

I would really appriciate any kind of help here, or on [email protected]
I do not wanna have a brick, cos I'm not currently building any kind of structure.

Have a nice day!

  • 0

#2
graviton

graviton

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:LG GT540
Update
I tried to start it normaly and now the phone won't get it to the lockscreen even I didn't do anything:\..
It's loop of LG than Android logo.
Please help, I'm without a phone :P .. >=E

  • 0

#3
graviton

graviton

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:LG GT540
So I've searched once again, and I think that I know where the mistake has happened.
http://android.modac...ug-is-repaired/
this is maybe my problem..
so since my mob won't regain consciousness..
Should I try to reflash ?

this is the script a2sd_data.sh which I probably shouldn't have run
#!/system/bin/sh

echo "APPS2SD by 4pda.ru";
echo "http://4pda.ru/forum/index.php?showtopic=187486";

mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
cat /sdcard/app2sd/busybox > /system/bin/busybox && chmod 700 /system/bin/busybox;
if busybox [ $? = "0" ];
  then
	  if [ -d /system/sdcard ];
	   then
			  echo "sdcard OK continue ...";
	   else
			   echo "sdcard created!";
			   mkdir /system/sdcard;
	  fi;
	  mount -t ext2 /dev/block//vold/179:2 /system/sdcard
	  if [ -d /system/sdcard ];
	   then
		echo "sdcard cleaning!";
		rm -r /system/sdcard/*;
	   else
		echo "no data of sdcard. continue ...";
	  fi ;  
	  echo "ext2 partition mounted, you can expect: copied application ... ";
	  mv /system/bin/vold /system/bin/vold2;
	  cat /sdcard/app2sd_data/vold > /system/bin/vold && chmod 777 /system/bin/vold;
	  cat /sdcard/app2sd_data/vold_data.sh > /system/etc/vold.sh && chmod 777 /system/etc/vold.sh;
	  sync;	
	  busybox cp -p -d -r /data /system/sdcard;
	  sync;
	  echo "done, reboot phone";
  else
	echo "can not mount the partition ext2, returning to its original state";
	rm -r /system/sdcard;
	rm /system/bin/busybox;
fi

Edited by graviton, 28 May 2011 - 11:45 PM.

  • 0

#4
Stephen J. Knill

Stephen J. Knill

    Regular

  • Members
  • PipPip
  • 105 posts
  • Gender:Male
  • Location:Adelaide, Australia
  • Devices:LG GT540f Android 2.3.5

So I've searched once again, and I think that I know where the mistake has happened.
http://android.modac...ug-is-repaired/
this is maybe my problem..
so since my mob won't regain consciousness..
Should I try to reflash ?

this is the script a2sd_data.sh which I probably shouldn't have run

#!/system/bin/sh

echo "APPS2SD by 4pda.ru";
echo "http://4pda.ru/forum/index.php?showtopic=187486";

mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
cat /sdcard/app2sd/busybox > /system/bin/busybox && chmod 700 /system/bin/busybox;
if busybox [ $? = "0" ];
  then
	  if [ -d /system/sdcard ];
	   then
			  echo "sdcard OK continue ...";
	   else
			   echo "sdcard created!";
			   mkdir /system/sdcard;
	  fi;
	  mount -t ext2 /dev/block//vold/179:2 /system/sdcard
	  if [ -d /system/sdcard ];
	   then
		echo "sdcard cleaning!";
		rm -r /system/sdcard/*;
	   else
		echo "no data of sdcard. continue ...";
	  fi;  
	  echo "ext2 partition mounted, you can expect: copied application ... ";
	  mv /system/bin/vold /system/bin/vold2;
	  cat /sdcard/app2sd_data/vold > /system/bin/vold && chmod 777 /system/bin/vold;
	  cat /sdcard/app2sd_data/vold_data.sh > /system/etc/vold.sh && chmod 777 /system/etc/vold.sh;
	  sync;	
	  busybox cp -p -d -r /data /system/sdcard;
	  sync;
	  echo "done, reboot phone";
  else
	echo "can not mount the partition ext2, returning to its original state";
	rm -r /system/sdcard;
	rm /system/bin/busybox;
fi


That's one nasty looking script... I'd avoid using any method that calls that script personally, it's too "loose".

Given that your phone is already in the "dead" state, I'd just do a re-flash and try and find a more stable script to use in place of this one. (there are a few)

Furthermore, I must advise that before you go playing too much with these changes that you look into installing ClockworkMod Recovery... at least with that you'll be able to make a backup of your working phone setup before trying any tweaks in the future (so on the sad occurrence that something like this happens again, it's a pieca' cake to revert back to a working set.) -- Which you should probably do now... while the phone's out for the count anyways.

  • 0

Programs are like Cathedrals, first we build them... then we pray!


#5
JackG

JackG

    Regular

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
  • Location:/dev/null
  • Devices:LG Optimus GT540 White
When you have flashed your ROM again, root your phone and install "Link2SD" from the market. This will give you "Froyo Style" App2sd, you can select apps to move to SD instead of moving them all. Make sure you DO NOT move Widgets and Launcher apps, they will cause the phone to crash.

Jack

  • 0

#6
graviton

graviton

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:LG GT540
So I'm flashing
folowing
http://android.modac...ference-thread/
downloaded Baltic V20D downloaded from
http://android.modac...pdates-from-lg/

i firstly downloaded lg pc suite IV
i disabled lge virtual modem
then i tried to kdz
3GQCT with diag and the phone in the loop of lg, android logos
it stopped with an error messagebox
"Upgrade Error
wparam : 100
lparam : 2"

log:
[13:50:02:340]  : =============================================
[13:50:02:340]  : Log is started on 29.05.2011, at 13:50:02:340, 
executable: D:\DATA\android\KDZ_FW_UPD_EN\KDZ_FW_UPD.exe (ProcID: 0x00001a3c), 
compile time : Sep  8 2010 17:19:53
[13:50:02:340]  : Version : 
[13:50:02:341]  : strFilename1 = V20

[13:50:02:342]  : m_DlMode = 4, m_strBinaryPath = C:\ProgramData\LGMOBILEAX\Phone\DZ_GT540AT-00-V20d-BAL-XXX-DEC-02-2010.dz, m_nSelectedImages= 70787108

[13:50:17:822]  : Start Web Downloading
[13:50:17:822]  : Get Usb Port
[13:50:17:824]  : rsi.strFriendlyName=LGE Bluetooth TransPort (COM3) 

[13:50:17:825]  : Remove LGE Bluetooth TransPort (COM3) 

[13:50:17:825]  : TYPE_WPARAM_UPGRADE_ERROR
[13:50:17:825]  : ¸Ţ˝ĂÁö ş¸łż - TYPE_WPARAM_UPGRADE_ERROR Error Code = 2
[13:50:17:862]  : Log finished

so i get the phone into emergency download mode
and tried again with 3GQCT - EMERGENCY
it started to do something, but now it stopped..
http://pastebin.com/ntXf37vP

Iam waiting now about half an hour
What happen if I stop the program?

Should I try another ROM?
for example Baltic V20B ?

the phone was bought in the UK in mobile-warehouse (or something like that)
as I said it was 1.6 offiicialy upgraded to 2.1..
so should I try UK V20B ?

I'm scared 8-O

  • 0

#7
graviton

graviton

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:LG GT540
so I've exited the KDZ_updater,
removed the sd card
and try it with baltic V20B
it worked..
i also have my old app
i don't know how it is possible..
I'm going to try linksd

  • 0

#8
graviton

graviton

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:LG GT540
I used ext2 partition and it works now ..
I don't think that I'll be messing up with the firmware for now, and so I won't install the clockwork orange :D..
I'll just wait till the camera and fm-radio works on cyanogen :D

Thank you for your answers :o

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users