Jump to content


Photo

Firmware for U8510-0 ? (IDEOS X3 2100 Mhz only version)

- - - - -

  • Please log in to reply
3 replies to this topic

#1
pirh

pirh

    Newbie

  • Members
  • Pip
  • 21 posts
Hi !

I'm looking for Huawei firmware for the IDEOS X3 for the U8510-0 i.e. the 2100 Mhz only version.
As I understand the U8510-1 is 900/2100 and therefore I'm not sure firmware for that device will be compatible.

Does anyone have any info to offer ?
I found a (Malaysia General) firmware in the wiki: (thanks to McSpoon I assume :-)
http://wiki.modaco.c..._Firmware_U8510

But it is for the U8510-1 and I'm not sure what it might to do to my U8510-0 unit..

Rgds!
pirh

  • 0

#2
McSpoon

McSpoon

    Enthusiast

  • PipPipPip
  • 280 posts
  • Gender:Male
  • Location:England
  • Devices:Galaxy Tab 10.1
Hi pirh, I've only just discovered this U8510 sub-forum so apologies for not replying sooner.

Huawei have at least 2 separate download areas on their website - one is Worldwide and the other is Chinese. I rarely find any new files in the Chinese one but on this occasion there is a U8510-0 firmware. Here is the link.
U8510-0 V100R001C197B819

Since the wiki is down at the moment here are all of the other U8510 links that I can find in case they're of any use to you.
U8510-1 V100R001C00B822 (Malaysia General)
U8510-1 V100R001C02B827 (Portugal Vodafone)
U8510-92 V100R001C26B826SP01 (Japan Emobile)

  • 0

#3
pirh

pirh

    Newbie

  • Members
  • Pip
  • 21 posts
Hi McSpoon,

No worries :)

Thank you very much ! It is indeed very helpful.. I've successfully flashed the U8510-1V100R001C00B822(Malaysia General) version on my U8510-0
The only difference seems to be the baseband version which has changed - this leads me to think that the U8510-1 and U8510-0 hardware is identical, simply with a different baseband (radio) firmware used.

Btw the U8510-0 firmware you found is the Taiwan FarEasTone version.

Thanks again and keep us posted on new versions !
-pirh

  • 0

#4
john.smith

john.smith

    Enthusiast

  • Members
  • PipPipPip
  • 274 posts
  • Devices:Orange San Francisco
I managed to flash my U8510-0 (bought from Taiwan) with a U8510-1 ROM.

Everything appears OK at first, but then sometimes it shows no signal and I need to reboot the machine occasionally.

I am not sure if it matters with the ROM.... will try with another U8510-0 ROM if I manage to find one.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users