Jump to content


Photo

[2/Nov/11] Android 2.3.7 Gingerbread (Swiftdroid) CM 7.1 For LG GT540 [New Method]

- - - - -

  • Please log in to reply
123 replies to this topic

#41
ThornInMySide

ThornInMySide

    Newbie

  • Members
  • Pip
  • 21 posts
  • Location:New Zealand
  • Devices:LG GT540
Found an alternate KDZ Updater download link.

Successfully updated as per instructions B)

Thanks awesome dudes!

Edited by ThornInMySide, 27 August 2011 - 10:38 PM.

  • 0

#42
biglaci

biglaci

    Newbie

  • Members
  • Pip
  • 4 posts
hello, thank you for this release, working great. /for example superb performance in angry birds, but in all!/

thank you once again

Edited by biglaci, 29 August 2011 - 05:58 PM.

  • 0

#43
Red_Machine

Red_Machine

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Devices:LG Optimus GT540
Hey guys, having a bit of a problem with this! I followed the instructions up to the "boot into quickboot" part. No matter what I do, I can't get it to do it.

The first time I tried to flash the quickboot rom, it seemed to get stuck at the android logo and KDZ reported that the upgrade was complete; so I unplugged it but it didn't finish the boot. I pulled the battery and it booted up fine. I tried to boot it into quickboot, but had no success.
The second and third times completed the reboot and KDZ reported upgrade complete with the phone sitting on the homescreen. I tried to boot into quickboot again, but still no luck.
I performed a factory reset, as per someone's recommendation and flashed again. Same thing as before.

Can someone help me out with this? I initially tried just to root and install app2sd so I could install more apps, but the app2sd packaged provided didn't work and the third party tools I downloaded just ended up making the phone almost unusable.

My KDZ logs are attached in case you need them.

Attached Files


Edited by Red_Machine, 03 September 2011 - 11:37 AM.

  • 0

#44
raistland

raistland

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:a
  • Twitter:@ss
thank you for all.
I did all of them yesterday. And I use my gt 540. But in the morning my battery was down. After that i couldn't open my phone. I see only LG logo. I tried to charge. But also i see Lg logo again. I tried to make hard reset but it didnt work.
How can i do ? Can anyone help me ?

  • 0

#45
Simonsimon1234

Simonsimon1234

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:GT540GO
I'm going to start updating in an hour or so. Will be updating from (unofficial) 2.1. Wish me luck! I'll be posting rants about things that don't go smoothly :D

Could you upload the files to somewhere where they don't nag as much about downloading multiple files, having to input captcha's and stuff? Rapidshare is probably better than this crappy site?

  • 0

#46
Simonsimon1234

Simonsimon1234

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:GT540GO
Well, I'll be damned. Everything went smoothly and I now have gingerbread on my gt540. Seems to be working perfectly, although I haven't done anything except reboot it yet :P

  • 0

#47
Stephen J. Knill

Stephen J. Knill

    Regular

  • Members
  • PipPip
  • 105 posts
  • Gender:Male
  • Location:Adelaide, Australia
  • Devices:LG GT540f Android 2.3.5

Hey guys, having a bit of a problem with this! I followed the instructions up to the "boot into quickboot" part. No matter what I do, I can't get it to do it.

The first time I tried to flash the quickboot rom, it seemed to get stuck at the android logo and KDZ reported that the upgrade was complete; so I unplugged it but it didn't finish the boot. I pulled the battery and it booted up fine. I tried to boot it into quickboot, but had no success.
The second and third times completed the reboot and KDZ reported upgrade complete with the phone sitting on the homescreen. I tried to boot into quickboot again, but still no luck.
I performed a factory reset, as per someone's recommendation and flashed again. Same thing as before.

Can someone help me out with this? I initially tried just to root and install app2sd so I could install more apps, but the app2sd packaged provided didn't work and the third party tools I downloaded just ended up making the phone almost unusable.

My KDZ logs are attached in case you need them.


You mean Fastboot (Black screen after LG Logo) - Power up the phone holding the camera button in (Fully pressed in till you feel it click the second time, first is just focus); from your log files it seems that you may have left the LG Modem installed. (You should remove this before updating)

  • 0

Programs are like Cathedrals, first we build them... then we pray!


#48
Red_Machine

Red_Machine

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Devices:LG Optimus GT540
I disabled and uninstalled the modem (it's still detected as an unknown device, however). I even tried plugging it into one of my rear USB ports, but it STILL refuses to boot into fastboot mode after three more KDZ flashing attempts. (yes, I did make sure the camera button clicked twice)

WHy is it that this stuff never works when I try it? :(

  • 0

#49
Stephen J. Knill

Stephen J. Knill

    Regular

  • Members
  • PipPip
  • 105 posts
  • Gender:Male
  • Location:Adelaide, Australia
  • Devices:LG GT540f Android 2.3.5

I disabled and uninstalled the modem (it's still detected as an unknown device, however). I even tried plugging it into one of my rear USB ports, but it STILL refuses to boot into fastboot mode after three more KDZ flashing attempts. (yes, I did make sure the camera button clicked twice)

WHy is it that this stuff never works when I try it? :(



Just checking....


Type: 3GQCT
Mode: DIAG
KDZ: *pathtofile*\romfastboot.kdz <--- this rom MUST be the last one flashed, or it won't have fastboot. -- Flashing another ROM will remove it. (You may also use the partition re-size kdz, which will shrink the system down to 150mb and expand the userdata up to 230mb and add a visual fastboot -- Blue screen with status text)

Personaly I suggest using the partition re-size ROM, as this not only adds fastboot but also optimizes the partition sizes. (An extra 100mb to use never goes astray)


------------------------

These files are hosted on my personal server, and are a one-click download. (Supplied as alternative download links for all GT540 users)

KDZ Updater
Fastboot - ROM
Partition Resize - ROM (150mb system, 233mb userdata, 64mb cache) -- This re-size can be undone by using any other ROM listed.


V20A_00 - ROM (LG Stock ROM v1)
OUT ROM - Boot logo restore.

V20D_00 - ROM (Latest LG Stock ROM) -- Use this if reverting back to LG Default.

Browse ROM Directory

------------------------

Flash Player for GT540 -- Swiftdroid tested, it works... but not so great. This is NOT Flash Lite, it's full 10.1
(QR Code below for direct download to phone)
http://qrcode.kaywa....6%20android.apk

------------------------


EDIT: Hmm, yep my post has gone past the 5 lines it started with... thank goodness for Edit ;-)

Edited by Stephen J. Knill, 06 September 2011 - 06:05 AM.

  • 1

Programs are like Cathedrals, first we build them... then we pray!


#50
B-ZiGER

B-ZiGER

    Newbie

  • Members
  • Pip
  • 2 posts
I just sing in to say this i have succesfuly done all steps from number 1. i hawe 2.1 official. Everething was ok untill 13.step installation didnt wont do start automaticly(my mob was in fastboot) so i had started it form C:\GT540\inico_update2 and installation finished ok but my phone didin't wont to boot it frozen it self on Cyongenmod 7 android skate logo.I tried to pull battery and restart but again the same so i used recovery and i am now back again on 2.1.Any tips what to do...

Edited by B-ZiGER, 06 September 2011 - 12:52 PM.

  • 0

#51
Stephen J. Knill

Stephen J. Knill

    Regular

  • Members
  • PipPip
  • 105 posts
  • Gender:Male
  • Location:Adelaide, Australia
  • Devices:LG GT540f Android 2.3.5

I just sing in to say this i have succesfuly done all steps from number 1. i hawe 2.1 official. Everething was ok untill 13.step installation didnt wont do start automaticly(my mob was in fastboot) so i had started it form C:\GT540\inico_update2 and installation finished ok but my phone didin't wont to boot it frozen it self on Cyongenmod 7 android skate logo.I tried to pull battery and restart but again the same so i used recovery and i am now back again on 2.1.Any tips what to do...



(I'd suggest downloading the partition re-size ROM I posted above and flashing it using the KDZ method before doing this, it adds 100mb more user space... lets you see what's going on in fastboot, so should there be any problem, you can see what's going on.)


You can try using this download, it's pretty much the same (Swiftdroid 2.0 RC4) but a different method (*.img files)... download and unzip the file... run the fastbootflashereng.exe file, click on the buttons for each of the files and direct them to their locations (sadly it doesn't find them itself). Boot you'r phone back into fastboot mode, plug it in and press the run button

This should give you a working version.



  • 0

Programs are like Cathedrals, first we build them... then we pray!


#52
Red_Machine

Red_Machine

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Devices:LG Optimus GT540
Thanks Stephen, that worked. I can now boot into fastboot mode. However, Windows cannot find drivers for the phone now, and I don't know which one I should install. I'm using 64-bit Vista, btw.

Edited by Red_Machine, 06 September 2011 - 06:17 PM.

  • 0

#53
Stephen J. Knill

Stephen J. Knill

    Regular

  • Members
  • PipPip
  • 105 posts
  • Gender:Male
  • Location:Adelaide, Australia
  • Devices:LG GT540f Android 2.3.5
-Possibility Factor Edit-

Edited by Stephen J. Knill, 06 September 2011 - 07:37 PM.

  • 0

Programs are like Cathedrals, first we build them... then we pray!


#54
Red_Machine

Red_Machine

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Devices:LG Optimus GT540
I installed it, but "Android" still has a yellow exclamation mark next to it in Device Manager. I could try installing it manually, but I'm not sure which driver exactly it is I need to install.

  • 0

#55
Stephen J. Knill

Stephen J. Knill

    Regular

  • Members
  • PipPip
  • 105 posts
  • Gender:Male
  • Location:Adelaide, Australia
  • Devices:LG GT540f Android 2.3.5

I installed it, but "Android" still has a yellow exclamation mark next to it in Device Manager. I could try installing it manually, but I'm not sure which driver exactly it is I need to install.



Hmmz, best way for you to do it is by going into the Add/Remove (Programs and Features) Programs and removing ALL *driver* installations. (Make sure the phone is un-pluged when you do this.) And reboot.

Download and install these 3 files; (Source: LG)

http://www.sknill.co..._ML_Ver_1.0.exe
http://www.sknill.co..._ML_Ver_1.0.exe
http://www.sknill.co...L_Ver_3.2.1.exe

Then plug your phone back in, this should restore pretty much all access... and these are offical drivers. (This does not give all drivers, but the rest are available through Windows Update)

Edited by Stephen J. Knill, 06 September 2011 - 07:31 PM.

  • 1

Programs are like Cathedrals, first we build them... then we pray!


#56
Red_Machine

Red_Machine

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Devices:LG Optimus GT540
Thanks dude, you're awesome. That worked perfectly!

Only one thing left to do: change the language. My Russian's not so good, so could you give me a step-by-step guide?

  • 1

#57
Stephen J. Knill

Stephen J. Knill

    Regular

  • Members
  • PipPip
  • 105 posts
  • Gender:Male
  • Location:Adelaide, Australia
  • Devices:LG GT540f Android 2.3.5

Thanks dude, you're awesome. That worked perfectly!

Only one thing left to do: change the language. My Russian's not so good, so could you give me a step-by-step guide?


Ahhh, yer that should be a headliner step lol...

Open the Root Explorer (File Manager) -- Grant it Permission when asked, go into the /system folder press the "Mount R/W" button so it shows "Mount R/O"

Click and hold on the build.prop file untill you get a popup, scroll down the list to Open in Text Editor.

Change these 2 lines;

ro.product.locale.language=ru
ro.product.locale.region=RU

To;

ro.product.locale.language=en
ro.product.locale.region=AU

Press the Menu button, and save and exit.

Now... reboot into recovery and do "wipe data/factory reset", and just reboot the phone... it should all be in readable English now :P

---Added--
Oh, and enjoy your fully unlocked and updated GT540! Posted Image

Edited by Stephen J. Knill, 06 September 2011 - 08:13 PM.

  • 1

Programs are like Cathedrals, first we build them... then we pray!


#58
Red_Machine

Red_Machine

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Devices:LG Optimus GT540
It won't let me edit it as it's a read-only file. I also can't change permissions on it either.

Also, can you remind me how to boot into recovery mode? Thanks.

  • 0

#59
Stephen J. Knill

Stephen J. Knill

    Regular

  • Members
  • PipPip
  • 105 posts
  • Gender:Male
  • Location:Adelaide, Australia
  • Devices:LG GT540f Android 2.3.5

It won't let me edit it as it's a read-only file. I also can't change permissions on it either.

Also, can you remind me how to boot into recovery mode? Thanks.


Yer, I missed a step there sorry... I've fixed it up now.

Also it's really easy to boot into recovery with SwiftDroid, just hold the power button as you do to turn it off... but press Reboot instead of Power Off and then select the Recovery check and then click OK. (The menu also pops up when phone is locked.) -- You'll also notice it now has a "Screenshot" option too ;-)

Edited by Stephen J. Knill, 06 September 2011 - 08:16 PM.

  • 1

Programs are like Cathedrals, first we build them... then we pray!


#60
Red_Machine

Red_Machine

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Devices:LG Optimus GT540
That's great, all done and dusted. Ty muchly!

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users