Jump to content


Photo

Seriously, I'm lost


  • Please log in to reply
19 replies to this topic

#1
monstaloc

monstaloc

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Dell Streak 5
Hey Everyone,

I've been trying to restore my girlfriend's Dell Streak 5 for about 2 weeks now and it's driving me nuts.

Basically, the phone was purchased off Ebay with 2.2 on it. I don't really know which build/version other that 2.2 since I'm not an android user and since it just worked, I never bothered paying it any attention.

So then one day, the phone loses charge, reboots and stuck at the Dell Logo.

I've tried reflashing with the stock recovery, and then loading the Update.pkg file to the SDCard and 1 time, the update failed but suddenly started working. The wifi was messed, and so I rebooted the phone. Stuck at teh dell logo again.

I've tried, stock recovery with android 1.6
QDL repair tool
Went to the wiki page and tried to use the matching recovery and update package, 309, 315 and 318..still nothing.
I did the *#301# to test the sim and sdcard, and everything comes back green. no errors.

Now, when I choose option 2, to update the from the sdcard, I just get 3 flashing lights, every few minutes. I've searched and searched, and finally decided to post to get help from the experts.

I'm not having any problems with the drivers, fastboot is working for me, I just don't know what combination of files I need to just wipe this phone and start over. Thanks guys. FYI, I would say I'm technically inclined, just not familiar with the android platform.


Device info:
Black Streak
SInce I used the QDL tool, it has that GAUSxxxxx00 modem version or whatever.

Edited by monstaloc, 30 September 2011 - 08:31 PM.

  • 0

#2
monstaloc

monstaloc

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Dell Streak 5
What I haven't tried is the streakmod recovery. I'm going to try that tonight but any other suggestions would be great.

  • 0

#3
cdzo72

cdzo72

    Regular

  • Members
  • PipPip
  • 78 posts

Hey Everyone,

I've been trying to restore my girlfriend's Dell Streak 5 for about 2 weeks now and it's driving me nuts.

Basically, the phone was purchased off Ebay with 2.2 on it. I don't really know which build/version other that 2.2 since I'm not an android user and since it just worked, I never bothered paying it any attention.

So then one day, the phone loses charge, reboots and stuck at the Dell Logo.

I've tried reflashing with the stock recovery, and then loading the Update.pkg file to the SDCard and 1 time, the update failed but suddenly started working. The wifi was messed, and so I rebooted the phone. Stuck at teh dell logo again.

I've tried, stock recovery with android 1.6
QDL repair tool
Went to the wiki page and tried to use the matching recovery and update package, 309, 315 and 318..still nothing.
I did the *#301# to test the sim and sdcard, and everything comes back green. no errors.

Now, when I choose option 2, to update the from the sdcard, I just get 3 flashing lights, every few minutes. I've searched and searched, and finally decided to post to get help from the experts.

I'm not having any problems with the drivers, fastboot is working for me, I just don't know what combination of files I need to just wipe this phone and start over. Thanks guys. FYI, I would say I'm technically inclined, just not familiar with the android platform.



Hey man, sorry to hear you are having issues with your Streak....

Ok, go back to the wiki page and download the recovery and update package for the latest retail ROM which is the 360... make sure you rename the package to update.pkg and that there is nothing else in the root of the sdcard that could mess with it (in other words, any thing not in a folder, create a Miscellaneous folder and put it all in there and you can put it back once you are up and running again

Seems you know how to fastboot flash your new recovery image, so I will leave you to it and get back with us and let us know how it went...

  • 0

#4
Atipin

Atipin

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:Dell Streak 5
Are you able to boot into recovery mode so you can do the factory restore?

Hey Everyone,

I've been trying to restore my girlfriend's Dell Streak 5 for about 2 weeks now and it's driving me nuts.

Basically, the phone was purchased off Ebay with 2.2 on it. I don't really know which build/version other that 2.2 since I'm not an android user and since it just worked, I never bothered paying it any attention.

So then one day, the phone loses charge, reboots and stuck at the Dell Logo.

I've tried reflashing with the stock recovery, and then loading the Update.pkg file to the SDCard and 1 time, the update failed but suddenly started working. The wifi was messed, and so I rebooted the phone. Stuck at teh dell logo again.

I've tried, stock recovery with android 1.6
QDL repair tool
Went to the wiki page and tried to use the matching recovery and update package, 309, 315 and 318..still nothing.
I did the *#301# to test the sim and sdcard, and everything comes back green. no errors.

Now, when I choose option 2, to update the from the sdcard, I just get 3 flashing lights, every few minutes. I've searched and searched, and finally decided to post to get help from the experts.

I'm not having any problems with the drivers, fastboot is working for me, I just don't know what combination of files I need to just wipe this phone and start over. Thanks guys. FYI, I would say I'm technically inclined, just not familiar with the android platform.


Device info:
Black Streak
SInce I used the QDL tool, it has that GAUSxxxxx00 modem version or whatever.


  • 0

#5
monstaloc

monstaloc

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Dell Streak 5

Are you able to boot into recovery mode so you can do the factory restore?



It allows me to do a factory restore, the devices reboots a few times, and then stuck at the dell logo again.

  • 0

#6
monstaloc

monstaloc

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Dell Streak 5

Hey man, sorry to hear you are having issues with your Streak....

Ok, go back to the wiki page and download the recovery and update package for the latest retail ROM which is the 360... make sure you rename the package to update.pkg and that there is nothing else in the root of the sdcard that could mess with it (in other words, any thing not in a folder, create a Miscellaneous folder and put it all in there and you can put it back once you are up and running again

Seems you know how to fastboot flash your new recovery image, so I will leave you to it and get back with us and let us know how it went...


Thanks for the advice. I'll try the latest 360 build. One curious thing I did notice when the updating function worked, is when copying the update.pkg to the sdcard, the U had to be in upper case or I got a file not found error.

Edited by monstaloc, 30 September 2011 - 08:42 PM.

  • 0

#7
cdzo72

cdzo72

    Regular

  • Members
  • PipPip
  • 78 posts

Thanks for the advice. I'll try the latest 360 build. One curious thing I did notice when the updating function worked, is when copying the update.pkg to the sdcard, the U had to be in upper case or I got a file not found error.


hmmm, I've never run across that issue before, as a matter of fact, I have always been under the impression that it had to be lowercase for the file verification stage to pass... very interesting

  • 0

#8
monstaloc

monstaloc

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Dell Streak 5

hmmm, I've never run across that issue before, as a matter of fact, I have always been under the impression that it had to be lowercase for the file verification stage to pass... very interesting


To be clear, it didn't say "FILE NOT FOUND" it was something about couldn't locate sdcard:Update.pkg MISC error or something like that.

Edited by monstaloc, 30 September 2011 - 08:54 PM.

  • 0

#9
cdzo72

cdzo72

    Regular

  • Members
  • PipPip
  • 78 posts

To be clear, it didn't say "FILE NOT FOUND" it was something about couldn't locate sdcard:Update.pkg MISC error or something like that.



AAAAAhhhhhhh OK, thanks for clearing that up for me

  • 0

#10
mellojoe

mellojoe

    Newbie

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Devices:Dell STREAK, Dell Axim x50
I wonder if maybe your SD card is going bad.

See if you happen to have another SD card running around that you can put in. Copy the update.pkg to the new one. Flast the amss.mbn, and the dsp1.mbn from your computer. Then flash the ROM off the new SD card.

It sounds like something is corrupted in the boot process and mabye it is the file on the SD card not getting written correctly somehow.

Good luck. This sounds like a monster of a problem. :(

  • 0

#11
spanner44

spanner44

    Regular

  • Members
  • PipPip
  • 145 posts
  • Gender:Male
  • Location:United Kingdom
  • Devices:Samsung Galaxy S i9000
As a long shot, you could try and replace the internal sd card (in case its corrupted) with a new one and see if it then reboots okay.

  • 0
Posted Image

#12
monstaloc

monstaloc

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Dell Streak 5
Thanks guys. I just ordered another 16gb card. Hopefully it's as simple as a bad micro sd card.

  • 0

#13
Azurren

Azurren

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,964 posts
  • Gender:Male
  • Location:Cornwall
  • Devices:Dell Streak
  • Twitter:@Azurren
Yeah, it could be your external SD (As your internal one passes the tests)
You could always test it on your PC :)

Otherwise it maybe hardware failure :S
If its out of warranty it maybe worth replacing the internal SD just to be sure.. You never know

Edited by Azurren, 01 October 2011 - 10:01 AM.

  • 0

#14
monstaloc

monstaloc

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Dell Streak 5
okay, finally came home and tried out several different things, 2 SD cards, the current 16gb, and a known working 256mb card stolen from my old blackberry. Tried the following with both cards.

1st thing I tried was the streakmod recovery. I can navigate through the menus and was able to perform a format, just to see if things were working.
I didn't know where to find a proper update.zip file because alot of this is still new to me. I'm pretty confused about dj steve's version, offical versions, etc etc. I'll read up on that unless someone can give me the 5 second rundown.

So without knowing what to do at this point, I tried flashing to the 360 rom and update package. I get the same powered on black screen, 3 blinking lights. FAIL!

More reading, I run across a thread from radimus on another forum. I flash to 309 recovery and the 318 package. use the fastboot to reboot, pick option 2, and now I don't get 3 flashing lights, the 3 lights on the left are on, but then dimmed a bit a few seconds after choosing option 2, and now it just sits there with a powered on black screen.

You guys mentioned changing the internal SD, how do I do that? I have my GF's first dell streak 5 (red) that's around for spare parts. Thanks again for your help everyone.

  • 0

#15
cdzo72

cdzo72

    Regular

  • Members
  • PipPip
  • 78 posts

okay, finally came home and tried out several different things, 2 SD cards, the current 16gb, and a known working 256mb card stolen from my old blackberry. Tried the following with both cards.

1st thing I tried was the streakmod recovery. I can navigate through the menus and was able to perform a format, just to see if things were working.
I didn't know where to find a proper update.zip file because alot of this is still new to me. I'm pretty confused about dj steve's version, offical versions, etc etc. I'll read up on that unless someone can give me the 5 second rundown.

So without knowing what to do at this point, I tried flashing to the 360 rom and update package. I get the same powered on black screen, 3 blinking lights. FAIL!

More reading, I run across a thread from radimus on another forum. I flash to 309 recovery and the 318 package. use the fastboot to reboot, pick option 2, and now I don't get 3 flashing lights, the 3 lights on the left are on, but then dimmed a bit a few seconds after choosing option 2, and now it just sits there with a powered on black screen.

You guys mentioned changing the internal SD, how do I do that? I have my GF's first dell streak 5 (red) that's around for spare parts. Thanks again for your help everyone.


Here in MoDaCo is probably the best thread with details and the pics (look for a thread called replacing the LCD screen) and they talk of two ways... you can either take the Streak apart OR there is a small plastic piece you can cut with a hobby knife to get at the sd card (I personally just did the cutting) also, when you replace, replace with a 4GB class 10 and the performance increase is notable to say the least. The card with the best stats is a Patriot LX 4GB class 10. You could use an 8 gb also, but would need Linus to format the partitions so you can use the rest of the unused space left after the install

  • 0

#16
monstaloc

monstaloc

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Dell Streak 5
Saw the guide on how to get to the internal SD card. Since the red streak i have is already torn apart due to my GF dropping in, I can see just how to remove everything.

I did some more reading and discovered simple streak and streakmod 1.9. I used the recovery and applied the streakmod 1.9.0 zip file and the installation went through fine. Did a reboot, stuck at the dell logo.

Did a factory reset, rebooted itselt, and stuck at the logo again. I'm starting to think there is simply a hardware problem somewhere inside the phone.

  • 0

#17
monstaloc

monstaloc

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Dell Streak 5

Saw the guide on how to get to the internal SD card. Since the red streak i have is already torn apart due to my GF dropping in, I can see just how to remove everything.

I did some more reading and discovered simple streak and streakmod 1.9. I used the recovery and applied the streakmod 1.9.0 zip file and the installation went through fine. Did a reboot, stuck at the dell logo.

Did a factory reset, rebooted itselt, and stuck at the logo again. I'm starting to think there is simply a hardware problem somewhere inside the phone.


Should I start thinking about instaling the latest baseband? where do i get that amss file. every link i see seems dead.

  • 0

#18
cdzo72

cdzo72

    Regular

  • Members
  • PipPip
  • 78 posts

Should I start thinking about instaling the latest baseband? where do i get that amss file. every link i see seems dead.


After you do the flashing, are you booting back into recovery and doing a DELL factory reset... what I mean is this...

Once you have flashed the zip of the ROM you want to try, you will go back to StreakMod recovery, option 1 to reboot will be highlighted, press the shutter button to begin rebooting, as soon as you see the DELL logo, press both volume buttons to get back into STOCK recovery, scroll up to option 1 (factory reset) press the shutter button and let the Streak perform a FACTORY reset... the OMISSION of this step is the reason many times our Streaks get stuck at the DELL logo.

2) To get the rest of the Streak's files in sync is the reason I always update to the latest stock ROM so that all the phone's firmware will be in sync. Simply flashing the dsp1 and the amss is not enough (advice from TheManii over at xda) and I have found it to be very true.

  • 0

#19
monstaloc

monstaloc

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Dell Streak 5
What a noob I am. I didn't know the buttons work in this mode. Anyway, i see an error:

Install from sdcard complete:
E:Error in CACHE:recovery/log
(Read-only file system)

wiped the cache, fixed the permissions, still get the error. what does it all mean Basil?

Edited by monstaloc, 01 October 2011 - 08:57 PM.

  • 0

#20
monstaloc

monstaloc

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Dell Streak 5
Good news today. Finally found the right torx bit to open it up. Replaced the internal memory card with the one from the broken phone. Reinstalled the streakmod 1.90 and this timr no errors. Reset to factory and everything is up. Thanks to all you helped lead me to this solution. Cheers!!!!

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users