Jump to content


Photo

Stock 20L: 3g disconnects and huge battery drain

- - - - -

  • Please log in to reply
61 replies to this topic

#21
MrOtacon

MrOtacon

    Newbie

  • Members
  • Pip
  • 22 posts

Thats great news MrOtacon, ill probably flash it later on today, keep us updated for any unfortunate incident (related to what we were talking about) - hopefully everything will turn out ok.


I will do :D

At the moment, i havent encountered the network issue. Its been stable, and fast.
Cant comment on the battery for another day or so until its been calibrated - but I was on time for work this morning :D

Baseband Version on phone information (version info on hiddenmenu): 1035.21_20110725
AP Version: lgp990-v20l.422c563e


14 Hours so far and am currently at 30% battery, with some youtube playing use, texts and calls, plus a bit of a stint on tweetdeck. etc etc
Battery is not great - but its not a complete calibration cycle yet - so not worried about that for now

I will say this though - there were a few issues with the Build.prop file used in this rom.
Forinstance user.feature.lgdrm and user.feature.lgresource were set to true and then set to false again near the end of the file - which caused the true entry to be disregarded, and stopped customization for ringtones, alarms etc. A quick edit of Build.prop and a reboot fixed this!
Also - wifi.supplicant_scan_interval=180, 180seconds is a crazy amount of time - so i removed the whole line.

Edited by MrOtacon, 08 November 2011 - 04:14 PM.

  • 0

#22
Ximo F. Verde

Ximo F. Verde

    Enthusiast

  • Members
  • PipPipPip
  • 236 posts
  • Gender:Male
  • Devices:LG Optimus 2X

I will do :D

At the moment, i havent encountered the network issue. Its been stable, and fast.
Cant comment on the battery for another day or so until its been calibrated - but I was on time for work this morning :D

Baseband Version on phone information (version info on hiddenmenu): 1035.21_20110725
AP Version: lgp990-v20l.422c563e


14 Hours so far and am currently at 30% battery, with some youtube playing use, texts and calls, plus a bit of a stint on tweetdeck. etc etc
Battery is not great - but its not a complete calibration cycle yet - so not worried about that for now

I will say this though - there were a few issues with the Build.prop file used in this rom.
Forinstance user.feature.lgdrm and user.feature.lgresource were set to true and then set to false again near the end of the file - which caused the true entry to be disregarded, and stopped customization for ringtones, alarms etc. A quick edit of Build.prop and a reboot fixed this!
Also - wifi.supplicant_scan_interval=180, 180seconds is a crazy amount of time - so i removed the whole line.


Great news MrOtacon, getting ready to flash. Ill let u know of any progress.
Laters

  • 0

LG Optimus 2X
stock v20l - rooted & deodexed by Paul
v20l BB (725)


#23
vrowdy

vrowdy

    Regular

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Devices:Xperia S, Lumia 800

I will say this though - there were a few issues with the Build.prop file used in this rom.
Forinstance user.feature.lgdrm and user.feature.lgresource were set to true and then set to false again near the end of the file - which caused the true entry to be disregarded, and stopped customization for ringtones, alarms etc. A quick edit of Build.prop and a reboot fixed this!
Also - wifi.supplicant_scan_interval=180, 180seconds is a crazy amount of time - so i removed the whole line.


How can one edit that file?
After flashing on the phone itself? Or via the pc and a special program?

Also, did you report these issues on the orignal thread on xda? Then the creator can fix it.

  • 0

#24
MrOtacon

MrOtacon

    Newbie

  • Members
  • Pip
  • 22 posts

How can one edit that file?
After flashing on the phone itself? Or via the pc and a special program?

Also, did you report these issues on the orignal thread on xda? Then the creator can fix it.


I did go to report them, but a member named: Craxx already seems to have discovered the problem himself, and has talked about these. He also noticed something I missed, ro.media.dec.jpeg.memcap is set at 20000000 ( ro.media.dec.jpeg.memcap=20000000 ) as well as 8000000 ( ro.media.dec.jpeg.memcap=80000000 ). The first entry ( ro.media.dec.jpeg.memcap=20000000 ) needs removing too!


To edit the build.prop file I used es file explorer from market. Go into settings, and mark the box next to root explorer, then the box next to mount as read / write (directly underneath it). now navigate to /system/ and click on Build.prop. open it in Es File Explorers text editor, and edit away. Have a quick scan for any duplicate lines both myself, and Craxx have missed. save the file once finished. I then recommend that you untick the box next to mount read and write until you need this again.
Restart the phone and it will use your new Build.prop

Edited by MrOtacon, 08 November 2011 - 07:24 PM.

  • 0

#25
vrowdy

vrowdy

    Regular

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Devices:Xperia S, Lumia 800

I did go to report them, but a member named: Craxx already seems to have discovered the problem himself, and has talked about these. He also noticed something I missed, ro.media.dec.jpeg.memcap is set at 20000000 ( ro.media.dec.jpeg.memcap=20000000 ) as well as 8000000 ( ro.media.dec.jpeg.memcap=80000000 ). The first entry ( ro.media.dec.jpeg.memcap=20000000 ) needs removing too!


To edit the build.prop file I used es file explorer from market. Go into settings, and mark the box next to root explorer, then the box next to mount as read / write (directly underneath it). now navigate to /system/ and click on Build.prop. open it in Es File Explorers text editor, and edit away. Have a quick scan for any duplicate lines both myself, and Craxx have missed. save the file once finished. I then recommend that you untick the box next to mount read and write until you need this again.
Restart the phone and it will use your new Build.prop


Thanks a lot! I also read 4.2 is going to be released soon, which includes the new HP kernel from Spica.

  • 0

#26
MrOtacon

MrOtacon

    Newbie

  • Members
  • Pip
  • 22 posts

Thanks a lot! I also read 4.2 is going to be released soon, which includes the new HP kernel from Spica.


No problem buddy :)
Yeah, apparently tomorrow. Using Sipca's second performance pack too.

Im not trying to sway people over to this rom, just offering it as an alternative for now, until GR5 is ready
Some of us do get better performance with this combo than on stock.

  • 0

#27
lap33733

lap33733

    Newbie

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Devices:lg optimus 2x
Does youre battery indicator also freezes? Mine indicates full and in battery status or lock screen I have another value ( sometimes it goes down to 70% before notification bar battery drops from 100%)

  • 0

#28
MrOtacon

MrOtacon

    Newbie

  • Members
  • Pip
  • 22 posts

Does youre battery indicator also freezes? Mine indicates full and in battery status or lock screen I have another value ( sometimes it goes down to 70% before notification bar battery drops from 100%)


I had that occuring with the stock when my network died. it would say 100% and as soon as I slid the screen up to unlock, it would half it on some occasions more.

  • 0

#29
vrowdy

vrowdy

    Regular

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Devices:Xperia S, Lumia 800

I had that occuring with the stock when my network died. it would say 100% and as soon as I slid the screen up to unlock, it would half it on some occasions more.


I just discovered it's indeed the entire radio that's crashed. I thought it was only 3G, but you can't receive calls either.
Anyway, I've had this happen twice in one day now, so I'm going to flash something else tonight. This is ridiculous.

  • 0

#30
lap33733

lap33733

    Newbie

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Devices:lg optimus 2x

I just discovered it's indeed the entire radio that's crashed. I thought it was only 3G, but you can't receive calls either.
Anyway, I've had this happen twice in one day now, so I'm going to flash something else tonight. This is ridiculous.


Those were the simptoms I was having. They are gone after new baseband flash. GPS and battery not updating bug still here.

Edited by lap33733, 09 November 2011 - 08:49 AM.

  • 0

#31
vrowdy

vrowdy

    Regular

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Devices:Xperia S, Lumia 800

Those were the simptoms I was having. They are gone after new baseband flash. GPS and battery not updating bug still here.


Which baseband did you flash exactly then?
And also something with the RIL? Or just baseband?

  • 0

#32
lap33733

lap33733

    Newbie

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Devices:lg optimus 2x

Which baseband did you flash exactly then?
And also something with the RIL? Or just baseband?

New base band 725 from 20l leak, all four files from bigger to smaller. Didn't need to update Ril because it matched with 20l leak. Installed not deodexed because couldn't aquire root with deodexed one.

  • 0

#33
Ximo F. Verde

Ximo F. Verde

    Enthusiast

  • Members
  • PipPipPip
  • 236 posts
  • Gender:Male
  • Devices:LG Optimus 2X

I just discovered it's indeed the entire radio that's crashed. I thought it was only 3G, but you can't receive calls either.
Anyway, I've had this happen twice in one day now, so I'm going to flash something else tonight. This is ridiculous.


This happened to you while you were on Thanatos 4.1? I didnt have cell problems this morning, but data was dead. Doesnt seem resolved, maybe a bit better though. Ill give a bit more testing time maybe

EDIT: Terrible battery life on Thanatos4.1 though.. practically unusable

Edited by Ximo F. Verde, 09 November 2011 - 09:20 AM.

  • 0

LG Optimus 2X
stock v20l - rooted & deodexed by Paul
v20l BB (725)


#34
vrowdy

vrowdy

    Regular

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Devices:Xperia S, Lumia 800

This happened to you while you were on Thanatos 4.1? I didnt have cell problems this morning, but data was dead. Doesnt seem resolved, maybe a bit better though. Ill give a bit more testing time maybe

EDIT: Terrible battery life on Thanatos4.1 though.. practically unusable


No, sorry for the confusion, this is still on stock 20L. I haven't had the time to change to something different yet.

  • 0

#35
vrowdy

vrowdy

    Regular

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Devices:Xperia S, Lumia 800

New base band 725 from 20l leak, all four files from bigger to smaller. Didn't need to update Ril because it matched with 20l leak. Installed not deodexed because couldn't aquire root with deodexed one.


Strange, I have updated with the 20L KDZ-Flash, so I should already have this baseband. Perhaps these four files are different then.

  • 0

#36
Ximo F. Verde

Ximo F. Verde

    Enthusiast

  • Members
  • PipPipPip
  • 236 posts
  • Gender:Male
  • Devices:LG Optimus 2X

Strange, I have updated with the 20L KDZ-Flash, so I should already have this baseband. Perhaps these four files are different then.



If u used the kdz file u definetely have the v20l BB. Note that there are 3 different basebands that show up as 725. The v10d-Jul25, the v20c-Aug2 and the latest v20l (3 fls files) that is included in case of kdz flashing

  • 0

LG Optimus 2X
stock v20l - rooted & deodexed by Paul
v20l BB (725)


#37
MrOtacon

MrOtacon

    Newbie

  • Members
  • Pip
  • 22 posts

This happened to you while you were on Thanatos 4.1? I didnt have cell problems this morning, but data was dead. Doesnt seem resolved, maybe a bit better though. Ill give a bit more testing time maybe

EDIT: Terrible battery life on Thanatos4.1 though.. practically unusable


No I havent had any data problems, My network is fine now - but your right about the battery life. I've fully calibrated now, and have gone through half my battery whilest browsing the net in bed for an hour or two and my alarms going off this morning.. I snoozed a few times - but ultimately That is trash!

  • 0

#38
lap33733

lap33733

    Newbie

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Devices:lg optimus 2x

Those were the simptoms I was having. They are gone after new baseband flash. GPS and battery not updating bug still here.

Ok just found battery issue it looks like first step ends at 70%.

  • 0

#39
MrOtacon

MrOtacon

    Newbie

  • Members
  • Pip
  • 22 posts

Ok just found battery issue it looks like first step ends at 70%.


What Launcher is everyone using, out of curiosity?

I am only asking because, I ran the other 20L rom in mention here for one night with Go Launcher Ex (was fine). Now after running a night with LauncherPro (Paid) Im getting a few FCs, excessive battery drainage and the Network Issue!

Could it be launcher related? (well, I guess it COULD, but is it is what I mean)



  • 0

#40
Ximo F. Verde

Ximo F. Verde

    Enthusiast

  • Members
  • PipPipPip
  • 236 posts
  • Gender:Male
  • Devices:LG Optimus 2X

What Launcher is everyone using, out of curiosity?

I am only asking because, I ran the other 20L rom in mention here for one night with Go Launcher Ex (was fine). Now after running a night with LauncherPro (Paid) Im getting a few FCs, excessive battery drainage and the Network Issue!

Could it be launcher related? (well, I guess it COULD, but is it is what I mean)


Ever since v20e leak was out, im on Go Launcher. Therefore, any comment about relative power consumption between GB ROMs that i make, assumes Go Launcher as a constant

  • 0

LG Optimus 2X
stock v20l - rooted & deodexed by Paul
v20l BB (725)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users