Jump to content


Photo

Unlocking San Fran 2

- - - - -

  • Please log in to reply
213 replies to this topic

#61
sej7278

sej7278

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,647 posts
  • Gender:Male
  • Devices:ZTE Blade
anyone done this (or skate) using linux?

i mean fastboot/adb will work fine, but what about this download.exe and qpst stages? i guess this would work in virtualbox if not pure linux?

otherwise i've got to route around looking for a laptop or something that still has its windoze partition lol. any requirements - xp/win7 or what?

  • 0

#62
project_tt

project_tt

    Newbie

  • Members
  • Pip
  • 24 posts
hi

i just unlocked a t-mobile Vivacity

i used the

Unlock_OSF2 by accident cos i did not read any other posts and just rushed into things

then i flashed r0_de-branded_blade2-update-signed.zip

onto the phone with clockwork

i for got to back up NV file of the vivacity with QPST

so i got the mac address error with wifi ..... lucky for me i backed up the NV file from a san fran 2 that i bricked the other day

i restored the san fran 2 NV file to the Vivacity and wifi is all working now

all seems to be working fine

it just says its a BLADE now when i turn it on

  • 0

#63
unrandomsam

unrandomsam

    Addict

  • Members
  • PipPipPipPipPip
  • 916 posts
  • Gender:Not Telling
  • Devices:Xperia Play / Xoom / ZTE Blade

anyone done this (or skate) using linux?

i mean fastboot/adb will work fine, but what about this download.exe and qpst stages? i guess this would work in virtualbox if not pure linux?

otherwise i've got to route around looking for a laptop or something that still has its windoze partition lol. any requirements - xp/win7 or what?


I think glossywhite has done that stuff under Virtualbox dunno that I would recommend it though

  • 0

#64
unrandomsam

unrandomsam

    Addict

  • Members
  • PipPipPipPipPip
  • 916 posts
  • Gender:Not Telling
  • Devices:Xperia Play / Xoom / ZTE Blade

hi

i just unlocked a t-mobile Vivacity

i used the

Unlock_OSF2 by accident cos i did not read any other posts and just rushed into things

then i flashed r0_de-branded_blade2-update-signed.zip

onto the phone with clockwork

i for got to back up NV file of the vivacity with QPST

so i got the mac address error with wifi ..... lucky for me i backed up the NV file from a san fran 2 that i bricked the other day

i restored the san fran 2 NV file to the Vivacity and wifi is all working now

all seems to be working fine

it just says its a BLADE now when i turn it on


What about the IMEI ?

  • 0

#65
project_tt

project_tt

    Newbie

  • Members
  • Pip
  • 24 posts
ah .... good question did not check that

i have just *# 0 6 # the phone to get the imei number

it its exactly as it should be ..... as printed on the sticker under the battery cover and on the side of the box.
makes call and recives calls

all is good i think


What about the IMEI ?


  • 0

#66
unrandomsam

unrandomsam

    Addict

  • Members
  • PipPipPipPipPip
  • 916 posts
  • Gender:Not Telling
  • Devices:Xperia Play / Xoom / ZTE Blade

ah .... good question did not check that

i have just *# 0 6 # the phone to get the imei number

it its exactly as it should be ..... as printed on the sticker under the battery cover and on the side of the box.
makes call and recives calls

all is good i think




Useful side effect then (QPST not seeing all nvitems).

  • 0

#67
buzz53

buzz53

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:Orange San Francisco 2
I have followed the unlock tutorial as far as step 6, however I can't get into FTM. The phone stays at the green Android and after about 30 seconds the PC pops up a systray notification :

"USB device not recognised. One of the USB devices attached to this computer has malfunctioned and Windows does not recognise it."

Is FTM entry dependant in any way on the PC or is it purely a phone internal thing?

I have installed the handset drivers and can flash "recovery.img" (both using the .bat and entering the commands individually at a command line to observe the results) which suggest the drivers are OK? If I boot the phone normally (to the original Orange ROM which so far is untouched ) then all USB drivers are found correctly. It is only when booting without the battery and holding VOL DOWN that this happens.

This happens with both a Win7 32 bit desktop and an XP laptop.

Advice much appreciated, TIA.

Alan

  • 0

#68
ian_blade2

ian_blade2

    Regular

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:the midlands
  • Devices:blade 2, sf1
i cant seem to get this part done with i understand the rest .............if im right in thinking u need to reload rom after unlocking ??

Go into “Preparation” folder and run the “install-recovery-windows.bat”. This should flash stock recovery and reboot the phone.


anyhelp with this would be muchly appreciated its just i cannot seem to see my phone ?? it keeps saying cant find devices :(

  • 0

#69
Collywob

Collywob

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:Orange San Francisco II

i cant seem to get this part done with i understand the rest .............if im right in thinking u need to reload rom after unlocking ??

Go into “Preparation” folder and run the “install-recovery-windows.bat”. This should flash stock recovery and reboot the phone.


anyhelp with this would be muchly appreciated its just i cannot seem to see my phone ?? it keeps saying cant find devices :(


Hi Ian
you need to enable usb debugging on the phone,,, in settings-> Application Settings -> Development
cheers
C

  • 0

#70
ian_blade2

ian_blade2

    Regular

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:the midlands
  • Devices:blade 2, sf1
hi mate i did that and still cant get into it ? any ideas ..............................im gutted i got this far lol .....maybe i shouldve unlocked the phone before i put the new rom on etc aswell ..........im totally confused by this but want to finish where i started cant be beaten lol thank you.Posted Image

  • 0

#71
ian_blade2

ian_blade2

    Regular

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:the midlands
  • Devices:blade 2, sf1
this is doing my head in lol :( is there a way round this ? i have put the phone in usb debugging deleted the usb driver and readded as i thought it may have corrupted it still wont recognise the phone :( and if i go into the qpst programs it asks u to go into i cant even see the phone :( i sooooo wana sort this lol thanks for any help ian.Posted Image

  • 0

#72
fr0do

fr0do

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,156 posts
  • Gender:Male
  • Devices:Huawei G300
Do you have the right files Ian? Collywob uploaded the Orange files merged & not the T-Mob ones.

  • 0

Posted Image


#73
ian_blade2

ian_blade2

    Regular

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:the midlands
  • Devices:blade 2, sf1
hi frodo can u put me a link to the correct files buddy ? yeh im sure i got the right ones but just want to check ...........also im unsure if im missing a driver or something to find the device i downloaded the usb driver ?? is that the one many thx ian. :rolleyes:

  • 0

#74
fr0do

fr0do

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,156 posts
  • Gender:Male
  • Devices:Huawei G300
Hey Ian

So you downloaded "Unlock-OMC-Skate" and extracted somewhere. Then you downloaded "Unlock-VIVACITY" and extracted the files and put the content of the subfolder "files" into the "preparation" folder yes? (overwriting the "recovery.img" file and adding a few others)

Hold on...

everyone is saying "overwrite the preparation folder" but the Unlock-VIVACITY.zip doesn't contain those files. It contains replacement files for the 'Unlock' folder and the 'files' subfolder under that! Can someone clarify please???

Edited by fr0do, 30 November 2011 - 10:47 AM.

  • 0

Posted Image


#75
buzz53

buzz53

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:Orange San Francisco 2

Hold on...

everyone is saying "overwrite the preparation folder" but the Unlock-VIVACITY.zip doesn't contain those files. It contains replacement files for the 'Unlock' folder and the 'files' subfolder under that! Can someone clarify please???


Fr0do has a good point. To enlarge on it: there are 2 "recovery.img" files in the "Unlock-OMC-Skate" package. One in "Preparation" and one in "Unlock/files". They are identical. However "Unlock-OSF2" only has one, in the "files" folder, and it is different to the OMC ones. The procedure says it should overwrite the file in the "unlock/files" folder from "Unlock-OSF2", but should it also overwrite the one in the Preparation folder? Otherwise at step 4, the OMC stock recovery will surely be flashed instead of the OSF2 one?

Alan

  • 1

#76
ian_blade2

ian_blade2

    Regular

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:the midlands
  • Devices:blade 2, sf1
im getting more confused by the minute now :( should i just put this bk to the stock rom lol and take it bk to the shop ?




all i want is to unlock it then i will keep it at that many thx for all ur help ian.


  • 0

#77
ian_blade2

ian_blade2

    Regular

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:the midlands
  • Devices:blade 2, sf1
frodo to add ,




i downloaded the unlock omc skate folder and the unlock osf2 folders i didnt merge and files or anything like that im really stuck on this now lol im far from stupid but i feel it at the moment lol




thanks for ur help ian.


  • 0

#78
Enimaxi

Enimaxi

    Newbie

  • Members
  • Pip
  • 20 posts
  • Gender:Male
  • Devices:Nokia N95, ZTE Crescent (SFII)
  • Twitter:@N/A

Fr0do has a good point. To enlarge on it: there are 2 "recovery.img" files in the "Unlock-OMC-Skate" package. One in "Preparation" and one in "Unlock/files". They are identical. However "Unlock-OSF2" only has one, in the "files" folder, and it is different to the OMC ones. The procedure says it should overwrite the file in the "unlock/files" folder from "Unlock-OSF2", but should it also overwrite the one in the Preparation folder? Otherwise at step 4, the OMC stock recovery will surely be flashed instead of the OSF2 one?

Alan


I was struggling with the exact same thing. Flashing the OMC recovery to your SF2/TMV is not a good idea, that's for sure.
Seeing as the two OMC recovery files (the one in the "unlock/files"-folder and the one in "preperation") are identical, I think the SF2/TMV recovery files should be overwritten to both these folders.

  • 0

#79
fr0do

fr0do

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,156 posts
  • Gender:Male
  • Devices:Huawei G300

i downloaded the unlock omc skate folder and the unlock osf2 folders i didnt merge and files or anything like that im really stuck on this now lol im far from stupid but i feel it at the moment lol

Well no wonder it didn't work! lol

So I take it you have a SF2 and not a Vivacity... then you can simply download the ready merged files by Collywob here: http://android.modac...ost__p__1854057

  • 0

Posted Image


#80
buzz53

buzz53

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:Orange San Francisco 2

I was struggling with the exact same thing. Flashing the OMC recovery to your SF2/TMV is not a good idea, that's for sure.
Seeing as the two OMC recovery files (the one in the "unlock/files"-folder and the one in "preperation") are identical, I think the SF2/TMV recovery files should be overwritten to both these folders.


Progress of sorts. I did as I described i.e. copied the OSF2 "recovery.img" file from the "unlock/files" folder to the "Preparation" folder and followed step 4 again. Now at step 5, instead of getting permanent green Android I find:

1) Removing the battery and powering up with VOL DOWN pressed, I get a vibration, followed by green Android, followed by the screen blanking, repeating forever.
2) Ditto, but quickly insert the battery after the first vibration, now finally progresses to the FTM screen.
3) Don't plug in the USB cable, just insert the battery and power on while pressing VOL DOWN. Also goes to the FTM screen.

I guess (2) may indicate my USB port isn;t feeding enough power, although I'd have thought that was standard.

My new question is therefore: what is the significance of powering up just on USB rather than battery? Outwardly it seems to do the same thing?

Alan

PS if I'm right about copying the "recovery.img" maybe the tutorial needs a tweak? I know this stuff is obvious if you've already done it.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users