Jump to content


Photo

[RECOVERY] : ClockworkMod Recovery for ZTE Blade 2

- - - - -

  • Please log in to reply
39 replies to this topic

#1
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404
*MY* build of Koush's ClockworkMod Recovery for the Orange San Francisco II/T-Mobile Vivacity/ZTE Blade2.

I have tested it as much as I can, but I'm always open to any more constructive feedback.

It is not officially supported by Koush, please do not bother him with support questions for this build.

Koush seems not to publish a traditional change log, however you can see the project's commit history for details

[RECOVERY] : ClockworkMod Recovery for ZTE Blade 2

NOTE: Currently the only way to install ClockworkMod Recovery is via the fastboot method, instructions can be found by following the above link.

  • 1

#2
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404
before anyone asks, yes its works on both the San Francisco 2 & the Vivacity.

  • 0

#3
todoleo

todoleo

    Geek at heart, Tech Support Monkey and feeder of Wobbles (@fatol

  • Moderator Team
  • PipPipPip
  • 225 posts
  • Gender:Male
  • Devices:Galaxy Nexus / Lumia 710
  • Twitter:@Todoleo
Wow! Well done @Sebastian404! That was mega fast!

  • 0
Twitter: @Todoleo
Identi.ca: @Todoleo

Blog: Todoleo.com

#4
The Soup Thief

The Soup Thief

    Hardcore

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 1,041 posts
  • Gender:Male
  • Location:Dublin
  • Devices:Nexus 5 (N4 etc retired)
  • Twitter:@TheSoupThief
Outstanding!

  • 0

#5
KACE_231

KACE_231

    Diehard

  • Members
  • PipPipPipPip
  • 305 posts
  • Devices:Orange San Francisco (White)
How do we install this? and root the device? thankyou

  • 0
<a href="http://giffgaff.com/...ffiliate/gagira" target="_blank"><img src="http://giffgaff.com/...r/06_250x52.png" width="250" height="52" alt="Get a free Giffgaff Sim" /></a>

#6
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,220 posts
  • Gender:Male
  • Location:northampton
  • Devices:Samsung i9305
  • Twitter:@meritez

How do we install this? and root the device? thankyou


I gather its through adb and fastboot.

  • 0

#7
raverrr

raverrr

    Recognised Ginger Ninja

  • Moderator Team
  • PipPipPipPipPipPip
  • 1,063 posts
  • Gender:Male
  • Devices:Moto G, ZTE Blate
after running reboot bootloader command the device is aparently not connected :S
"fastboot is not a recognised command" even tho i have fastboot ready in icon tray :S

Edited by raverrr, 27 November 2011 - 02:40 AM.

  • 0
-If i've been helpfull to you in any way, press that little green thanks button

#8
JudasLucifer

JudasLucifer

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,342 posts
  • Gender:Male
  • Devices:Zte Blade

after running reboot bootloader command the device is aparently not connected :S
"fastboot is not a recognised command" even tho i have fastboot ready in icon tray :S


This might be a stupid point, but don't different devices have different fastboots? So if you are trying to use the blade's one it might not work.

But I'm probably wrong.

Got the Zte drivers installed?

Trying to remember the last time I used fastboot...

  • 0

Sig.png


What Font Are You Using? (thats legible of course :P)


 


#9
ian_blade2

ian_blade2

    Regular

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:the midlands
  • Devices:blade 2, sf1
the command is fastboot-windows.exe just thought id add have u read through the rest in sebastians guide thx ian.

  • 0

#10
Bouncer5

Bouncer5

    Regular

  • Members
  • PipPip
  • 137 posts
  • Gender:Male
  • Location:Glasgow
  • Interests:Android oh course!
  • Devices:GS2
  • Twitter:@zumodoki
I need some help with this -.-

Edited by Bouncer5, 29 November 2011 - 06:52 PM.

  • 0

Posted Image


#11
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,641 posts
Seb any chance to increase the screen brightness and enable the capacitive button lights please?

  • 0

#12
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404

Seb any chance to increase the screen brightness and enable the capacitive button lights please?


what's-a-matter? your eyes not working :)

yeah, good point, I'll look into that one :)

EDIT:

LCD Backlight is fixed.. keypad is tricky, seem the kernel source is missing part of the keypad drivers....

  • 0

#13
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,641 posts

what's-a-matter? your eyes not working :)

yeah, good point, I'll look into that one :)

EDIT:

LCD Backlight is fixed.. keypad is tricky, seem the kernel source is missing part of the keypad drivers....


Another thing ZTE missed from the source release? They are on a roll! :lol:

  • 0

#14
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404
ok, I've added a couple of fixes, so the screen and keypad are now at maximum brightness..

  • 0

#15
admanirv

admanirv

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 417 posts
  • Gender:Male
  • Location:UK
  • Devices:Galaxy S3
LOL, cheat menu worked - thanks Seb.

Buttons now light up but capacitive keys still dont work, my only guess is myabe my TMV has different firmware or source? (Since I've only had it 2 days).

Cheers

  • 0

#16
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,641 posts
Might be better to use a stock Vivacity kernel for recovery as this supports both devices without any issues. The ZTE source is really buggy for blade2 devices :(

I have replaced the kernel with stock vivacity but the volume rocker doesn't work. Everything else does though.. easy fix?

  • 0

#17
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404

LOL, cheat menu worked - thanks Seb.

Buttons now light up but capacitive keys still dont work, my only guess is myabe my TMV has different firmware or source? (Since I've only had it 2 days).

Cheers


Im testing it on my Vivacity primarily over the San Francisco II.... it works fine for me, and others here....


I wonder if they have done the old Blade trick of changing parts, if you dial *983*24474636# what does it say under LCD Information?

San Francisco II
Attached File  sfo.png   35.4KB   45 downloads

Vivacity
Attached File  tmv.png   38.77KB   41 downloads

  • 0

#18
admanirv

admanirv

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 417 posts
  • Gender:Male
  • Location:UK
  • Devices:Galaxy S3
Info was...

Truly yorys
Sypnaptics
3000 series
0x22
Synaptic+ tpk

Cheers

  • 0

#19
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,641 posts
My Vivacity is Truly screen with atmel touch controller.

Looks like some may have truly screen with synaptics, or even LEAD with atmel controller.

Damn you ZTE.. stop using different parts!

  • 0

#20
admanirv

admanirv

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 417 posts
  • Gender:Male
  • Location:UK
  • Devices:Galaxy S3
Yup, I was reading about zte and Samsung said the only company that bothers them are zte due to fact they make phones so damn cheap, so it's no surprise they fit what they have in stock or what is cheapest at the time.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users