Jump to content


Photo

Blade WiFi Issue

- - - - -

  • Please log in to reply
4 replies to this topic

#1
ColdEmbrace

ColdEmbrace

    Addict

  • Members
  • PipPipPipPipPip
  • 611 posts
  • Location:United Kingdom
  • Devices:San Francisco
I've had my blade for 10 months or so now, all has been working well. I am running CM7 N241. The last day or so I have noticed that I have been having WiFi connection issues. About 6 days ago I configured my router to statically assign an IP address to my phone so that it was easier to FTP into my phone.
Yesterday I noticed that my phone was not connecting to the router it was just waiting for an IP address. So I changed the IP address assigned to my phone from my router. This seemed to have fixed the problem.
Today however I got home from work and my phone is telling me it cannot find the Wireless access point even though it is right next to it. I know my WiFi is working due to the fact that my laptop is connected to the network.
I have disabled the router from auto assigning an IP to the phone and it has made no difference at all.
Any help would be lovely.

  • 0
Orange San Francisco TFT - GiffGaff - CM7

Posted Image

#2
PeterLeics

PeterLeics

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:San Fransisco
I had a similar problem with CM7, it COULD be the 'wpa_supplicant.conf', the file which stores your previous wifi connections has become corrupted.

If you go into a Root Explorer, then into 'data', 'misc', 'wifi' and then select 'wpa_supplicant.conf', delete this item and then reboot your 'phone, it should solve the prblem, it did for me!


This is a configuraion file which will not do any harm to your 'phone but as always, any changes you make, will be at your own risk...


Regards

  • 0

#3
Sborovm

Sborovm

    Regular

  • Members
  • PipPip
  • 56 posts
  • Devices:ZTE Blade TFT (OSF)
I had similar problem yesterday but with GSF rom. The phone was waiting for IP adress assignment from the router. But then disconnected. I had rebooted the phone but without efect. I had also wiped all cache in clockworkmod but the same result.

I could connect from my Nokia phone and PC without problems. But then I discovered that I couldn't connect with my Amazon kindle ebook reader.

Then I rebooted the router and it was ok :D


  • 0

#4
ColdEmbrace

ColdEmbrace

    Addict

  • Members
  • PipPipPipPipPip
  • 611 posts
  • Location:United Kingdom
  • Devices:San Francisco
Seems to be okay for now, I was more concerned the issue had happened twice in two days. I will keep an eye out on it to see if i suffer with the problem anymore.
Thank you for the helpful advice, I am sure it might have helped me had I have used it.

  • 0
Orange San Francisco TFT - GiffGaff - CM7

Posted Image

#5
ColdEmbrace

ColdEmbrace

    Addict

  • Members
  • PipPipPipPipPip
  • 611 posts
  • Location:United Kingdom
  • Devices:San Francisco
Just in case anyone has the same issue I did. I discovered that statically assigning the IP via the phone and not the router fixed my issue.

I have a new issue now, one that I have had for a while and not really noticed but due to having some time off work I have noticed a lot more.
The WiFi icon turns white when connecting to the internet then turns green to show that it is connected to the google servers (actually having internet access) this is fine for some time but soon maybe 5mins the icon turns white and I lose connection. The only way to regain the connection is to turn Wifi off and on again. This is in no way practical. I have my phone connected to the charger most of the time and I have the screen kept awake whilst charging.
My Wireless settings are set to turn off never. This issue arose in a CM7 upgrade a few months ago and it has not gone away in subsequent upgrade to CM7 or when I was running CM10.
Having the WiFi icon white all the time means although it looks like I have a data connection there isn't one at all so I get no Gmail notification, Facebook notifications, WhatsApp notification etc.
I hope someone might be able to help me sort this out. Please let me know if you need anymore information.

  • 0
Orange San Francisco TFT - GiffGaff - CM7

Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users