Jump to content


Photo

Speaker not working on San Franciso II

- - - - -

  • Please log in to reply
4 replies to this topic

#1
mauwf

mauwf

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:San Francisco II
Hi all, I have a strange problem with my recently bought OSF2 that hopefully some of the experts on here may be able to help me with.

As I'm not on Orange, after buying the phone I turned it on to make sure it worked and then went ahead with what seemed to be the very straightforward instructions HERE for rooting, unlocking, and installing a new rom.

All works fine except the speaker doesn't work. No ringtone/notification, no media sound (e.g. music), no sound from games, etc. I can get sound through headphones but nothing through the speaker. Similarly I can make a call ok but when I switch to speakerphone all sound cuts off.

I suspect this could be a hardware issue rather than to do with the unlocking, etc. but I don't really know. So a couple of questions.

Could the unlocking, etc have somehow caused the speaker to stop working. Has anyone else heard of this?

What's the easiest way of bringing it back to a stock OSF2. Firstly to check that the unlocking didn't mess up the speaker and secondly in case I have to return it.

Very grateful for any help.

  • 0

#2
PsYcHoKiLLa

PsYcHoKiLLa

    Addict

  • Members
  • PipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Devices:LG Nexus 4, Tesco Hudl
  • Twitter:@djsubterrain
Stock Orange Rom

Just use Clockwork to flash that rom back onto your phone (presuming you managed to get Clockwork working)

  • 0

#3
lovewookie

lovewookie

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:ZTE Crescent
Sorry to resurrect this, but I have a similar problem, no sound through speaker. I get sound for a fraction of a second occasionally so I don't think it's hardware. was running FnC7 fine until a couple of days ago, where the sound just stopped. I get headphone sound and can hear callers, but no speaker.

Tried flashing CM9 too, as that's worked previously, but still the same.

Will try the stock orange rom and report back, unless someone has any other ideas about what it could be?

Thanks.

Edited by lovewookie, 31 July 2012 - 09:12 AM.

  • 0

#4
lovewookie

lovewookie

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:ZTE Crescent
Nope, that didn't work.

Any ideas?

  • 0

#5
lovewookie

lovewookie

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:ZTE Crescent
What does work, for about 2 seconds of working speaker is blowing on it. I guess it's new speaker time? Any guides on how to replace or what it can be replaced with? the original SF could use iphone parts i believe, anyone any ideas?

Thanks

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users