Jump to content


Photo

cant boot into clockworkmod


  • Please log in to reply
33 replies to this topic

#1
Richard_Arkless

Richard_Arkless

    Addict

  • Members
  • PipPipPipPipPip
  • 928 posts
REWRITE as people dont seem to understand me and the issue I am having


Hi my sister got a vega for christmas, anyway im planning on putting honeyice on it, well I heard that there is a wifi issue in honeyice and I have to boot first into vegacomb, set it up then boot back into recovery and install the honeyice update, problem is that once I am in vegacomb I can not boot into recovery (could when I was in modded stock- Android 2.2) , I hold the power button for 3 odd seconds until the dialogue comes up and select recovery, all that it does is reboot back into vegacomb, no grey screen aka stale boot

So far I have tried

  • Reinstalling moddedstock v2, same issue occurs
  • Reinstalling clockworkmod using vegatools, the error "segmentation fault" appears
  • Using vegatools to boot into clockworkmod, the error recovery 2 not found appears, reboots back into vegacomb like if I done it from the tablet
  • Flashing recovery from the tablet, flashed fine but would still reboot back into vegacomb when selecting the recovery option
  • Flashing recovery in the boot partition, failed to boot and needed to reflash back to modded stock


My aunt also got a vega for Christmas and I had no issue installing honeyice or getting into recovery and I also had a vega since January


I guess I can leave vegacomb on it but if I cant boot into recovery then how can I apply any future updates, I cant keep starting from scratch and setting it up everytime there is an update

Hi my sister just had a vega for christmas, anyway installed moddedstock fine, rebooted into clockworkmod fine, the problem is that I have been trying to install honeyice

anyway if I

  • install vegacomb then honeyice = wifi says error
  • install vegacomb then update 3 then honeyice, same issue


So I assume that the problem is that vegacomb needs to boot first before applying honeyice, problem is that I now cant boot into recovery, all it does is reboot itself (honeyice is also the same so I have to start afresh each time)

Also tried using the adb and it says recovery_2 not found, ive tried flashing recovery again and still wont work, what is the problem here?

I have also got a vega which I got last january and that can boot into recovery fine

Edited by Richard_Arkless, 31 December 2011 - 12:59 AM.

  • 0

#2
IanTurner

IanTurner

    Diehard

  • Members
  • PipPipPipPip
  • 306 posts
  • Devices:Advent Vega
Install vegacomb, setup wifi then install honeyice (or don't bother with honeyice as it just messed up your wifi which is not a great sign).
Ignore any suggestions of viewcomb as I suspect that's partly honeyice and will therefore deprive you of the opportunity to setup the wifi between
Stages,
Have you used Audi to help select the correct adb drivers?

Edited by IanTurner, 26 December 2011 - 09:44 AM.

  • 0

#3
Richard_Arkless

Richard_Arkless

    Addict

  • Members
  • PipPipPipPipPip
  • 928 posts

Install vegacomb, setup wifi then install honeyice.


Well that was my intention but like I said earlier once I am in vegacomb I cant get back into clockworkmod to install the honeyice update, all it does is reboot back into vegacomb

I just dont understand, for the fun of it I started afresh on my tablet, done exactly the same and yet I can still get into clockwork recovery

Have you used Audi to help select the correct adb drivers?



Yes I used vega tools to install the correct drivers

Edited by Richard_Arkless, 26 December 2011 - 11:52 AM.

  • 0

#4
Bazabaza

Bazabaza

    Enthusiast

  • Members
  • PipPipPip
  • 165 posts
  • Location:Stoke on Trent
  • Devices:Advent Vega, Dell Streak
I take it you are selecting the recovery option in the power down menu. if you do this you will get a grey screen. Press power to turn off then on again you should then boot into recovery. Is this what you are doing?

  • 0
Light travels faster than sound. This is why some people appear bright until you hear them speak

#5
Richard_Arkless

Richard_Arkless

    Addict

  • Members
  • PipPipPipPipPip
  • 928 posts

I take it you are selecting the recovery option in the power down menu. if you do this you will get a grey screen. Press power to turn off then on again you should then boot into recovery. Is this what you are doing?


Yea selected the recovery option and it reboots back into vegacomb, like I said I got my own vega so I do know what I need to do to flash a update or a new rom

My aunt also bought a vega and I had no problems getting into recovery

Edited by Richard_Arkless, 29 December 2011 - 12:22 AM.

  • 0

#6
Bazabaza

Bazabaza

    Enthusiast

  • Members
  • PipPipPip
  • 165 posts
  • Location:Stoke on Trent
  • Devices:Advent Vega, Dell Streak

  • 0
Light travels faster than sound. This is why some people appear bright until you hear them speak

#7
richardmlea

richardmlea

    Diehard

  • Members
  • PipPipPipPip
  • 327 posts
  • Gender:Male
  • Location:Manchester, England
  • Interests:Technology, science, movies, motorcycles, classic volkswagons, paintball, skiing to name a few of my interests.
  • Devices:P10AN01, TF201, HTC Sensation
  • Twitter:@richard lea
There is a known issue with honeyice. To work around the bug you need to setup the wifi in vegacomb 9n and when its connected then boot into recovery and apply the honeyice update.
If you read the first page of the honeyice thread it mentions this problem and how to work around it.

From honeyice thread on XDA, post number 1

"Public Beta 2 of HoneyIce 3.2.7 version known bugs:

-When Adobe Flash installed, browser FC! Use Maxthon or Dolphin for Tab instead.
-On first boot, two markets are seen, press on the one on the Desktop (it says not installed), reboot, the correct market is now shown.
-BT and wifi @ the same time is buggy.
-Kernelbug: it needs a working wi-fi connection before booting into CWM!"

The recovery problem is also a known issue and is mentioned on known bugs page of the vegacomb thread on XDA.

Heres the workaround

To boot into recovery from vegacomb 9n dont select recovery option in the clockworkmod program, it has never worked in vegacomb.
You need to press the power button for a few seconds and bring up the power menu, then select recovery from the power menu. the vega will re-boot and stale boot (just black screen), now press the power button again to turn it off and then again to turn it back on. It will now boot into recovery.
Have fun

Edited by richardmlea, 29 December 2011 - 05:06 PM.

  • 0
Richard Lea
[email protected]
Replacement Tablet Screens UK
I offer a friendly, UK Advent Vega repair service for hardware problems. Just PM or email me your requirements.
Replacement Touchscreens, LCD's and repair service for most Tablets.

#8
Richard_Arkless

Richard_Arkless

    Addict

  • Members
  • PipPipPipPipPip
  • 928 posts

See if this helps

http://forum.xda-dev...d.php?t=1041036

Thanks for the suggestion, problem is that the links are dead and the attached file has do not download in it


There is a known issue with honeyice. To work around the bug you need to setup the wifi in vegacomb 9n and when its connected then boot into recovery and apply the honeyice update.
If you read the first page of the honeyice thread it mentions this problem and how to work around it.

From honeyice thread on XDA, post number 1

"Public Beta 2 of HoneyIce 3.2.7 version known bugs:

-When Adobe Flash installed, browser FC! Use Maxthon or Dolphin for Tab instead.
-On first boot, two markets are seen, press on the one on the Desktop (it says not installed), reboot, the correct market is now shown.
-BT and wifi @ the same time is buggy.
-Kernelbug: it needs a working wi-fi connection before booting into CWM!"

The recovery problem is also a known issue and is mentioned on known bugs page of the vegacomb thread on XDA.

Heres the workaround

To boot into recovery from vegacomb 9n dont select recovery option in the clockworkmod program, it has never worked in vegacomb.
You need to press the power button for a few seconds and bring up the power menu, then select recovery from the power menu. the vega will re-boot and stale boot (just black screen), now press the power button again to turn it off and then again to turn it back on. It will now boot into recovery.
Have fun

I do know that workaround which is why I stated it in the original thread (quote below)

So I assume that the problem is that vegacomb needs to boot first before applying honeyice


the issue is that I cant boot into clockworkmod once I am on vegacomb , I hold the power button until the dialog comes up, I select recovery and it reboots back into vegacomb, no grey screen

Ive made some changes to the original thread so please re-read it

Edited by Richard_Arkless, 29 December 2011 - 09:22 PM.

  • 0

#9
Andy_E

Andy_E

    Newbie

  • Members
  • Pip
  • 37 posts

Thanks for the suggestion, problem is that the links are dead and the attached file has do not download in it

I do know that workaround which is why I stated it in the original thread (quote below)

the issue is that I cant boot into clockworkmod once I am on vegacomb , I hold the power button until the dialog comes up, I select recovery and it reboots back into vegacomb, no grey screen

Ive made some changes to the original thread so please re-read it


It sounds like it would be worth flashing the recovery image yourself...

I downloaded the 3.0.2.7 for the Vega from here:

http://www.clockworkmod.com/rommanager

I did it from a shell directly on the vega having copied the image onto my SD card but doing it via adb shell should work just as well:

flash_image recovery recovery-clockwork-3.0.2.7-vega.img

Alternatively I imagine you could use fastboot.exe as well.

Edited by Andy_E, 30 December 2011 - 10:53 AM.

  • 0

#10
Richard_Arkless

Richard_Arkless

    Addict

  • Members
  • PipPipPipPipPip
  • 928 posts

It sounds like it would be worth flashing the recovery image yourself...

I downloaded the 3.0.2.7 for the Vega from here:

http://www.clockworkmod.com/rommanager

I did it from a shell directly on the vega having copied the image onto my SD card but doing it via adb shell should work just as well:

flash_image recovery recovery-clockwork-3.0.2.7-vega.img

Alternatively I imagine you could use fastboot.exe as well.


Still doesnt work :(

ok heres the steps

  • I went into the terminal on the tablet and given it su permissions
  • I cd to the sdcard and typed that command in
  • A long list of mtd: successfully wrote block at x comes up
  • Once it goes back to where I can type commands in I hold the power button, click recovery
  • Reboot back into vegacomb
WHAT HAS ADVENT DONE, like seriously I know 3 people (my aunt and two of my friends) who I recommended the vega to and I had no problems going into recovery and installing honeyice

Edited by Richard_Arkless, 30 December 2011 - 03:12 PM.

  • 0

#11
Andy_E

Andy_E

    Newbie

  • Members
  • Pip
  • 37 posts

Still doesnt work :(


Well, there don't seem to have been any errors writing the recovery image.... so it's a bit mystifying to say the least. I'll have a think to see if I can come up with anything else to try.

:unsure:

  • 0

#12
Andy_E

Andy_E

    Newbie

  • Members
  • Pip
  • 37 posts
Apologies if you've already tried this but what happens if from a terminal (as su) you type:

reboot recovery_2

?

  • 0

#13
Richard_Arkless

Richard_Arkless

    Addict

  • Members
  • PipPipPipPipPip
  • 928 posts

Apologies if you've already tried this but what happens if from a terminal (as su) you type:

reboot recovery_2

?


Typed it in and it reboots back into vegacomb

The only solution I can think of is I flash the recovery image to the boot partition, that way it will boot straight into recovery then when im finished ill install a custom update which flashes the boot.img back in

EDIT: ok I tried that out, flashes fine, reboot and now its stuck on a black screen with the text "starting fastboot USB download protocol" on the top, oh well back to nvflash I go

Edited by Richard_Arkless, 30 December 2011 - 05:44 PM.

  • 0

#14
gooner1001

gooner1001

    Newbie

  • Members
  • Pip
  • 2 posts
Hi Guys,

I have the exact same issue. It must be rare as no one else seems to believe me. It basically makes upgrading the vega an impossible task and stops the upgrade to honey ice.

Any sugestions would be greatly appreciated as i am losing patience.

Thanks,

Jamie

  • 0

#15
Richard_Arkless

Richard_Arkless

    Addict

  • Members
  • PipPipPipPipPip
  • 928 posts

Hi Guys,

I have the exact same issue. It must be rare as no one else seems to believe me. It basically makes upgrading the vega an impossible task and stops the upgrade to honey ice.

Any sugestions would be greatly appreciated as i am losing patience.

Thanks,

Jamie


When did you buy your vega

  • 0

#16
gooner1001

gooner1001

    Newbie

  • Members
  • Pip
  • 2 posts

When did you buy your vega


October. I new the issue was there and have worked round it until honey ice and the need to ensure wifi is working before upgrading.

  • 0

#17
Andy_E

Andy_E

    Newbie

  • Members
  • Pip
  • 37 posts

EDIT: ok I tried that out, flashes fine, reboot and now its stuck on a black screen with the text "starting fastboot USB download protocol" on the top, oh well back to nvflash I go


Ah yes.... that particular error tells you your boot image is sh*gged. But you already know that now....

Had I seen your post in time, I would have told not to bother.

I have plans once the Honey Ice 3.2.7 beta / rc / rc2 etc etc settles down to knock up a single NVFLASH installer for the lot. It was going to be for my own purposes but I imagine you both might be interested in it as well....

  • 0

#18
Richard_Arkless

Richard_Arkless

    Addict

  • Members
  • PipPipPipPipPip
  • 928 posts

Ah yes.... that particular error tells you your boot image is sh*gged. But you already know that now....

Had I seen your post in time, I would have told not to bother.

I have plans once the Honey Ice 3.2.7 beta / rc / rc2 etc etc settles down to knock up a single NVFLASH installer for the lot. It was going to be for my own purposes but I imagine you both might be interested in it as well....



Ok thanks, I was going to do something similar but was going to make a backup of my working tablet and restore it in clockworkmod after installing moddedstock on my sisters tablet

This would be okay for now but I will still need to find a solution on how to get into clockworkmod for when an inevitable update gets released so if you think of something please comment

Edited by Richard_Arkless, 31 December 2011 - 01:01 AM.

  • 0

#19
emigabi

emigabi

    Newbie

  • Members
  • Pip
  • 2 posts
Isn't working for me either.
Tried every trick in the book, even the ones for POV tablets.
What I do every time is an update is start from scratch.
1.10 v2 - wi-fi setup - boot recovery - install VegaComb_HC3.2_Build9n and all Honey Ice updates on top and then boot back into Honey Ice RC2.1 and use it without recovery.
Wi-fi works.

Regards and Happy New Year.

  • 0

#20
Andy_E

Andy_E

    Newbie

  • Members
  • Pip
  • 37 posts
I've got one further thing you could try (in an attempt to find out why this doesn't work). It's another shell command + su:

setrecovery boot-recovery recovery

There's a data structure in the misc partition that allows the bootloader and recovery to communicate. I think it's probable this isn't getting written properly - hence you always get a normal reboot. The command above should set the boot command correctly - an empty command / message is a normal reboot & CWM clears this block when you do the "reboot now" option.

I got some crap out of memory read errors before I got a successful write message and then issuing a reboot command from the shell rebooted into recovery.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users