Jump to content


Photo

[ROM] {26/01} | Oodie Prime - Miui 4 (ICS 4.0.3) Alpha 1 Launched !

- - - - -

  • Please log in to reply
7 replies to this topic

#1
Oodie

Oodie

    Enthusiast

  • Members
  • PipPipPip
  • 167 posts
  • Gender:Male
  • Location:Kuliyapitiya - SriLanka
  • Devices:Xperia X10
I've Got the rom to a Stable Alpha stage . Now you can try out with confidence Posted Image

Miui 4 Alpha 1 .

This is based on FXP CM9 & will be improved when fxp improves . You can try this to see what MIUI 4 looks like & what features it includes .

Please remember that like FXP cm9 , MIUI 4 is also @ Alpha stage . There is no stable release & the only release is for Nexus S . So it may take very long time to get this stable for daily use .

My goal was to get my buddies , the first MIUI 4 for X10 & I've succeeded to get it boot & you can play around a little to feel this . I'll keep on working on this , since Prime X most probably be final . Please don't blame me for bugs .

Posted Image


-(screenshots are not mine . I stole it from sinmiui thread . Thanks to saosin )-


Installation steps .

1. Download the FXP ICS kernel - From here -

2. Download the rom from here - Download -

3. Flash the kernel via Flashtool & Flash the rom from recovery ( Do a full wipe before flashing )

4. Reboot . Reboot will take a long time . Please wait . In the first boot Go to security settings & enable Superuser permissions .

5. After boot . please give it some time to settle & reboot again . ( remember to enable USB debugging from developer options menu )

6. Try out the rom . & Give me detailed reports Posted Image



Not working .

Mobile Data
Camera
Usb tether
usb mount ( UMS app included & with su permission it works well )

Working

GSM
Phone
Messaging
Wifi
Bluetooth ( should work )
Wifi tether ( with given app )
Superuser Permissions
Music
GPS

Credits :

FXP Team
- For everything , everything & everything They've given us & giving us to feel still alive .

Spaarc , Cobrato , Doomlord , crowds & all helped me & all are with me .



-------------------------------------------------------------------
Please don't Post useless things . Only post what will give me more to improve this & also your experiments that worked to get some bugs solved . Thankyou .
-------------------------------------------------------------------

Edited by Oodie, 26 January 2012 - 02:31 AM.

  • 1

Always Use "+" Button If Anyone Helps You


Posted Image


! You Can DONATE Me - If I've been any help to you !
----------------------------
: Oodie's Goal :
* Develop Most Complete & Stable Custom Ported Roms *
* Developing Them with Minimum Issues *
* Never Brag About what I do *

----------------------------
- MY Miui Rom / MY CM 7 Rom -
----------------------------


#2
Oodie

Oodie

    Enthusiast

  • Members
  • PipPipPip
  • 167 posts
  • Gender:Male
  • Location:Kuliyapitiya - SriLanka
  • Devices:Xperia X10
Changelog . Alpha 1

* Phone & Messaging fixed .

* Superuser working . ( Miui Security app )

* Sound settings FC fixed .

* Wifi working .

* Wlod fixed when entering rom manager or the browser .

* Market downloads work fine .

* Gps OK

* Music works well with FX on .

* Contacts work fine .

* Added Nofrills cpu manager & CPUspy for user convenience .

* Graphically cool installation procedure Posted Image




Apart from the lags , I can say that this version is pretty stable after the first boot & settling down for few hours . I tried Go launcher with it & the lag is almost gone with using it . Try some other things & let me know Posted Image

  • 2

Always Use "+" Button If Anyone Helps You


Posted Image


! You Can DONATE Me - If I've been any help to you !
----------------------------
: Oodie's Goal :
* Develop Most Complete & Stable Custom Ported Roms *
* Developing Them with Minimum Issues *
* Never Brag About what I do *

----------------------------
- MY Miui Rom / MY CM 7 Rom -
----------------------------


#3
1eyedmonster

1eyedmonster

    Regular

  • Members
  • PipPip
  • 95 posts
  • Devices:nokia 6630
Will you still support prime rom until ics is Stable ?

Edited by 1eyedmonster, 26 January 2012 - 11:33 AM.

  • 0

#4
mt2jjj

mt2jjj

    Enthusiast

  • Members
  • PipPipPip
  • 282 posts
  • Gender:Male
  • Location:croatia
  • Interests:everything about; phones, cameras, android OS, computers(expert;-))
  • Devices:I9100

Will you still support prime rom until ics is Stable ?


I hope that he will update M1U1Prime as well from time to time, but its near to final i think

  • 0
"Yet even that enemy of God and man had friends and associates in his desolation; I am alone."


#5
SONB

SONB

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:Sony Ericsson XPERIA x10i
Good to see your MIUI 4 thread here on Modaco, Ooodie. I can't post on XDA because of the 10-posts-restriction.

My problem with the ROM is that it says "no service" all the time and doesn't ask for the SIM number. There is just no prompt screen for it on the first boot and after every single reboot. The first thing I see on [re]boot is the UMS app telling me that the USB is not connected. I close it with the "BACK" button, then comes the MIUI Security app asking me to activate it in the Settings. After activating it I close it with the "BACK" button again. After that it jumps instantly to the home screen and shows no signal icon in the status bar.

I'm using your ROMs since Prime 7 and havn't had any problems like this one. The launcher, as you said, is very laggy (it's ok, is an alpha), but everything else feels very smooth for an alpha. Especially the settings menus seem to be a bit smoother than in Prime X.

Sorry, I had not much time to test anything else, had to restore Prime X as soon as possible. But if you have any suggestion about the SIM card problem I could find a minute or two and flash the ROM again ;)

  • 0

#6
1eyedmonster

1eyedmonster

    Regular

  • Members
  • PipPip
  • 95 posts
  • Devices:nokia 6630
Have you used the kernel provided?

  • 0

#7
Oodie

Oodie

    Enthusiast

  • Members
  • PipPipPip
  • 167 posts
  • Gender:Male
  • Location:Kuliyapitiya - SriLanka
  • Devices:Xperia X10

Good to see your MIUI 4 thread here on Modaco, Ooodie. I can't post on XDA because of the 10-posts-restriction.

My problem with the ROM is that it says "no service" all the time and doesn't ask for the SIM number. There is just no prompt screen for it on the first boot and after every single reboot. The first thing I see on [re]boot is the UMS app telling me that the USB is not connected. I close it with the "BACK" button, then comes the MIUI Security app asking me to activate it in the Settings. After activating it I close it with the "BACK" button again. After that it jumps instantly to the home screen and shows no signal icon in the status bar.

I'm using your ROMs since Prime 7 and havn't had any problems like this one. The launcher, as you said, is very laggy (it's ok, is an alpha), but everything else feels very smooth for an alpha. Especially the settings menus seem to be a bit smoother than in Prime X.

Sorry, I had not much time to test anything else, had to restore Prime X as soon as possible. But if you have any suggestion about the SIM card problem I could find a minute or two and flash the ROM again ;)


GSM signal works fine for me . & in anyrom there wasn't a sim number prompt for me . maybe its your service provider & miui 4 still doesn't support it . Let's wait for upcoming releases & see if its been solved . & Thanks for your review :)

  • 0

Always Use "+" Button If Anyone Helps You


Posted Image


! You Can DONATE Me - If I've been any help to you !
----------------------------
: Oodie's Goal :
* Develop Most Complete & Stable Custom Ported Roms *
* Developing Them with Minimum Issues *
* Never Brag About what I do *

----------------------------
- MY Miui Rom / MY CM 7 Rom -
----------------------------


#8
9Lukas5

9Lukas5

    Regular

  • Members
  • PipPip
  • 91 posts
  • Gender:Male
  • Location:Stuttgart (Germany)
  • Devices:Se XPERIA X10i

Good to see your MIUI 4 thread here on Modaco, Ooodie. I can't post on XDA because of the 10-posts-restriction.

My problem with the ROM is that it says "no service" all the time and doesn't ask for the SIM number. There is just no prompt screen for it on the first boot and after every single reboot. The first thing I see on [re]boot is the UMS app telling me that the USB is not connected. I close it with the "BACK" button, then comes the MIUI Security app asking me to activate it in the Settings. After activating it I close it with the "BACK" button again. After that it jumps instantly to the home screen and shows no signal icon in the status bar.

I'm using your ROMs since Prime 7 and havn't had any problems like this one. The launcher, as you said, is very laggy (it's ok, is an alpha), but everything else feels very smooth for an alpha. Especially the settings menus seem to be a bit smoother than in Prime X.

Sorry, I had not much time to test anything else, had to restore Prime X as soon as possible. But if you have any suggestion about the SIM card problem I could find a minute or two and flash the ROM again ;)


You have to flash any 2.3 rom, remove the simpin and then flash ics again. Then you'll get a signal.

  • 0
[HOW-TO]UNLOCK bootloader for X10


Device: SE-Xperia X10i
Baseband version: 2.1.71
Android version: 2.3.7
Bootloaderstatus: UNLOCKED
Kernel Version: 2.6.29-modFXP-DooMKernel-v06
DooMLoRD@chaos) )
Build Number: MIUI-2.1.13 OODIE|pRiMe 9
Updated through romupdater from market




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users