Jump to content


Photo

[ DEV ] HTC Sense

* * * - - 11 votes

  • Please log in to reply
226 replies to this topic

#141
John Enter

John Enter

    Newbie

  • Members
  • Pip
  • 43 posts
  • Devices:ZTE Blade
Alpha 3.1 resets here after a few seconds, both with and without sim.

  • 0

#142
the_crevis

the_crevis

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Gender:Male
  • Devices:LG Nexus 4, ZTE Crescent
  • Twitter:@the_crevis
Yes, alpha 3.1 does reboot immediately, sorry I can see the mistake, I'm fixing atm and will release a new alpha soon.

Edit: okay... this is more complex than I thought. On my backup of sense which is the same as alpha3.1 I get no reboots, but if I then wipe the data and boot up again I get reboots and logcat isn't helping :/ Any ideas?

Edited by the_crevis, 21 March 2012 - 05:20 PM.

  • 0
LG Nexus 4 (daily driver) - CM10.2
ZTE Crescent (backup) - CM9
ZTE Blade - Deceased
If I helped you at all then remember to hit that green up arrow! Posted Image

#143
XMasterNinni

XMasterNinni

    Diehard

  • Members
  • PipPipPipPip
  • 427 posts
  • Gender:Male
  • Location:Austria
  • Devices:ZTE Blade
Hmmh...

There was a reboot problem with the old Galaxy Ace ICS Builds...

The problen happened only with some Sim Cards but now they changed the kernel and it works...

Will try booting up without sim card...

  • 0

ZTE Porting Tool



Ever wondered how to Port ROMs from one Phone to another? Well it isn't that easy if you do it manually. But, luckily, there is a simple tool, which makes it easy for you to port ROMs. Curious?


Easy ROM Porting for Everyone


#144
John Enter

John Enter

    Newbie

  • Members
  • Pip
  • 43 posts
  • Devices:ZTE Blade

Yes, alpha 3.1 does reboot immediately, sorry I can see the mistake, I'm fixing atm and will release a new alpha soon.

Edit: okay... this is more complex than I thought. On my backup of sense which is the same as alpha3.1 I get no reboots, but if I then wipe the data and boot up again I get reboots and logcat isn't helping :/ Any ideas?


Odd suggestion, but would formatting /system instead of wiping data help?

  • 0

#145
the_crevis

the_crevis

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Gender:Male
  • Devices:LG Nexus 4, ZTE Crescent
  • Twitter:@the_crevis

Odd suggestion, but would formatting /system instead of wiping data help?


No cause you need the data from my build in the first place, I could include my data but that's not a proper fix.

  • 0
LG Nexus 4 (daily driver) - CM10.2
ZTE Crescent (backup) - CM9
ZTE Blade - Deceased
If I helped you at all then remember to hit that green up arrow! Posted Image

#146
the_crevis

the_crevis

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Gender:Male
  • Devices:LG Nexus 4, ZTE Crescent
  • Twitter:@the_crevis

Hmmh...

There was a reboot problem with the old Galaxy Ace ICS Builds...

The problen happened only with some Sim Cards but now they changed the kernel and it works...

Will try booting up without sim card...


Its nothing to do with the sim card... I just seem to get a heck of a lot of errors on a build where I've wiped the data, and I don't get them at all when I haven't wiped.

  • 0
LG Nexus 4 (daily driver) - CM10.2
ZTE Crescent (backup) - CM9
ZTE Blade - Deceased
If I helped you at all then remember to hit that green up arrow! Posted Image

#147
the_crevis

the_crevis

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Gender:Male
  • Devices:LG Nexus 4, ZTE Crescent
  • Twitter:@the_crevis
Here's the logcat around the error: http://pastebin.com/dC7Vpwau and normally I don't get any audio errors :/

  • 0
LG Nexus 4 (daily driver) - CM10.2
ZTE Crescent (backup) - CM9
ZTE Blade - Deceased
If I helped you at all then remember to hit that green up arrow! Posted Image

#148
fonix232

fonix232

    Addict

  • Members
  • PipPipPipPipPip
  • 942 posts
  • Location:Hungary, Debrecen
  • Devices:ZTE Blade [TFT 512RAM]
  • Twitter:@fonix232
It seems to be a problem with NetworkLocation (the service death occurs after an error with NetworkLocation).

  • 0
If you like my work, invite me for a drink or two!

Also, take a look at my Blade-dedicated site too! fonix232.co.cc

#149
Sulthekk

Sulthekk

    Addict

  • Members
  • PipPipPipPipPip
  • 619 posts
  • Devices:ZTE Blade
But then why restoring data helps for crevis? If NetworkLocation reads something from there, then how that data has been written there for crevis for the first time?

  • 0

#150
John Enter

John Enter

    Newbie

  • Members
  • Pip
  • 43 posts
  • Devices:ZTE Blade
I'm not trying to put you guys under pressure or annoy you, but is there any news for an update this weekend? There used to be a lot of posts daily but the project seems to have gotten in a bad patch or something(again, nothing against the developers or anything).

Anyway, still loving the work the developers put in this, and I'm hoping to see some news soon Posted Image

  • 0

#151
Sulthekk

Sulthekk

    Addict

  • Members
  • PipPipPipPipPip
  • 619 posts
  • Devices:ZTE Blade
My current guess is this error:

E/AndroidRuntime( 755): FATAL EXCEPTION: NetworkLocationProvider
E/AndroidRuntime( 755): java.lang.SecurityException: Neither user 10010 nor current process has android.permission.ACCESS_COARSE_LOCATION.

Crevis, can you make log on non-rebooting backup? Seems like that NetworkLocationProvider has no permission to get network location, but would be nice to see the difference, unluckily I can't reproduce the non-rebooting state.

  • 0

#152
the_crevis

the_crevis

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Gender:Male
  • Devices:LG Nexus 4, ZTE Crescent
  • Twitter:@the_crevis

My current guess is this error:

E/AndroidRuntime( 755): FATAL EXCEPTION: NetworkLocationProvider
E/AndroidRuntime( 755): java.lang.SecurityException: Neither user 10010 nor current process has android.permission.ACCESS_COARSE_LOCATION.

Crevis, can you make log on non-rebooting backup? Seems like that NetworkLocationProvider has no permission to get network location, but would be nice to see the difference, unluckily I can't reproduce the non-rebooting state.


Thing is, it has that permission so I don't know why its saying it doesn't, and the well the difference is that there are no errors on the backup, I'll make a log if I can't fix it soon.

  • 0
LG Nexus 4 (daily driver) - CM10.2
ZTE Crescent (backup) - CM9
ZTE Blade - Deceased
If I helped you at all then remember to hit that green up arrow! Posted Image

#153
weeo

weeo

    Addict

  • Members
  • PipPipPipPipPip
  • 607 posts
  • Gender:Male
  • Devices:ZTE Blade & Galaxy Nexus
Hey The_Crevis. Sorry I couldn't help during the week. I can only help on weekends. So here I am. Let me know if you need anything

  • 0
Who said other phones cant have Ice Cream Sandwich?
Spreading the fun on Android 4.0.3
Check out my YouTube for Androidy Things: www.youtube.com/theandroidcity
Check out my blog for Androidy new, reviews and other: www.theandroidcity.wordpress.com

#154
Sulthekk

Sulthekk

    Addict

  • Members
  • PipPipPipPipPip
  • 619 posts
  • Devices:ZTE Blade

Hey The_Crevis. Sorry I couldn't help during the week. I can only help on weekends. So here I am. Let me know if you need anything


If you read a few posts back, then you see that the current problem is NetworkLocation, if you could help, it would be appreciated.

Crevis:
Those working data must got into your backup somehow. How did you exactly flashed it the time you made the backup? Is it possible that you didn't actually wipe and it's from a previous rom?

  • 0

#155
weeo

weeo

    Addict

  • Members
  • PipPipPipPipPip
  • 607 posts
  • Gender:Male
  • Devices:ZTE Blade & Galaxy Nexus

If you read a few posts back, then you see that the current problem is NetworkLocation, if you could help, it would be appreciated.

Crevis:
Those working data must got into your backup somehow. How did you exactly flashed it the time you made the backup? Is it possible that you didn't actually wipe and it's from a previous rom?

Yeah I've read them. What build are we on? Sorry Im still in bed and I can't comprehend anything. Ill get to work after breakfast :-)

  • 0
Who said other phones cant have Ice Cream Sandwich?
Spreading the fun on Android 4.0.3
Check out my YouTube for Androidy Things: www.youtube.com/theandroidcity
Check out my blog for Androidy new, reviews and other: www.theandroidcity.wordpress.com

#156
the_crevis

the_crevis

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Gender:Male
  • Devices:LG Nexus 4, ZTE Crescent
  • Twitter:@the_crevis
Right, I can only conclude that it is actually the fixed libsurfaceflinger that causes the reboots. This is because on the alpha2 build with the upside down screen, there are no reboots. Then I replace the libsurfaceflinger, make a new build and I get the reboots. I didn't get reboots in the first place with it because I just pushed it to a alpha2 build. Its all very strange :S

  • 0
LG Nexus 4 (daily driver) - CM10.2
ZTE Crescent (backup) - CM9
ZTE Blade - Deceased
If I helped you at all then remember to hit that green up arrow! Posted Image

#157
weeo

weeo

    Addict

  • Members
  • PipPipPipPipPip
  • 607 posts
  • Gender:Male
  • Devices:ZTE Blade & Galaxy Nexus

Right, I can only conclude that it is actually the fixed libsurfaceflinger that causes the reboots. This is because on the alpha2 build with the upside down screen, there are no reboots. Then I replace the libsurfaceflinger, make a new build and I get the reboots. I didn't get reboots in the first place with it because I just pushed it to a alpha2 build. Its all very strange :S

I've only had 2 reboots on alpha3... let me look into aswell

  • 0
Who said other phones cant have Ice Cream Sandwich?
Spreading the fun on Android 4.0.3
Check out my YouTube for Androidy Things: www.youtube.com/theandroidcity
Check out my blog for Androidy new, reviews and other: www.theandroidcity.wordpress.com

#158
weeo

weeo

    Addict

  • Members
  • PipPipPipPipPip
  • 607 posts
  • Gender:Male
  • Devices:ZTE Blade & Galaxy Nexus
Firstly, today I will update and upload stuff to the project website. Then I can get a fix from some developers from the LG, Samsung ports as I believe they to had this problem.

  • 0
Who said other phones cant have Ice Cream Sandwich?
Spreading the fun on Android 4.0.3
Check out my YouTube for Androidy Things: www.youtube.com/theandroidcity
Check out my blog for Androidy new, reviews and other: www.theandroidcity.wordpress.com

#159
android@sam

android@sam

    Enthusiast

  • Members
  • PipPipPip
  • 259 posts
  • Gender:Male
  • Location:Nagpur,India
  • Interests:Computers, MObilez...
  • Devices:DELL XCD35 aka ZTE BLADE
hey how did you fix the rosie.apk?bcauz when i try ahdpi launcher it force closes.
thanks in advance.

  • 0

Sony Ericsson UI On your ZTE BLADE

"CYANSCAPE"


#160
weeo

weeo

    Addict

  • Members
  • PipPipPipPipPip
  • 607 posts
  • Gender:Male
  • Devices:ZTE Blade & Galaxy Nexus

hey how did you fix the rosie.apk?bcauz when i try ahdpi launcher it force closes.
thanks in advance.

You will have to ask the_crevis on that one

  • 0
Who said other phones cant have Ice Cream Sandwich?
Spreading the fun on Android 4.0.3
Check out my YouTube for Androidy Things: www.youtube.com/theandroidcity
Check out my blog for Androidy new, reviews and other: www.theandroidcity.wordpress.com




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users