Jump to content


Photo

Keep Wi-Fi on during sleep?

- - - - -

  • Please log in to reply
10 replies to this topic

#1
Zarch1972

Zarch1972

    Diehard

  • Senior News Team
  • PipPipPipPip
  • 405 posts
  • Gender:Male
  • Location:Sheffield
  • Interests:Husband, Dad, Wednesdayite and Geek!
  • Devices:iPhone 5S, Nexus 7, Chromebook
  • Twitter:@Zarch1972
I was wondering what the majority of people have this set to? And what is your battery life like?

I'm not a heavy user of my phone and it can sit idle on my desk for hours on end during the day (away from home, so no Wi-Fi available). But it can still consume large amounts of battery.(more than i'd expect anyway)

I've spent a while using BetterBatteryStats etc looking for culprits and I can only put it down to Wi-Fi as other apps barely register. I though this because when looking in "BatteryMonitorWidget" graphs, I could see the mA usage whilst sleeping was quite high even when the phone was idle.

Ever since i'd got the phone i'd got 'Keep Wi-Fi on during sleep' set to "Always", but just last week I decided to changed to "Never" to see what effect it would have.

Well i've been stunned. My battery life has taken a massive jump and i'm getting far more out of it. And the mA graph in "BatteryMonitorWidget" now shows much lower levels whilst idle (25mA etc) as opposed to 70ish before I made the Wi-Fi setting change.

It does ask the question, what was happening with the radio/wi-fi even though I had no Wi-Fi to connect to when it was sat on my desk before I made the setting change? Was it constantly polling and eating battery? Radio problem? or by design?

My set-up is as follows.

3.0.8-franco-kernel-nightly #97
MoDaCo ir 11 (IMM30B) GSM
I9250XXKL1

Will be interested to hear other people's experiences.

The only downside I can see from this change is that whilst at home and the phone is sleeping, it uses mobile data rather than Wi-Fi. But its only a few Kb for mail and tweets etc in background, so i'm not too concerned about high data usage.

Edited by Zarch1972, 19 March 2012 - 08:42 AM.

  • 0

#2
CaspaTheGhost

CaspaTheGhost

    Enthusiast

  • Members
  • PipPipPip
  • 153 posts
  • Gender:Male
  • Location:West London
  • Devices:Galaxy Nexus
  • Twitter:@Caspa_TheGhost
I keep mine set to 'Always'... This gives me better battery life as I am on WiFi at home and work. WiFi has a lower power draw compared to Mobile Data so when in use it's definitely a better option.

I never turn WiFi off though.

On some kernels (Franco's included I believe) the polling interval has been increased in order to reduce the drain but I've never found it to be an issue (and I've managed 5hrs screen on time!)...

  • 0

#3
Zarch1972

Zarch1972

    Diehard

  • Senior News Team
  • PipPipPipPip
  • 405 posts
  • Gender:Male
  • Location:Sheffield
  • Interests:Husband, Dad, Wednesdayite and Geek!
  • Devices:iPhone 5S, Nexus 7, Chromebook
  • Twitter:@Zarch1972

I keep mine set to 'Always'... This gives me better battery life as I am on WiFi at home and work. WiFi has a lower power draw compared to Mobile Data so when in use it's definitely a better option.

I never turn WiFi off though.

On some kernels (Franco's included I believe) the polling interval has been increased in order to reduce the drain but I've never found it to be an issue (and I've managed 5hrs screen on time!)...


Thanks for taking the time to reply.

I may have to do some proper testing because my situation seems to yield the opposite results to yourself.

Having the setting to turn Wi-Fi off during sleeps gives me better battery life. This is when i'm somewhere that I can't use Wi-Fi. (ie at work)

According to Battery Monitor Widget, I use less mA this way than when I leave "Keep Wi-Fi On" set to Always. Maybe its a polling thing? Can't find a connection, but just keeps polling/searching?

Edited by Zarch1972, 21 March 2012 - 03:19 PM.

  • 0

#4
CaspaTheGhost

CaspaTheGhost

    Enthusiast

  • Members
  • PipPipPip
  • 153 posts
  • Gender:Male
  • Location:West London
  • Devices:Galaxy Nexus
  • Twitter:@Caspa_TheGhost

Thanks for taking the time to reply.

I may have to do some proper testing because my situation seems to yield the opposite results to yourself.

Having the setting to turn Wi-Fi off during sleeps gives me better battery life. This is when i'm somewhere that I can't use Wi-Fi. (ie at work)

According to Battery Monitor Widget, I use less mA this way than when I leave "Keep Wi-Fi On" set to Always. Maybe its a polling thing? Can't find a connection, but just keeps polling/searching?


Yes, it will continue to poll but it shouldn't make that much of a difference - at least it hasn't in my experience. My suggestion would be to try another kernel, I'm sure Imoseyon's LeanKernel includes some sort of wakelock tweaks for WiFi... With the latest version of Franco's app you can now flash Leankernel...

  • 0

#5
Zarch1972

Zarch1972

    Diehard

  • Senior News Team
  • PipPipPipPip
  • 405 posts
  • Gender:Male
  • Location:Sheffield
  • Interests:Husband, Dad, Wednesdayite and Geek!
  • Devices:iPhone 5S, Nexus 7, Chromebook
  • Twitter:@Zarch1972

Yes, it will continue to poll but it shouldn't make that much of a difference - at least it hasn't in my experience. My suggestion would be to try another kernel, I'm sure Imoseyon's LeanKernel includes some sort of wakelock tweaks for WiFi... With the latest version of Franco's app you can now flash Leankernel...

I've done some testing this morning and i'm more confused than ever. During both tests, the phone was sat in my pocket doing nothing except picking up any push emails and sync twitter/facebook/tweetdeck.

And at my desk at work, I have no Wi-Fi to connect to, but there are plenty around advertising themselves.

8am to 10am
Keep Wi-Fi on during sleep: NEVER
Start Battery: 95%
End Battery: 91%
CPU Spy: 0%, 8%, 91% (deep sleep)
mA rating through period: 27mA

10am to Noon
Keep Wi-Fi on during sleep: ALWAYS
Start Battery: 91%
End Battery: 87%
CPU Spy: 1%, 8%, 90% (deep sleep)
mA rating through period: 30mA


So really, bugger all difference. :blink:

All I can think is that Franco kernel has brought some improvements recently? I upgraded to Milestone #2 since initially observing the higher Wi-Fi power usage. And that is the only thing that has changed on the phone.

Edited by Zarch1972, 22 March 2012 - 01:01 PM.

  • 0

#6
Zarch1972

Zarch1972

    Diehard

  • Senior News Team
  • PipPipPipPip
  • 405 posts
  • Gender:Male
  • Location:Sheffield
  • Interests:Husband, Dad, Wednesdayite and Geek!
  • Devices:iPhone 5S, Nexus 7, Chromebook
  • Twitter:@Zarch1972
More testing and I can only assume it was something in an earlier version of Franco Kernel that was causing the high mA / battery usage problem I experienced.

I took Caspa's advice and tried Lean Kernel (stable 2.6.0)

Tests show there is very little, if any difference now between Lean Kernel and Franco in both ALWAYS and NEVER Wi-Fi sleep settings when the phone is dormant in my pocket doing the odd bit of syncing.

8am to 9am
Keep Wi-Fi on during sleep: ALWAYS
Start Battery: 93%
End Battery: 91%
CPU Spy: 0%, 0%, 9%, 91% (deep sleep)
mA rating through period: 25mA

9am to 10am
Keep Wi-Fi on during sleep: NEVER
Start Battery: 91%
End Battery: 89%
CPU Spy: 0%, 0%, 11%, 89% (deep sleep)
mA rating through period: 25mA

So a negligible 5mA here and there between kernels and settings.

Thanks for the help Caspa....... appreciated. :P

  • 0

#7
CaspaTheGhost

CaspaTheGhost

    Enthusiast

  • Members
  • PipPipPip
  • 153 posts
  • Gender:Male
  • Location:West London
  • Devices:Galaxy Nexus
  • Twitter:@Caspa_TheGhost
Welcome mate...

Didn't think there would be a real noticeable difference, glad your tests showed it to be negligible... Like I said, I never think about WiFi it just stays on all day everyday regardless of whether I have a connection...

  • 0

#8
Zarch1972

Zarch1972

    Diehard

  • Senior News Team
  • PipPipPipPip
  • 405 posts
  • Gender:Male
  • Location:Sheffield
  • Interests:Husband, Dad, Wednesdayite and Geek!
  • Devices:iPhone 5S, Nexus 7, Chromebook
  • Twitter:@Zarch1972

Welcome mate...

Didn't think there would be a real noticeable difference, glad your tests showed it to be negligible... Like I said, I never think about WiFi it just stays on all day everyday regardless of whether I have a connection...

Usually the same here, but must have been something in the kernel I was running... maybe I was too eager with a nightly update or something? :D

  • 0

#9
Zarch1972

Zarch1972

    Diehard

  • Senior News Team
  • PipPipPipPip
  • 405 posts
  • Gender:Male
  • Location:Sheffield
  • Interests:Husband, Dad, Wednesdayite and Geek!
  • Devices:iPhone 5S, Nexus 7, Chromebook
  • Twitter:@Zarch1972
Further to this story, I heartily recommend you check out the latest stable version of Imoseyon's Lean Kernel.

v 2.7.2 is giving me stunning "standby" battery life. I've done very little on the phone today, but in the 8 hours i've had it off charge i'm only down to 83%.

That's not on Wi-Fi and at times i'm only peaking at 20 mA whilst in my pocket.

Edited by Zarch1972, 26 March 2012 - 01:07 PM.

  • 0

#10
CaspaTheGhost

CaspaTheGhost

    Enthusiast

  • Members
  • PipPipPip
  • 153 posts
  • Gender:Male
  • Location:West London
  • Devices:Galaxy Nexus
  • Twitter:@Caspa_TheGhost
Have just flashed Franco's latest nightly, r110... So gonna give that a spin for a bit as I've been really impressed with his latest work, performs really well for me...

Imosoyen's kernel is definitely my other choice, was using it when I first got my GN and then when the combination of Franco and MCR had GPS issues...

  • 0

#11
MLB1949

MLB1949

    Newbie

  • Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:Chicago, IL USA
  • Interests:Samsung Galaxy S3 (SGH-T999)
  • Devices:T-Mobile Samsung Galaxy S3
I keep my Wi-Fi connected at night, with the AC charger plugged-in, so that my Android Market/Play Store updates are automatically installed and, also, so that my e-mail messages arrive. I set the Play Store updates for "by Wi-Fi only" in order to lessened my cell plan's data-use. So far, no problems (Samsung Galaxy Nexus i9250), night or day with battery use (ROM Mod: BlackIce Maguro 31 31).

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users