Jump to content


Photo

[ROM] VegaCream for Advent Vega / PoV Mobii Tegra


  • Please log in to reply
229 replies to this topic

#161
Daedric1383

Daedric1383

    Regular

  • Members
  • PipPip
  • 148 posts

On tabletroms richard found out that it could be the simcard module that us causing the problems. He disconnected the simcard module and his reboot problems were gone.....
I am in NL.... pretty close near DE :P


I also remember Richard saying that without a sim module, the whole EM770W is disabled :) He tried to upgrade one in windows, and because it did not have a sim, it wouldn't work.
IT makes some sense, as GPS does not work without 3G working ;)

  • 0

#162
c31b32364ce19ca8

c31b32364ce19ca8

    Newbie

  • Members
  • Pip
  • 7 posts

I cannot see it in astro file manager or any other file manger, "directory does not exist" is the error.

Not show up in storage in the settings either...

I assume that you do something wrong. I just tested the USB host mode, i.e. attaching USB mass storage with Beta4.1 (w/ new kernel) and it works here. As scanno said, it is mounted to /mnt/usbdisk and it shows up in settings app > storage. You can even unmount, remount it from there.

One thing you need to know when trying to introduce the permanent USB host mode "hack" to vega_postboot.sh running Beta4.1 w/ new kernel (CWM zip) ... You need to temporarily remount the /system partition rw (this isn't needed with Beta3 or Beta4.1 w/ old kernel). Please read http://www.tabletrom....html#post66492 for a howto (I just posted this over at tabletroms.com)

Edited by c31b32364ce19ca8, 04 July 2012 - 11:33 PM.

  • 0

#163
Daedric1383

Daedric1383

    Regular

  • Members
  • PipPip
  • 148 posts

@All,

Here is a CWM update zip with an updated kernel. Flash this in recovery. It just installs the kernel so *DO NOT* wipe.

http://www.mediafire...y947uc1889uxoxl


Ok last_kmsg for you... it doesn't look good.

http://pastebin.com/KMawNFZs

  • 0

#164
elf69

elf69

    Newbie

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Penzance, Cornwall
  • Interests:Classic cars, photography, RC rock crawlers, Playing with android stuff
  • Devices:Orange San Diego

I assume that you do something wrong. I just tested the USB host mode, i.e. attaching USB mass storage with Beta4.1 (w/ new kernel) and it works here. As scanno said, it is mounted to /mnt/usbdisk and it shows up in settings app > storage. You can even unmount, remount it from there.

One thing you need to know when trying to introduce the permanent USB host mode "hack" to vega_postboot.sh running Beta4.1 w/ new kernel (CWM zip) ... You need to temporarily remount the /system partition rw (this isn't needed with Beta3 or Beta4.1 w/ old kernel). Please read http://www.tabletrom....html#post66492 for a howto (I just posted this over at tabletroms.com)


Thank you.

Yes I think it must be me and NOT your wonderful ROM :)

It settings app > Storgae my USB flash drive does NOT show.

I do not require a permenant host hack I dont mine shuttle tools im used to it from viewcomb :)

I will flash my tablet with latest ROM when I have time but busy and my tablet going off for repair very soon (bady fitted replacement touchscreen).

I just wanted to know what im doing wrong or is it my flashing didnt go right?

You guys are great and have told many friends to come here :)

Edited by elf69, 05 July 2012 - 09:13 AM.

  • 0
Currently have: Orange San Diego, Orange San Francisco, Viewsonic 10S, Freelander PD10 3G "Monster phone"

#165
c31b32364ce19ca8

c31b32364ce19ca8

    Newbie

  • Members
  • Pip
  • 7 posts

I just wanted to know what im doing wrong or is it my flashing didnt go right?

I cannot see it in astro file manager or any other file manger, "directory does not exist" is the error.

I just re-read your previous posting and assumed you're running either VC Beta3 and/or Beta4.1 (haven't tested other versions), you really should have a directory /mnt/usbdisk/

One last try: Please open Terminal app, type "su" (without the quotes), accept su request (if you haven't done so already), type "cd /mnt" (without the quotes), type "ls" (without the quotes) and again please watch out for the usbdisk directory within the listing. If it doesn't show up, type "mkdir /mnt/usbdisk" (without the quotes), switch to host mode and plug in the USB mass storage device again. Verify a successful mount by typing "df" (without the quotes). If /mnt/usbdisk shows in df listing, good, otherwise please re-flash as I'd really need physical access to your device to see for myself what's going on there.

Btw, ROM is courtesy of scanno and others. I'm just another user of Vegacream.

Edited by c31b32364ce19ca8, 05 July 2012 - 10:31 AM.

  • 0

#166
elf69

elf69

    Newbie

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Penzance, Cornwall
  • Interests:Classic cars, photography, RC rock crawlers, Playing with android stuff
  • Devices:Orange San Diego
well just flashed the latest ROM.

USB is not working at all now, no power light on my flash drive or external HDD.

also when trying to setup my google account for market "Unfortunately, the process.com.process.gapps has stopped"

Will roll back to previous ROM I had as the market worked.

although now listed in storage is USB however its all greyed out.

Im gonna flash viewcomb just to see if my USB port has failed as I know for sure that it worked in that ROM.

Im starting to think my tablet is failing on me :(

  • 0
Currently have: Orange San Diego, Orange San Francisco, Viewsonic 10S, Freelander PD10 3G "Monster phone"

#167
elf69

elf69

    Newbie

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Penzance, Cornwall
  • Interests:Classic cars, photography, RC rock crawlers, Playing with android stuff
  • Devices:Orange San Diego
OK Flashed viewcomb and my USB is working.

after leaving the latest ISC for 5 mins it did try to read my USB hard drive but the tablet rebooted and then hung on the android loading screen.

Anyone else with a viewsonic viewpad 10S with latest ROM to see if its a chipset conflict or just my tablet.

Really annoying me now, I'll drive dads works van over it soon, lol

  • 0
Currently have: Orange San Diego, Orange San Francisco, Viewsonic 10S, Freelander PD10 3G "Monster phone"

#168
Scanno

Scanno

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 437 posts
  • Location:Arnhem
  • Devices:HTC Desire Z, POV Mobii Tegra

OK Flashed viewcomb and my USB is working.

after leaving the latest ISC for 5 mins it did try to read my USB hard drive but the tablet rebooted and then hung on the android loading screen.

Anyone else with a viewsonic viewpad 10S with latest ROM to see if its a chipset conflict or just my tablet.

Really annoying me now, I'll drive dads works van over it soon, lol

Please if you want a stable version of vegacream use beta2.1 or 3. Version 4 is with the new kernel and still experimental.

  • 0
If you feel VegaCream is worth it and would like to show your gratitude (the donate link is added on request):
Posted Image
AND also do NOT forget about ejtagle and brucelee666 for their great work.

#169
elf69

elf69

    Newbie

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Penzance, Cornwall
  • Interests:Classic cars, photography, RC rock crawlers, Playing with android stuff
  • Devices:Orange San Diego
I know its experimental :)
but version 3 the USB did not work for me either :(

Rolled back to viewcomb but right now I cannot get the tablet to go into flash mode with power and back button :(

Im gonna leave it go for a bit then try in few days.

  • 0
Currently have: Orange San Diego, Orange San Francisco, Viewsonic 10S, Freelander PD10 3G "Monster phone"

#170
Scanno

Scanno

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 437 posts
  • Location:Arnhem
  • Devices:HTC Desire Z, POV Mobii Tegra
@All who want to experiment....
Here are two CWM zip files with two different kernels.
These kernels are attempts to get everything working.
The first kernel is pretty stable, but the touchscreen can lockup (i had that happen once):
Download: http://www.mediafire...2yopmiahbwwyay1

The second kernel i did not try yet, but it is an attempt to fix the problem in the first kernel.
Download: http://www.mediafire...hdcajlm3r7ahi4e

Please remember these are experimental and must be flashed with CWM and over Beta4.1

Please let me know if these work or not.

  • 0
If you feel VegaCream is worth it and would like to show your gratitude (the donate link is added on request):
Posted Image
AND also do NOT forget about ejtagle and brucelee666 for their great work.

#171
Daedric1383

Daedric1383

    Regular

  • Members
  • PipPip
  • 148 posts

@All who want to experiment....
Here are two CWM zip files with two different kernels.
These kernels are attempts to get everything working.
The first kernel is pretty stable, but the touchscreen can lockup (i had that happen once):
Download: http://www.mediafire...2yopmiahbwwyay1

The second kernel i did not try yet, but it is an attempt to fix the problem in the first kernel.
Download: http://www.mediafire...hdcajlm3r7ahi4e

Please remember these are experimental and must be flashed with CWM and over Beta4.1

Please let me know if these work or not.


Since i hate CWM on the Vega, do you mind if i replace the boot.img of VC4.1 with one of these and NVFlash ?

  • 0

#172
Scanno

Scanno

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 437 posts
  • Location:Arnhem
  • Devices:HTC Desire Z, POV Mobii Tegra

Since i hate CWM on the Vega, do you mind if i replace the boot.img of VC4.1 with one of these and NVFlash ?

If you want you can do that.... But then you better extract the boot.img and put it on your sdcard... open a terminal do a su and type:
flash_image boot /sdcard/boot.img

The flash_image executable is included in VC4.1.

If you do a nvflash you have to restore all your data again...

Edited by Scanno, 05 July 2012 - 10:16 PM.

  • 0
If you feel VegaCream is worth it and would like to show your gratitude (the donate link is added on request):
Posted Image
AND also do NOT forget about ejtagle and brucelee666 for their great work.

#173
Daedric1383

Daedric1383

    Regular

  • Members
  • PipPip
  • 148 posts

If you want you can do that.... But then you better extract the boot.img and put it on your sdcard... open a terminal do a su and type:
flash_image boot /sdcard/boot.img

The flash_image executable is included in VC4.1.

If you do a nvflash you have to restore all your data again...


Scanno, there's no data, it's as "virgin" as B4.1 can get. I only enable USBHost, disable 3g+GPS (just in case), and enable wifi.

Got 1 hotreboot, and 1 reboot. trying to get last_kmsg (damn MTP... how i miss USB Mass Storage)

My last_kmsg is the same... "Null pointer dereference at virtual address 00000000"
and
do_write_oob: dma completion timout
and
Kernel Panic - not syncing: Fatal exception

What's wrong with SquashFS ?

http://www.mediafire...qywt2f32pn25fy1

Edited by Daedric1383, 05 July 2012 - 10:40 PM.

  • 0

#174
Scanno

Scanno

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 437 posts
  • Location:Arnhem
  • Devices:HTC Desire Z, POV Mobii Tegra

Scanno, there's no data, it's as "virgin" as B4.1 can get. I only enable USBHost, disable 3g+GPS (just in case), and enable wifi.

Got 1 hotreboot, and 1 reboot. trying to get last_kmsg (damn MTP... how i miss USB Mass Storage)

My last_kmsg is the same... "Null pointer dereference at virtual address 00000000"
and
do_write_oob: dma completion timout
and
Kernel Panic - not syncing: Fatal exception

What's wrong with SquashFS ?

http://www.mediafire...qywt2f32pn25fy1


As I wrote, during install the system.img is written partly on bad nand blocks... It looks like one of the squashfs files.... squashfs is trying to 'unzip' it, but cannot do that, because the data is not correct because of the bad hand block it is written on.... each time that you flash with nvflash, you will get that problem because the bad block markers are gone... a long time ago there was a post about this and you could try wiping and flashing with cwm a couple of times without booting so the bad blocks can be marked and will not be used...

At least this is my interpretation...

  • 0
If you feel VegaCream is worth it and would like to show your gratitude (the donate link is added on request):
Posted Image
AND also do NOT forget about ejtagle and brucelee666 for their great work.

#175
Daedric1383

Daedric1383

    Regular

  • Members
  • PipPip
  • 148 posts

As I wrote, during install the system.img is written partly on bad nand blocks... It looks like one of the squashfs files.... squashfs is trying to 'unzip' it, but cannot do that, because the data is not correct because of the bad hand block it is written on.... each time that you flash with nvflash, you will get that problem because the bad block markers are gone... a long time ago there was a post about this and you could try wiping and flashing with cwm a couple of times without booting so the bad blocks can be marked and will not be used...

At least this is my interpretation...


You might be right, but if the squashfs are stored on damaged blocks, i would get troubles on the very 1st boot.
I never get troubles on ANY boot, just during suspend where those messages pop up.

I will try your idea, flash 4.1 with the latest from CWM, several times with full wipes inbetween. Will report back.

Still badblocks are reported on dmesg, for those who have them, and i got no such thing on dmesg.

Correction:

1 bad block on mtdblock6 ... /data

Edited by Daedric1383, 06 July 2012 - 12:24 AM.

  • 0

#176
c31b32364ce19ca8

c31b32364ce19ca8

    Newbie

  • Members
  • Pip
  • 7 posts

Still badblocks are reported on dmesg, for those who have them, and i got no such thing on dmesg.

Me neither but http://www.tabletrom....html#post66591

  • 0

#177
Scanno

Scanno

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 437 posts
  • Location:Arnhem
  • Devices:HTC Desire Z, POV Mobii Tegra
@all,

another kernel to try to solve the problems.. same as previous kernel, but with the config option CONFIG_TEGRA_PREINIT_CLOCKS set to yes.

Download: VegaCream-b4.1-0706.zip.zip

  • 0
If you feel VegaCream is worth it and would like to show your gratitude (the donate link is added on request):
Posted Image
AND also do NOT forget about ejtagle and brucelee666 for their great work.

#178
elf69

elf69

    Newbie

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Penzance, Cornwall
  • Interests:Classic cars, photography, RC rock crawlers, Playing with android stuff
  • Devices:Orange San Diego
OK so with viewcomb opened CWM and cleared all caches and then flashed with beta 3.

OI file manger CAN see and mount my flash drive!

however my wifi keyboard and mouse still NOT working :(
the usb adaptor is powered as red light on but nothing happens when keys pressed.

will try astro again as I prefer it to OI manager.

Still if anyone has ideas about the keyboard I like to use it again as I use my tab as media PC with my 32" TV.

  • 0
Currently have: Orange San Diego, Orange San Francisco, Viewsonic 10S, Freelander PD10 3G "Monster phone"

#179
Scanno

Scanno

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 437 posts
  • Location:Arnhem
  • Devices:HTC Desire Z, POV Mobii Tegra

OK so with viewcomb opened CWM and cleared all caches and then flashed with beta 3.

OI file manger CAN see and mount my flash drive!

however my wifi keyboard and mouse still NOT working :(
the usb adaptor is powered as red light on but nothing happens when keys pressed.

will try astro again as I prefer it to OI manager.

Still if anyone has ideas about the keyboard I like to use it again as I use my tab as media PC with my 32" TV.

On which rom did your keyboard work?

  • 0
If you feel VegaCream is worth it and would like to show your gratitude (the donate link is added on request):
Posted Image
AND also do NOT forget about ejtagle and brucelee666 for their great work.

#180
elf69

elf69

    Newbie

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Penzance, Cornwall
  • Interests:Classic cars, photography, RC rock crawlers, Playing with android stuff
  • Devices:Orange San Diego
My keyboard used to work with viewcomb until I did the upgrade to the beta 3.
Wired USB keyboard DOES work!

Now after a reboot even OI cannot see the flash drive.

Do you think my nand storage is corrupt and thats causing the issue?

if I try to open the storage in settings "settings has stopped working" is my error :(

Edited by elf69, 06 July 2012 - 12:23 PM.

  • 0
Currently have: Orange San Diego, Orange San Francisco, Viewsonic 10S, Freelander PD10 3G "Monster phone"




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users