Jump to content


Photo

"Wi-Fi disconnected"

- - - - -

  • Please log in to reply
17 replies to this topic

#1
bananas33

bananas33

    Regular

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Devices:HAG300
My biggest problem with this phone is the popup when leaving wi-fi coverage:

Wi-Fi disconnected
Continuing Internet access will lead to traffic. Continue?

This regularly happens unseen behind the lock screen leaving me disconnected.

It looks identical to this topic: http://android.modac...affic-continue/ and I guess the fix would be the same, alter the setting in build.prop, but that's root write only and I'm trying to avoid rooting the thing.

Is there any alternative, like a trusted app which could toggle the ro.config.hw_new_wifitopdp value without risking the warranty?

  • 0

#2
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,657 posts
No. You need root access to be able to edit the build.prop.

  • 0

#3
bananas33

bananas33

    Regular

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Devices:HAG300
Fair enough, but I assume it would be possible for Huawei to make such an app, if suitably pressured... Or perhaps one of the devs.

I've no idea how this works in android - like would it need to be a setuid root binary? And if so how to get something like that to run - probably needs root too right?

  • 0

#4
dbaseii

dbaseii

    Enthusiast

  • Members
  • PipPipPip
  • 287 posts
  • Gender:Male
  • Devices:POV Mobii 10.1
  • Twitter:@dbase
Is there a way to let the wifi stay on even when the screen is locked as it doesnt sync emails when its in this state

  • 0

#5
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200

Is there a way to let the wifi stay on even when the screen is locked as it doesnt sync emails when its in this state


Go into wifi settings and press menu. Then advanced. Set wifi sleep policy to never. Surely that works?

  • 0

#6
dbaseii

dbaseii

    Enthusiast

  • Members
  • PipPipPip
  • 287 posts
  • Gender:Male
  • Devices:POV Mobii 10.1
  • Twitter:@dbase

Go into wifi settings and press menu. Then advanced. Set wifi sleep policy to never. Surely that works?


dammit, i always forget the advanced menu

  • 0

#7
EddyC01

EddyC01

    Newbie

  • Members
  • Pip
  • 18 posts
I have just been searching my build.prop and can't see "ro.config.hw_new_wifitopdp" anywhere in there, am I just blind or is it not there?

  • 0

#8
bananas33

bananas33

    Regular

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Devices:HAG300
Yes, that variable isn't in mine, but there's a similar one:


# DTS2010090602461 kange159607 20100906 begin
ro.config.hw_RemindWifiToPdp=true
# DTS2010090602461 kange159607 20100906 end

which seems to be the right name - sorry, I didn't check when I copied from the other topic :blush:

The problem remains the same though: no root so can't change the value.

  • 0

#9
EddyC01

EddyC01

    Newbie

  • Members
  • Pip
  • 18 posts

Yes, that variable isn't in mine, but there's a similar one:


# DTS2010090602461 kange159607 20100906 begin
ro.config.hw_RemindWifiToPdp=true
# DTS2010090602461 kange159607 20100906 end

which seems to be the right name - sorry, I didn't check when I copied from the other topic :blush:

The problem remains the same though: no root so can't change the value.


Ah good spot!

I can confirm that changing this setting to "false" does indeed disable that really annoying popup when you switch between WIFI and mobile data.

Thanks!

  • 0

#10
bananas33

bananas33

    Regular

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Devices:HAG300
Looks like I'm going to have to root it...

  • 0

#11
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
Why not root. Change the build.prop then unroot?

  • 0

#12
bananas33

bananas33

    Regular

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Devices:HAG300
Good point, thanks.

I saw this recently: http://www.modaco.co...t/#entry1947148 suggesting that the SuperSU app can do it, if that's right I'll give it a go, although with my luck it'll probably fail just after I've rooted and I'll get refused a warranty repair/replacement.

Edited by bananas33, 11 May 2012 - 09:52 AM.

  • 0

#13
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
If it "fails" you can just flash vodafone stock rom. Unless it fails to a point it wont switch on...where they couldn't tell its rooted anyway.

  • 0

#14
bananas33

bananas33

    Regular

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Devices:HAG300
You'd hope so, but this is more or less the argument I'm having over a stone dead OSF right now - 'they' claim to have found 'unauthorised software' on it and won't repair under warranty, so I'm trying to avoid ending up in the same position.

  • 0

#15
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
That's fair enough but the Huawei updater runs at such a low level it would be hard to get a stone dead G300.

  • 0

#16
bananas33

bananas33

    Regular

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Devices:HAG300
Would it still need to show as connected via USB? I thought the OSF was similarly robust, but once it'd stopped working it didn't show at all so I couldn't try any kind of clean up.

  • 0

#17
highlandbuck

highlandbuck

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:SGS2,SGSA,SGA2,HuaweiY300
I can confirm that altering build.prop 100% worked.

I used this guide to root and it only took 5 minutes and no need to unlock bootloader which is EXCELLENT: http://forum.xda-developers.com/showthread.php?t=2290610

Then I just used ES File Explorer, mounted system as R/W, browsed to Root>System, opened build.prop with file explorer's own built-in text editor and looked for this line, it's about two thirds down the entire list:

ro.config.hw_GSensorOptimize=true
ro.config.hw_proximity=true
ro.config.hw_menu_unlockscreen=false
ro.config.hw_RemindWifiToPdp=true
ro.config.hw_lockscreen=true
ro.config.hwft_PinPukUnlockscr=true
ro.config.xtra_support=true

Change it to "false":


ro.config.hw_GSensorOptimize=true
ro.config.hw_proximity=true
ro.config.hw_menu_unlockscreen=false
ro.config.hw_RemindWifiToPdp=false
ro.config.hw_lockscreen=true
ro.config.hwft_PinPukUnlockscr=true
ro.config.xtra_support=true



I also changed this line which is not far from the end of the list:

ro.config.hw_battery_percent=true

because I like the battery percentage next to the battery icon.

Hope this helped!

  • 0

#18
Mike White

Mike White

    Newbie

  • Members
  • Pip
  • 3 posts
I'd like to say "thanks" and this also works for the Y300.

Mike

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users