Jump to content


Photo

[ROM][GEN2/3][31.10.] CyanogenMod 9 - KonstaKANG (Android 4.0.4)

* * * * * 25 votes

  • Please log in to reply
1485 replies to this topic

#1241
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,591 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

Thanks a lot KonstaT.
And thanks a lot to Ganster too for the new breakup.
With new libs to this Qualcomm chip (MSM7x27).....is FM radio still out of question?


First you'd need to explain what new libs and what it has to do with FM radio. :P

FM radio has never been out of the questions. It's always been simply not worth the trouble.

CyanogenMod as a project has decided not to include FM radio. There's few reasons to this. AOSP devices (Nexus) don't have FM and thus there is no FM support in AOSP. CM supports devices on all major platforms (Qualcomm, TI OMAP, Tegra, Exynos) and finding a solution that would work on all platforms and all of the supported devices would be extremely difficult. Making FM radio work on a single Qcom or TI device should be relatively straight forward. Even that said, it is not something that you should expect to happen - unless you're going to do it yourself.

maybe this list should be updated :)

Already updated once today and it's up to date.

Camcorder videos can't be played via gallery? Why? On my ROM gallery only can't generate thumbnail, but plays ok...

You can't play camcordered videos via gallery on your ROM either (at least not on the one I tested). It's most likely because of the missing metadata that needs to be disabled for the encoder. You've always been able to playback videos that you've previously recorded with gingerbread ROMs etc.

  • 1

#1242
Ganster

Ganster

    Regular

  • Members
  • PipPip
  • 92 posts
  • Gender:Male
  • Location:Ukraine
  • Devices:Orange San Francisco
  • Twitter:@Ganster41
:wacko:
My actions:
1. Take video from camera - OK:
2. Open DCIM/Camera folder in gallery, thumbnail for my video from previous step are missed(Software decoder can't extract it, because don't understand color format in that video);
3. Click on video icon - gallery already try to get thumbnail - FAIL;
4. Click on preloader - opens Video Player select dialog;
4. Select VIdeo Player(its embedded in gallery player) - video plays OK.

WTF? May be you wait playing on step 3? It never been, with any video file, just showing thumbnail :)
So, I see only thumbnails getting issue...

Edited by Ganster, 31 October 2012 - 12:40 PM.

  • 0

#1243
anantk

anantk

    Regular

  • Members
  • PipPip
  • 124 posts
  • Gender:Male
  • Location:India
  • Devices:Idea Blade

First you'd need to explain what new libs and what it has to do with FM radio. :P

FM radio has never been out of the questions. It's always been simply not worth the trouble.

CyanogenMod as a project has decided not to include FM radio. There's few reasons to this. AOSP devices (Nexus) don't have FM and thus there is no FM support in AOSP. CM supports devices on all major platforms (Qualcomm, TI OMAP, Tegra, Exynos) and finding a solution that would work on all platforms and all of the supported devices would be extremely difficult. Making FM radio work on a single Qcom or TI device should be relatively straight forward. Even that said, it is not something that you should expect to happen - unless you're going to do it yourself.


Anyone expert here to make FM Radio work on ZTE Blade to achieve last milestone and make the fully functional ICS ROM for ZTE Blade?

  • 0

#1244
Ganster

Ganster

    Regular

  • Members
  • PipPip
  • 92 posts
  • Gender:Male
  • Location:Ukraine
  • Devices:Orange San Francisco
  • Twitter:@Ganster41
I already tried to add FM radio support, but it requires MANY changes in framework. I understand CM team :)

  • 0

#1245
anantk

anantk

    Regular

  • Members
  • PipPip
  • 124 posts
  • Gender:Male
  • Location:India
  • Devices:Idea Blade

I already tried to add FM radio support, but it requires MANY changes in framework. I understand CM team :)


Really appreciate your efforts

Is it possible to port FM Radio apk available on ZTE Blade CM7 or SSRLS7 to ICS and make it work?

Edited by anantk, 31 October 2012 - 01:36 PM.

  • 0

#1246
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,591 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

:wacko:
My actions:
1. Take video from camera - OK:
2. Open DCIM/Camera folder in gallery, thumbnail for my video from previous step are missed(Software decoder can't extract it, because don't understand color format in that video);
3. Click on video icon - gallery already try to get thumbnail - FAIL;
4. Click on preloader - opens Video Player select dialog;
4. Select VIdeo Player(its embedded in gallery player) - video plays OK.

WTF? May be you wait playing on step 3? It never been, with any video file, just showing thumbnail :)
So, I see only thumbnails getting issue...


I've been testing these with full wipe. I don't have video player select dialog because I don't have any other video players. It still tries to use software decoder and it still fails on metadata. Only thing changed from before is that instead of 'can't play this video' message you'll get that Android wait animation (spinning ball) but no playback.

I had some logcat output leftover on one of my terminal windows. Can't be bothered to flash it back to get proper logs. It's looping this:

I/OMXCodec( 116): Attempting to allocate OMX node 'OMX.google.h263.decoder'
I/OMXCodec( 116): Successfully allocated OMX node 'OMX.google.h263.decoder'
E/OMXCodec( 116): [OMX.google.h263.decoder] Video O/P format.eColorFormat 0x40b6a225
I/OMXCodec( 116): [OMX.google.h263.decoder] Enable frame by frame mode
W/OMXCodec( 116): Failed to set frame packing format on component
I/OMXCodec( 116): [OMX.google.h263.decoder] video dimensions are 352 x 288
I/OMXCodec( 116): [OMX.google.h263.decoder] Crop rect is 352 x 288 @ (0, 0)
E/SoftMPEG4( 116): failed to decode video frame.
E/OMXCodec( 116): [OMX.google.h263.decoder] ERROR(0x80001001, 0)
E/OMXCodec( 116): [OMX.google.h263.decoder] in error state, check omx il state and decide whether to free or skip
E/OMXCodec( 116): [OMX.google.h263.decoder] OMX IL is in state 3
E/MetadataRetrieverClient( 116): failed to capture a video frame
E/MediaMetadataRetrieverJNI( 813): getFrameAtTime: videoFrame is a NULL pointer
W/ImageCacheRequest( 813): decode orig failed /local/video/item/29,MICROTHUMB
E/MetadataRetrieverClient( 116): failed to extract an album art
E/MediaMetadataRetrieverJNI( 813): getEmbeddedPicture: Call to getEmbeddedPicture failed.

Is it possible to port FM Radio apk available on ZTE Blade CM7 or SSRLS7 to ICS and make it work?

The radio app is least of the problems. It's only a frontend for controlling FM functions. Sure you can install all kinds FM radio apps but there won't be anything to control.

Here is a summary post I wrote for CM10. It will give you an idea what kind of changes we are talking here (and it's still missing bunch of stuff for our device's audio system).

  • 1

#1247
jventura

jventura

    Diehard

  • Members
  • PipPipPipPip
  • 454 posts
  • Gender:Male
  • Location:Portugal
  • Devices:ZTE Blade

Fixed all things.

cm-9-20121031-KonstaKANG-blade.zip
http://www.mediafire...7t1ua131atz770l
md5:fb64b09327c304ff25b934c00432a0da

-fixed Youtube HQ (thanks to Ganster)
-fixed possible connection drops
-fixed possible bluetooth issues


Hi Konsta,

any chance something of this can get its way to cm9/cm10 gerrit repo? :)

  • 0

#1248
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,591 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

Hi Konsta,

any chance something of this can get its way to cm9/cm10 gerrit repo? :)

Well, not really.

I think it's up to Ganster to upload his patch for review. 'singlepdp' was my own addition so it's fine upstream. And for bluetooth, it's a change in proprietaries.

I could submit my improved volume key cursor control to ics branch since it was already merged in jellybean, but I really haven't bothered. :P

  • 1

#1249
Ganster

Ganster

    Regular

  • Members
  • PipPip
  • 92 posts
  • Gender:Male
  • Location:Ukraine
  • Devices:Orange San Francisco
  • Twitter:@Ganster41

I/OMXCodec( 116): [OMX.google.h263.decoder] Crop rect is 352 x 288 @ (0, 0)
E/SoftMPEG4( 116): failed to decode video frame.
E/OMXCodec( 116): [OMX.google.h263.decoder] ERROR(0x80001001, 0)

Its log of thubnail getting error. Try to click on loading animation after it ;)

  • 1

#1250
De@n

De@n

    Addict

  • Members
  • PipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:UK
  • Devices:Xperia S & Blade
Anyone managed to get Droidwall working properly on ICS/JB?

  • 0

#1251
fuzzyy

fuzzyy

    Regular

  • Members
  • PipPip
  • 138 posts
  • Gender:Male
  • Devices:Moto G, Huawei G300

Anyone managed to get Droidwall working properly on ICS/JB?


You must disable in "data usage" the option "mobile data limit" and it will work.

Sorry for my English

Edited by fuzzyy, 31 October 2012 - 03:37 PM.

  • 2

Moto G 8GB

Tesco 4.4


#1252
De@n

De@n

    Addict

  • Members
  • PipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:UK
  • Devices:Xperia S & Blade

You must disable in "data usage" the option "mobile data limit" and it will work.

Sorry for my English


Still not working :huh:

[Edit]
Blacklist works with this script :)

$IPTABLES -D OUTPUT -j droidwall
$IPTABLES -I OUTPUT2 -j droidwall

Edited by De@n, 01 November 2012 - 09:06 PM.

  • 0

#1253
masterlud

masterlud

    Regular

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Devices:Globul Z3 (ZTE Blade)
I have only one question: why not working speed test-apps.

  • 0

#1254
cowscrubber

cowscrubber

    Regular

  • Members
  • PipPip
  • 59 posts
  • Devices:ZTE Blade
Thanks to Ganster, I'm contemplating on whether or not to go back to this rom from JB. :D

JB and ICS are mostly similar anyway, and I want the ability to play HQ videos when needed.

  • 0

#1255
neothegod

neothegod

    Newbie

  • Members
  • Pip
  • 22 posts
  • Devices:Dell XCD35

:wacko:
My actions:
1. Take video from camera - OK:
2. Open DCIM/Camera folder in gallery, thumbnail for my video from previous step are missed(Software decoder can't extract it, because don't understand color format in that video);
3. Click on video icon - gallery already try to get thumbnail - FAIL;
4. Click on preloader - opens Video Player select dialog;
4. Select VIdeo Player(its embedded in gallery player) - video plays OK.

WTF? May be you wait playing on step 3? It never been, with any video file, just showing thumbnail :)
So, I see only thumbnails getting issue...


:D You are the real developer. Awesome job done. Big slap on people who said that HQ/HD Youtube will never work on CM9. I am hopeful you or someone will be able to crack it for CM10 too. ;)

Edited by neothegod, 31 October 2012 - 08:55 PM.

  • 0

#1256
kahush

kahush

    Newbie

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Devices:ZTE Blade
Great work KonstaT for fixing Youtube HQ.

  • 0

#1257
cowscrubber

cowscrubber

    Regular

  • Members
  • PipPip
  • 59 posts
  • Devices:ZTE Blade
Is there any way for me to change the Nav Bar height?

  • 0

#1258
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,591 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

Its log of thubnail getting error. Try to click on loading animation after it ;)

Lol, how should I know you still need to poke it after that. I spent like three minutes testing... Works fine. :P

I have only one question: why not working speed test-apps.

Iirc it's the same issue with our device not populating /sys/class/net/usb0/. Few apps have issue with this.

Great work KonstaT for fixing Youtube HQ.

I did nothing to fix it. It was all Ganster.

  • 1

#1259
Majkl007

Majkl007

    Newbie

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:Brno, CZ
  • Devices:ZTE Blade, Huawei U8120
Ganster,
you did very great step to make ARMv6 devices useable for a years in future. Really thanks very much for your work. I hoped all the time sbd like you is alive :-)
Thanks very much and many greetings to UA. Keep your work as good as now.
Sry for my bad english - I'm ill and drunk (it didn't heal me :-( )

  • 0
ZTE Blade Gen2, CWM-6.0.1.1 Touch Stable, CyanogenMod 7 - Latest Nightly - mainboard death (No SIM detected) :-(
ZTE V970 - V3.1MOD (27-12-2012)

#1260
neothegod

neothegod

    Newbie

  • Members
  • Pip
  • 22 posts
  • Devices:Dell XCD35

Great work KonstaT for fixing Youtube HQ.


It was fixed by Ganster. Please give credit to the actual person.

  • 0




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users