Jump to content


Photo

ICS Spellcheck Fix

- - - - -

  • Please log in to reply
79 replies to this topic

#41
khumhurezu

khumhurezu

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:Ascend G300
Used method 2 on B927, worked perfectly.

  • 0

#42
goekane

goekane

    Regular

  • Members
  • PipPip
  • 52 posts
  • Devices:G300
Thank You, davepwsmith,
worked like a charme!Method 1 unrooted phone

  • 0

#43
Ascend

Ascend

    Enthusiast

  • Members
  • PipPipPip
  • 151 posts
  • Gender:Not Telling
  • Devices:S3, Cubot GT99, G300

That did the trick, cheers. I had two choices in there that appeared identical (in name), so I just chose the other one.

This did it for me too. Both were named "Android correction"

  • 0
Huawei G300 ICS

#44
RannyDoscoe

RannyDoscoe

    Newbie

  • Members
  • Pip
  • 14 posts
I tried using method 1 on B934, but the install failed. It didn't back up my dictionary, but did delete it! Currently stuck with the Huawei dictionary!

  • 0

#45
samjam

samjam

    Addict

  • Members
  • PipPipPipPipPip
  • 557 posts

I tried using method 1 on B934, but the install failed. It didn't back up my dictionary, but did delete it! Currently stuck with the Huawei dictionary!


Was your phone rooted AND was USB-debug enabled?
Repeat method 1 again. I had to do it twice, I forget why now

  • 0

#46
RannyDoscoe

RannyDoscoe

    Newbie

  • Members
  • Pip
  • 14 posts

Was your phone rooted AND was USB-debug enabled?
Repeat method 1 again. I had to do it twice, I forget why now


Yeah, tried it a few times, can't save the output from the cmd window (it closes), but it says something about "no such file or directory"...

  • 0

#47
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
Option 2 is easy. Used that method twice without issues.

  • 0

#48
@it

@it

    Newbie

  • Members
  • Pip
  • 7 posts
Worked perfectly here.

@it

  • 0

#49
RannyDoscoe

RannyDoscoe

    Newbie

  • Members
  • Pip
  • 14 posts
OK. Checked root and get the OK.

Tried method 2 in several root explorer apps, usually get "operation failed". The smaller file copies OK, but the big one copies around 25% and I get the failed meassage. In ASTRO, I get the message "Copy Error: libcore.io.ErrnoException: open failed: EACCES (permission denied)"...

  • 0

#50
davepwsmith

davepwsmith

    Newbie

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Devices:Huawei Ascend G300/U8815
  • Twitter:@davepwsmith

it says something about "no such file or directory"...

Tried method 2 in several root explorer apps, usually get "operation failed". The smaller file copies OK, but the big one copies around 25% and I get the failed meassage. In ASTRO, I get the message "Copy Error: libcore.io.ErrnoException: open failed: EACCES (permission denied)"...


This sounds a lot like you might have some sort of problem with your SD card or permissions on your SD card. In fact, do you even have an SD card in the phone? The script relies on that to backup your old dictionary.

This isn't something I can particularly help you with! Try running 'Fix permissions' in clockwork recovery then try again, although this won't necessarily fix permissions on the SD card. As far as I'm aware, the easiest way to fix SD card permissions is to format the card and then copy all your data back. That the file manager is failing to read the files from your SD card has nothing to do with the files themselves, I shouldn't think.

Edited by davepwsmith, 20 August 2012 - 09:26 AM.

  • 0

#51
RannyDoscoe

RannyDoscoe

    Newbie

  • Members
  • Pip
  • 14 posts

This sounds a lot like you might have some sort of problem with your SD card or permissions on your SD card. In fact, do you even have an SD card in the phone? The script relies on that to backup your old dictionary.

This isn't something I can particularly help you with! Try running 'Fix permissions' in clockwork recovery then try again, although this won't necessarily fix permissions on the SD card. As far as I'm aware, the easiest way to fix SD card permissions is to format the card and then copy all your data back. That the file manager is failing to read the files from your SD card has nothing to do with the files themselves, I shouldn't think.


Yeah, when I first installed ICS I had a weird issue with Titanium backup, it didn't see my backups until I changed the location to "sdcard2", which was a bit strange. It hasn't really affected anything else and I haven't noticed any issues since. After your suggestion twigged this I switched the default storage location from SD Card to internal storage and back, but still no luck! Appreciate the help though.

Tried fix permissions, but still getting the same errors. Haven't done the copy/format yet. It's next on the to try list, suppose the last option is reinstalling the ROM!

  • 0

#52
The White Sock

The White Sock

    Regular

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Location:France
  • Devices:Huawei Ascend G300

Yeah, tried it a few times, can't save the output from the cmd window (it closes), but it says something about "no such file or directory"...

Did you verified that adb was well installed and fully functional?

  • 0

#53
davepwsmith

davepwsmith

    Newbie

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Devices:Huawei Ascend G300/U8815
  • Twitter:@davepwsmith

Yeah, when I first installed ICS I had a weird issue with Titanium backup, it didn't see my backups until I changed the location to "sdcard2"



Can you list the contents of your /mnt/ directory? Your external SD should be mounted at /mnt/sdcard, the internal sd card at /mnt/sdcard2. Is it possible that your SD is partitioned (e.g from clockwork mod)? I think that backing up, formatting your SD and restoring the data might be your best bet.

  • 0

#54
RannyDoscoe

RannyDoscoe

    Newbie

  • Members
  • Pip
  • 14 posts
My System ROM is full! Can anybody help me find the culprit, how much free space should there be?

  • 0

#55
PandaThing

PandaThing

    Newbie

  • Members
  • Pip
  • 48 posts
Have run in B936 rooted. Worked perfectly thank you.

  • 0

#56
ElectricPics

ElectricPics

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Huawei Ascend G300
Just used the Win batch file to fix unrooted NZ B936. No problems at all. Thanks!

  • 0

#57
Faelon

Faelon

    Newbie

  • Members
  • Pip
  • 30 posts
  • Devices:Huawei Ascend G300
Installed it using the script. Works like a charm! Thank you OP.

  • 0

#58
b4da55

b4da55

    Addict

  • Members
  • PipPipPipPipPip
  • 919 posts
Have used this more than once

Cheers

  • 0

#59
2thin2swim

2thin2swim

    Newbie

  • Members
  • Pip
  • 8 posts
  • Gender:Female
  • Location:Sheffield
  • Devices:Huawei G300
Oh yuo legand. It was making me think taht I cuoldn't spel my own langauge... :huh:

  • 0

#60
fr0do

fr0do

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,156 posts
  • Gender:Male
  • Devices:Huawei G300

Oh yuo legand. It was making me think taht I cuoldn't spel my own langauge... :huh:

^ this lol! :D

  • 0

Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users