Jump to content


Photo

Cyanogenmod 7.2 Kang for Optimus L3

- - - - -

  • Please log in to reply
106 replies to this topic

#1
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,224 posts
  • Gender:Male
  • Location:northampton
  • Devices:Samsung i9305
  • Twitter:@meritez
uploading my cm7.2 files made so far:

http://www.multiuplo...o.uk/RJYKS2YY0E

drop the e400 folder in /devices/lge

cyanogen_e400.mk in /vendor/cyanogen/products

and vendor if needed.

builds, may need some fixing though.

on github https://github.com/hecatae/e400

updated today, may need some more files

  • 0

#2
Remloup

Remloup

    Newbie

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:France
  • Devices:LG Optimus L3
  • Twitter:@remmloup
Thanks :D

  • 0
Samsung Galaxy Spica I5700 / Android 2.2.3 / Spicagenmod Beta 6.3
Xperia Mini Pro SK17i / Android 4.1.1 / ParanoidAndroid
Archos 70b IT / Android 3.2.1 / Only root
LG Optimus L3/ Android 4.0.4 / CyanogenMod 9

Sorry for my poor english, I am French :P

#3
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,224 posts
  • Gender:Male
  • Location:northampton
  • Devices:Samsung i9305
  • Twitter:@meritez

Thanks :D


No problem got updated ones that build with libs. Just sorting out other files will get cm7 booting first then move to cm9 cm10 and aokp

  • 0

#4
Remloup

Remloup

    Newbie

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:France
  • Devices:LG Optimus L3
  • Twitter:@remmloup
Ok ;)

  • 0
Samsung Galaxy Spica I5700 / Android 2.2.3 / Spicagenmod Beta 6.3
Xperia Mini Pro SK17i / Android 4.1.1 / ParanoidAndroid
Archos 70b IT / Android 3.2.1 / Only root
LG Optimus L3/ Android 4.0.4 / CyanogenMod 9

Sorry for my poor english, I am French :P

#5
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,224 posts
  • Gender:Male
  • Location:northampton
  • Devices:Samsung i9305
  • Twitter:@meritez
updated device tree, builds and pulls in libs.

now to work on build.prop

  • 0

#6
Cobmaster

Cobmaster

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:LG e400

updated device tree, builds and pulls in libs.

now to work on build.prop

What do you need on build.prop?

  • 0

#7
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,224 posts
  • Gender:Male
  • Location:northampton
  • Devices:Samsung i9305
  • Twitter:@meritez

What do you need on build.prop?


just a simple build.prop that gives the system what it needs to function, like: dpi, vmheap, ril.

got a boot issue at present, looking at cmdline in kernel source and the commandline given as it currently hangs

http://www.multiuplo...o.uk/QBAQO8YPB8

above is current build, does not boot

  • 0

#8
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,224 posts
  • Gender:Male
  • Location:northampton
  • Devices:Samsung i9305
  • Twitter:@meritez
guess which numpty included an incorrect kernel....

http://www.multiuplo...o.uk/CSXH6YEMIU

still dont boot, but correct kernel included

  • 0

#9
Remloup

Remloup

    Newbie

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:France
  • Devices:LG Optimus L3
  • Twitter:@remmloup
Thanks :)

  • 0
Samsung Galaxy Spica I5700 / Android 2.2.3 / Spicagenmod Beta 6.3
Xperia Mini Pro SK17i / Android 4.1.1 / ParanoidAndroid
Archos 70b IT / Android 3.2.1 / Only root
LG Optimus L3/ Android 4.0.4 / CyanogenMod 9

Sorry for my poor english, I am French :P

#10
jvid93

jvid93

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:Lg Optimus L3
Hello friends :D A question.
I can overclock with this rom?
or need a kernel for that?
is free of bugs?
Sorry for my english I use the translator

  • 0

#11
Ygreck

Ygreck

    Regular

  • Members
  • PipPip
  • 133 posts

Hello friends :D A question.
I can overclock with this rom?
or need a kernel for that?
is free of bugs?
Sorry for my english I use the translator

still dont boot, but correct kernel included

yes it is bugfree... oh wait, one bug only

it doesn't boot!

  • 0

#12
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,224 posts
  • Gender:Male
  • Location:northampton
  • Devices:Samsung i9305
  • Twitter:@meritez
You beat me to it. Stock kernel minimum speed is 640 mhz!!!

We definitely need a custom kernel meanwhile I'm pulling apart the stock ramdisk for the booting issue

  • 0

#13
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,224 posts
  • Gender:Male
  • Location:northampton
  • Devices:Samsung i9305
  • Twitter:@meritez
anyone want me to upload this on github or bitbucket?

  • 0

#14
roanja

roanja

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:lg l3, htc desire, some berrys
  • Twitter:@roanja

anyone want me to upload this on github or bitbucket?


Github pls

  • 0

#15
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,224 posts
  • Gender:Male
  • Location:northampton
  • Devices:Samsung i9305
  • Twitter:@meritez
https://github.com/hecatae/e400

here's how far i got

  • 0

#16
roanja

roanja

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:lg l3, htc desire, some berrys
  • Twitter:@roanja

https://github.com/hecatae/e400

here's how far i got


installing ubuntu fresh to see if i can make anything of it.

How about porting from l5, did anyone tried a 1 on 1 port.

  • 0

#17
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,224 posts
  • Gender:Male
  • Location:northampton
  • Devices:Samsung i9305
  • Twitter:@meritez

installing ubuntu fresh to see if i can make anything of it.

How about porting from l5, did anyone tried a 1 on 1 port.


the l5 kernel has only one driver different.

let me throw up a diff

  • 0

#18
Dengem

Dengem

    Newbie

  • Members
  • Pip
  • 17 posts
  • Devices:Zte Racer
I understand for the assembly lacks only the custom kernel??

  • 0

#19
Cobmaster

Cobmaster

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:LG e400
I've tried to flash the boot.img. It doesn't boot.
I think that the problem is only the boot.img that's not working.
I'll try with the stock one and the build.prop I've rewritten a few days ago, I think it will boot.

  • 0

#20
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,224 posts
  • Gender:Male
  • Location:northampton
  • Devices:Samsung i9305
  • Twitter:@meritez

I've tried to flash the boot.img. It doesn't boot.
I think that the problem is only the boot.img that's not working.
I'll try with the stock one and the build.prop I've rewritten a few days ago, I think it will boot.


Please do

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users