Jump to content


Photo

[DEV][ROM][8.1.] CyanogenMod 10 (Android 4.1.2)

* * * * * 69 votes

  • Please log in to reply
3134 replies to this topic

#2581
anantk

anantk

    Regular

  • Members
  • PipPip
  • 124 posts
  • Gender:Male
  • Location:India
  • Devices:Idea Blade

Here is quick summary of my FM radio experiment. These are the commits that I had (with some minor adjustments to get everything compiled).

Framework:
https://www.codeauro...3fc359317f72ee9
https://www.codeauro...594631624efe7e6
https://www.codeauro...0440552628cd431

si4708 driver from CM7:
https://github.com/C...e_fm_si4708.cpp

FM radio app from CAF:
https://www.codeauro...fs/heads/jb_rel

These are already merged in CM10:
https://www.codeauro...33e20f70dadb33d
https://www.codeauro...b0cc0ebbb004edf


FM radio is switched on in kernel but then gets stuck in for loop in framework. Nothing happening in the audio system. Any volunteers to add FM support? ;) Any ideas what I'm missing here?

In logcat:

D/FMRadio ( 1716): Load preferences
D/FMRadio ( 1716): =====================================================
D/FMRadio ( 1716): Country :1
D/FMRadio ( 1716): RadioBand :4
D/FMRadio ( 1716): Emphasis :1
D/FMRadio ( 1716): ChSpacing :1
D/FMRadio ( 1716): RdsStd :1
D/FMRadio ( 1716): LowerLimit :87500
D/FMRadio ( 1716): UpperLimit :108000
D/FMRadio ( 1716): =====================================================
D/FMRadio ( 1716): onCreate - Height : 800 - Width : 480
E/FMRadio ( 1716): bindToService: Context with serviceconnection callback
D/FMRadio ( 1716): onCreate: Start Service completed successfully
D/FMRadio ( 1716): FMRadio: onstart
D/FMRadio ( 1716): FMRadio: onresume
D/FMRadio ( 1716): Load preferences
D/FMRadio ( 1716): =====================================================
D/FMRadio ( 1716): Country :1
D/FMRadio ( 1716): RadioBand :4
D/FMRadio ( 1716): Emphasis :1
D/FMRadio ( 1716): ChSpacing :1
D/FMRadio ( 1716): RdsStd :1
D/FMRadio ( 1716): LowerLimit :87500
D/FMRadio ( 1716): UpperLimit :108000
D/FMRadio ( 1716): =====================================================
D/FMRadio ( 1716): Load preferences
D/FMRadio ( 1716): =====================================================
D/FMRadio ( 1716): Country :1
D/FMRadio ( 1716): RadioBand :4
D/FMRadio ( 1716): Emphasis :1
D/FMRadio ( 1716): ChSpacing :1
D/FMRadio ( 1716): RdsStd :1
D/FMRadio ( 1716): LowerLimit :87500
D/FMRadio ( 1716): UpperLimit :108000
D/FMRadio ( 1716): =====================================================
D/FMService( 1716): is A2DP device Supported In HALfalse
D/FMService( 1716): onstart
D/FMService( 1716): onBind
D/FMService( 1716): onCallStateChanged: State - 0
D/FMService( 1716): onCallStateChanged: incomingNumber -
D/FMService( 1716): onDataActivity - 0
D/FMService( 1716): ACTION_HEADSET_PLUG Intent received
D/FMService( 1716): mReceiver: ACTION_HEADSET_PLUG
D/FMService( 1716): ==> intent: Intent { act=android.intent.action.HEADSET_PLUG flg=0x40000010 (has extras) }
D/FMService( 1716): state: 1
D/FMService( 1716): name: Headset
E/FMRadio ( 1716): onServiceConnected: mCallback
E/FMRadio ( 1716): ServiceConnection: onServiceConnected:
D/FMService( 1716): fmOn: RadioBand :4
D/FMService( 1716): fmOn: Emphasis :1
D/FMService( 1716): fmOn: ChSpacing :1
D/FMService( 1716): fmOn: RdsStd :1
D/FMService( 1716): fmOn: LowerLimit :87500
D/FMService( 1716): fmOn: UpperLimit :108000
V/FMRadio ( 1716): enable: CURRENT-STATE : FMOff ---> NEW-STATE : FMRxStarting
D/FmTransceiver( 1716): Opened 40
D/FmTransceiver( 1716): turning on 1
D/fmradio_si4708( 1716): FMRadio on
D/FmTransceiver( 1716): Calling fmConfigure
V/FmConfig( 1716): In fmConfigure
V/FmConfig( 1716): fmConfigure() : FM Srch Alg : OLD
D/FMService( 1716): Analog Path is not supported
D/FMRadio ( 1716): Starting listener 40
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
V/FMRadio ( 1716): RxEvtList: CURRENT-STATE : FMRxStarting ---> NEW-STATE : FMRxOn
D/FMService( 1716): FmRxEvEnableReceiver
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMService( 1716): mReceiver.enable done, Status :true
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMService( 1716): setLowPowerMode: false
D/FMRadio ( 1716): Received <0>
D/FMService( 1716): setLowPowerMode done, Status :true
D/FMRadio ( 1716): Got READY_EVENT
D/FMService( 1716): mAudioManager.setFmRadioOn = true
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMService( 1716): In startFM
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
I/AudioService( 386): AudioFocus requestAudioFocus() from [email protected]vice$13@40fe2640
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMService( 1716): FM registering for registerMediaButtonEventReceiver
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
I/AudioService( 386): Remote Control registerMediaButtonIntent() for PendingIntent{4106d350: PendingIntentRecord{4124c8f0 com.quicinc.fmradio broadcastIntent}}
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMService( 1716): FMRadio: sending the intent
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
V/AudioService( 386): FM Intent received
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMService( 1716): mAudioManager.setFmRadioOn done
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FmRxRdsData( 1716): In rdsOn: RDS is true
D/FMRadio ( 1716): Received <0>
D/FmRxRdsData( 1716): In rdsOptions: rdsMask: 23
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMService( 1716): registerRdsGroupProcessing done, Status :true
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMService( 1716): enableAutoAF: true
D/FMRadio ( 1716): Received event. Count: 1
D/FmRxRdsData( 1716): In rdsOn: RDS is true
D/FMRadio ( 1716): Received <0>
D/FmRxRdsData( 1716): In enableAFjump: AFenable : true
D/FMRadio ( 1716): Got READY_EVENT
D/FmRxRdsData( 1716): Currently set rds_group_mask : 0
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FmRxRdsData( 1716): After enabling the rds_group_mask is : 0
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMService( 1716): enableAutoAF done, Status :true
D/FMService( 1716): setInternalAntenna done, Status :true
D/FMRadio ( 1716): Got READY_EVENT
D/FMService( 1716): getInternalAntenna: false
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>

In dmesg:
<6>[10-06 10:08:49.369999] [1716: quicinc.fmradio]snd_hph_amp_ctl:0
<6>[10-06 10:08:49.649999] [1716: quicinc.fmradio]snd_hph_amp_ctl:1


Any genius can take forward KonstaT's work regarding FM radio and make it functional on our Blade?

  • 0

#2582
mostertruck

mostertruck

    Newbie

  • Members
  • Pip
  • 21 posts
how do get previous version of these roms tried the date they were released but on mediafile says not available.

  • 0

#2583
De@n

De@n

    Addict

  • Members
  • PipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:UK
  • Devices:Xperia S & Blade
Double post :(

Edited by De@n, 28 November 2012 - 10:18 PM.

  • 0

#2584
De@n

De@n

    Addict

  • Members
  • PipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:UK
  • Devices:Xperia S & Blade

how do get previous version of these roms tried the date they were released but on mediafile says not available.

Post #2564

  • 0

#2585
mostertruck

mostertruck

    Newbie

  • Members
  • Pip
  • 21 posts
thanks deano! i see you got aokp rom and wbaw tpt but the rom requires 220mb system and wbaw tpt is 215mb how did you manage to get that on and also looking for a stable rom which is better konstat 9/10 or the one akops..Thanks for the link.

  • 0

#2586
De@n

De@n

    Addict

  • Members
  • PipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:UK
  • Devices:Xperia S & Blade

thanks deano! i see you got aokp rom and wbaw tpt but the rom requires 220mb system and wbaw tpt is 215mb how did you manage to get that on and also looking for a stable rom which is better konstat 9/10 or the one akops..Thanks for the link.

215mb is more than enough for AOKP-CM10

  • 0

#2587
ALIENwoods

ALIENwoods

    Newbie

  • Members
  • Pip
  • 1 posts
Hy,

Is anyone tried out MTP, and PTP connection? Because it always craches my Settings app, after i check one of this port communications :(

  • 0

#2588
NickNuke33

NickNuke33

    Newbie

  • Members
  • Pip
  • 48 posts
  • Gender:Male
  • Devices:OLED ZTE Blade
Hey guys, I haven't been on the forums for a while...I see alot has happened which is great! :)
I've installed the latest version (24.11) and everything is working great except I'm experiencing a significant battery drain issue. In the screenshots attached, it appears that the "cell standby" is consuming a significant amount of battery. All data connections except cell signal are turned off (bluetooth, 3g, wifi), brightness is on minimum, no apps are running in background processes, I performed a clean install and I have used the search function but no one else appears to have this issue with the current version.
If anyone could provide suggestions or solutions to this problem, it would be greatly appreciated. :)
>I have an OLED GEN 2 TPT Blade.

Attached Files


  • 0

#2589
ty_hot

ty_hot

    Regular

  • Members
  • PipPip
  • 77 posts
After installing this ROM I felt the battery was draining way too much. But after the second charge its really good, lasts all day long easily.

  • 0

#2590
jpdoliveira

jpdoliveira

    Regular

  • Members
  • PipPip
  • 132 posts
  • Gender:Male
  • Location:Portugal
  • Devices:ZTE Libra
  • Twitter:@jpdoliveira

Hey guys, I haven't been on the forums for a while...I see alot has happened which is great! :)
I've installed the latest version (24.11) and everything is working great except I'm experiencing a significant battery drain issue. In the screenshots attached, it appears that the "cell standby" is consuming a significant amount of battery. All data connections except cell signal are turned off (bluetooth, 3g, wifi), brightness is on minimum, no apps are running in background processes, I performed a clean install and I have used the search function but no one else appears to have this issue with the current version.
If anyone could provide suggestions or solutions to this problem, it would be greatly appreciated. :)
>I have an OLED GEN 2 TPT Blade.



seem like you phone is always awake.

  • 0

#2591
matcho13579

matcho13579

    Enthusiast

  • Members
  • PipPipPip
  • 285 posts
  • Gender:Male
  • Location:Slovakia
  • Devices:Samsung i9000, ZTE Blade
  • Twitter:@matcho13579

Hey guys, I haven't been on the forums for a while...I see alot has happened which is great! :)
I've installed the latest version (24.11) and everything is working great except I'm experiencing a significant battery drain issue. In the screenshots attached, it appears that the "cell standby" is consuming a significant amount of battery. All data connections except cell signal are turned off (bluetooth, 3g, wifi), brightness is on minimum, no apps are running in background processes, I performed a clean install and I have used the search function but no one else appears to have this issue with the current version.
If anyone could provide suggestions or solutions to this problem, it would be greatly appreciated. :)
>I have an OLED GEN 2 TPT Blade.

Try to install "BetterBatteryStats" from Play and it can show you what is consuming battery so much

  • 0

#2592
jonmac73

jonmac73

    Enthusiast

  • Members
  • PipPipPip
  • 199 posts
  • Gender:Male
  • Devices:Orange San Fran - Huawei G510
Early days yet (and I have seen Konsta's confirmation of no difference in WiFi etc. between recent versions) BUT..........
have upgraded from early version (28/09 I think) to 16/11. Noticed MASSIVE improvement in wireless signal performance at home. Constant signal connection in all rooms where previously would drop to 3G.
Will try over next few days, and then try out latest version and report back.

UK Orange San Fran, originally GEN1, TPT'd to GEN2.

  • 2

UK Orange San Fran Gen2 TPT'd running CM9 ECO

 

UK Huawei Ascend G510 running stock 4.1.1


#2593
mostertruck

mostertruck

    Newbie

  • Members
  • Pip
  • 21 posts
i have working camera but when i switch to camorder or pan i get lots of glitch on preview however when i play back video its o.k can see slight frame overlapping etc....anyone else camcorder o.k but camera work fine,,,,

  • 0

#2594
elrond_bs

elrond_bs

    Diehard

  • Members
  • PipPipPipPip
  • 395 posts
  • Gender:Male
  • Devices:ZTE Blade
Again, same questions every page, answer is on the previous page and the page before and the page before that.......

Edited by elrond_bs, 29 November 2012 - 04:38 PM.

  • 3

ZTE Blade with CyanogenMod 11 (Android 4.4.4 KitKat)


#2595
bbdoc

bbdoc

    Regular

  • Members
  • PipPip
  • 52 posts
Hi,

My phone is getting very slow those times. I'm not sure this is linked to the ROM (I'm using the latest build) but have the impression this is due to my SD card, as the icons for the applications moved to my SD can take more than 5 minutes to appear on my home screen after a reboot. I installed an app called "System Test" which tells me my writing speed to SD is 3.0 MB/s and reading speed is 1.0 MB/s.

So, two questions relative to that :

- Can anyone tell me if those values look normal, and if not, what they should normally be ?
- If I change SD card, knowing I'm using S2E, is there any way I can "clone" my current SD card to the new one, including the /sd-ext/ partition ?

Thanks for your support.

  • 0
Device: ZTE Blade GEN2
ROM Version: CyanogenMod 10 - KonstaKANG (Android 4.1.2)

#2596
mostertruck

mostertruck

    Newbie

  • Members
  • Pip
  • 21 posts

Again, same questions every page, :angry: answer is on the previous page and the page before and the page before that.......

No wonder KonstaT is fed up with this. The real questions for real problems are lost in the countless useless posts, because you don't know how to use search or just read 1 or 2 pages back. :huh:


read thru 129-131 no issue of camcorder only people with wifi issue and battery drainage problem and people with camera problem to revert back to previous released rom.

Edited by mostertruck, 29 November 2012 - 03:51 PM.

  • 0

#2597
mostertruck

mostertruck

    Newbie

  • Members
  • Pip
  • 21 posts

Hey guys, I haven't been on the forums for a while...I see alot has happened which is great! :)
I've installed the latest version (24.11) and everything is working great except I'm experiencing a significant battery drain issue. In the screenshots attached, it appears that the "cell standby" is consuming a significant amount of battery. All data connections except cell signal are turned off (bluetooth, 3g, wifi), brightness is on minimum, no apps are running in background processes, I performed a clean install and I have used the search function but no one else appears to have this issue with the current version.
If anyone could provide suggestions or solutions to this problem, it would be greatly appreciated. :)
>I have an OLED GEN 2 TPT Blade.


have you tried wipeing battery stat in clockwork.....charge battery full take off charge boot into clockwork wip battery...might help you.

  • 0

#2598
RZRV8

RZRV8

    Newbie

  • Members
  • Pip
  • 40 posts
  • Devices:ZTE Blade
  • Twitter:@RZRV8
I am currently on Stock Gen2 TPT. So, the Partition layout is: 37.5MB cache, 220MB system, 162.5MB data. Now, everything is fine. No issues. ROM working greatly. But, I am thinking of upgrading to Custom Gen2 TPT. The Partition layout is: 38MB cache, 215MB system, 204MB data. And, there's something like "it will unlock your full RAM." I have the Dell XCD35. And, it says its possible to unlock full RAM. Joy, joy, joy. I am happy with a lot of things the custom TPT is providing. So, I just need to ask you all one thing, especially KonstaT. Should I or should I not upgrade? :wacko:

Note: When I access any "Info" app it says, usually, 90-100MB/412MB RAM available. Shite. Anyway, I atleast know that 'around' 512MB is unlocked on my Stock Gen2.

Please. Really badword confused here.

  • 0

#2599
stephen m

stephen m

    Enthusiast

  • Members
  • PipPipPip
  • 272 posts
  • Gender:Male
  • Devices:ZTE Blade, Nexus 7 & Xolo x900
Soz guys if I've missed something, but lots of posts on this and just moving back to my Blade. Is everything working as it should with the 2 latest roms!

  • 0

#2600
elrond_bs

elrond_bs

    Diehard

  • Members
  • PipPipPipPip
  • 395 posts
  • Gender:Male
  • Devices:ZTE Blade
@ stephen m - some people have issues with wifi, try to see for youself, I had none. 24.11 has issues with video files playback, 18.11 is ok.

@ mostertruck - try the camera from 4.2 (for ARМ6, posted here) or Camera ICS

@ RZRV8 - it always shows around 420MB for 512MB RAM. The rest are reserved for the system, but are used. Unlocking of RAM is for some models with 256MB RAM, not for you. Use TPT to increase your internal memory (used for installing apps) - you need one with at least 160MB for system to use this ROM.

Edited by elrond_bs, 29 November 2012 - 04:50 PM.

  • 0

ZTE Blade with CyanogenMod 11 (Android 4.4.4 KitKat)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users