Jump to content


Photo

Imei Problem

- - - - -

  • Please log in to reply
48 replies to this topic

#41
Rico_89

Rico_89

    Addict

  • Members
  • PipPipPipPipPip
  • 767 posts
  • Gender:Male
  • Location:London, UK
  • Devices:Huawei Ascend G300, Vowney V5.
  • Twitter:@Rico_89_

Hi all
I am lost my 5irom folder with my IMEI backup.. And my Imei was 0.Now I have my Imei back and I do this:

1. You must enter the engineering menu. Dial * # * # 2846579 # * # *
2. Go to ProjectMenu/Background setting/Usb ports setting and select Manufacture mode
3. Back to
Background setting and go to Qualcomm background open setting and select background open (pass is 0 (ZERO))
4. Exit the
engineering menu and turn on USB debugging (settings/developer tools/usb debugging)
5. Restart the phone

6. On PC install the DFS Tool (http://cdmatool.com/Demo).Connect the phone and run DFS tool.
7. Go to Ports and double click on dbAdapter Reserved Interface.
8. Close the Ports window and click on SPC.In DFS log must write UNLOCKED DEVICE.
9. If this OK go to Programming and type your IMEI in right place. (you can read Imei from phone box)
10. Click write.

11. When all finish go to ports and disabe dbAdapter Reserved Interface.Unplug your phone.
12. Go to engineering menu again.
13.
Go to ProjectMenu/Background setting/Usb ports setting and select Normal mode
14. Back to Background setting and go to OTP NV filter switch and click Confirm
15.
Back to Background setting and go to Qualcomm background open setting and select background close.
16. Restart Phone.

Thats all.. you now have YOUR IMEI!!! Dial *#06# for check.


Thanks to cicki for founding this tutorial and thanks to tutorial maker :)

YOU DO IT AT ONLY YOUR RISK!!!

copied from Rostilj xd post


What can I say but damn good find there cicki.

It's great to have a safety net when altering your IMEI number and it will make the process slightly less stressful, although I really hope people don't look at this as something to fall back on .. Really just make sure you back up your IMEI number in as many places as you can.

Edited by Rico_89, 19 July 2012 - 03:48 PM.

  • 0

#42
cddt

cddt

    Newbie

  • Members
  • Pip
  • 10 posts
Got the same problem. but the password for the "Background open setting is not "0" on b882. What rom did you use to set?

  • 0

#43
RicardoABCosta

RicardoABCosta

    Newbie

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Devices:ZOPO ZP980+
Hi,

I made a downgrade to b882 and made a backup to my IMEI... but only saved the "imeibackup" folder with 3 files in it. My IMEI is 0 right now, so no network (vodafone) for me now.... so I went and restored it with 5IromToolBox and it gave me no errors. When rebooting the phone, it still gives me IMEI 0 (zero).

Im rooted.

What am I missing here?

Regards.

PS: I've already replaced the files on the sdcard\5irom\imeibackup with the ones I've saved elsewhere... nothing happened...

I tryed the guide on this thread but it gives me the same error ... Background open setting is not "0".

Edited by RicardoABCosta, 21 July 2012 - 04:46 PM.

  • 0

Current device:
ZOPO ZP980+ 

Previous devices:
Huawei G300


#44
RicardoABCosta

RicardoABCosta

    Newbie

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Devices:ZOPO ZP980+
Don't ask me why... but I've upgraded from b882 to b927 and it restored my IMEI ... for god's sake! :)

  • 0

Current device:
ZOPO ZP980+ 

Previous devices:
Huawei G300


#45
cddt

cddt

    Newbie

  • Members
  • Pip
  • 10 posts
I found similar and I don't know why. if I install any ROM other than b927 my imei is blank therefore no network, no restores work. So i'm stuck with b927 atm!

I think my problem is caused by upgrading from stock (when I got the phone) straight to b927.

Edited by cddt, 22 July 2012 - 10:18 AM.

  • 0

#46
RicardoABCosta

RicardoABCosta

    Newbie

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Devices:ZOPO ZP980+
At first went from stock to b885 and then to b926 (chinese version). Then I had problems upgrading it normally to b927... no method worked... it all crashed during installation... then I managed to upgrade to b927 from the flashable .zip. Wasn't happy with it so I downgraded to b882 and, as expected, my Imei was lost to zero (0)... on b882 I couldn't manage to restore my Imei that I backedup earlier and I was getting worried and thinking that I had bricked my phone... and then I tryed upgrading it from b882 to b927 by the "normal" way (up+down volume press and power up) and it installed perfectly... and... when I checked, it automatically restored my Imei. Didn't had to manully restore it with 5iromtoolbox.

Its now running b927, european version, smoothly and I have no complains so far.

@cddt:
Are you on b927? try to downgrade to b882 (search the forum for the rom). Then proceed to upgrade, the normal way as I described above (dload and vendor), to b927 and see if restores your Imei. Don't forget, whatever you do, backup FIRST your Imei and save it in multiple locations on your PC/USB Flashdrive/Whatever with 5IromToolBox - search the forum for the guide to backup the Imei. -Caution as you do something wrong or omit some of the step you will brick your phone dead!-

Cheers,
RC

  • 0

Current device:
ZOPO ZP980+ 

Previous devices:
Huawei G300


#47
Hogweed

Hogweed

    Diehard

  • Members
  • PipPipPipPip
  • 392 posts
  • Devices:Huawei Ascend G300
Just a general reminder (not to anyone in particular) that you cannot switch between B926/927 ICS ROMs and any earlier Gingerbread versions by using CWM Recovery. You MUST use the full update packages to switch as different radio interfaces are flashed to firmware. You MUST backup IMEI and make multiple remote copies. You MAY need to use one or both of the tricks to fool the bootloader.

Some of the symptoms being reported may be consistent with using CWM to change between ICS and GB.

You can switch between B926 and B927 based ROMS using CWM but that's all for now.

Edited by Hogweed, 22 July 2012 - 02:57 PM.

  • 1

#48
cddt

cddt

    Newbie

  • Members
  • Pip
  • 10 posts
Thank Hogweed. Your information explains my problems, don't think I saw anywhere about different radios.

Full update packages are now hanging, so need to try the bootloader tricks. One for tomorrow I think!

Thanks @RicardoABCosta

  • 0

#49
efix_LT

efix_LT

    Regular

  • Members
  • PipPip
  • 67 posts
  • Devices:U8815, U8800Pro
deleted

Edited by efix_LT, 27 July 2012 - 05:12 AM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users