Jump to content


Photo

is anyone else's battery life 'below average'

- - - - -

  • Please log in to reply
16 replies to this topic

#1
Lidds123

Lidds123

    Newbie

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:North Yorkshire
  • Devices:G300
Hi All,

After reading the post your uptimes thread i came to realise my battery life seems very poor.
I am currently on The Infusion Rom (2nd realease) however it has been the same on the offical ROMS 2.3 and 4.03 (927)

i only use my phone lightly during the day maybe a few texts a 2/3 min phone call and check a couple of webpages, from 100% in the mornign i am down to about 50% when i get home at about 5pm.

After recently installing infusion (i cleared Everythign before intalling to make sure it was clean) i then thought i would charge to 100% calibrate my bat and 'test'.

I have attahced the screen shot of the battery. the first dip is me usign wifi to browse, download apps, watch videos (all using wifi), then the flat line it during the night. The next coupld of quite large sharp dips are me firstly using the rightmove app for a few mins, then just browsing the net (using data/3g). as you can see these seriously impct on the battery. does anyone have any idea what could cause this. iv just charge it up again to 100%. and after a house or sitting there doing nothing and a 2 min browse on the net it is down to 90%.

I have also shwon a screen shot of the calibration tool, shown my Mv im not sure if this will help at all. it did go just over 4200 at 100%

If anyone could help i would really apreciate it. thank yoo.

Attached Files


  • 0

#2
FrankieADZ

FrankieADZ

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,255 posts
certain thing ive found can run ur battery down quicker....certain apps & ones running in the background, brightness, haptic feedback.

tbf..think I have reasonably good battery life(on AtomicMod)

  • 0

#3
Konstipated Kiwi

Konstipated Kiwi

    Enthusiast

  • Members
  • PipPipPip
  • 254 posts
I think (although have never really tested) that having 3G enabled eats battery pretty quickly. I switch off 3G and GPS when not in use. I leave the WiFi on all the time, though. I also use the auto screen brightness. I am on B888 (unmodified) and typically get about 3-4 days out of similar usage to yourself. I have Tasker switch the GPS on when loading up apps that require it and off again when I exit, so I never need to switch on GPS manually. I also use Tasker to set Airplane mode overnight, because I really don't need to be receiving emails or Twitter/Facebook updates while I am asleep.

As others have suggested, it could be a particular application that is causing the drain. If it is really bothering you, I would install your ROM from fresh and only install the apps that you really, really need for a day or two then add others in gradually to see whether oyu can identify the culprit.

  • 0

#4
b4da55

b4da55

    Addict

  • Members
  • PipPipPipPipPip
  • 919 posts
Maybe try better battery stats.
Really useful

  • 0

#5
dbaseii

dbaseii

    Enthusiast

  • Members
  • PipPipPip
  • 287 posts
  • Gender:Male
  • Devices:POV Mobii 10.1
  • Twitter:@dbase
I have just moved into a new house so no adsl at the moment. I'm using giffgaff for my internet.
I am down to 84% after 18 minutes use. Is this right. Using 927.

  • 0

#6
wrtease

wrtease

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,456 posts
  • Gender:Male
  • Location:SCOTLAND
  • Interests:TESTING ANDROID MOBILES TO THE LIMIT
    ALWAYS READY TO TRY OUT ANY ROM AND MOBILE TO THE LIMIT
  • Devices:SAMSUNG GALAXY TAB2 & S1 8GB
  • Twitter:@none
you could be right as your mobile uses more for 3g .i could be wrong to.

  • 0

#7
Hogweed

Hogweed

    Diehard

  • Members
  • PipPipPipPip
  • 392 posts
  • Devices:Huawei Ascend G300
On 3G your phone could be talking back to a tower several miles away through the odd wall or two. This causes it to use maximum transmit power which drains the battery quickly. If you are very close to the cell tower, the phone uses low power to transmit and the drain is less.

Edited by Hogweed, 05 August 2012 - 06:43 PM.

  • 0

#8
Lidds123

Lidds123

    Newbie

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:North Yorkshire
  • Devices:G300
Thanks for the help, I wouldn't think it would be a certain app, as it has done it after fresh installs. Looks like it may be the 3G then, but dropping 10% for maybe 5 mins data usage seems a Bit excessive. Just used we7 for a Bit and it eat through the battery in no time

  • 0

#9
Hogweed

Hogweed

    Diehard

  • Members
  • PipPipPipPip
  • 392 posts
  • Devices:Huawei Ascend G300
It is not unusual for a displayed battery percentage to drop faster with the same drain when the battery is fully charged. Especially as the battery ages. A very rapid initial drop is one sign a battery is on the way out. The percentage you see is the best estimate of the charging circuitry. That said the battery monitoring seems much better to me after the B892 update.

Edited by Hogweed, 05 August 2012 - 07:07 PM.

  • 0

#10
aig

aig

    Newbie

  • Members
  • Pip
  • 13 posts
it will drop quickly on this phone as I have noticed when using. use greenpower premium with some tinkering and when not in use that will kick in and conserve battery power i can get through about 1 1/2 - 2 days depending on use with 1 charge

  • 0

#11
Lidds123

Lidds123

    Newbie

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:North Yorkshire
  • Devices:G300
I just downloaded the get jar app and installed a small app and my battery dropped from 74% to 60. It only took about 5 mins to do. Does anyone think it could be the battery. I have also noticed my charger 'buzzes' could a iffy charger also be a factor; thanks for any help guys

  • 0

#12
Konstipated Kiwi

Konstipated Kiwi

    Enthusiast

  • Members
  • PipPipPip
  • 254 posts
Aye, my charger sometimes 'buzzes' too, although I would describe it more as a whistle - quite high pitched. Battery seems perfectly fine though.

  • 0

#13
Skip Tracer

Skip Tracer

    Regular

  • Members
  • PipPip
  • 85 posts
  • Gender:Male
  • Location:Bristol UK
  • Devices:Nexus 7+G300+Moto G
  • Twitter:@3plus5
I stumbled on a good battery saving mode by un-ticking the “Enable always-on mobile” in the mobile network menu.

I live in an area where 2G is maximum bars and 3G from zilch to 3 bars and sometimes it jumps to GPRS when downloading large files so I found by un-ticking the said box it stops the phone from searching for stronger but slower connections.

Had no problem with this other than an extra hours of battery use but that said ticking this box may cause problems if your moving about at speed because you can lose coverage altogether.

  • 0

#14
Lidds123

Lidds123

    Newbie

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:North Yorkshire
  • Devices:G300
Hi Thanks for your input, it is fine when just on 'standby' i have had it unplugged for 5 hours today and it is sown to 88% wiht a 5 min phone call. im happy wiht this but if i was to browse the web or use something else that involves data it would plummet, more than i have seen on other android phones i have had

also not sure if it makes any difference (or if i can change it) but my network is mainly on HSPDA9 or UMTS3 this is with 3mobilie in the UK

Edited by Lidds123, 14 August 2012 - 11:32 AM.

  • 0

#15
GaryM30

GaryM30

    Newbie

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Devices:Huawei Ascend G300
This is after nearly 2 days of what I would call normal use.

I am on B934.

No cwm.

60 odd apps,

but no 3G signal locally.

Still got 78% left.




Attached File  screenshot(1).jpg   117.66KB   5 downloads

  • 0

#16
ryan2801

ryan2801

    Newbie

  • Members
  • Pip
  • 14 posts
I've tried a few roms and the battery definitely suffers with 3G on.With data switched off and Wi-Fi on the battery is fine. With data on/WifFi on it's awful and with Wifi off/data on it's just as awful
Very odd.

  • 0

#17
Lidds123

Lidds123

    Newbie

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:North Yorkshire
  • Devices:G300

This is after nearly 2 days of what I would call normal use.

I am on B934.

No cwm.

60 odd apps,

but no 3G signal locally.

Still got 78% left.




Attached File  screenshot(1).jpg   117.66KB   5 downloads


lucky bugger haha, i think it might be the battery as even with 3g off if im playing music in my car it drops very quick too :) will call in at vodaphone and see if they can give me a new one tomorrow

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users