Jump to content


Photo

[Recovery] ClockWorkMod 6.0.x.x for ZTE Acqua

* * * * * 1 votes

  • Please log in to reply
219 replies to this topic

#61
decapitado

decapitado

    Newbie

  • Members
  • Pip
  • 5 posts
Lost_Animal how long you think it´s gonna take?
Do you know someone to try the rom in the Acqua?

  • 0

#62
Lost_Animal

Lost_Animal

    Regular

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Patras - Greece
  • Interests:Computer, Dedicated Servers, Forums and GameServers Owner
  • Devices:ZTE Blade x 2
I have 1 AQUA - 1 BLADE III and 2 BLADE devices for testing....
So don't worry about.

I don't how long will take.
I have already some failures.... lol

  • 0
Posted Image
Posted Image

#63
decapitado

decapitado

    Newbie

  • Members
  • Pip
  • 5 posts
Hi Lost_animal

How is it going? Will we have a custom rom for the acqua? :)

Edited by decapitado, 06 January 2013 - 02:33 AM.

  • 0

#64
papars

papars

    Enthusiast

  • Members
  • PipPipPip
  • 157 posts
  • Gender:Male
  • Devices:ZTE Acqua
I tried to load B11 but failed miserably. Although I loaded up the right image the phone died. I lost boot / recovery and ended up with a brick. My phone was replaced but I'm reluctant to try again.
There is something wrong with this recovery. As I state few posts back, format fails from within script and behaviour in some cases is not as expected.
Unless there is a way to recover the phone from a dead state I cant risk killing it again.

The trecovery tools for blade 1 do work but I can't find the correct files for aqua. I'm going to try again when I feel brave or when the correct tools are found.

By the way my phone is the p740 and I wonder if the hardware is identical to any other model out there.

  • 0

#65
decapitado

decapitado

    Newbie

  • Members
  • Pip
  • 5 posts
No custom roms I guess :( But there is root that´s not bad ;)

  • 0

#66
papars

papars

    Enthusiast

  • Members
  • PipPipPip
  • 157 posts
  • Gender:Male
  • Devices:ZTE Acqua
After my 2 times brick I'm not trying anything else until I find a recovery procedure that works.
Either from DFU or better from QDL.

Right now I can't even find jtag that works in this phone.

  • 0

#67
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,760 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio
I posted a new recovery for atlas40 here. Would someone be kind enough to test it on Acqua? It should work just fine as far I can tell.

  • 0

#68
decapitado

decapitado

    Newbie

  • Members
  • Pip
  • 5 posts

I posted a new recovery for atlas40 here. Would someone be kind enough to test it on Acqua? It should work just fine as far I can tell.

I´m a bit noobish, tell me what´s the point in that if the recovery on this post already works?

Will you be able to port roms if the atlas 40 recovery works?

  • 0

#69
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,760 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

I´m a bit noobish, tell me what´s the point in that if the recovery on this post already works?

Will you be able to port roms if the atlas 40 recovery works?

Well, for one it's much newer version of course (5.x vs. 6.x). There's no official changelog for CWM but it has faster and smaller backups, adb sideload support etc. And this time I actually have a device and I can test that everything works as it should.

It's possible that the ROM I posted for Blade 3 will work on other atlas40 devices. It's also possible that it might require some kind of patch to make it work on Acqua. Blade 3 is P772N10, Acqua is P740something. With ZTE that usually means that there's some differences in radio firmware. Most likely it won't work in dual-sim devices (V889D, V880E) without modification and N880E is a CDMA device (and it has different wifi hardware).

We don't know until someone is brave enough to test...

  • 0

#70
papars

papars

    Enthusiast

  • Members
  • PipPipPip
  • 157 posts
  • Gender:Male
  • Devices:ZTE Acqua
The 5.x version has problem. Format /system does not work from within updater-script. In order to load a non official version you have to format /system manually and then install the version without this line to work: "format("ext4", "EMMC", "/system");". I wonder if this is fixed in the 6.x version.

Is there a way to get a eMMC backup? (without jtag)
After a failed upgrade I end up in DFU mode. There are no tools to get out of DFU for aqua. I tried to use the DFU tools from Blade III and some other atlas40 model and failed. Then phone is stuck in QDL mode. Even worse than DFU - there are no tools for this either.

Anybody with the skills to make proper recovery files (DFU and/or QDL) for aqua?

  • 0

#71
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,760 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

The 5.x version has problem. Format /system does not work from within updater-script. In order to load a non official version you have to format /system manually and then install the version without this line to work: "format("ext4", "EMMC", "/system");". I wonder if this is fixed in the 6.x version.

That is simply not true and how can I fix something that's never been broken?

You are still failing on the assumption that official update packages are something that you should be able to install via custom recovery. IIRC it was you who I told that you need to repack them using e.g. CyanogenMod update zip from another device. I've now done that and it works perfectly fine. Format fails on custom recovery because ZTE has modified update-binary in their official packages. I've also told that it is only safe to flash partitions that ClockWorkMod can backup and restore (system, data, cache, boot, recovery). Flashing radio/etc partitions is something that you are not supposed to do unless you really know what you are doing.

  • 0

#72
papars

papars

    Enthusiast

  • Members
  • PipPipPip
  • 157 posts
  • Gender:Male
  • Devices:ZTE Acqua
I'm not trying to flash an official rom, but a "custom" rom.
I only include system directory structure, boot.img, fat.bin and splash.img. (and of course META-INF structure). Recovery and other partitions are not included.

I tested several update-binary files but all gave the same error. You have one that might work?

  • 0

#73
epyloxias

epyloxias

    Regular

  • Members
  • PipPip
  • 149 posts
  • Gender:Male
  • Location:Greece
  • Devices:ZTE ACQUA JB 4.1.2
After adb -reboot bootloader- command my phone reboots and stays with green android logo. I 'm giving second command and the message i get is: waiting for device.

Is that normal?

  • 0

#74
epyloxias

epyloxias

    Regular

  • Members
  • PipPip
  • 149 posts
  • Gender:Male
  • Location:Greece
  • Devices:ZTE ACQUA JB 4.1.2

After adb -reboot bootloader- command my phone reboots and stays with green android logo. I 'm giving second command and the message i get is: waiting for device.

Is that normal?




Well i did managed to get the procces till the end, downloading the bootloader in previous post, BUT as it seems i still have stock 3E and not the one it should be.
Does anybody else facing the same problem?

Edited by epyloxias, 29 January 2013 - 02:08 PM.

  • 0

#75
epyloxias

epyloxias

    Regular

  • Members
  • PipPip
  • 149 posts
  • Gender:Male
  • Location:Greece
  • Devices:ZTE ACQUA JB 4.1.2
No one else?

It's a pitty to leave this model in "stock" mode. I believe it has potentials but they aren't shown up yet....
I wish I was able to develope a functionable cwm or even a custom rom but I don't know how...
Please guys do not abandone the phone... Do not abandone us...

  • 0

#76
thmnss

thmnss

    Newbie

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Devices:ZTE BLADE and ZTE SKATE ACQUA
Is not it possible to make a custom ROM Port of ZTE Blade III or Hauwei G300? Are "almost" equal to Acqua ... It's a shame not to have custom ROM for the Acqua ....

  • 0

#77
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,760 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

Is not it possible to make a custom ROM Port of ZTE Blade III or Hauwei G300? Are "almost" equal to Acqua ... It's a shame not to have custom ROM for the Acqua ....

I already answered you this once! Most certainly it will never happen if no one has the balls to test it and tell me what works and what doesn't.

Blade III ROMs will boot in Acqua. If telephony works, I don't know yet. And if it doesn't, it's most likely possible to fix with a compatibility patch containing few RIL libs from this device.

  • 0

#78
papars

papars

    Enthusiast

  • Members
  • PipPipPip
  • 157 posts
  • Gender:Male
  • Devices:ZTE Acqua
I have already bricked my phone twice with experiments.
Unless somebody comes up for a way to recover the phone from QDL I'm not willing to experiment another time.

I have the desire to buy jtag programmer -I love this phone- but I can't find a jtag that supports this phone.

Furthermore, I would like to ask KonstaT to point me to the tool that converts the original roms to files compatible to his recovery image. So far my attempts to do this manually failed at this command: format("ext4", "EMMC", "/system");

I have made an upgrade from B02 to B07 that works great but the only way to install this is by manually formating system and omitting the above command from updater-script. Several friends are using this ROM without problems for several months now. For the reasons I state above I will stay to B07 for the time being.

  • 0

#79
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,760 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

I have already bricked my phone twice with experiments.
Unless somebody comes up for a way to recover the phone from QDL I'm not willing to experiment another time.

Furthermore, I would like to ask KonstaT to point me to the tool that converts the original roms to files compatible to his recovery image. So far my attempts to do this manually failed at this command: format("ext4", "EMMC", "/system");

You simply can't brick your phone with ClockWorkMod unless you're doing it wrong. Only use it to flash partitions that CWM can backup and restore!

Lol, the tool is called winzip (or whatever zip tool you prefer). Just replace system folder, boot.img and modify updater-script of a CyanogenMod ROM update zip (e.g. the ones in Blade III subforum will work just fine).

You just simply can't pack your "custom" ROM inside the official update zip from ZTE. You are still failing to understand this.

  • 0

#80
thmnss

thmnss

    Newbie

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Devices:ZTE BLADE and ZTE SKATE ACQUA
KonstaT excuse the repeated questions!
I ended up installing the ROM-Aurora Borealis-RLSx.zip from Blade III and is working, and telephony seems to work perfectly, no bugs so far ...

Just missing the Portuguese language pack, Acqua is known in my country as SMART TMN A15, and change the model number for ZTE SKATE ACQUA instead of ZTE BLADE III. lool

Later I will test your release CyanogenMod 10

Thanks for the good work.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users