Jump to content


Photo

[4 Nov 2012] [Jellybean] AOKPCM10 Remix RC 2.4

* * * * * 7 votes

  • Please log in to reply
209 replies to this topic

#121
neothegod

neothegod

    Newbie

  • Members
  • Pip
  • 22 posts
  • Devices:Dell XCD35
Burstlam

Not sure if this question is already asked here. Does the following work on this rom?
  • Hardware acceleration and OpenGL rendering
  • Hardware video decoding & encoding
This supposedly works on konstaT's ROM. Haven't tested his ROM as I am not fond of small ROMs. I am currently on AOKP-CM9 Remix RC 7.1.0. So I was hoping that we have a working Youtube HQ and movies on AOKPCM10.

Thanks for your contribution to this project. You have been favorite developer. With your ROM, we always get best of both worlds which is hard to find anywhere else. :)

Edited by neothegod, 19 November 2012 - 07:51 PM.

  • 0

#122
burstlam

burstlam

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 283 posts
Patch already applied just missed a proper XML file for the OMX encoder/decoder like streaming and video

flashed this with recovery and basically the rom will have same as Kosta's one : Attached File  ARMv6-Qcom-media-codec-fix.zip   163.55KB   67 downloads

  • 1

#123
neothegod

neothegod

    Newbie

  • Members
  • Pip
  • 22 posts
  • Devices:Dell XCD35

Patch already applied just missed a proper XML file for the OMX encoder/decoder like streaming and video

flashed this with recovery and basically the rom will have same as Kosta's one : Attached File  ARMv6-Qcom-media-codec-fix.zip   163.55KB   67 downloads


Thanks! Will try this out and post my experience soon.

  • 0

#124
archish

archish

    Regular

  • Members
  • PipPip
  • 90 posts
  • Gender:Male
Burstlam I find the app loads and is usable faster than other CM10/CM9 builds compared to yours. Is there any specific patch which is applied for this. Can you please share the github link for the same? Thanks.

  • 0

#125
Droopy_be

Droopy_be

    Regular

  • Members
  • PipPip
  • 117 posts
  • Gender:Male
  • Location:Brussels
  • Devices:ZTE Blade

Patch already applied just missed a proper XML file for the OMX encoder/decoder like streaming and video

flashed this with recovery and basically the rom will have same as Kosta's one : Attached File  ARMv6-Qcom-media-codec-fix.zip   163.55KB   67 downloads


With this patch, youtube works fine in NON HQ mode.
Thx.

  • 0

#126
Loren82

Loren82

    Enthusiast

  • Members
  • PipPipPip
  • 270 posts
  • Gender:Male
  • Location:Bilbao
  • Devices:ZTE Blade - Xperia U - Moto G
HQ youtube works perfect, camera and video recording, the only thing is not going panorama Mode

  • 0

#127
archish

archish

    Regular

  • Members
  • PipPip
  • 90 posts
  • Gender:Male
Burstlam small issue in CPU performance setting, its seems to reset to default after a shutdown or reboot.

  • 0

#128
DarkChaosPaladin

DarkChaosPaladin

    Newbie

  • Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:Germany
  • Devices:ZTE Blade
which gapps did you use? When i start up the camera i get an green screen :-(

  • 0

#129
burstlam

burstlam

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 283 posts

Burstlam small issue in CPU performance setting, its seems to reset to default after a shutdown or reboot.


You have to wait the superuser process finish before u go for next move.(ie. the notification fade out)
make sure u checked the set on boot option as well.
After Reboot, the performanace setting will be the last startup process . (Superuser notification will popup and the option saved would be applied.)

Edited by burstlam, 21 November 2012 - 04:49 AM.

  • 0

#130
burstlam

burstlam

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 283 posts

which gapps did you use? When i start up the camera i get an green screen :-(


not compatible with google gallery. please remove it from the google apps package you flash.
indeed, paranoma works with the free version of ics camera in play store.

Edited by burstlam, 21 November 2012 - 04:44 AM.

  • 0

#131
KonstaT

KonstaT

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,761 posts
  • Gender:Male
  • Location:Finland
  • Devices:Moto G, ZTE Open C
  • Twitter:@konstatuomio

not compatible with google gallery. please remove it from the google apps package you flash.
indeed, paranoma works with the free version of ics camera in play store.

It's Ganster's preview optimization patch that breaks camera preview (green screen) on Jelly Bean camera apps (both 4.1 and 4.2). In legacy camera (4.0 camera) it's this commit that breaks panorama now that we are running without the egl hacks. Revert those two commits and you'll have working camera in all apps.

  • 1

#132
archish

archish

    Regular

  • Members
  • PipPip
  • 90 posts
  • Gender:Male

You have to wait the superuser process finish before u go for next move.(ie. the notification fade out)
make sure u checked the set on boot option as well.
After Reboot, the performanace setting will be the last startup process . (Superuser notification will popup and the option saved would be applied.)


All is set as mentioned by you. Only difference I notice is there is no superuser notification after reboot. This and the WiFi not working not reconnecting after sleep( keep wifi on setting: only when plugged in) are the only major issues for now. This is on clean install after wipe. Excellent rom overall.

  • 0

#133
Droopy_be

Droopy_be

    Regular

  • Members
  • PipPip
  • 117 posts
  • Gender:Male
  • Location:Brussels
  • Devices:ZTE Blade
I have configured my phone to be in vibrate mode when I flip it.

It works fine when my phone isn't in sleep mode, but when the screen is lock and black (sleep mode), it doesn't work.
I must use the power button before flip the phone.

  • 0

#134
burstlam

burstlam

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 283 posts

It's Ganster's preview optimization patch that breaks camera preview (green screen) on Jelly Bean camera apps (both 4.1 and 4.2). In legacy camera (4.0 camera) it's this commit that breaks panorama now that we are running without the egl hacks. Revert those two commits and you'll have working camera in all apps.


yeah. I noticed that.
ganster's patch breaks the new cameras yet it gives a stable image to us with the legacy camera
I hope I could find out why mdp composition is not 100% working why we got glitches here and there.

  • 0

#135
burstlam

burstlam

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 283 posts

I have configured my phone to be in vibrate mode when I flip it.

It works fine when my phone isn't in sleep mode, but when the screen is lock and black (sleep mode), it doesn't work.
I must use the power button before flip the phone.


um... no idea on that.
flip action is controlled by accelerometer sensor. sensors are off in deep sleep mode
and I suppose the phone should be wake up(so as the sensor) when received a call. it is weird I need to reproduce the scenario and take some logs about it.

  • 0

#136
Droopy_be

Droopy_be

    Regular

  • Members
  • PipPip
  • 117 posts
  • Gender:Male
  • Location:Brussels
  • Devices:ZTE Blade
Problem bleutooth between my phone and my car with RC 2.3 (after 5-6 min, the phone is disconnected and I can't modified the car system configuration, bleutooth menu blocked).
With RC 2.2 and CM7, all works fine.

  • 0

#137
anantk

anantk

    Regular

  • Members
  • PipPip
  • 124 posts
  • Gender:Male
  • Location:India
  • Devices:Idea Blade
ROM update today 24NOV2012 from Burstlam:

Changelog :

RC 2.3.4
- backport wifi resume fix for wpa6 device (CM10)
- Wifi Settings: Allow to define the idle timeout (5 mn to 3 hours) (CM10)
- Fix Stream playing with Stock Browser (credits to Ganster and KostaT)

  • 0

#138
archish

archish

    Regular

  • Members
  • PipPip
  • 90 posts
  • Gender:Male
Thanks for the update Burstlam. The WiFi not working after sleep is fixed now :)
The small nagging issue is the performance governor resets to default after each reboot, I remember this issue being there in the earlier builds of cm9aokp, the latest build had this fixed, I hope this helps to find root cause.

On the issue list I do notice the transition smoothness is reduced with this build. There is visible lag when I swipe between difference home screen, the animated transition are sometimes visibly slow.
Lastly, minor issue, the exit to home on end call in call menu setting doesn't seem to work.

  • 0

#139
Grey94

Grey94

    Newbie

  • Members
  • Pip
  • 19 posts
  • Devices:zte blade

There are statments from QC and it's been repeated about 500 times at least in this very forum that it will NEVER work.

Are you familiar with the concept of "never"?


  • 0

#140
Snap.IT

Snap.IT

    Addict

  • Members
  • PipPipPipPipPip
  • 861 posts
  • Gender:Male
  • Location:Stockholm, Sweden
  • Devices:ZTE Blade 3, Alcatel OT995

*quote of a post of mine from 25/8*


That post is months old and since then the old version of OMX has been hacked to work with both CM9 and CM10.

There are still no Android 4.0.4 or 4.1.2 versions of OMX libs for armv6 from QC and there still never will be but i was wrong on HQ video decoding never working for ICS and JB on the ZTE Blade.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users