Jump to content


Photo

CM9 for Lg Optimus L3 (E400)

* * * * * 2 votes

  • Please log in to reply
848 replies to this topic

#661
Kumanovac

Kumanovac

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Lg L3 e400

If you can find ics compatible libs libs instead of us hacking the gingerbread camera driver


What should I search or edit .... Thanks for the reply :) (under /system/etc/)

  • 0

#662
Julio18

Julio18

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:LG E400, LG P350
Mass Storage is not working on my phone :( .. Is there a way to fix it?

  • 0

#663
Ygreck

Ygreck

    Regular

  • Members
  • PipPip
  • 133 posts
usb debbuging disabled?

  • 0

#664
michael.naca1

michael.naca1

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:lg e400
  • Twitter:@mike
i already upgraded my lg e400 to cm9 but the color is blurred its hard for me to read some message and apps, is there any solution, i just buy my phone 2 months ago

  • 0

#665
Chingizzka

Chingizzka

    Newbie

  • Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:Kazakhstan
  • Interests:Religion....Islam
  • Devices:LG OPTIMUS L3 e-400R

i already upgraded my lg e400 to cm9 but the color is blurred its hard for me to read some message and apps, is there any solution, i just buy my phone 2 months ago


http://www.modaco.co...ue/page__st__20 <------------FLASH FLASH FLASH DAT KERNEL)

  • 0
Posted Image

#666
Ygreck

Ygreck

    Regular

  • Members
  • PipPip
  • 133 posts
This thread need a first-post-update!

Edited by Ygreck, 19 February 2013 - 01:32 PM.

  • 0

#667
pardeeptummala

pardeeptummala

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:lg e400
finally the display is fixed ..but after installing hike in cm9 the phone is not responding hand i need to reboot the phone this is the only problem for me

  • 0

#668
misterff1

misterff1

    Regular

  • Members
  • PipPip
  • 86 posts
  • Devices:LG Optimus e400
The new kernel with blurred screen fix is posted on e400roms.blogspot.com!

Refresh your apps or visit this page:http://e400roms.blog...een-fix-v2.html to download this brilliant mod right away!

  • 0

#669
Flowfx

Flowfx

    Newbie

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Devices:LG Optimus L3 E400
I was running ICS and flahed back to gingerbread to install now I cant root my phone. I was using V10k, but the download link is broken. I have tried 10I and 10E, but for some reason no program will let me re root. Im using the GBR software, my phone was purchased unbranded

Solved - I used Superoneclick v1.7 in rageagainstthecage mode. For some reason the latest version 2.3.3 does not work with our device

Edited by Flowfx, 21 February 2013 - 08:34 PM.

  • 0

#670
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,195 posts
  • Gender:Male
  • Location:northampton
  • Devices:Samsung i9305
  • Twitter:@meritez

This thread need a first-post-update!


done, tony_secreto has not been seen since 4th September 2012

  • 0

#671
henfri1

henfri1

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:e900, p920
Hello,

with only very few Apps installed, I still get the message, that no memory is left, when installing Dropbox.
When looking at the Device in Windos Explorer, I see 473M free, and 599M used.

Any Ideas?

Greetings,
Hendrik

  • 0

#672
xshinichix

xshinichix

    Newbie

  • Members
  • Pip
  • 14 posts
  • Devices:lg e400, NOKIA 3310
i have a problem guys on my cm9. i cant use the camera on my phone properly because the display is all red. everything is working fine. its just the camera. :(

  • 0

#673
Ygreck

Ygreck

    Regular

  • Members
  • PipPip
  • 133 posts

Hello,

with only very few Apps installed, I still get the message, that no memory is left, when installing Dropbox.
When looking at the Device in Windos Explorer, I see 473M free, and 599M used.

Any Ideas?

Greetings,
Hendrik


Open link2sd
Display only updated apps
Convert all this updated system apps too system apps!

System APP update going every time in user space...

  • 0

#674
ajeeshvijayan

ajeeshvijayan

    Newbie

  • Members
  • Pip
  • 34 posts
  • Devices:LG optimus L3 e400
any way to have Wi-Fi hotspot on cm9?

  • 0

#675
andwie

andwie

    Newbie

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Indonesia
  • Devices:LGE-E400, Samsung GT-S5830
  • Twitter:@ndwtf

any way to have Wi-Fi hotspot on cm9?

download and use wifi-tether app from PlayStore

Edited by andwie, 24 February 2013 - 08:27 AM.

  • 0

#676
Flowfx

Flowfx

    Newbie

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Devices:LG Optimus L3 E400
Specs for new L II series is out. Here You will have to translate. I dont think I will be upgrading just yet,im really happy with this phone and feel that the new l3 is not much of an upgrade. Kinda of like when I went for an LG Viewty (KU990) to an LG Viewty Smart (GC900)

  • 0

#677
misterff1

misterff1

    Regular

  • Members
  • PipPip
  • 86 posts
  • Devices:LG Optimus e400
Okay guys i'm working on something big for the e400 ROMs site and I would like to hear from you what you want to be included on the new site i'm making right now. Also I would like to know a very good webhosting service that can handle alot of pressure, because i'm gonna need it:D If you have an idea, please share!

  • 0

#678
gellmar

gellmar

    Enthusiast

  • Members
  • PipPipPip
  • 189 posts
  • Devices:LG Optimus L3 E400
Well, a couple of thoughts regarding full device encryption with CM9. Generall, I went for CM9 only to get the ability to encrypt my phone fully, because the stock Ginger had no such capability. The encryption did not work, and that time I was not so experienced so I gave up. Tonight I installed the latest CM9 nightly and the encryption stucked too, but in a three hours I made it work.

I used adb logcat and found out that the cryptfs ends up with an error:

orig filesystem overlaps crypto footer region: cannot make in-place encryption

Having googled a bit, I realized that CWM recovery formats the whole data partition, while it need the last 16 kb to be unallocated in order to store the encryption-related stuff. So I booted into a CWM, formatted the /data partition, turned adb shell and typed the command (note, CM9 system partition was there!):

/system/bin/mke2fs -Ldata -T ext4 /dev/block/mmcblk0p21 163824

where -Ldata is a label "data", mmcblk0p21 is a /data partition (you can check yourself by mounting /data partition in CWM and issuing a mount command in adb root shell on your PC) and 163824 is a number of 1024-byte blocks that should cover the whole /data partition without the latter 16 kb. The formula is straight and inspired by this post. So you can obtain the size availiable, subtract 16*1024 bytes and divide the following on 1024 bytes per block:

data_dev_size=$(cat /sys/block/mmcblk0/mmcblk0p21/size)
new_fs_size=$(( data_dev_size - 16*1024 ))
new_fs_blocks = $(( new_fs_size / 1024 ))

That was it! Now you have the place for crypto footer. I rebooted my phone. logged in and started encrypting again along with logcat pumping the logs in my favourite black console =) But.... aaaargh! once more failed! Now with a next error:

unmounting /data succeeded
Trigger fs-post-data
Error: No data changed, rebooting...

Thatt time I referred to the 'Notes on the implementation of encryption in Android 3.0' and found out that the line '#setprop vold.post_fs_data_done 1' must be uncommented in init.rc. So I extracted boot.img, got ramdisk and edited the init.rc:

...
# create the lost+found directories, so as to enforce our permissions
mkdir /data/lost+found 0770 root root
# create directory for DRM plug-ins - give drm the read/write access to
# the following directory.
mkdir /data/drm 0770 drm drm
# If there is no fs-post-data action in the init.<device>.rc file, you
# must uncomment this line, otherwise encrypted filesystems
# won't work.
# Set indication (checked by vold) that we have finished this action
setprop vold.post_fs_data_done 1
chown system system /sys/class/android_usb/android0/f_mass_storage/lun/file
chmod 0660 /sys/class/android_usb/android0/f_mass_storage/lun/file
chown system system /sys/class/android_usb/android0/f_rndis/ethaddr
chmod 0660 /sys/class/android_usb/android0/f_rndis/ethaddr
...


then re-assembled the image and flashed it with CWM. And now I am able to encrypt my phone.

The only disadvantage is that after CM9's boot.img alteration, the battery bug during charging results in constant LG logo that does not go even after the charger is plugged out. The same behaviour has the irberserk's kernel though, so I guess we need to ask the CM9 LG E400 maintainer to include our fixes in the next nightly.

UPD: comparing initrams from CM9 last nightly and irberserk, I noticed that irberserk's one has no charger module inside. Maybe it is a sourve of our bug?

Edited by gellmar, 04 March 2013 - 05:31 PM.

  • 0

#679
gellmar

gellmar

    Enthusiast

  • Members
  • PipPipPip
  • 189 posts
  • Devices:LG Optimus L3 E400
Some notes on battery bug. The irberserk's overclocked-no-battery-bug kernel solves this bug but adds a much more annoying one. If the phone is turned off (i.e shutdown) and the charger cord is plugged, the bootsplash1 logo (LG) appears but the kernel does not boot. To turn off the phine one needs to pull the battery off the box, which is fairly unacceptable. So I digged inside the sources of https://github.com/C...ics/init/init.c and https://github.com/C.../BoardConfig.mk and found out that the root of all evil here is the string in kernel cmdline:

lge.reboot=pwroff

In init.c, the is_charger trigger can be activated ever if bootmode is charger, or

COMMON_GLOBAL_CFLAGS += -DBOARD_CHARGING_CMDLINE_NAME='"lge.reboot"' -DBOARD_CHARGING_CMDLINE_VALUE='"pwroff"'

if (!strcmp(name,BOARD_CHARGING_CMDLINE_NAME)) {
			strlcpy(battchg_pause, value, sizeof(battchg_pause));

if (strcmp(bootmode, "charger") == 0 || strcmp(battchg_pause, BOARD_CHARGING_CMDLINE_VALUE) == 0)
		 charging_mode = 1;

By series of sequential patches I determined that the bootmode does not affect the charger trigger on our device, and the trigger activation relies solely on that pwroff parameter. This is a actually a hack created on xda-developers http://forum.xda-dev...&postcount=4113 and it looks like it does not work on e400. If omitting the pwroff check inside init, the phone boots into CM after the first tap, and boots in CM when you plug the cord. To step further, I am investigating which kernel parameters are passed to stock GB e400 kernel, assuming the firmware is the same and there is a "boot-pause" trigger equal to "charger" trigger in CM's init code.

UPD1: In stock e400 Gingerbread V10F_00 init the same pwroff check leads to trigger "boot-pause" that is declared in init.e0.rc as:

on boot-pause
#    exec system/bin/battery_charging
## enable adbd in chargerlogo mode
#   start adbd
    exec /sbin/chargerlogo

so it is time to inspect LG's chargerlogo.

Edited by gellmar, 06 March 2013 - 08:36 PM.

  • 0

#680
misterff1

misterff1

    Regular

  • Members
  • PipPip
  • 86 posts
  • Devices:LG Optimus e400
Please check out my message: http://www.modaco.co...be-me-anymore.. and help me out if you can

  • 0




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users