Jump to content


Photo

Orange San Diego screen timeout issue

- - - - -

  • Please log in to reply
6 replies to this topic

#1
Roger Barnett

Roger Barnett

    Regular

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Devices:Pulse 8220, OSD
I don't understand why this happens, does anybody else experience this problem?

I set my screen timeout to, say, 1 minute through Settings-->Display-->Screen timeout.
Immediately afterwards things are fine and the screen times out as expected, but some time afterwards, after I have made some other actions with the phone, ie general use, the OSD seems to 'forget' that I set the screen timeout. So then, if I leave, say, the gmail app on the screen, the screen does not time out and just sits there lit up sapping battery. I'm not sure whether it's just certain apps where this happens, but it seems random. It also sometimes happens with the home screen.

Am I missing something, or is this a fault with my phone? I've had no problems like this with my old T-mobile pulse - it always times out and turns the screen off.

  • 0

#2
i am not a hacker

i am not a hacker

    Addict

  • Members
  • PipPipPipPipPip
  • 791 posts
  • Gender:Male
  • Location:Maidenhead, England
  • Devices:ZTE Blade and Orange San Diego
If you have certain apps open in the background or foreground, they can stop the screen from timing out as they have the permission to do so

  • 0
Nexus 10
Orange San Diego

#3
BlueMoonRising

BlueMoonRising

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,512 posts
  • Gender:Male
  • Location:Here, there and everywhere...
  • Devices:Orange San Diego, OSF
The next time it happens check which apps are running and check the permissions in app manager.

  • 0
Whoever exalts himself will be humbled, and whoever humbles himself will be exalted.

Matthew 23:12

#4
dec1153

dec1153

    Regular

  • Banned
  • PipPip
  • 71 posts
  • Gender:Male
  • Devices:Orange san diego
  • Twitter:@dec1153
Mine keeps changing by its self from 1min to 15secs

  • 0

#5
Roger Barnett

Roger Barnett

    Regular

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Devices:Pulse 8220, OSD

If you have certain apps open in the background or foreground, they can stop the screen from timing out as they have the permission to do so

If that's the case, it slightly defeats the object of having a screen timeout feature within the Android OS !!?? I would expect this feature to overide all apps ??.
Like I said before, my old Pulse 8220 with Cyanogen mod / Froyo 2.2 performed flawlessly in terms of the screen timeout; i had pretty much the same apps installed as on the OSD.

Edit:- Can I modify the app's ability to prevent the phone from sleeping?

Edited by Roger Barnett, 30 September 2012 - 08:05 PM.

  • 0

#6
BlueMoonRising

BlueMoonRising

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,512 posts
  • Gender:Male
  • Location:Here, there and everywhere...
  • Devices:Orange San Diego, OSF

If that's the case, it slightly defeats the object of having a screen timeout feature within the Android OS !!?? I would expect this feature to overide all apps ??.
Like I said before, my old Pulse 8220 with Cyanogen mod / Froyo 2.2 performed flawlessly in terms of the screen timeout; i had pretty much the same apps installed as on the OSD.

Edit:- Can I modify the app's ability to prevent the phone from sleeping?


Imagine if you're using it as a sat nav. You don't want it turning off every few minutes so apps can override the default behaviour. It only applies to apps that really need it normally and you accept the permissions when you install it. You can check the permissions in app manager but they're not normally changeable unless there's an option in the app itself.

  • 0
Whoever exalts himself will be humbled, and whoever humbles himself will be exalted.

Matthew 23:12

#7
Roger Barnett

Roger Barnett

    Regular

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Devices:Pulse 8220, OSD
So bearing that in mind, an app like gmail should timeout correctly, which it didn't.
Anyway, it seems to be behaving itself now.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users