Jump to content


Photo

[DEV][ROM] RacerMod 1.7 [19/04/2013] CyanogenMod 7.2 port with 2.6.35.7 kernel & CWM Recovery 5.0.2.8


  • Please log in to reply
388 replies to this topic

#221
Harsh37

Harsh37

    Newbie

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Devices:ZTE Racer
hey mke !!!!!!! Is Wifi working now On Ur Latest Update.....!!!!!!!!!!

  • 0

#222
-=PAC-MAN=-

-=PAC-MAN=-

    Newbie

  • Members
  • Pip
  • 14 posts
  • Gender:Male
  • Location:Russia, Siberia
  • Devices:MTC 916 (zte racer)

hey mke !!!!!!! Is Wifi working now On Ur Latest Update.....!!!!!!!!!!

I'm using the latest (15/12/12) ROM and WiFi on my Racer is working properly

Edited by -=PAC-MAN=-, 21 December 2012 - 02:55 PM.

  • 1
Sorry for my bad English

#223
Igor2112

Igor2112

    Newbie

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Russia, Togliatti
  • Devices:ZTE Racer

The new CWM won't be released yet because it has problems with backup/restore :( I don't know if I'll fix it.

A new build of CM7 is coming with some new features cherry-picked from CyanogenMod gerrit.



What do you mean? Overclocking is already enabled.

I mean overclocking to 800MHz. Is it possible?

  • 0

#224
noobzone

noobzone

    Regular

  • Members
  • PipPip
  • 57 posts
  • Devices:zte racer

I mean overclocking to 800MHz. Is it possible?

that's not stable. at any rom. at any kernel. I use mine @ 710mhz

  • 0

#225
Igor2112

Igor2112

    Newbie

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Russia, Togliatti
  • Devices:ZTE Racer
Will CM9 ported to ZTE Racer, or do we need special drivers?

  • 2

#226
d2sarwono

d2sarwono

    Newbie

  • Members
  • Pip
  • 45 posts
  • Devices:zte freddo
whoa!! havent been to modaco for few weeks and just saw this!!
i've tried the 1.4 on my freddo and beside the wifi everything is perfect!!

thanks mikeioannina!!... ^_^

  • 0

#227
d2sarwono

d2sarwono

    Newbie

  • Members
  • Pip
  • 45 posts
  • Devices:zte freddo
i meant months not weeks.. lol
btw mine stable at 725.. ^_^d

  • 0

#228
lfernandes

lfernandes

    Regular

  • Members
  • PipPip
  • 98 posts
  • Devices:ZTE RACER (SOFTSTONE TMN)
When I trie to enable wifi teathering the phone just reboot, even with other teathering software from playstore the result is the same, it reboot's

  • 0

#229
Aloxi Heiligsohn

Aloxi Heiligsohn

    Newbie

  • Members
  • Pip
  • 1 posts
Hi, you've done a very nice job there, your rom works really good, but i have a problem, it doesn't recognize my sim card, is this normal?, i've one of that weird racers with a different camera.

edit: that happened because your boot script detect my phone like a gen2 when it is a gen1, i just copied and renamed the gen1 boot file like gen2, and i forgot to do the same with the libs, i do this and everything works

i'll try it a few days and if i get a bug i'll report it

Edited by Aloxi Heiligsohn, 03 January 2013 - 12:49 AM.

  • 1

#230
CHE00

CHE00

    Newbie

  • Members
  • Pip
  • 9 posts
Hello, thank you for the excellent firmware. I have a few questions:
How to set the screen calibration in the original state it was when the firmware (software used for the calibration of the firmware - I do not like the result.)
What do you recommend settings for performance tuning.
thanks
Sorry for the google translate

  • 0

#231
a3171248

a3171248

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:zte x850
So far so good, it all has been working GREAT except for the screen sensitivity (it was better in the ROM I had previously, if I remember correctly, it was this one http://www.modaco.co...t-cm7-237-roms/ , but it was deleted) :/
One detail: the boot/check_generation.sh file is wrong for my phone (chilean zte racer gen1), so I had to modify it a bit, and replace "generation=2" with "generation=1"
This is the script I'm talking about:
#!/sbin/sh
check_gen1=`cat /proc/mtd | grep "mtd1: 0048"`
if [ "$check_gen1" != "" ]
then
echo "generation=1" > /tmp/gen.prop
else
echo "generation=2" > /tmp/gen.prop
fi

For the record:
# cat /proc/mtd
dev: size erasesize name
mtd0: 00500000 00020000 "recovery"
mtd1: 00500000 00020000 "boot"
mtd2: 00180000 00020000 "splash"
mtd3: 00080000 00020000 "misc"
mtd4: 02800000 00020000 "cache"
mtd5: 0dc00000 00020000 "system"
mtd6: 0a280000 00020000 "userdata"
mtd7: 01500000 00020000 "oem"
mtd8: 00180000 00020000 "persist"

Anyways, thank you VERY MUCH for your work!

  • 1

#232
d2sarwono

d2sarwono

    Newbie

  • Members
  • Pip
  • 45 posts
  • Devices:zte freddo
hi mike, i have use your 1.4 rom for my zte freddo for about two weeks now. the phone seems to be stable at 729mhz and somehow i like the sensitivity of the touchscreen.. feels almost like a capacitive touchscreen now.. lol
however i'd like to report some glitches that i have found:

1. wifi: as we all now, it isn't working yet.. :D

2. bluetooth: it works but sometimes you need to enable it couple of times.

3. screen orientation: works fine but sometimes it splashes a green screen before rotating from portrait to landscape and vice versa.. and sometimes the green screen is gone by itself.. not a big deal for me though..

4. i dunno which sensor that deal with this. i am using an app named google sky map for locating stars, etc. it seem like the compass on the phone only working when the phone is held flat but not working if the phone is held upward..

that is all that i have found so far but the phone is blazing fast now!!

great work mike and thanks.. you have given this old phone a new life... ^_^d


  • 0

#233
mikeioannina

mikeioannina

    Regular

  • Members
  • PipPip
  • 147 posts
  • Gender:Male
  • Location:Ioannina, Greece
  • Devices:ZTE Carl
Thanks for all the answers, I have not built a new version yet because I was busy during the holidays. I'm working slowly on RacerMod, don't think that I forgot you :P

  • 3

If you like my work, don't forget to press the vote up button!
Current phones:
SE Xperia x10 mini - MiniCM10 & nAa-jb kernel
Using custom built roms by me:
SE Xperia mini - CyanogenMod 10 & FXP kernel

ZTE Carl - CyanogenMod 7 & 2.6.35.7 kernel


#234
Raphael Machado

Raphael Machado

    Regular

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:Brazil
  • Devices:Nokia Lumia 520 + ZTE Racer
  • Twitter:@_mraphael
Great to see you back mike!

  • 1
ZTE Racer x850 - RacerMod 1.5 alpha 2 (CyanogenMod7.2 w/ 2.6.35.7 kernel)
Nokia Lumia 520 - Windows Phone 8
Genesis GT-8230 - ParanoidAndroid 2.53 (AOSP 4.1.2 w/ 3.0.42 kernel)

#235
idrisov

idrisov

    Newbie

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Russia
  • Interests:Android/Linux/
  • Devices:ZTE Racer
Hi Mike, I think the problem is that the screen goes white in the ics-dev kernel . When I was building a ICS with gingerbread kernel he don't boot at all ,but he doesn't go to white screen.

  • 0
Sorry for my bad English.
I'm from Russia

#236
mikeioannina

mikeioannina

    Regular

  • Members
  • PipPip
  • 147 posts
  • Gender:Male
  • Location:Ioannina, Greece
  • Devices:ZTE Carl
Some download statistics from my website:

27 Dec 2012 - 15 Jan 2013

170 downloads/RacerMod-1.4-Racer.zip
93 downloads/gapps-gb-20110828-minimal.zip
69 downloads/CWM-5.0.2.8-1.3.zip
53 downloads/RacerMod-1.4-Carl.zip
16 downloads/RacerMod-1.3-Racer.zip
9 downloads/RacerMod-1.3-Carl.zip

I'm impressed by how many people download my rom but only very few participate in this thread.

  • 3

If you like my work, don't forget to press the vote up button!
Current phones:
SE Xperia x10 mini - MiniCM10 & nAa-jb kernel
Using custom built roms by me:
SE Xperia mini - CyanogenMod 10 & FXP kernel

ZTE Carl - CyanogenMod 7 & 2.6.35.7 kernel


#237
SoftStoner

SoftStoner

    Regular

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Queluz, Portugal
  • Devices:ZTE Racer (TMN Soft Stone)

I'm impressed by how many people download my rom but only very few participate in this thread.


I actually installed your 1.4 version yesterday on my Gen1 Racer but hadn't got the time to test it very thoroughly. :) Some thoughts, though...

- The dock bar often disappears, for whatever reason.
- Using Google Maps for a few seconds didn't reboot the phone (used to happen A LOT on every 3D application, either it's fixed or maybe I just didn't stress it enough).
- Compcache still doesn't work (used swap stays at 0 after enabling and rebooting).
- I have to test if the selected wifi sleep policy is honoured (it wasn't on RacerBoy's versions, it always dropped the connection when the screen turned off even if "never" was selected).
- The touch screen precision is God-awful, but I think it uses closed libraries, so there's nothing that can be done about it (hopefully I'm wrong :P).
- Haptic feedback can be completely disabled with this kernel, yay!
- The answer button doesn't work in CWM 5.0.2.8, must enable the back button and use the power button to select menu entries.

That's mostly what I gathered after playing with it for five minutes. I didn't test GSM/UMTS connectivity, phone calls or SMS. Anyway, I must say this is looking really great. Thanks a lot for your work on a newer kernel for the ZTE Racer, it was sorely, sorely needed. :)

  • 0

#238
mikeioannina

mikeioannina

    Regular

  • Members
  • PipPip
  • 147 posts
  • Gender:Male
  • Location:Ioannina, Greece
  • Devices:ZTE Carl

- The dock bar often disappears, for whatever reason.
- Using Google Maps for a few seconds didn't reboot the phone (used to happen A LOT on every 3D application, either it's fixed or maybe I just didn't stress it enough).
- Compcache still doesn't work (used swap stays at 0 after enabling and rebooting).
- I have to test if the selected wifi sleep policy is honoured (it wasn't on RacerBoy's versions, it always dropped the connection when the screen turned off even if "never" was selected).
- The touch screen precision is God-awful, but I think it uses closed libraries, so there's nothing that can be done about it (hopefully I'm wrong :P).
- The answer button doesn't work in CWM 5.0.2.8, must enable the back button and use the power button to select menu entries.


Thanks for the feedback.

-You mean the launcher dock bar? It disappears for some unknown reason (maybe the bad touchscreen driver is related to this) Current solution is to install another launcher like LauncherPro
-We still don't have full 3D acceleration... In fact this is the part I spend most of my time to find out what's wrong and fix it but haven't found anything yet :(
-I haven't tried compcache because I spent all my time in fixing the bigger problems first
-I can't test anything about wifi because I don't own a Racer, I own a variant of Racer (ZTE Carl) that uses different wifi (which doesn't work with the newer kernel, no sources released from zte or any other manufacturer that work)
-The touchscreen calibration is bad. There is no good method to calibrate these older touchscreens in gingerbread. I've done my best to have a usable driver but it doens't work the same for all the people. In the next release I'll probably include a second touchscreen driver with disabled dual touch hacks and hope that it's working better.
-In CWM 5.0.2.8 I changed the buttons from answer/decline to home/back. These are the buttons that all other phones use in recovery.

  • 2

If you like my work, don't forget to press the vote up button!
Current phones:
SE Xperia x10 mini - MiniCM10 & nAa-jb kernel
Using custom built roms by me:
SE Xperia mini - CyanogenMod 10 & FXP kernel

ZTE Carl - CyanogenMod 7 & 2.6.35.7 kernel


#239
a3171248

a3171248

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:zte x850

Thanks for the feedback.

-You mean the launcher dock bar? It disappears for some unknown reason (maybe the bad touchscreen driver is related to this) Current solution is to install another launcher like LauncherPro
-We still don't have full 3D acceleration... In fact this is the part I spend most of my time to find out what's wrong and fix it but haven't found anything yet :(
-I haven't tried compcache because I spent all my time in fixing the bigger problems first
-I can't test anything about wifi because I don't own a Racer, I own a variant of Racer (ZTE Carl) that uses different wifi (which doesn't work with the newer kernel, no sources released from zte or any other manufacturer that work)
-The touchscreen calibration is bad. There is no good method to calibrate these older touchscreens in gingerbread. I've done my best to have a usable driver but it doens't work the same for all the people. In the next release I'll probably include a second touchscreen driver with disabled dual touch hacks and hope that it's working better.
-In CWM 5.0.2.8 I changed the buttons from answer/decline to home/back. These are the buttons that all other phones use in recovery.


- this is the dock thing you talking about? http://forum.cyanoge...cons-disappear/
this is how I solved it: http://forum.cyanoge...ar/#entry111133

menu -> settings -> adw settings (or just straight to adw settings) -> UI settings and the second section down will be called "hidden dockbar", and right under that header the button next to "Dockbar" will be checked by default. Uncheck it.

- as I said, the calibration worked fine in other build. can you just take the settings from there? also, I noticed something: it works OK when pressing the screen quickly, but it doesn't when pressing "normally" (i.e., slowly). can it be too "reactive"? is there a setting to configure the speed to which the screen should react?
- also, the home, menu and back buttons seem to be badly configured. I'd say they are too below in the screen. when you press the top of them, you may end pressing objects in the screen.
I'd just ask the other devs here in this subforum or try copying their settings and see if they work.

Sorry if I wasn't too clear, english is not my first language and I don't know much about android dev.
I hope this helps.

  • 0

#240
mikeioannina

mikeioannina

    Regular

  • Members
  • PipPip
  • 147 posts
  • Gender:Male
  • Location:Ioannina, Greece
  • Devices:ZTE Carl

I actually installed your 1.4 version yesterday on my Gen1 Racer but hadn't got the time to test it very thoroughly. :) Some thoughts, though...

- The dock bar often disappears, for whatever reason.
- Using Google Maps for a few seconds didn't reboot the phone (used to happen A LOT on every 3D application, either it's fixed or maybe I just didn't stress it enough).
- Compcache still doesn't work (used swap stays at 0 after enabling and rebooting).
- I have to test if the selected wifi sleep policy is honoured (it wasn't on RacerBoy's versions, it always dropped the connection when the screen turned off even if "never" was selected).
- The touch screen precision is God-awful, but I think it uses closed libraries, so there's nothing that can be done about it (hopefully I'm wrong :P).
- Haptic feedback can be completely disabled with this kernel, yay!
- The answer button doesn't work in CWM 5.0.2.8, must enable the back button and use the power button to select menu entries.

That's mostly what I gathered after playing with it for five minutes. I didn't test GSM/UMTS connectivity, phone calls or SMS. Anyway, I must say this is looking really great. Thanks a lot for your work on a newer kernel for the ZTE Racer, it was sorely, sorely needed. :)


About compcache: you need to insmod the zram.ko, lzo_compress.ko and lzo_decompress.ko modules. Try that and report if it works

  • 2

If you like my work, don't forget to press the vote up button!
Current phones:
SE Xperia x10 mini - MiniCM10 & nAa-jb kernel
Using custom built roms by me:
SE Xperia mini - CyanogenMod 10 & FXP kernel

ZTE Carl - CyanogenMod 7 & 2.6.35.7 kernel





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users