Jump to content


Photo

No avatar in messages

- - - - -

  • Please log in to reply
10 replies to this topic

#1
Konstipated Kiwi

Konstipated Kiwi

    Enthusiast

  • Members
  • PipPipPip
  • 254 posts
Since switching to Xolo ICS I have not been able to get my avatar displaying in the messaging app. This coincided with porting my Giffgaff number to Orange, so I don't know which of the two events caused the fault. What conditions need to be met for my own avatar to display? I just get the blank grey box at the moment.

  • 0

#2
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,651 posts
I'm sure you already posted about this before? Your SIM needs to have the correct number on it for your messages to be linked to the correct account. Or you can try setting your details in the 'People' app if you haven't done already.

  • 0

#3
Konstipated Kiwi

Konstipated Kiwi

    Enthusiast

  • Members
  • PipPipPip
  • 254 posts
Aye, that I did. I started a thread specifically asking how to change the phone number on the SIM, as I figured this was the most likely cause of the problem. After somebody helpfully pointed out you can do this through ICS (rather than the 'My phone number' app by Lytsing - which wouldn't install - or inserting the SIM in an old mobile phone - which I don't have ready access to) this turned out not to be the case. The other thread was just about one potential cause, which has now been ruled out. I felt it best to start a new thread with a title clearly explaining the actual problem so as others who have had the same issue may be encouraged to take a look.

This 'people' app you mention; is it the 'people widget' listed here? I can't figure out how to use that. If I select 'People' from the app drawer it just opens my existing contacts. If I try to drag the widget to one of my homescreens it reports that I cannot add widgets from the drawer without root access (which I have) and suggests enabling root helper from Advanced Settings of Super User (I can't find the advanced settings menu within the Super User app). I am using Apex Launcher (paid version).

Edited by Konstipated Kiwi, 31 October 2012 - 03:13 PM.

  • 0

#4
BlueMoonRising

BlueMoonRising

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,520 posts
  • Gender:Male
  • Location:Here, there and everywhere...
  • Devices:Orange San Diego, OSF

This 'people' app you mention; is it the 'people widget' listed here? I can't figure out how to use that. If I select 'People' from the app drawer it just opens my existing contacts. If I try to drag the widget to one of my homescreens it reports that I cannot add widgets from the drawer without root access (which I have) and suggests enabling root helper from Advanced Settings of Super User (I can't find the advanced settings menu within the Super User app). I am using Apex Launcher (paid version).


It's a widget...

Long press on the homescreen and add widget, however it does say :-

tested on:
- adw launcher
- launcher pro

Not working on:
launchers not using scrollable widgets


Edit :- Just tried it and it doesn't work on Apex Launcher, it leaves you with just an empty translucent background. Maybe https://play.google....re=related_apps if you're not using a suitable launcher?

Edited by BlueMoonRising, 31 October 2012 - 04:32 PM.

  • 0
Whoever exalts himself will be humbled, and whoever humbles himself will be exalted.

Matthew 23:12

#5
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,651 posts
Nope I mean the 'People' contacts app. Open that and there should be a contact right at the top called Me. Select that and make sure it's set up with your details.

  • 0

#6
Konstipated Kiwi

Konstipated Kiwi

    Enthusiast

  • Members
  • PipPipPip
  • 254 posts
Thanks flibblesan. It still doesn't work. There is a contact I have called 'me' right at the top of the list. The record just contains my phone number and the avatar. Are there any other essential fields required for the picture to display?

  • 0

#7
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,651 posts
All I know is the phone number has to match the number currently being used by the SIM. In the phone status part of Settings > About phone is a phone number showing up and is it your current number?

Try syncing your google contacts and signing into google talk and google plus if your number is displayed correctly.

  • 0

#8
Konstipated Kiwi

Konstipated Kiwi

    Enthusiast

  • Members
  • PipPipPip
  • 254 posts
Aye, the correct numbers appear in both 'my profile' in my contacts and in Settings - - > About Phone - - > status. Contacts are syncing correctly as far as I can tell. I haven't used Google+ at all...ever. Nor have I ever used Google Talk. That said, when I load the latter it uses the avatar from the full entry in my contacts (a separate entry from 'my profile'). The full entry is the one that used to make my avatar appear in messaging apps when using Gingerbread. It is also the one Gmail uses when I log in. I have tried putting a dummy number and Gmail address in there in case it is confusing the messaging app but it hasn't made a difference.

I think I may have to install Xolo ICS again and start from scratch.

Edited by Konstipated Kiwi, 31 October 2012 - 09:53 PM.

  • 0

#9
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,651 posts
OK I just wiped my phone so thought I'd try this out. By default I have nothing listed for the 'Me' contact. Connecting to Google+ adds my information to this so thats OK. But what I've also tested is manually adding my details and adding a user photo and thats works.

I think the confusion here is that, for some reason, it's not grabbing your details from the Google account like I would expect it to do.

  • 0

#10
Konstipated Kiwi

Konstipated Kiwi

    Enthusiast

  • Members
  • PipPipPip
  • 254 posts
Thank you for your efforts, flibblesan. I think I may have to wipe and start again. I have a pay monthly sim in now, which will be my regular one for the future. I suspect issue was caused when I ported my Giffgaff number to Orange. Hopefully all should be okay when I start afresh.

  • 0

#11
Konstipated Kiwi

Konstipated Kiwi

    Enthusiast

  • Members
  • PipPipPip
  • 254 posts
Right, on Sunday I wiped all the USB data and installed Xolo ICS fresh using the 'Update from USB storage' option in the Settings menu. Using the stock messaging app I now have my avatar against my messages when sending them. Yay; result!

Except...

I prefer to use Handcent SMS. For some reason, this still does not display my avatar against my messages; just the generic silhouette icon. Is anybody else using Handcent for SMS and successfully displaying their own avatar? Can anybody think of a reason why it would work for the stock app and not Handcent?

I'll maybe try one or two other 3rd party apps and see whether it is only Handcent that is affected. It worked ok on my Blade and my G300, but they were running Gingerbread.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users