Jump to content


Photo

Problems with SD cards

- - - - -

  • Please log in to reply
12 replies to this topic

#1
thebuell

thebuell

    Regular

  • Members
  • PipPip
  • 101 posts
  • Gender:Male
  • Devices:Y300, Nexus 7
I recently bought a 32GB Sandisk Ultra class 10 micro SD card for use with my G300. Ever since I installed it into my G300 I've been plagued with random dismounts and remounts. I've reformatted the card a few times but still have the same recurring problem. Any ideas what else I can try before I return.the card for a refund? thanks :-(

  • 0

#2
bartman11

bartman11

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:Huawei G300
I've had problems since installing that card too - the most frequent one being that some/all of my mp3 files keep getting dumped into the "lost.dir" folder which gets created,

I've tried reformatting the card in my PC, then transferring the files using the PC, reformatting using the phone and transferring files via USB, and combinations of those methods - same result always.

Sometimes when I attach the USB I get a message on the PC telling me the card needs formatting before I can use it. Sometimes the phone tells me there is no SD card, and when I go into settings it is unmounted.

The files are usually OK for a while, I can see them on the phone and play them, but after a while when I go to play them again there are no files the player can find, and when I go to file manager there they all are in "lost.dir".

When I leave the card plugged in to the reader on my PC it behaves perfectly normally, no problems at all. So I don't know whether it's the card or the phone causing the problem - but I think it's most probably the phone.

Any suggestions for a remedy would be welcome.

  • 0

#3
fuzzyy

fuzzyy

    Regular

  • Members
  • PipPip
  • 138 posts
  • Gender:Male
  • Devices:Moto G, Huawei G300
Sounds like it could be a combination of the card and the phone, since only you two have reported problems. Could it be the card is too fast? I've had no problems with an no-brand 16GB class 4.

  • 0

Moto G 8GB

Tesco 4.4


#4
holtend

holtend

    Regular

  • Members
  • PipPip
  • 59 posts
  • Gender:Male
  • Devices:Nexus 4
Ive had exactly the same problems with my class 4 sandisk 32gb card.
Entire directories randomly disappearing and random unmounts, bloody annoying!
I think a lot of people have this problem with this phone.

  • 0

#5
thebuell

thebuell

    Regular

  • Members
  • PipPip
  • 101 posts
  • Gender:Male
  • Devices:Y300, Nexus 7
If there's enough feedback I may compile a list of compatible micro SD cards, keep them coming.

I've ordered a 4GB transcend SD card to see if it is the phone or not. Fingers crossed.

  • 0

#6
wouterbeer

wouterbeer

    Enthusiast

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Devices:G300
Also have a 32GB SD card, class4. Working perfectly fine on my g300, had no issues whatsoever.

  • 0

#7
wouterbeer

wouterbeer

    Enthusiast

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Devices:G300
Oh, and it's a transcend.

  • 0

#8
Cyda

Cyda

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,448 posts
  • Gender:Male
  • Location:Wales
  • Devices:Nexus 4 & 7 running PAC

If there's enough feedback I may compile a list of compatible micro SD cards, keep them coming.

I've ordered a 4GB transcend SD card to see if it is the phone or not. Fingers crossed.

I bought this for my G300 and it works well. http://www.amazon.co...l/dp/B005FY61EK

I'd say you really want at least a class 6 these days.

  • 0

#9
thebuell

thebuell

    Regular

  • Members
  • PipPip
  • 101 posts
  • Gender:Male
  • Devices:Y300, Nexus 7
Yeah the card I ordered is class 10. Hopefully it will arrive in the post later today. Soon I will know if it's the phone or not.

  • 0

#10
thebuell

thebuell

    Regular

  • Members
  • PipPip
  • 101 posts
  • Gender:Male
  • Devices:Y300, Nexus 7
Hurrah!! It is not the phone at all. With the 4GB transcend card that arrived in the post it worked perfectly. I tested the 32GB sandisk card with a new card reader that also arrived in the post, and had so many disk errors, so it is being sent back to the retailer. Happy all is well :-)

  • 0

#11
LesMcQueen

LesMcQueen

    Newbie

  • MoDaCo Silver
  • Pip
  • 19 posts
I also had problems with my 32GB class 4 Sandisk card.
I was losing photos and MP3s, getting SD card dismounts and random reboots.

I bought a generic class 10 32GB card off Ebay and it's been fine ever since.

EDIT: This was the one I bought --> http://www.ebay.co.uk/itm/200766372219

Edited by LesMcQueen, 15 November 2012 - 09:30 PM.

  • 0

#12
toge64

toge64

    Diehard

  • Members
  • PipPipPipPip
  • 376 posts
  • Gender:Male
  • Interests:Bargain android devices... (and high end ones too)
  • Devices:Nexus 4, Galaxy Tab 2
I have a class 10 16GB and it works fine.

  • 0
Have: Nexus 4, Galaxy Tab 2, HP Touchpad
Sold: Orange OSF/ZTE Blade AMOLED, Huawei Ascend G300

#13
rob4x4

rob4x4

    Diehard

  • Members
  • PipPipPipPip
  • 326 posts
  • Gender:Male
  • Location:GPS off
  • Devices:Nexus 4,Tesco Hudl
I've been using a 32GB SanDisk Ultra Class 10 in my G300 (running latest Infusion) and it works perfectly. I've been using it since July without any issues. Not sure that helps anyone on this thread but I thought I'd say it.
My father in-law has had issues with his Transend 16GB class 4 card in his G300. Lost all data and became inaccessible. He had to return the card for a identical replacement which so far seems ok.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users