Jump to content


Photo

[RECOVERY] [CWM] ClockworkMod Recovery v6.0.4.5 [CM] [Last updated: 21/12]


430 replies to this topic

#181
mr_mufy

mr_mufy

    Diehard

  • Members
  • PipPipPipPip
  • 300 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TICs/Electronics.
    Btt
  • Devices:ZTE - Blade / Huawei G300
HI.

I have Hybrid touch 6.0.2.1 installed, and i liked, it's very cool.
TKs for this.
But when I need to backup all my data i can't recover all, because i use the internal Storage like System data.
And the backup can't read that partition.

It's any think i can do to workaround this?

  • 0
Mr_mufy

#182
Fagulhas

Fagulhas

    Regular

  • Members
  • PipPip
  • 75 posts
  • Gender:Male
  • Devices:Huawei Ascend G300

HI.

I have Hybrid touch 6.0.2.1 installed, and i liked, it's very cool.
TKs for this.
But when I need to backup all my data i can't recover all, because i use the internal Storage like System data.
And the backup can't read that partition.

It's any think i can do to workaround this?


The next version will have several new options, including one to backup the internal partition.

  • 1
If you appreciated my work or help and would like to donate, please follow this link Donate!

#183
mr_mufy

mr_mufy

    Diehard

  • Members
  • PipPipPipPip
  • 300 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TICs/Electronics.
    Btt
  • Devices:ZTE - Blade / Huawei G300
When we ill espect the new version?

  • 0
Mr_mufy

#184
Rostilj xD

Rostilj xD

    Enthusiast

  • Members
  • PipPipPip
  • 188 posts
  • Gender:Male
  • Devices:Huawei Ascend G300
  • Twitter:@Milos_Zx
No ETAs.

  • 0

#185
mr_mufy

mr_mufy

    Diehard

  • Members
  • PipPipPipPip
  • 300 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TICs/Electronics.
    Btt
  • Devices:ZTE - Blade / Huawei G300
tks.

  • 0
Mr_mufy

#186
Noak_One

Noak_One

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:huawei ascend g300
sorry if i ask so silly but how can i install this ? :P

  • 0

#187
Melvo

Melvo

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:Huawei Ascend g300
I've tried putting both on my sd card and tried to update but get a e:signature verification failure notification. Does anyone know what causes this issue/

  • 0

#188
Fagulhas

Fagulhas

    Regular

  • Members
  • PipPip
  • 75 posts
  • Gender:Male
  • Devices:Huawei Ascend G300

I've tried putting both on my sd card and tried to update but get a e:signature verification failure notification. Does anyone know what causes this issue/


Read a few pages behind, there's an post explaining how to install it.

  • 0
If you appreciated my work or help and would like to donate, please follow this link Donate!

#189
rale_ts

rale_ts

    Regular

  • Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Devices:Huawei Ascend G300, ZTE V11A
  • Twitter:@rale_ts
Great new release is out, I'm gonna try now :)
Tnx. Keep up good work!

  • 0

#190
kyan31

kyan31

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,889 posts
  • Gender:Male

sorry if i ask so silly but how can i install this ? :P


Install CWM (in stickies) and then flash this with it.

  • 0

e2199c4dbb.png823c51b6b0.pngc3f6e04cdb.pngbc36a18046.pngead60d1912.pnge46a22ae54.png

 

Phones: Samsung Galaxy S4 Qualcomm & Huawei Ascend G300

PC: AMD FX 8350 8 CORE 4.2Ghz CPU, 16GB 1600Mhz Kingston HyperX RAM, Gigabyte R9 270X Winforce Edition GPU

Like my work? Hit that +1 button as a thank you! Want to support me? You could consider donating!  :)

Subscribe to my YT Channel: https://www.youtube.com/user/thekyan31


#191
kyan31

kyan31

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,889 posts
  • Gender:Male
I'm gonna try the new update, thanks Dazzozo and Fagulhas :D

Edited by kyan31, 15 January 2013 - 09:57 PM.

  • 0

e2199c4dbb.png823c51b6b0.pngc3f6e04cdb.pngbc36a18046.pngead60d1912.pnge46a22ae54.png

 

Phones: Samsung Galaxy S4 Qualcomm & Huawei Ascend G300

PC: AMD FX 8350 8 CORE 4.2Ghz CPU, 16GB 1600Mhz Kingston HyperX RAM, Gigabyte R9 270X Winforce Edition GPU

Like my work? Hit that +1 button as a thank you! Want to support me? You could consider donating!  :)

Subscribe to my YT Channel: https://www.youtube.com/user/thekyan31


#192
Cyda

Cyda

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,448 posts
  • Gender:Male
  • Location:Wales
  • Devices:Nexus 4 & 7 running PAC
Thanks for the update, some great new features.

Is there any trick to getting this version to backup internal storage? I've been to Extras and enabled the option but it always says 'backup of internal storage disabled. skipping.'.

Here's a poor pic of the messages...

Attached File  IMG_20130115_220200.png   1.58MB   57 downloads

  • 0

#193
Fagulhas

Fagulhas

    Regular

  • Members
  • PipPip
  • 75 posts
  • Gender:Male
  • Devices:Huawei Ascend G300

Thanks for the update, some great new features.

Is there any trick to getting this version to backup internal storage? I've been to Extras and enabled the option but it always says 'backup of internal storage disabled. skipping.'.

Here's a poor pic of the messages...

Attached File  IMG_20130115_220200.png   1.58MB   57 downloads


Odd, its working fine on my local build, maybe i forgot to push something to the repos, hold on ;)

Edit: Pushed all the stuff, tested and working here, re-release should happen in a few minutes. If for some reason it still doesn't work for you, i'm gonna ask you to a few things ;)
Also fixed the backup order so folks that backup emmc don't end up backing up the current nandroid thats taking place.

Edit2: My internal build until its on the OP - http://db.tt/yGhjkgxX

Edited by Fagulhas, 16 January 2013 - 12:07 AM.

  • 1
If you appreciated my work or help and would like to donate, please follow this link Donate!

#194
Cyda

Cyda

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,448 posts
  • Gender:Male
  • Location:Wales
  • Devices:Nexus 4 & 7 running PAC

Odd, its working fine on my local build, maybe i forgot to push something to the repos, hold on ;)

Edit: Pushed all the stuff, tested and working here, re-release should happen in a few minutes. If for some reason it still doesn't work for you, i'm gonna ask you to a few things ;)
Also fixed the backup order so folks that backup emmc don't end up backing up the current nandroid thats taking place.

Edit2: My internal build until its on the OP - http://db.tt/yGhjkgxX

Same problem with that build except the 'backup of internal storage disabled. Skipping' message is now at the top of the log instead of the end. Tried it twice with the same result. Let me know what info you need.

Is it working for anyone else or just failing for me?

Edit: Also, are the 'toggle' options in the Extras menu actually meant to toggle the setting on & off? Because when I use any of them they just enable the setttings and if you use the again you still get the same enabled message, they don't toggle to disabled.

Edited by Cyda, 16 January 2013 - 12:42 AM.

  • 0

#195
Fagulhas

Fagulhas

    Regular

  • Members
  • PipPip
  • 75 posts
  • Gender:Male
  • Devices:Huawei Ascend G300

Same problem with that build except the 'backup of internal storage disabled. Skipping' message is now at the top of the log instead of the end. Tried it twice with the same result. Let me know what info you need.

Is it working for anyone else or just failing for me?

Edit: Also, are the 'toggle' options in the Extras menu actually meant to toggle the setting on & off? Because when I use any of them they just enable the setttings and if you use the again you still get the same enabled message, they don't toggle to disabled.


Yeah they are, each option when enable writes a small file to /emmc/clockworkmod/. Can you check if you have that folder in your internal storage and some of those files? They should be hidden by default. ".backup_internal" or ".restore_internal" is one of them.

You can also enable/disable the option and then go Advanced Options -> Show log and post the results here.

Edited by Fagulhas, 16 January 2013 - 05:28 AM.

  • 0
If you appreciated my work or help and would like to donate, please follow this link Donate!

#196
wouterbeer

wouterbeer

    Enthusiast

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Devices:G300
I have the same issue concerning toggling on/off; it seems to only want to toggle it 'on'. (with newest build R4)

Also I found another glitch; when going to delete an old backup, nothing happens. So built-in delete function is not working (for me).

Nevertheless really appreciate your work, keep on the good work Fagulhas!

  • 0

#197
Cyda

Cyda

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,448 posts
  • Gender:Male
  • Location:Wales
  • Devices:Nexus 4 & 7 running PAC
I've just looked at the log after selecting the 'toggle enable internal storage' option and it gave the error that the file/folder doesn't exist. I checked the internal storage and there was no clockworkmod folder so I created one manually, tried another backup and it seemed to work fine. After creating the folder manually the toggle function also works. Seems the problem is the folder not being created.

I don't mean to criticise the great work you are doing but wouldn't it be better to store the .backup_internal file etc in the /sdcard/clockworkmod folder with the .default_backup_format file?

I also checked the delete from external sd function and strangely it works fine here.

Edit: Just doing a bit of testing with this and thought I'd test a full restore. So I format /system, /cache, /data and /emmc before restoring the backup (as a way to make sure everything works)... and thats when I realise that I just wiped the preferences from the /emmc partition and can't enable 'restore internal storage' because the clockworkmod folder doesn't exist. I had to do a restore without internal storage and then boot up, create the /emmc/clockworkmod folder and then go back to recovery and then restore the /emmc partition. On the plus side, the restore worked fine. :P

Edited by Cyda, 16 January 2013 - 10:31 AM.

  • 0

#198
Fagulhas

Fagulhas

    Regular

  • Members
  • PipPip
  • 75 posts
  • Gender:Male
  • Devices:Huawei Ascend G300

I've just looked at the log after selecting the 'toggle enable internal storage' option and it gave the error that the file/folder doesn't exist. I checked the internal storage and there was no clockworkmod folder so I created one manually, tried another backup and it seemed to work fine. After creating the folder manually the toggle function also works. Seems the problem is the folder not being created.

I don't mean to criticise the great work you are doing but wouldn't it be better to store the .backup_internal file etc in the /sdcard/clockworkmod folder with the .default_backup_format file?

I also checked the delete from external sd function and strangely it works fine here.

Edit: Just doing a bit of testing with this and thought I'd test a full restore. So I format /system, /cache, /data and /emmc before restoring the backup (as a way to make sure everything works)... and thats when I realise that I just wiped the preferences from the /emmc partition and can't enable 'restore internal storage' because the clockworkmod folder doesn't exist. I had to do a restore without internal storage and then boot up, create the /emmc/clockworkmod folder and then go back to recovery and then restore the /emmc partition. On the plus side, the restore worked fine. :P


Thats how originally i was planning to do, store all the preferences at /sdcard BUT that means users with no external sd card were not gonna be able to activate them either. Never occurred to me we could have a problem with the folder not being created, thats why it was failing for all of you and not for me. Cheers for the debugging.

I may just end up choosing another partition for the option files that most don't touch (/cust) if more issues appear.

  • 0
If you appreciated my work or help and would like to donate, please follow this link Donate!

#199
Cyda

Cyda

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,448 posts
  • Gender:Male
  • Location:Wales
  • Devices:Nexus 4 & 7 running PAC

that means users with no external sd card were not gonna be able to activate them either.

I might be missing something but isn't that actually a good thing? I mean why would a user with no sdcard need to backup/restore the internal_sd with cwm? And given that they could enable this feature how well is cwm going to handle backing up the internal_sd partition to itself?

Edited by Cyda, 16 January 2013 - 03:52 PM.

  • 0

#200
Fagulhas

Fagulhas

    Regular

  • Members
  • PipPip
  • 75 posts
  • Gender:Male
  • Devices:Huawei Ascend G300

I might be missing something but isn't that actually a good thing? I mean why would a user with no sdcard need to backup/restore the internal_sd with cwm? And given that they could enable this feature how well is cwm going to handle backing up the internal_sd partition to itself?


The same applies to all the other options Cyda, not just for the emmc backup toggle. All the extra options work by reading the files created by each and activates the code in question. Once they are removed, the options are disabled.

  • 0
If you appreciated my work or help and would like to donate, please follow this link Donate!




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users